Setup & Software Discussions
Issues with rmbp 15" 2017 x Razer Core
 

Issues with rmbp 15" 2017 x Razer Core  

  RSS

fledged
(@fledged)
Active Member
Joined: 2 years ago
 

hey there

 

I’m new here

forgive my poor english plz

hope that u guys could catch me..

 

i brought a brand new 15” MacBook pro with AMD Radeon Pro 560

and i got a Razer Core with TITAN BLACK

 

the problem is that core can’t be used in both 10.13 (internal SSD) or 10.12.6 (external SSD, i build a system for spare)

 

Core - Unsupported:

 

  Vendor Name: Razer

  Device Name: Core - Unsupported

  Vendor ID: 0x127

  Device ID: 0x215

  Device Revision: 0x1

  UID: 0x80864F4098291510

  Route String: 1

  Firmware Version: 16.16

 

i heard that 10.13 officially support eGPU so i updated to 10.13 as soon as i get my new mac

but the fact is this doesn’t work

 

i also tried automate-eGPU in 10.12.6 but it returns:

 

bash-3.2# /Users/FledgeD/Desktop/automate-eGPU.sh 

Thunderbolt device is connected, but no external GPUs detected.

or

bash-3.2# /Users/FledgeD/Desktop/automate-eGPU.sh -a

Application support path not found. Please install automate-eGPU first.

 

and Rastafabi's eGPU Enabler: nothing changes

 

 

but it do work in windows i installed in another external ssd perfectly

no code 12

i tried crysis3 and Davinci Resolve Studio and i think the eGPU do works

 

May i ask if there is any solution for MacBook pro 2017 with Razer Core

 

thank you🙏 

Pending: Add my system information and expected eGPU configuration to my signature to give context to my posts


ReplyQuote
nando4
(@nando4)
Noble Member Admin
Joined: 3 years ago
 

@fledged,  the TI82-based Razer Core requires TB3-enabler to allow eGPU detection to occur. There are hit and miss reports of it working on High Sierra. Please review https://egpu.io/forums/mac-setup/tb3-script-enabler-issues/#post-15752 and if get nowhere consider updating to a TI83-based TB3 enclosure from https://egpu.io/external-gpu-buyers-guide-2017/#tb3-enclosures

eGPU Setup 1.35    •    eGPU Port Bandwidth Reference Table

15" Dell Precision 7510 (Q M1000M) (6th,4C,H) + GTX 1080 Ti @ 32Gbps-M2 (ADT-Link R43SG) + macOS 10.13.6 & Win10


fledged and itsage liked
ReplyQuote
ualwayaslose
(@ualwayaslose)
Active Member
Joined: 3 years ago
 

Follow this:

 

Posted by: ibob

Hi! I am new in the forum, but wanted to share my experience. I have this AKiTiO Thunder3 with an NVidia GTX 1050 Ti that I've been using in Windows, no problem. But wasn't using it on macOS simply because it is not supported. I have macOS High Sierra Beta 3 installed, and when I found the patch, I tried and it didn't work, until I found this forum. It is recognized now, although, the video card is not working because NVidia Beta Drivers doesn't support macOS H.S. What I did:

1) Downloaded iHex and Kext Utility.
2) Booted recovery, open terminal, and ran "csrutil disable", reboot.
3) Copied /System/Library/Extensions/IOThunderboltFamily.kext to my desktop.
4) With iHex open /System/Library/Extensions/IOThunderboltFamily.kext/Contents/MacOS/IOThunderboltFamily
5) Find 55 48 89 E5 41 57 41 56 41 55 41 54 53 48 81 EC 28 01, replace by 55 48 89 E5 31 C0 5D C3 41 55 41 54 53 48 81 EC 28 01 and save.
6) Open Kext Utility, enter password and let it do it's thing. 
7) Drag IOThunderboltFamily.kext into Kext Utility, let it do it's thing... 
8) Restart. 
9) Done.

So It's basically that. I guess when NVidia releases the final Driver, I'll be able to get this card working. 
Thanks for the help!

Screen Shot 2017 07 21 at 7.09.59 PM

 

Depending on your system the hex codes are as follows:

 

Posted by: itsage

Until the author of tb3-enabler updates the script, you can manually modify IOThunderboltFamily.kext to accomplish the same thing. Read my instructions in an earlier response.

For macOS Sierra 10.12.x

55 48 89 E5 41 57 41 56 41 55 41 54 53 48 81 EC 38 01 
55 48 89 E5 31 C0 5D C3 41 55 41 54 53 48 81 EC 38 01

For macOS High Sierra 10.13.x

55 48 89 E5 41 57 41 56 41 55 41 54 53 48 81 EC 28 01 
55 48 89 E5 31 C0 5D C3 41 55 41 54 53 48 81 EC 28 01

 

I could not get a Razer Core and AMD 570 to work in Sierra 10.12.6. 

I updated to High Sierra and got it working twice both in PB5 and PB6.

Final cut Pro does not work though, due to Intel Accelerated Graphics switching not supported with AMD 570 (Or something like that still researching but not a major issues for me to try to resolve it)

With AMD cards, you should be fine just doing the HEX edit, then restarting, plugging in EGPU and it telling you to log out and log back in.

Pending: Add my system information and expected eGPU configuration to my signature to give context to my posts


nando4, fledged and itsage liked
ReplyQuote
fledged
(@fledged)
Active Member
Joined: 2 years ago
 

Okay thank u dude! it seems that Core is back online in High Sierra
i tried the usb hub and it works

10.12.6 still untested

still, GTX TITAN BLACK can't be find in graphic cards because there isn't any driver released right?
i may try 10.12.6 or find another graphic card to see if it can work

thanks again!

BTW is there any chance that core can be officially supported by apple? or shall i get a new tb3 enclosure with TI83 if i need to work with eGPU?

 


and finally in 10.12.6 i got this

NVIDIA Chip Model:

 

  Chipset Model: NVIDIA Chip Model

  Type: GPU

  Bus: PCIe

  PCIe Lane Width: x4

  Vendor: NVIDIA (0x10de)

  Device ID: 0x100c

  Revision ID: 0x00a1

  ROM Revision: preset 1.0.0

  Automatic Graphics Switching: Supported

  gMux Version: 4.0.29 [3.2.8]

 

  Metal: Supported

Pending: Add my system information and expected eGPU configuration to my signature to give context to my posts


nando4 liked
ReplyQuote
fledged
(@fledged)
Active Member
Joined: 2 years ago
 

finally it seems I'm done

thank you guys, all of you

1
2
3

Pending: Add my system information and expected eGPU configuration to my signature to give context to my posts


itsage liked
ReplyQuote
ualwayaslose
(@ualwayaslose)
Active Member
Joined: 3 years ago
 

It seems to just be TI-83 that are supported by Apple.

 

Do you have final cut pro? Can you test if that is working for you?

Pending: Add my system information and expected eGPU configuration to my signature to give context to my posts


ReplyQuote
fledged
(@fledged)
Active Member
Joined: 2 years ago
 

fcpx 10.3.4 crashes when 560 and titan black both running

disable internal screen using titan black and external display only could solve this

fcpx 10.2.3 seems working right

Pending: Add my system information and expected eGPU configuration to my signature to give context to my posts


ReplyQuote
ualwayaslose
(@ualwayaslose)
Active Member
Joined: 3 years ago
 

How do you disable the internal screen?

Pending: Add my system information and expected eGPU configuration to my signature to give context to my posts


ReplyQuote
fledged
(@fledged)
Active Member
Joined: 2 years ago
 

I use SwitchResX to fix resolution of  internal screen at 2880x1800

it can enable/disable a screen as well

hope it could help

Pending: Add my system information and expected eGPU configuration to my signature to give context to my posts


ReplyQuote
ualwayaslose
(@ualwayaslose)
Active Member
Joined: 3 years ago
 

I tried disabling internal screen with latest version of Final Cut Pro and it still crashes.

How did you download/install the older version (10.2.3)

 

Or did the latest version work by disabling the internal screen. I just tried it with SwitchResX Still getting same crash error.

Pending: Add my system information and expected eGPU configuration to my signature to give context to my posts


ReplyQuote
fledged
(@fledged)
Active Member
Joined: 2 years ago
 

Oh im not sure because FCPX crashed today when I'm trying to import something

i have  a cr**ked standalone older version of FCPX i used before

and i found when i open the Premiere Pro project created with OpenCL in Mac Pro

it causes Premiere to crash or not responding with eGPU

and if i change the accelerator to Metal in Radeon and open again

it is able to open the project and set it to CUDA

it may have some problem with nvidia driver and openCL?

Pending: Add my system information and expected eGPU configuration to my signature to give context to my posts


ReplyQuote
(@hoangphuc_nguyen)
New Member
Joined: 2 years ago
 
Posted by: ualwayaslose

Follow this:

 

Posted by: ibob

Hi! I am new in the forum, but wanted to share my experience. I have this AKiTiO Thunder3 with an NVidia GTX 1050 Ti that I've been using in Windows, no problem. But wasn't using it on macOS simply because it is not supported. I have macOS High Sierra Beta 3 installed, and when I found the patch, I tried and it didn't work, until I found this forum. It is recognized now, although, the video card is not working because NVidia Beta Drivers doesn't support macOS H.S. What I did:

1) Downloaded iHex and Kext Utility.
2) Booted recovery, open terminal, and ran "csrutil disable", reboot.
3) Copied /System/Library/Extensions/IOThunderboltFamily.kext to my desktop.
4) With iHex open /System/Library/Extensions/IOThunderboltFamily.kext/Contents/MacOS/IOThunderboltFamily
5) Find 55 48 89 E5 41 57 41 56 41 55 41 54 53 48 81 EC 28 01, replace by 55 48 89 E5 31 C0 5D C3 41 55 41 54 53 48 81 EC 28 01 and save.
6) Open Kext Utility, enter password and let it do it's thing. 
7) Drag IOThunderboltFamily.kext into Kext Utility, let it do it's thing... 
8) Restart. 
9) Done.

So It's basically that. I guess when NVidia releases the final Driver, I'll be able to get this card working. 
Thanks for the help!

Screen Shot 2017 07 21 at 7.09.59 PM

 

Depending on your system the hex codes are as follows:

 

Posted by: itsage

Until the author of tb3-enabler updates the script, you can manually modify IOThunderboltFamily.kext to accomplish the same thing. Read my instructions in an earlier response.

For macOS Sierra 10.12.x

55 48 89 E5 41 57 41 56 41 55 41 54 53 48 81 EC 38 01 
55 48 89 E5 31 C0 5D C3 41 55 41 54 53 48 81 EC 38 01

For macOS High Sierra 10.13.x

55 48 89 E5 41 57 41 56 41 55 41 54 53 48 81 EC 28 01 
55 48 89 E5 31 C0 5D C3 41 55 41 54 53 48 81 EC 28 01

 

I could not get a Razer Core and AMD 570 to work in Sierra 10.12.6. 

I updated to High Sierra and got it working twice both in PB5 and PB6.

Final cut Pro does not work though, due to Intel Accelerated Graphics switching not supported with AMD 570 (Or something like that still researching but not a major issues for me to try to resolve it)

With AMD cards, you should be fine just doing the HEX edit, then restarting, plugging in EGPU and it telling you to log out and log back in.

I do the same like the quote but why it doesn't work?

Pending: Add my system information and expected eGPU configuration to my signature to give context to my posts


ReplyQuote
fledged
(@fledged)
Active Member
Joined: 2 years ago
 

this helps you to enable tb3 equipments with TI82, eg. enclosure like razor core shows Unsupported in system report

make sure your enclosure is compatible with macOS/if not u need to disable SIP and do the quote content

if you can see your enclosure working but still no card appear in Graphics/Displays

check the connectivity of enclosure and graphic card

make sure u r using AMD cards with 10.13 or higher, there is no solution for nvidia cards (for now? maybe)

Pending: Add my system information and expected eGPU configuration to my signature to give context to my posts


ReplyQuote
(@hoangphuc_nguyen)
New Member
Joined: 2 years ago
 
Posted by: fledged

this helps you to enable tb3 equipments with TI82, eg. enclosure like razor core shows Unsupported in system report

make sure your enclosure is compatible with macOS/if not u need to disable SIP and do the quote content

if you can see your enclosure working but still no card appear in Graphics/Displays

check the connectivity of enclosure and graphic card

make sure u r using AMD cards with 10.13 or higher, there is no solution for nvidia cards (for now? maybe)

hi, i connect my razer with my macbook, it doesnt appear Unsupported, and i saw in your picture, u use GTX titan x,and it work so why no solution for nvidia cards? i have GTX 980 ti

Pending: Add my system information and expected eGPU configuration to my signature to give context to my posts


ReplyQuote
tbl777
(@tbl777)
Trusted Member
Joined: 2 years ago
 
Posted by: HoangPhuc Nguyen
Posted by: fledged

this helps you to enable tb3 equipments with TI82, eg. enclosure like razor core shows Unsupported in system report

make sure your enclosure is compatible with macOS/if not u need to disable SIP and do the quote content

if you can see your enclosure working but still no card appear in Graphics/Displays

check the connectivity of enclosure and graphic card

make sure u r using AMD cards with 10.13 or higher, there is no solution for nvidia cards (for now? maybe)

hi, i connect my razer with my macbook, it doesnt appear Unsupported, and i saw in your picture, u use GTX titan x,and it work so why no solution for nvidia cards? i have GTX 980 ti

Are you capable of distinguishing MACOSX10.13 or WIN10?

IF you have, you should know no-go for Nvidia in 10.13, don't argue this, this is common sense.

late-2013 15" MacBook Pro GT750M + RX580@16Gbps-TB2 (AKiTiO thunder 2) + macOS 10.13


ReplyQuote
fledged
(@fledged)
Active Member
Joined: 2 years ago
 

notice that nvidia cards are not compatible with macOS 10.13
but thanks to goalque, it is possible to use them in 10.12 or earlier
i have a back-up-system of 10.12.6 with external ssd and win10 with another external ssd...so i just attach one and restart when i need
its not convenient but efficient, i just don't need eGPU for all the time

if ur MacBook is running 10.12.6 or lower, GTX980ti shall work,
otherwise, u shall downgrade, or wait like any other does here

Pending: Add my system information and expected eGPU configuration to my signature to give context to my posts


ReplyQuote
(@hoangphuc_nguyen)
New Member
Joined: 2 years ago
 
Posted by: fledged

hey there

 

I’m new here

forgive my poor english plz

hope that u guys could catch me..

 

i brought a brand new 15” MacBook pro with AMD Radeon Pro 560

and i got a Razer Core with TITAN BLACK

 

the problem is that core can’t be used in both 10.13 (internal SSD) or 10.12.6 (external SSD, i build a system for spare)

 

Core - Unsupported:

 

  Vendor Name: Razer

  Device Name: Core - Unsupported

  Vendor ID: 0x127

  Device ID: 0x215

  Device Revision: 0x1

  UID: 0x80864F4098291510

  Route String: 1

  Firmware Version: 16.16

 

i heard that 10.13 officially support eGPU so i updated to 10.13 as soon as i get my new mac

but the fact is this doesn’t work

 

i also tried automate-eGPU in 10.12.6 but it returns:

 

bash-3.2# /Users/FledgeD/Desktop/automate-eGPU.sh 

Thunderbolt device is connected, but no external GPUs detected.

or

bash-3.2# /Users/FledgeD/Desktop/automate-eGPU.sh -a

Application support path not found. Please install automate-eGPU first.

 

and Rastafabi's eGPU Enabler: nothing changes

 

 

but it do work in windows i installed in another external ssd perfectly

no code 12

i tried crysis3 and Davinci Resolve Studio and i think the eGPU do works

 

May i ask if there is any solution for MacBook pro 2017 with Razer Core

 

thank you🙏 

even thought I can't connect razer core with My MacBook Pro, but it should appear Core - Unsupported like yours, but mine, it doesn't show like that!

Pending: Add my system information and expected eGPU configuration to my signature to give context to my posts


ReplyQuote
Lukas
(@lukas)
New Member
Joined: 2 years ago
 

Hi

Could you send step by step how to connect a macbook pro 2017 15 inch to the razer core with a gtx 1070 on bootcamp

Pending: Add my system information and expected eGPU configuration to my signature to give context to my posts


ReplyQuote