Kryptonite: eGFX Support for All Thunderbolt Macs with FileVault, SIP, and ART E...
 
Notifications
Clear all

Kryptonite: eGFX Support for All Thunderbolt Macs with FileVault, SIP, and ART Enabled on macOS + Windows  

 of  30
  RSS

Yukikaze
(@yukikaze)
Noble Member Moderator
Joined: 5 years ago
 

@mac_editor, oh, right. I saw that post-install section but I was doing this setup on-and-off for a long time due to work and I forgot all about it by the time I finished. Thanks for the reminder!

 

Want to output 4K@60Hz out of an old system on the cheap? Read here.
Give your Node Pro a second Thunderbolt3 controller for reliable peripherals by re-using a TB3 dock (~50$).

"Always listen to experts. They'll tell you what can't be done, and why. Then do it."- Robert A. Heinlein, "Time Enough for Love."

 
2012 Mac Mini [3rd,4C,Q] + RX 480 @ 10Gbps-TB1 (Atto Thunderlink) + macOS 10.15.7 [build link]  


ReplyQuote
Jeducious
(@jeducious)
New Member
Joined: 3 weeks ago
 

Hello from Australia everyone in the eGPU.io community. I've recently joined the forum after getting into using eGPUs. Long story short though, my name is James and I am a software dev, Blender user and founder of Crowdrender which makes software for distributing 3d rendering over a network.

I got an eGPU as part of working on a partnership with a local PC retailer. We're making videos with their gear. Since I have a MacBook, and its a bit of Potato now being 6-7 years old, I managed to get a Razer Core X to test. We've been playing with purge-wrangler and Kryptonite and its been really great to be able to use a real GPU with the MacBook.

So thats me/Crowdrender. What I'd really like to ask though, is to get in touch with Mayank K, he just posted a comment on a video tutorial I did on setting up Kryptonite with a MacBook pro and I'd like to be able to ask a few Q's Smile

Thanks everyone!

 

Hi @mac_editor, ummmm, I just did an introduction post, but it seems to have been moved to this topic. Was that supposed to happen? 

Macbook Pro Retina early 2015, Razer Core X + Gigabyte Aorus 5700XT 8GB


ReplyQuote
PsyPryss
(@psypryss)
Trusted Member
Joined: 4 years ago
 

Kryptonite doesn't seem to be working with OCLP 0.2.5. Beware. Can't do more troubleshooting as my internal screen is almost shot... 0.2.4 works with 1.0.0 it but haven't tested with Kryptonite 1.0.1. Thanks @mac_editor for your work.

@jeducious, This is where you ask about Kryptonite and it's solutions.

 

Update: Kryptonite does work perfectly with OCLP 0.2.4 and 0.2.5.

This post was modified 2 weeks ago

Mid 2012 15" (Non-Retina) MBP GT650M (macbookpro9,1) + RX580 (AKiTio Node via TB3 -> TB2/TB1 Adaptor) via OCLP -> Kryptonite
macOS 11.4(20F71)/Win10(20H71)


ReplyQuote
mac_editor
(@mac_editor)
Famed Member Moderator
Joined: 5 years ago
 
Posted by: @jeducious

What I'd really like to ask though, is to get in touch with Mayank K, he just posted a comment on a video tutorial I did on setting up Kryptonite with a MacBook pro and I'd like to be able to ask a few Q's

Ask away (I posted the comment), but read this wiki in case your questions are already addressed: https://github.com/mayankk2308/kryptonite/wiki

Posted by: @jeducious

Hi @mac_editor, ummmm, I just did an introduction post, but it seems to have been moved to this topic. Was that supposed to happen?

Perhaps someone else may have moved it, I’m not sure. But you’d have better visibility here if you want to discuss kryptonite (plus other users can chime in).

@psypryss yeah it seems they made significant changes including legacy acceleration patches. In case you find a solution, do let me know. If I have time, I’ll attempt to investigate myself.

"Desultory reading is delightful, but to be beneficial, our reading must be carefully directed." — Seneca

Author: kryptonitepurge-wranglertbt-flashpurge-nvdaset-eGPU
Insights Into macOS Video Editing Performance
Launching Apps on Specific (e)GPUs on macOS

Master Threads:
2014 15-inch MacBook Pro 750M
2018 15-inch MacBook Pro

 
2019 13" MacBook Pro [8th,4C,U] + RX Vega 64 @ 32Gbps-TB3 (Mantiz Venus) + macOS 10.14.6 & Win10 [build link]  


ReplyQuote
nu_ninja
(@nu_ninja)
Reputable Member
Joined: 4 years ago
 

Just chiming in to say I installed macOS 11.6 on my old 2012 13" MBP and it's working fine with OCLP 0.2.4 and Kryptonite 1.0.1. I'll try OCLP 0.2.5 when I get a chance

Mid-2012 13" Macbook Pro (MacBookPro9,2) TB1 -> RX 460/560 (AKiTiO Node/Thunder2)
+ macOS 10.15+Win10 + Linux Mint 19.1

 
2012 13" MacBook Pro [3rd,2C,M] + RX 460 @ 10Gbps-TB1 (AKiTiO Thunder2) + macOS 10.14.4 [build link]  


ReplyQuote
PsyPryss
(@psypryss)
Trusted Member
Joined: 4 years ago
 

@mac_editor, Alright. But unlikely for now. I can't even see the apple logo during boot! Imagine having to use the boot picker blind. The internal screen's almost dead. Debating whether to replace or wait and get a complete new system. A waste though. The 2012 is highly upgradeable. But runs super hot. Thanks mac_editor.

 

This post was modified 3 weeks ago

Mid 2012 15" (Non-Retina) MBP GT650M (macbookpro9,1) + RX580 (AKiTio Node via TB3 -> TB2/TB1 Adaptor) via OCLP -> Kryptonite
macOS 11.4(20F71)/Win10(20H71)


ReplyQuote
PsyPryss
(@psypryss)
Trusted Member
Joined: 4 years ago
 

@nu_ninja, You're lucky you have that one. The nvidia iGPU is so....urgh!

 

Mid 2012 15" (Non-Retina) MBP GT650M (macbookpro9,1) + RX580 (AKiTio Node via TB3 -> TB2/TB1 Adaptor) via OCLP -> Kryptonite
macOS 11.4(20F71)/Win10(20H71)


ReplyQuote
omsine
(@omsine)
New Member
Joined: 3 weeks ago
 

BRAVO! new member here - Kryptonite works like a charm on my 2014 imac so far, with the internal monitor - seems a bit snappier and more responsive overall than with purge-wrangler. ~70fps on dota 2 at max graphics, similar performance on blizzard games with similar high end settings. build is in my sig, i will be doing a build guide when i get this fully wrapped, for the culture!

THANK YOU to @mac_editor and all of the other mods for your ongoing efforts and support, i have never quite seen anything like it the way y'all support this community! 

a note: i had to uninstall kryptonite in order to install Bootcamp / windows 12 - i was getting an error that the Bootcamp installer could not read the Assistant-created BOOTCAMP partition. uninstalling Kryptonite allowed me install Windows 10 / Bootcamp, and then I was able to successfully reinstall Kryptonite with no issues + confirmed eGPU connection & performance stability on macOS still.

and now, for a question: does anybody have any insights on getting the same eGPU performance on Bootcamp as in Mac OS? i am currently attempting windows 10 v1903 with November 2019 cumulative from bootcampdrivers.com, doing DDU in safe mode in between radeon driver attempts - my eGPU is currently recognized in windows device manager, but has code/error 12, and is also not recognized in this specific version of the Radeon software - radeon software is only recognizing the dGPU. i am trying the SSDT override tonight to see if that resolves it, and will attempt DSDT if that doesnt do it, from the post-install section on the Kryptonite wiki. any suggestions otherwise? ill take anything i can get at this point - been banging my head against this all week trying to get it to work. 

brief side note on this: i just wanna mention it because i thought this was odd; when i initially tried to get the eGPU working on Bootcamp, [when i was still using purge-wrangler, before upgrading to Kryptonite] i installed to the latest version of windows 10 and AMD drivers [because im a dummy and didnt do my due diligence] and the EGPU showed up both in the Radeon software, in the device manager, and in the Windows graphics settings for forcing high performance mode to specific apps - but when i launched an application, the game's video output to the screen was very lagged and choppy in-menu, 1-2 second delay on things loading when buttons were pressed, screen tearing, etc. - couldn't even try to load into the actual game beyond the menu. i do not recall it being yellow-banged with code 12 in the device manager at that point, either, but of course i could be mistaken. at that point i couldn't figure out how to get the eGPU to latch either, and thats where i decided to backtrack and upgrade from purge-wrangler to kryptonite to see if that made a difference [and subsequently discovered there was a methodical practice using earlier windows / bootcampdrivers, which brings me to here, now!]

thank you for your time and assistance, any insights are appreciated, i wish you all a lovely day, evening, and weekend :]

2014 27" iMac 5K (R9 M295X) [4th,4C,K] + RX 5700 XT @ 16Gbps-TB2>TB3 (Razer Core X) + macOS 11.6 & Win10 20H2 [build link]  

ReplyQuote
mac_editor
(@mac_editor)
Famed Member Moderator
Joined: 5 years ago
 

@omsine, most of your issues (except error 12) are probably due to OpenCore quirks so unfortunately not much I can do about it. I’d imagine as OpenCore matures further, such issues may get resolved.

Your egpu performance issues (also not related to purge-wrangler/Kryptonite) belong in a separate thread so I recommend a separate post. Although we can go there once you have a stable setup in Windows. For error 12, one thing to try before SSDT would be to set SignalAppleOS (should be in wiki) to true and see what happens.

 

"Desultory reading is delightful, but to be beneficial, our reading must be carefully directed." — Seneca

Author: kryptonitepurge-wranglertbt-flashpurge-nvdaset-eGPU
Insights Into macOS Video Editing Performance
Launching Apps on Specific (e)GPUs on macOS

Master Threads:
2014 15-inch MacBook Pro 750M
2018 15-inch MacBook Pro

 
2019 13" MacBook Pro [8th,4C,U] + RX Vega 64 @ 32Gbps-TB3 (Mantiz Venus) + macOS 10.14.6 & Win10 [build link]  


ReplyQuote
omsine
(@omsine)
New Member
Joined: 3 weeks ago
 

@mac_editor, hey thank you for your swift response!

interestingly enough, the plot thickens...

when i got home, woke the computer [it was asleep in W10 from last night] it had auto-downloaded the latest Windows 10 Update: 20H2

I restarted it, it updated, booted, and immediately AMD XConnect popped up. I almost didn't believe it. AMD Software now shows the eGPU and all its specs, the eGPU shows up in Device Manager WITHOUT error 12, and is able to have apps dedicated to it in Graphics Settings. I am running it on Diablo 2: Resurrected right now.

I do not understand. Lol. What just happened?! 

 

2014 27" iMac 5K (R9 M295X) [4th,4C,K] + RX 5700 XT @ 16Gbps-TB2>TB3 (Razer Core X) + macOS 11.6 & Win10 20H2 [build link]  

ReplyQuote
 of  30