Kryptonite: eGFX Support for All Thunderbolt Macs with FileVault, SIP, and ART E...
 
Notifications
Clear all

Kryptonite: eGFX Support for All Thunderbolt Macs with FileVault, SIP, and ART Enabled on macOS + Windows  

 of  30
  RSS

mac_editor
(@mac_editor)
Famed Member Moderator
Joined: 5 years ago
 
Posted by: @omsine

What just happened?! 

Welcome to bootcamp eGPUs 😉

I’m not up to speed on what’s going on with Bootcamp these days but it is definitely possible that recent versions of Windows may have fixed some stuff. Would be best for you to note your configuration at the moment and create a build.

"Desultory reading is delightful, but to be beneficial, our reading must be carefully directed." — Seneca

Author: kryptonitepurge-wranglertbt-flashpurge-nvdaset-eGPU
Insights Into macOS Video Editing Performance
Launching Apps on Specific (e)GPUs on macOS

Master Threads:
2014 15-inch MacBook Pro 750M
2018 15-inch MacBook Pro

 
2019 13" MacBook Pro [8th,4C,U] + RX Vega 64 @ 32Gbps-TB3 (Mantiz Venus) + macOS 10.14.6 & Win10 [build link]  


PsyPryss and omsine liked
ReplyQuote
Yukikaze
(@yukikaze)
Noble Member Moderator
Joined: 5 years ago
 

@mac_editor and/or @itsage - Question: Do you know if the Quadro K1200 (GM107 chip on that one) works in Catalina if I were to run with Kryptonite? Does the RX550 work?

Want to output 4K@60Hz out of an old system on the cheap? Read here.
Give your Node Pro a second Thunderbolt3 controller for reliable peripherals by re-using a TB3 dock (~50$).

"Always listen to experts. They'll tell you what can't be done, and why. Then do it."- Robert A. Heinlein, "Time Enough for Love."

 
2012 Mac Mini [3rd,4C,Q] + RX 480 @ 10Gbps-TB1 (Atto Thunderlink) + macOS 10.15.7 [build link]  


ReplyQuote
mac_editor
(@mac_editor)
Famed Member Moderator
Joined: 5 years ago
 

@yukikaze, neither would work.

https://github.com/mayankk2308/kryptonite/wiki/Compatibility#maxwellpascal-gtx-9xx10xx-gpus

RX 550 has no macOS drivers.

 

"Desultory reading is delightful, but to be beneficial, our reading must be carefully directed." — Seneca

Author: kryptonitepurge-wranglertbt-flashpurge-nvdaset-eGPU
Insights Into macOS Video Editing Performance
Launching Apps on Specific (e)GPUs on macOS

Master Threads:
2014 15-inch MacBook Pro 750M
2018 15-inch MacBook Pro

 
2019 13" MacBook Pro [8th,4C,U] + RX Vega 64 @ 32Gbps-TB3 (Mantiz Venus) + macOS 10.14.6 & Win10 [build link]  


Yukikaze liked
ReplyQuote
bitnaut
(@bitnaut)
Active Member
Joined: 1 year ago
 

As part of switching from PurgeWrangler to Kryptonite, I need to restore my macOS without data loss. However, I’m on the latest Monterey beta. Will the Apple Restore function put me back to Big Sur or keep me on the latest beta?

Mac Pro 6,1 12 core with 64GB RAM, 2TB disk and dual D500 running latest MacOS Big Sur beta. Hooked to a Razer Core X with Radeon VII


ReplyQuote
Yukikaze
(@yukikaze)
Noble Member Moderator
Joined: 5 years ago
 
Posted by: @mac_editor

@yukikaze, neither would work.

https://github.com/mayankk2308/kryptonite/wiki/Compatibility#maxwellpascal-gtx-9xx10xx-gpus

RX 550 has no macOS drivers.

 

Drat. Thanks. Wanted something to tide me over until my RX480 setup could be permanent.

What about a FirePro W600? Would that work?

 

Want to output 4K@60Hz out of an old system on the cheap? Read here.
Give your Node Pro a second Thunderbolt3 controller for reliable peripherals by re-using a TB3 dock (~50$).

"Always listen to experts. They'll tell you what can't be done, and why. Then do it."- Robert A. Heinlein, "Time Enough for Love."

 
2012 Mac Mini [3rd,4C,Q] + RX 480 @ 10Gbps-TB1 (Atto Thunderlink) + macOS 10.15.7 [build link]  


ReplyQuote
mac_editor
(@mac_editor)
Famed Member Moderator
Joined: 5 years ago
 
Posted by: @yukikaze

What about a FirePro W600? Would that work?

As the wiki says, if it can work natively in a Mac Pro PCIe slot, it may work as eGPU. AFAIK the W600 doesn’t unless someone has managed to make it work (I don’t know).

"Desultory reading is delightful, but to be beneficial, our reading must be carefully directed." — Seneca

Author: kryptonitepurge-wranglertbt-flashpurge-nvdaset-eGPU
Insights Into macOS Video Editing Performance
Launching Apps on Specific (e)GPUs on macOS

Master Threads:
2014 15-inch MacBook Pro 750M
2018 15-inch MacBook Pro

 
2019 13" MacBook Pro [8th,4C,U] + RX Vega 64 @ 32Gbps-TB3 (Mantiz Venus) + macOS 10.14.6 & Win10 [build link]  


Yukikaze liked
ReplyQuote
Yukikaze
(@yukikaze)
Noble Member Moderator
Joined: 5 years ago
 

@mac_editor, I checked the wiki and tried to get some information about it on various Mac forums, but it is pretty confusing. It seems like the W4100 (same graphics core as the W600) works with some kext tweaks, the W600 is barely mentioned anywhere, but the lists of AMD drivers in OS X included the graphics core, so I wasn't sure if it works or not.

The same with the K1200 - Even though it is a Maxwell chip, I saw that people got a K620 to work (which is also a GM107), and it is technically a part of a the 7th gen cards, so again not clear whether that worked or not.

There's even conflicting info on the RX550 out there :/

I guess I'll just wait to mod my Thunderlink into a permanent solution as I ran out of spare cards to consider Smile

 

This post was modified 3 weeks ago

Want to output 4K@60Hz out of an old system on the cheap? Read here.
Give your Node Pro a second Thunderbolt3 controller for reliable peripherals by re-using a TB3 dock (~50$).

"Always listen to experts. They'll tell you what can't be done, and why. Then do it."- Robert A. Heinlein, "Time Enough for Love."

 
2012 Mac Mini [3rd,4C,Q] + RX 480 @ 10Gbps-TB1 (Atto Thunderlink) + macOS 10.15.7 [build link]  


ReplyQuote
mac_editor
(@mac_editor)
Famed Member Moderator
Joined: 5 years ago
 

@yukikaze, you can reference https://dortania.github.io/GPU-Buyers-Guide/modern-gpus/amd-gpu.html#native-amd-gpus for a list of AMD GPUs you could try to get working (not guaranteed to function appropriately as eGPU). I’ve heard W4100 is similar to HD 7750 (I know that HD 7750 can be made to work in macOS via WhateverGreen). Whether it’ll work for you - idk. All 3 GPUs have different device ID so might need spoofing (which WhateverGreen can do I think).

Regarding Maxwell, please share source of someone who got it working in Catalina. Maxwell is only supported on High Sierra latest.

There are 2 RX 550 variants. Lexa variant is not supported while Polaris (Baffin) variant could work: https://dortania.github.io/GPU-Buyers-Guide/buyers-guide/gpu-avoid.html#powercolor

@bitnaut macOS can’t be downgraded unless you erase data and version depends on what recovery version you have and latest full installer available.

"Desultory reading is delightful, but to be beneficial, our reading must be carefully directed." — Seneca

Author: kryptonitepurge-wranglertbt-flashpurge-nvdaset-eGPU
Insights Into macOS Video Editing Performance
Launching Apps on Specific (e)GPUs on macOS

Master Threads:
2014 15-inch MacBook Pro 750M
2018 15-inch MacBook Pro

 
2019 13" MacBook Pro [8th,4C,U] + RX Vega 64 @ 32Gbps-TB3 (Mantiz Venus) + macOS 10.14.6 & Win10 [build link]  


ReplyQuote
Yukikaze
(@yukikaze)
Noble Member Moderator
Joined: 5 years ago
 

@mac_editor, my RX50 is unfortunately a Lexa (512SP). About the K620, I was mistaken - I confused 10.12 with 10.14, and was sure it was Mojave that they got it working on, rather than Sierra.

 

Want to output 4K@60Hz out of an old system on the cheap? Read here.
Give your Node Pro a second Thunderbolt3 controller for reliable peripherals by re-using a TB3 dock (~50$).

"Always listen to experts. They'll tell you what can't be done, and why. Then do it."- Robert A. Heinlein, "Time Enough for Love."

 
2012 Mac Mini [3rd,4C,Q] + RX 480 @ 10Gbps-TB1 (Atto Thunderlink) + macOS 10.15.7 [build link]  


ReplyQuote
cnon297
(@cnon297)
Trusted Member
Joined: 2 years ago
 

@mac_editor, my kryptonite install works great with my eGPU with one exception.  The 2012 15" MBPro High-res display is never recognized and is stuck on the macOS boot screen.  

I manually entered the MUX command from the post-install docs.  And I enabled Debug on the last install if that helps.  Is there anything more I can do to get the display working?  Thx!

2012 15" MacBook Pro hi res, 2.7GHz 4C i7, GT650M + Vega 56 eGPU
2009 Mac Pro 5,1 6-core Xeon 3.46GHz + HD 7970OC

 
2014 Mac Mini [4th,2C,U] + RX Vega 56 @16Gbps-TB2>TB3 (AKiTiO Node) + macOS 10.14.6 [build link]  


ReplyQuote
 of  30