Late 2013 15" MBPr w/ GT 750m - Mac OS Sierra - RX 460/470/480
 
Notifications
Clear all

Late 2013 15" MBPr w/ GT 750m - Mac OS Sierra - RX 460/470/480  

  RSS

zhutson24
(@zhutson24)
Active Member
Joined: 3 years ago
 

In the past I was successful in running an GTX 750ti eGPU setup with the Late 2013 15" MBPr w/ GT 750m in both Mac OS Sierra 10.12-10.12.2 and Windows 10.  I was unable to get Optimus working in Win10, but that was fine as I had dual external monitors at home for productivity/gaming.  The setup worked for Mac OS Sierra (up to 10.12.2) for FCPX/iMovie video editing/rendering without the need of an external display as I used a 1080p Headless plugged in the GPU.

I looked to upgrading and bought the ZOTAC GTX 1060 3gb.  Worked in Win10 with a performance bump.  However, I didn't do enough research beforehand for its compatibility with Mac OS.  So I just used the eGPU on Win10 for gaming and dealt with the GT 750m for Mac OS applications (iMovie/FCPX).  I did notice gaming on the MBPr in Win10 was consistently hot and in interest of prolonging the life of the MBPr I built a dualboot Skylake Hackintosh with a RX 480 for my video editing in Mac OS and 1080p gaming in Win10.  Works like a charm.

With no Pascal support in Mac OS still (4/5/17) and with an increase in video work, I wanted to try an upgrade again to my eGPU setup for a traveling workstation.  My current GTX 750ti just isn't providing enough performance boost over the internal GT 750m as iMovie/FCPX are favoring AMD RX GPUs.  I found that the RX 460 has similar to slight improved gaming performance to the GTX 750ti and is optimized for Mac OS productivity.  

However, I am stuck in the situation of my MBPr is running the Mac OS 10.12.4.  The V.1.0 automate.sh works without any errors after I had it point to the AMD9510Controller.kext rather than the 9500, but after restart neither the external display works nor does a 1080p headless plugged in the RX 460 work.  So I tried the it on a Mac OS 10.12.3 install on both a Macbook Air (~2011) and my MBPr; however, to no avail.  I was sure to uninstall and reinstall a fresh automate.sh.

Now I am attempting to locate a Mac OS 10.12.2 installer as I didn't save one from the App Store when they were downloadable.  I am also trying to migrate a TimeMachine backup of my Macbook Air onto an external SSD to boot my MBPr from and try again.  I don't have a 10.12.2 TimeMachine backup for my MBPr (big mistake, I know).

All help would be much appreciated!  I will keep posted if Macbook Air Mac OS 10.12.2 TimeMachine to SSD works.

Late 2013 15" MBPr w/ GT 750m - RX 460 4GB - Akitio Thunderbolt 2 Enclosure - Windows 10 - Mac OS 10.12.4
Node 202 Skylake Hackintosh - i5 6600k - RX 480 8GB - 16GB DDR4 - Dual Boot - Mac OS 10.12.3 - Windows 10


ReplyQuote
exam23
(@exam23)
Trusted Member
Joined: 3 years ago
 

This seems to be a common theme.  Mac OS 10.2.4 is something that us eGPU guys need to stay away from as of current.  

We would all truly appreciated when someone get us thru this hurdle...

Until then, DO NOT push UPDATE & INSTALL!!!

Pending: Add my system information and expected eGPU configuration to my signature to give context to my posts


ReplyQuote
mac_editor
(@mac_editor)
Famed Member Moderator
Joined: 3 years ago
 

Success in using RX 480 4GB with macOS 10.12.4 + Final Cut Pro Acceleration + Windows 10 (Latest) without DSDT + 100% boot success rate on Mid 2014 MBP with 750M. Implementation guide will be up soon. This was SO EASY to setup!

UPDATE: As already pointed out by @zhutson24 - the guide is available here.

purge-wranglertbt-flashpurge-nvdaset-eGPU
Insights Into macOS Video Editing Performance
2018 MacBook Pro 15" RP560X + RX 5700 XT (Mantiz Venus)

Master Threads:
2014 15-inch MacBook Pro 750M
2018 15-inch MacBook Pro


Rapunzel, Antharsious, zhutson24 and 2 people liked
ReplyQuote
Rapunzel
(@rapunzel)
Eminent Member
Joined: 3 years ago
 

Please tell us what you did to succeed!

Pending: Add my system information and expected eGPU configuration to my signature to give context to my posts


ReplyQuote
Kristera
(@kristera)
New Member
Joined: 3 years ago
 

Please keep us updated with a guide if possible as well! Also congrats! 

Pending: Add my system information and expected eGPU configuration to my signature to give context to my posts


ReplyQuote
zhutson24
(@zhutson24)
Active Member
Joined: 3 years ago
 
Posted by: Kristera

 

Please keep us updated with a guide if possible as well! Also congrats! 

   

Check this implementation: https://egpu.io/forums/builds/mid-2014-macbook-pro-w-750m-rx-480-akitio-node-on-macos-win-10/#post-6810

I'm not having any luck yet, but will keep updated.

Late 2013 15" MBPr w/ GT 750m - RX 460 4GB - Akitio Thunderbolt 2 Enclosure - Windows 10 - Mac OS 10.12.4
Node 202 Skylake Hackintosh - i5 6600k - RX 480 8GB - 16GB DDR4 - Dual Boot - Mac OS 10.12.3 - Windows 10


ReplyQuote