late-2016 13" MBP + Quadro M2000/FirePro WX5100/GTX750-TB3 (AKiTiO Thunder3) + m...
 
Notifications
Clear all

late-2016 13" MBP + Quadro M2000/FirePro WX5100/GTX750-TB3 (AKiTiO Thunder3) + macOS 10.12.3 [mehenn]^  

 of  4
  RSS

enjoy
(@enjoy)
Reputable Member
Joined: 4 years ago
 

US$234 HighPoint RocketStor 6361A Thunderbolt 2 PCIe (16Gbps-TB2)  

Is perfect for WX 5100 but TB2 🙁

 

 

 

MacBook Pro (Retina, 15-inch, Later 2013) 3.2GHz Quad Core Intel i7-4750HQ / 8 GB 1600 MHz DDR3 / 256GB SSD + 1TB
mini eGPUPCI Express vs. ThunderboltMac CAN gameGaming Laptops vs. MacBook Pro with eGPU

 
2012 13" MacBook Air [3rd,2C,U] + GTX 1060 @ 10Gbps-TB1 (AKiTiO Thunder2) + macOS 10.12 // external HDD Windows [build link]  


ReplyQuote
harkonnen
(@mehenn)
Estimable Member
Joined: 4 years ago
 

I let go of my old eGPU and now I MUST go for the TB3 enclosure. Ordered the WX5100 and will arrive by friday. Hopefully I will be able to make it run.

As a wrap-up:

  • Disable SIP via recovery mode - already done for previous eGPU
  • Use this tool to enable TB3 connectivity
  • Run the v1.0 of the automate-GPU
  • Brace myself and hope to work

Did I miss anything? Also I've read on @ikir's thread that he:

Optional run script for unlocking all Baffin units to boooooooost OpenCL

What is that?

late-2016 13" Macbook Pro + [email protected] (TB3 to TB2 adapter) (AKiTiO Thunder2) + macOS 10.12.3
late-2016 13" MBP + Quadro M2000/FirePro WX5100/GTX750-TB3 (AKiTiO Thunder3) + macOS 10.12.3
(Custom Thunder cables)

 
2016 13" MacBook Pro [6th,2C,U] + GTX 980 @ 16Gbps-TB3>TB2 (AKiTiO Thunder2) + macOS 10.12.3 [build link]  


ReplyQuote
harkonnen
(@mehenn)
Estimable Member
Joined: 4 years ago
 

Update time.

Ran the TB3 enabler script and I got an error (the 3 patches ran ok):

symlink("/System/Library/PrelinkedKernels/prelinkedkernel", "/System/Library/Caches/com.apple.kext.caches/Startup/kernelcache") failed 17 (File exists) <createPrelinkedKernel 2795>

But after reboot it seems that the TB3 enclosure is no longer unsupported. That means that I am now ready to insert the GPU once arrives?

Screen Shot 2017 03 01 at 6.18.15 PM

late-2016 13" Macbook Pro + [email protected] (TB3 to TB2 adapter) (AKiTiO Thunder2) + macOS 10.12.3
late-2016 13" MBP + Quadro M2000/FirePro WX5100/GTX750-TB3 (AKiTiO Thunder3) + macOS 10.12.3
(Custom Thunder cables)

 
2016 13" MacBook Pro [6th,2C,U] + GTX 980 @ 16Gbps-TB3>TB2 (AKiTiO Thunder2) + macOS 10.12.3 [build link]  


ReplyQuote
ikir
 ikir
(@ikir)
Prominent Member
Joined: 4 years ago
 

@Mehenn

There is a thread made by goalque which enable all gnu cores to boost OpenCL https://egpu.io/forums/mac-setup/enable-baffin-cus-sh-script/

About you error... cache? From your script it seems supported now.


MacBook Pro 13" 2020 Touch Bar M1 8-core CPU 8-core GPU - 16GB unified memory - 512GB PCIe SSD
MacBook Pro 13" 2020 Touch Bar i7 quad-core 2.3Ghz - 16GB RAM - 1TB PCIe SSD

my awesome Radeon VII eGPU
my Mantiz Venus extreme mod with Sapphire Nitro+ RX Vega 64

 
2018 13" MacBook Pro [8th,4C,U] + Radeon VII @ 32Gbps-TB3 (Mantiz Venus) + macOS 10.15 [build link]  


ReplyQuote
harkonnen
(@mehenn)
Estimable Member
Joined: 4 years ago
 

Ok, so the WX5100 is in, running, but slow as a snail... It is reportedly using 14CUs...


Later edit

Edited main post with new info/pics

late-2016 13" Macbook Pro + [email protected] (TB3 to TB2 adapter) (AKiTiO Thunder2) + macOS 10.12.3
late-2016 13" MBP + Quadro M2000/FirePro WX5100/GTX750-TB3 (AKiTiO Thunder3) + macOS 10.12.3
(Custom Thunder cables)

 
2016 13" MacBook Pro [6th,2C,U] + GTX 980 @ 16Gbps-TB3>TB2 (AKiTiO Thunder2) + macOS 10.12.3 [build link]  


ReplyQuote
harkonnen
(@mehenn)
Estimable Member
Joined: 4 years ago
 

Rebooted, now it shows 28 Grin Wooo wooow


Later edit

Still sucky scoring (compared to 460's...)


Later later edit

I just noticed (based on the screen shot) that one of my screens is running in 30Hz... Damn! Will check it again while at home...

systeminfo

late-2016 13" Macbook Pro + [email protected] (TB3 to TB2 adapter) (AKiTiO Thunder2) + macOS 10.12.3
late-2016 13" MBP + Quadro M2000/FirePro WX5100/GTX750-TB3 (AKiTiO Thunder3) + macOS 10.12.3
(Custom Thunder cables)

 
2016 13" MacBook Pro [6th,2C,U] + GTX 980 @ 16Gbps-TB3>TB2 (AKiTiO Thunder2) + macOS 10.12.3 [build link]  


ikir liked
ReplyQuote
harkonnen
(@mehenn)
Estimable Member
Joined: 4 years ago
 

With deep sorrow and sadness I announce the fact that I returned the WX5100. I could not make it work better than a GTX 750Ti which kinda is not right. I am running a GTX 750Ti for now (one monitor plugged in the DP of the GPU and one in the DP of the Thundefr3 enclosure) and waiting to get a M2000 by friday. I will try it and it still works lower than expected, 750Ti will be.

Screen Shot 2017 03 08 at 11.42.03 PM

late-2016 13" Macbook Pro + [email protected] (TB3 to TB2 adapter) (AKiTiO Thunder2) + macOS 10.12.3
late-2016 13" MBP + Quadro M2000/FirePro WX5100/GTX750-TB3 (AKiTiO Thunder3) + macOS 10.12.3
(Custom Thunder cables)

 
2016 13" MacBook Pro [6th,2C,U] + GTX 980 @ 16Gbps-TB3>TB2 (AKiTiO Thunder2) + macOS 10.12.3 [build link]  


ReplyQuote
harkonnen
(@mehenn)
Estimable Member
Joined: 4 years ago
 

The Quadro M2000 arrived and its in. Worked from the 1st boot. That is the good news

?raw=1

?raw=1

Screen Shot 2017 03 12 at 11.25.12 AM

The sad news is that is working still way below expectations:

Screen Shot 2017 03 12 at 11.29.56 AM

?raw=1

?raw=1

I think those cards are just slow. I will try one more thing before deciding what to do next. I ordered 2 USB-C to mDP adapters and just connect the monitors in tha MBP and use the Intel Iris Graphics 550 card to power them up. If that works and gives kinda the same results in Valley (above 500, 600) will just see my TB3 enclosure and return the M2000. My mission (to build a compact and powerful) eGPU failed.

If the dGPU fails to perform, I think I will have no other option that to put my Dell DA-2 to work, chop the enclosure and make a modded one.

 

late-2016 13" Macbook Pro + [email protected] (TB3 to TB2 adapter) (AKiTiO Thunder2) + macOS 10.12.3
late-2016 13" MBP + Quadro M2000/FirePro WX5100/GTX750-TB3 (AKiTiO Thunder3) + macOS 10.12.3
(Custom Thunder cables)

 
2016 13" MacBook Pro [6th,2C,U] + GTX 980 @ 16Gbps-TB3>TB2 (AKiTiO Thunder2) + macOS 10.12.3 [build link]  


nando4 liked
ReplyQuote
harkonnen
(@mehenn)
Estimable Member
Joined: 4 years ago
 

I've got the 2 USB-C to mDP adapters, fired up my 2 monitors in 4k and they work. So I am suspending my quest to build an compact eGPU since I could not find any GPU that will consume only 75W, have 2 DP ports and run on MacOS on a decent $/performance ratio.

Screen Shot 2017 03 13 at 5.50.32 PM

?raw=1


Edited main post also

late-2016 13" Macbook Pro + [email protected] (TB3 to TB2 adapter) (AKiTiO Thunder2) + macOS 10.12.3
late-2016 13" MBP + Quadro M2000/FirePro WX5100/GTX750-TB3 (AKiTiO Thunder3) + macOS 10.12.3
(Custom Thunder cables)

 
2016 13" MacBook Pro [6th,2C,U] + GTX 980 @ 16Gbps-TB3>TB2 (AKiTiO Thunder2) + macOS 10.12.3 [build link]  


ReplyQuote
nando4
(@nando4)
Noble Member Admin
Joined: 4 years ago
 

@Mehenn, there are three 75W GTX950 cards available:

http://www.anandtech.com/show/10150/msi-geforce-gtx-950-gpu-75w-tdp-2gd5-ocv2-2gd5t-ocv3

GTX950 cards have HDMI 2.0 output (+DP) making it possible to drive your 2x4K displays within macOS using a Thunder3 enclosure.

eGPU Setup 1.35    •    eGPU Port Bandwidth Reference Table

 
2015 15" Dell Precision 7510 (Q M1000M) [6th,4C,H] + GTX 1080 Ti @32Gbps-M2 (ADT-Link R43SG) + Win10 1803 // compares M.2 vs TB3 performance inc unoptimized H-CPU BIOS [build link]  


ReplyQuote
 of  4