Setup & Software Discussions
late MacBook 2016 13' touch bar + gtx 1050ti + akitio node with node plugged and...
 

[Solved] late MacBook 2016 13' touch bar + gtx 1050ti + akitio node with node plugged and powered before boot, accelerate internal screen WORK!!  

  RSS

ddqp
 ddqp
(@ddqp)
Eminent Member
Joined: 2 years ago
 

Thanks first for forum. I finally make the egpu work. I switched from AMD card to GTX to make EGPU work in WIN10.

Here is my configuration hardware:

1. late 2016 macbook pro 13' touchbar

2. gtx1050ti

3. akitio node

4. macOS 10.12.3

5. Microsoft Windows [Version 10.0.10586] UEFI

6. GTX driver: 378.92-desktop-win10-64bit-international-whql

7. no external screen connected

Here is my issue:

1. can't boot to win with egpu connected and powered, it give me black screen, but keyboard is working, I have to hot plug egpu during boot up

2. if I try to use   https://github.com/0xbb/apple_set_os.efi, boot from USB, it still give me black screen

3. if I try to use your 10.12.4 new apple_set_os.efi version to boot from USB with gpu-swith run in win before reboot, it can get into win10, but in a while, GTX driver will crash, can make it work anymore

 

-------------------updated in 24 March-------------------------------

After days and nights try and error, I finally solved it by:

1. Install rEFInd 

2. using 10.12.4 new apple_set_os.efi version to boot from USB by rEFInd 

3. connect akitio node to the right top port and power it on before you turn on macbook, of cause you can power on the node when you see spin circle

that's it, no driver crash, no black screen, no BSOD, nickel.

When you find the solution you will see how easy is it. 

Why it's the right top TB port? I have no idea, but it works, the top left port won't work.

Here you are the video (LATER)

 

 

 

Late Macbook Pro 2016 13' touch bar + AKITIO node + GTX 1050TI 4G Windows


itsage and nando4 liked
ReplyQuote
exam23
(@exam23)
Trusted Member
Joined: 3 years ago
 

I have a nMP and getting the GTX card to recognize in WIN10 is pretty weird.  It was a hit and miss for me.  I would have everything plugged in, but with the eGPU powered down.

 

Q1 - You stated you have a black screen.  Are you in WIN10?  You cant see the second monitor which is the eGPU?  

 Q2 - Have you checked device manager under display to ensure GTX is connected, even if the second screen is black? 

Pending: Add my system information and expected eGPU configuration to my signature to give context to my posts


ReplyQuote
ddqp
 ddqp
(@ddqp)
Eminent Member
Joined: 2 years ago
 
Posted by: exam23

 

I have a nMP and getting the GTX card to recognize in WIN10 is pretty weird.  It was a hit and miss for me.  I would have everything plugged in, but with the eGPU powered down.

 

Q1 - You stated you have a black screen.  Are you in WIN10?  You cant see the second monitor which is the eGPU?  

 Q2 - Have you checked device manager under display to ensure GTX is connected, even if the second screen is black? 

   

actually, I don't have a second screen, only internal display with fake HDMI plugged in EGPU. So I don't know what happened with the second screen when internal display is black.

by the way, all my setup are in win or to get into win, GTX 10 series will not work in macOS

Late Macbook Pro 2016 13' touch bar + AKITIO node + GTX 1050TI 4G Windows


ReplyQuote
ddqp
 ddqp
(@ddqp)
Eminent Member
Joined: 2 years ago
 

Updated!

Late Macbook Pro 2016 13' touch bar + AKITIO node + GTX 1050TI 4G Windows


ReplyQuote