Setup & Software Discussions
Mac mini 2018, ASUS Station Pro, ASUS AREZ STRIX VEGA 56... not plug and play fo...
 

Mac mini 2018, ASUS Station Pro, ASUS AREZ STRIX VEGA 56... not plug and play for me (yet).  

  RSS

lostdawg
(@lostdawg)
New Member
Joined: 10 months ago
 

Hi all, was hoping my first post was going to be a big thank you for everything I read here and the knowledge gained to help me do what I did. Alas, it's still a big thank you but I'm stuck and could use some trouble shooting ideas.  I've read and read everything, but I can't find a duplicate of my issue that gets my set up going. And I wish to post this before I start poking around in the guts of the system.
System
Brand new Mac mini i7 10Gbe 8Gb,1 TB. Have not installed my 32GB ram yet, its just sitting here smirking at me. I wish to resolve this egpu problem first.
GPU is a brand new VEGA 56 (box was sealed and from reputable store). Wanted the Sapphire, but not paying that price.
ASUS Station Pro. (This thing is very nice, thanks to the forum for this. Very pleased.)
Monitor is a Dell 32inch 4K 60Hz wide gamut variety UP3216Q. It has HDMI supporting 4k, but DP and miniDP are 1.2 (which is still 4k). I have read 1.4 from card should be backward compatible. Of course this could be an issue. Though HDMI from card got zero signal to screen as well.

Problem - no signal from card to monitor.
from card I've tried HDMI to HDMI, DP to mini DP, DP to DP. Multiple cables of DP to DP and HDMI to HDMI. and the DP to mini DP worked fine with my laptop to this monitor.
The only cable I have not swapped is the T3 from the mini to the ASUS Station Pro.  However, the Mac mini recognizes the ASUS Station Pro completely. shows speed up to 40Gb/s x1, so thinking that T3 cable is fine.

Under system report -PCI (using DP from card to DP on monitor cable) and viewing with HDMI from Mac mini to monitor...
Card =display
Type = VGA-Compatible Controller 
Driver installed = yes and lists slot with the thunderbolt@72,0,0
Also lists Audio device (guessing because I'm using a DP cable)
and the USB eXtensible Host Controller

with "Display" highlighted it lists vendor ID 0x1002 (which matches what I have seen in other screen grabs on here for the vega card I think)

Now the odd part that I haven't seen or read in any posts...
in system report under Graphics/Display
Video Card = Display 
Type = external GPU
slot = blank
Second row lists the internal graphics intel uhd graphics 630

with the "Display" egpu highlighted, I have the following info
Type = external display
Bus = PCIe
PCIe Lane Width: = x16
VRAM (Dynamic, Max): = it is blank
VENDOR: = AMD (0x1002)
Device ID = 0x687f
Revision ID = 0x00c3

Have tried all four T3 ports on the mini, no change from any of them, so using closest to the HDMI port for all my testing tonight with the other cables.
The card seems to ramp up and spin the fans and is putting out heat like expected. Just can't seem to get a signal to go from the VEGA 56 to the monitor.
I did try using a second old monitor, but it only has HDMI. so couldn't test other cables to it. That didn't get me anywhere i.e. still no signal for my 32 inch screen.
I have not loaded anything extra yet so this is a virgin Mac mini. latest build 10.14.2 came installed. with an update to garage band and numbers and a few other things when first hooked up. All were apple items, so just let it do its thing.

Have not tried to put windows on yet, as I want to make sure this can work as is, if possible, before introducing other variables.

At the moment it seems like OS X either can't see the card correctly, or hasn't loaded the right driver. Was hoping it was cables but I think that is not the case after tonights testing. Or the card is a dud.  But I will have to go buy a T3 to T2 adaptor (and a T2 cable) for my 2013 MacBook Pro to test the "dud card" idea. 

Anyway, I think I put enough info into this that somebody might be able to say oh yeah, try this. Fingers crossed anyway.

And much thanks for this forum, its seriously cool how everyone seems to be even keeled about things. Which is nice.
 

 

2018 Mac Mini OS X 10.14.2 i7 32GB, 1TB 10GbE, Dell UltraSharp UP3216Q, SAPPHIRE NITRO+ RX 580 Special Edition, ASUS Station Pro. Intent is Photography, not gaming. This set up works fine for that.


ReplyQuote
lostdawg
(@lostdawg)
New Member
Joined: 10 months ago
 

Long story short. It was the card. Works now with new (different brand and type) card.
I purchased a second enclosure that was Apple website recommended. Had ample power for the Vega 56 I have and can power the 64. I received the same negative result (OS X showed different enclosure of course).
So purchased a second card due to running out of time for RMA'ing stuff.
Second Card was plug and play thankfully.  Purchased a Sapphire RX 580 Special Edition. Two reasons. Different brand and I still wasn't 100% sure it wasn't a driver or hardware issue with 10.14.2 and my mac mini w/10GBe. Though this was doubtful as others have had success, there was still no exact duplicate of this particular AREZ VEGA card and my specced computer. If the Sapphire VEGA 56 was not still insanely priced, I probably would have rolled the dice and tried that card.

Will post my thoughts about the second enclosure I purchased after it goes back and is refunded.  Suffice to say the power supply that is noted on their website FAQ is not what was in the enclosure I received. That made the conundrum I thought I was going to be in about which enclosure to keep a null problem.  The ASUS XG Station Pro is clearly the better quality enclosure with the 33oW power supply being its only possible detractor.
Anyway ran some tests in capture one that were killing me with the igpu, those are all good now. Looks like the Vega 56 was overkill for my needs.

Take aways.
Should have just bought the RX 580 in the first place for photog, large 4k, and mac mini.
Been awhile since I got a nonworking computer part, guess I was due. 
Not having windows system makes trouble shooting cards beyond painful.
I now appreciate the ASUS XG Station Pro enclosure a lot more than I thought I would. No buyers remorse on this one.
My mac mini i7 seems to be happy heat wise. Guessing the heat issue is a result of slogging it for gaming or heavy video work? My photog playing software is a non issue so far, which was my goal all along.

2018 Mac Mini OS X 10.14.2 i7 32GB, 1TB 10GbE, Dell UltraSharp UP3216Q, SAPPHIRE NITRO+ RX 580 Special Edition, ASUS Station Pro. Intent is Photography, not gaming. This set up works fine for that.


ReplyQuote