Mac Mini (2018) No Display after a reboot or coming from a shutdown
 
Notifications
Clear all

Mac Mini (2018) No Display after a reboot or coming from a shutdown  

 of  2
  RSS

sas0ri
(@sas0ri)
Active Member
Joined: 3 years ago
 

Hi,

 

I am hoping someone can help me. I have the latest Mac mini (2018) hooked up with an external GPU (Vega 64) running a thunderbolt 3 connected to two LG 4K Displays 27 (LG 27UK850-W 27" 4K UHD IPS Monitor with HDR10 with USB Type-C Connectivity and FreeSync (2018)

 

So basically the connection goes

 

Mac mini --> Thunderbolt 3 --> EGPU (Vega 64 card) ---> Display port on two LG 4K displays

 

I don't have the filevault on and I have done all the necessary troubleshooting such as Reset PRAM and SMC. The setup works fine on a Macbook Pro and other portables, I am only having problem with this mac mini using this setup. If I connect the HDMI directly to the mac mini, it works fine.

 

Which suggest that this could possible be the Thundebolt and Displayport hardware connection?

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
Massimo Franzese
(@massimo_franzese)
Trusted Member
Joined: 1 year ago
 

@sas0ri

It happens if you upgrade or update MacOS or apply a security fix with the eGPU connected to the Mini. All MacOs updates need to be carried out with the eGPU disconnected and the monitor connected to the Mini or eGPU disconnected if connected to a laptop or unit with a screen

To sort out the problem connect the screen to the Mini and with the eGPU off reinstall Mac OSX once you have booted succesfully login disconnected the cable to the mini and switch on the eGPU 

From there onwards will boot OK. In the odd case it does not from all devices off switch on in rapid sequence mini egpu and display

Mac Mini 2018 3.2 Ghz 6 cores
Razer Core X enclosure with Sapphire Vega 64 Nitro
Benq PD2720U


ikir liked
ReplyQuote
sas0ri
(@sas0ri)
Active Member
Joined: 3 years ago
 

Is this a known bug?

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
Massimo Franzese
(@massimo_franzese)
Trusted Member
Joined: 1 year ago
 

@sas0ri

No it is not supported period. Read this note related to blackmagic but applies to any eGPU enclosure

 

https://support.apple.com/en-us/HT208897

Final part

 

Learn more

macOS currently doesn't support eGPUs in Windows using Boot Camp or when your Mac is in macOS Recovery, at FileVault login, or installing system updates.

This post was modified 1 year ago

Mac Mini 2018 3.2 Ghz 6 cores
Razer Core X enclosure with Sapphire Vega 64 Nitro
Benq PD2720U


ReplyQuote
Koncept_Zero
(@koncept_zero)
Trusted Member
Joined: 1 year ago
 

This only happens to me from a restart, not a reboot.

2018 Mac Mini [8th,6C,B] + RX 5700 XT @ 32Gbps-TB3 (Razer Core X) + macOS 10.15.5 [build link]  

ReplyQuote
sas0ri
(@sas0ri)
Active Member
Joined: 3 years ago
 

Thank you so much. I am not sure if a complete reinstall, seems a bit work there to put everything back up. I am testing to see If I just disconnect the egpu every single time i reboot, restart and do a software update while connected directly to the display via HDMI (no egpu).

 

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
Naurisolento
(@naurisolento)
Active Member
Joined: 1 year ago
 

I have this problem now. If I wait for the next system update and then remove the eGPU for the time of the update, does my boot screen work OK after that?

Mac Mini 2018 (i5/16gb/500gb) + Razer Core X (Silent Wings 3 120mm, Corsair SF600 Platinum PSU) + Sapphire Nitro+ 5700XT Special Edition


ReplyQuote
WillyC
(@willyc)
Active Member
Joined: 2 years ago
 

@naurisolento

I am also wondering exactly that. It’s pretty easy to forget to disconnect it since there’s no warning presented and having to reinstall the OS from such a minor error seems pretty silly. 
 If I boot with a screen connected directly it works fine and then I can disconnect the screen. Surely there’s some fix for an OS that was updated with the eGPU attached!

Mac Mini 2018 (64 GB, 1TB)
Asus XG Station Pro
Red Devil 5700XT


ReplyQuote
Lukáš Imrich
(@lukas_imrich)
New Member
Joined: 1 year ago
 

Have you guys @sas0ri @naurisolento been able to solve the problem without complete macOS reinstall? 
Or is there any workaround that you use to avoid the issue?

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
WillyC
(@willyc)
Active Member
Joined: 2 years ago
 

@lukas_imrich, last update I unplugged my eGPU prior and after the update I can now reboot with only my eGPU attached and it works. 

 

Mac Mini 2018 (64 GB, 1TB)
Asus XG Station Pro
Red Devil 5700XT


ReplyQuote
 of  2