Mac not using eGPU after upgrading to Big Sur
 
Notifications
Clear all

Mac not using eGPU after upgrading to Big Sur  

  RSS

furfur
(@furfur)
New Member
Joined: 4 months ago
 

I recently got a 2019 16-inch MacBook Pro. I updated the OS to Big Sur and noticed it's not properly utilizing my eGPU. I use Figma in my job. On my old Mac that's running Catalina, "Figma Helper (GPU)" would always show up under "AMD Radeon RX 5700 XT (Port 1)" in Activity Monitor (as long as I open/restart Figma when the eGPU is plugged in). After the update, now "Figma Helper (GPU)" would show up under both the internal graphics card (AMD Radeon Pro 5500M (Built-in)) as well as the external one in Activity Monitor. But only the internal one shows %GPU usage. The same thing happens to other apps that have a GPU helper. 

I did everything in the Troubleshooting guide, but it's still not working. The only work-around I found so far is to close the laptop, reopen the applications, then they will start using the eGPU. But as soon as the apps become idle, it will go back to using the internal graphics card.

Does this happen to anyone else? Any idea how I can fix it? Thanks in advance for your help! Below is my setup:

  • MacBook Pro (16-inch, 2019) with an external monitor
  • OS: Big Sur (Version 11.2.3 (20D91))
  • eGPU: AMD Radeon RX 5700 XT
  • eGPU is correctly showing up in the Graphics section in About This Mac
  • Enclosure: Razer Core X - Black

 

 

This topic was modified 4 months ago

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
Mini i5
(@mini-i5)
Prominent Member
Joined: 2 years ago
 

@furfur, From Apple:

You can configure applications to use an eGPU with one of the following methods.

Use the Prefer External GPU option

Starting with macOS Mojave 10.14, you can turn on Prefer External GPU in a specific app's Get Info panel in the Finder. This option lets the eGPU accelerate apps on any display connected to the Mac—including displays built in to iMac, iMac ProMacBook Air, and MacBook Pro:

  1. Quit the app if it's open.
  2. Select the app in the Finder. Most apps are in your Applications folder. If you open the app from an alias or launcher, Control-click the app's icon and choose Show Original from the pop-up menu. Then select the original app.
  3. Press Command-I to show the app's info window.
  4. Select the checkbox next to Prefer External GPU.
  5. Open the app to use it with the eGPU.

You won't see this option if an eGPU isn't connected, if your Mac isn't running macOS Mojave or later, or if the app self-manages its GPU selection. Some apps, such as Final Cut Pro, directly choose which graphics processors are used and will ignore the Prefer External GPU checkbox.

Set an external eGPU-connected display as the primary display

If you have an external display connected to your eGPU, you can choose it as the primary display for all apps. Since apps default to the GPU associated with the primary display, this option works with a variety of apps:

  1. Quit any open apps that you want the eGPU to accelerate on the primary display.
  2. Choose Apple menu  > System Preferences. Select Displays, then select the Arrangement tab.
  3. Drag the white menu bar to the box that represents the display that's attached to the eGPU. 
  4. Open the apps that you want to use with the eGPU.

If you disconnect the eGPU, your Mac defaults back to the internal graphics processors that drives the built-in display. When the eGPU is re-attached, it automatically sets the external display as the primary display.

 

 

2018 Mac Mini + AMD RX 5500 XT (Sonnet Breakaway Box 650) Big Sur 11.5 + Windows 21H1

 
2018 Mac Mini [8th,6C,B] + RX Vega 56 @ 32Gbps-TB3 (Sonnet Breakaway 650) + macOS 11.1 & Win10 [build link]  


hans-st. liked
ReplyQuote
furfur
(@furfur)
New Member
Joined: 4 months ago
 

@mini-i5, Hi there, thanks for the reply. As I mentioned in my original post, I tried all those things in the Troubleshooting guide, which includes the two tips you mentioned, but unfortunately it's still not working : ( 

 

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote