Macbook pro 2017 "15, Omen Accelerator, R9 290 bad performance  

  RSS

m1k3vr
(@m1k3vr)
New Member
Joined: 1 year ago
Posts: 3
August 26, 2017 4:08 pm  

Hey everyone,

 

I’ve been following the progress of eGPU’s here on egpu.io for some time now and earlier this week I finally ordered an Omen Accelerator shell. My setup is a 2017 Macbook pro 15”(Sierra 10.12.6), Omen Accelerator and a AMD R9 290. 

 

I’ve followed the Beginner’s eGPU Setup Guide For Mac and got it to work without much trouble, but there seems to be some bad performance and light glitches on the external monitor (1080p, 60hz, dvi). When dragging windows there is some obvious tearing and when I fired up a game (World of Warcraft) it seems to be stuck at 38frames per second while my dGPU (Radeon Pro 560) easily gets a steady 60fps. Weird thing is that I can change the settings from medium to ultra and the fps is still 38, also if I set the settings to low it keeps at 38. Only if I adjust the resolution from 1080p to 600p the fps goes up to 56-60 fps.

 

I tried mac_editor’s tip to disable “Displays have separate spaces” in mission control and and set the external display as main display but it did not help. 

 

Not sure where to go from here, does anyone know how to fix this?

 

Cheers,

 

 

Mike

Soon I will add my system & eGPU details or a build link to this my signature to give context to my posts


ReplyQuote
Flint Ironstag
(@flint-ironstag)
Estimable Member
Joined: 2 years ago
Posts: 166
August 27, 2017 2:01 am  

Might try posting at the official Mac support forum:

https://us.battle.net/forums/en/wow/1011702/

Some of the folks there are fairly experienced in tweaking config files, etc. to get maximum performance.  Got any pics of your setup?  12 year old me loves it, but not sure I want it in the office where clients see LOL.

MP 6,1 | 4c | d700
MP 6,1 | 6c | d500


m1k3vr liked
ReplyQuote
m1k3vr
(@m1k3vr)
New Member
Joined: 1 year ago
Posts: 3
August 27, 2017 1:10 pm  

Hehe, I did not buy the Omen for its looks, if they ditched the fins it would actually be an allright box but... Anyhow, it was practical and cheap. I really liked the Mantiz Venus but to ship it to the Netherlands it would cost ~580 euro's compared to the 300 euro Omen including shipping from HP.

Anyways, I swapped out the AMD R9 290 with a Nvidia 1060 and it runs perfectly. I think the card drew too much power (up to 300w) from the Omen, which offers up to 300w for gpu's. But that's only speculation since I have no way to really test that stuff.

Thanks, and cheers to the eGPU.io community!

Soon I will add my system & eGPU details or a build link to this my signature to give context to my posts


ReplyQuote
Flint Ironstag
(@flint-ironstag)
Estimable Member
Joined: 2 years ago
Posts: 166
August 29, 2017 5:07 pm  

Nice - glad you have a working solution now.  How do you find the performance of 1060 vs R9 290 in your apps?

Now I'm waiting for the next wave of eGPU chassis - multiple GPUs at reasonable cost. 

MP 6,1 | 4c | d700
MP 6,1 | 6c | d500


ReplyQuote
m1k3vr
(@m1k3vr)
New Member
Joined: 1 year ago
Posts: 3
August 29, 2017 7:30 pm  

I didn't really get the chance to try out the R9 290 with any apps, because the os was unusable with slow down's glitches. The only apps I tried were Photoshop (laggy as F) World of Warcraft (Laggy as F) and Autodesk Maya which kept crashing at launch. With the 1060 everything worked great (Photoshop, WoW, Maya, Resolve, Fusion, Substance painter and Houdini). Although I did not get a chance to use any of the programs for more than 1 hour, so can't say for sure its crash free.

Soon I will add my system & eGPU details or a build link to this my signature to give context to my posts


keesdev liked
ReplyQuote
keesdev
(@keesdev)
New Member
Joined: 7 months ago
Posts: 4
May 16, 2018 9:51 pm  

Sorry to break into this old thread, but I've seen it while Google-ing on 'amd r9 290x macos egpu support', because I'm thinking of keeping my OMEN by HP Accelerator for when I have a new Macbook Pro 2017 edition this summer (it has some/a lot of troubles with TB2 on my early 2015 model) and I've been reading AMD support is way better than NVIDIA on MacOS.

That's why I want to ask you, @m1k3vr :
- Was your AMD R9 setup plug and play? And under which OS?
- Is your NVIDIA setup plug and play? And under which OS?

I am looking for a working and kinda plug and play solution for my future TB3 Macbook for (if possible) both MacOS High Sierra (10.13) and Windows 8.1/10 via Bootcamp. If not: at least it must be plug and play (or usable like 'plug in your eGPU while booting' - no problem whatsoever) in any Windows version via Bootcamp.

Cheers!

13" Macbook Pro 2015 ft. i5 // 16GB // 512SSD
HP Omen Accelerator ft. MSI GTX970 4GB GDDR5 OC


ReplyQuote