MacBook Pros + Sonnet eGFX Breakaway Box + Radeon 5700 XT = resiliency is awful
 
Notifications
Clear all

MacBook Pros + Sonnet eGFX Breakaway Box + Radeon 5700 XT = resiliency is awful  

  RSS

Eugene Obrezkov
(@eugene_obrezkov)
Active Member
Joined: 1 year ago
 

Hi everyone!
I'm a new here, decided to join the community of eGPU enthusiasts. So far it was a messy experience, so I'm writing this post now Smile

My hardware configuration:

- MacBook Pro 15' Mid 2019
- MacBook Pro 16' Late 2019
- Sonnet eGFX Breakaway Box
- Sapphire Radeon 5700 XT

My software configuration:

- Both MacBook Pros have the latest macOS Cataliina (10.15.4 (19E266))
- No custom drivers, kext or anything that will require additional setup (just few .app applications and several binaries installed through brew)

The Problem:

Sometimes macOS can become frozen, after few minutes it spins out fans to the max and reboots. What is notably is that it sometimes can happen even without eGPU connected (but not so often, with eGPU it become an annoying issue).

I even can't figure out the dependencies here and why or when it is happening. For example, here are some scenarios I've faced:

- MacBook Pro 15' Mid 2019 - when it is on and I'm plugging in eGPU "on the fly" mac continues to work but there is no response from eGPU or external monitor at all. eGPU enclosure LED is on, my Mac starts to charging, but no display. It works only when I'm booting macOS with eGPU already connected. Even so, it can sometimes be totally fine and work the whole day on the external monitor and sometimes it can just froze and go into reboot.
- MacBook Pro 16' Late 2019 - when it is on and I'm pluggin in eGPU "on the fly" mac continues to work AND eGPU detects normally. This the case when Plug-n-Play really works out. After I plug in Thunderbolt 3, external monitor came to live and macOS switched to eGPU (it says on Displays tab and About tab). Though, when I'm trying to power on it with eGPU connected - it freezes after I pressed Enter after typing in my password. I can power on MacBook normally only without eGPU. And yet, behavior while working the same as in Mid 2019, it sometimes can just freeze my Mac, spin out the fans to max and reboot.

What else have I noticed?

When I'm using not so expensive operations - seems like it is working more stable. Though, when I'm starting to use eGPU for BOINC project (donating eGPU to science projects) or start Steam to play some games - it can hold for few minutes and the boom again - fans to the max and reboot.

Kernel dump after reboot not so useful... No info about stack traces, registers state or anything related to the MacOS, just few of "Core 0" with empty data "0000000...00" that repeats several times.

Any ideas to debug it, at least?

So far, my suspicions is that macOS have awful drivers for 5700 XT OR it is macOS Catalina that is awful OR BOTH. Anyway, I hope that it is software-related problem and I didn't spent my money for nothing.

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
Lawless Heaven
(@lawless_heaven)
Active Member
Joined: 3 years ago
 

Drivers for RX 5700 XT are awful in general 

Asus G501VW I7 6700HQ Razer Core X RTX 2070 SUPER


ReplyQuote
Eugene Obrezkov
(@eugene_obrezkov)
Active Member
Joined: 1 year ago
 

I've just caught some useful information in kernel dump (x86 CPU CATERR detected)

Spoiler
Kernel Dump

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
Mini i5
(@mini-i5)
Prominent Member
Joined: 2 years ago
 

Nah, both the 5700XT and 10.15.4 work great on my Mac Mini 2018. 

Not a single issue with either one. 

  1. On your Mac, choose Apple menu
  2.  > System Preferences, then click Energy Saver.
  3. Do one of the following:
    • If you see Graphics options, select Higher Performance.
      You need to log out and then log in again for the change to take effect.
    • If you see the “Automatic graphics switching” option, deselect it.
      Your Mac will always use high-performance graphics.

Also, use a standard 18” 40Gbs thunderbolt cable

2018 Mac Mini [8th,6C,B] + RX Vega 56 @ 32Gbps-TB3 (Sonnet Breakaway 650) + macOS 11.1 & Win10 [build link]  

ReplyQuote
Eugene Obrezkov
(@eugene_obrezkov)
Active Member
Joined: 1 year ago
 

I've already did that before, set the "Automatic graphics switching" to OFF. Also, I made a primary display on my MacBook Pro the one which is connected to eGPU through DisplayPort directly.

As a result I have the following in "About" all the time:

Screenshot 2020 03 28 at 20.33.03

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote