Notifications

macOS 10.15.3 beta  

 of  2
  RSS

ikir
 ikir
(@ikir)
Prominent Member
Joined: 3 years ago
 

Any update on new macOS 10.15.3?

Does it fix Mac mini eGPU black display?


MacBook Pro 2018 Touch Bar i7 quad-core 2.7Ghz - 16GB RAM - 512GB PCIe SSD
my awesome Radeon VII eGPU
my Mantiz Venus extreme mod with Sapphire Nitro+ RX Vega 64


ReplyQuote
zhangd116
(@zhangd116)
Active Member
Joined: 3 years ago
 

Curious about this too. Also would like to know if it improves performance on navi cards, my RX 5700 feels almost no difference compared to RX 580...

 

2018 Mac Mini i7 with AMD Radeon RX 5700 in Razer Core X


ReplyQuote
zhangd116
(@zhangd116)
Active Member
Joined: 3 years ago
 

Figured things couldn't be worse so I performed a full TM backup and installed 10.15.3 public beta 1.

Performance on RX 5700 is still miserable, but it does seem like Apple fixed the black screen booting issue, at least for RX 5700

 

Update - it worked for a few tries but then black screen issue came back again... dang

This post was modified 2 months ago

2018 Mac Mini i7 with AMD Radeon RX 5700 in Razer Core X


ikir liked
ReplyQuote
ikir
 ikir
(@ikir)
Prominent Member
Joined: 3 years ago
 
Posted by: @zhangd116

Figured things couldn't be worse so I performed a full TM backup and installed 10.15.3 public beta 1.

Performance on RX 5700 is still miserable, but it does seem like Apple fixed the black screen booting issue, at least for RX 5700

 

Update - it worked for a few tries but then black screen issue came back again... dang

Terrible. Can you use beta report to send these issue to Apple?


MacBook Pro 2018 Touch Bar i7 quad-core 2.7Ghz - 16GB RAM - 512GB PCIe SSD
my awesome Radeon VII eGPU
my Mantiz Venus extreme mod with Sapphire Nitro+ RX Vega 64


ReplyQuote
jefniro
(@jefniro)
Estimable Member
Joined: 3 years ago
 

My Catalina 10.15.3 beta (developper) performances, away from Windows results but definitely better than before (+12%):

Schermata 2020 01 05 alle 12.01.21

 

Catalina 10.15.2:

https://egpu.io/forums/which-gear-should-i-buy/amd-navi-7nm-for-egpu-radeon-rx-5700-rx-5700-xt/paged/12/#post-70528

 

This post was modified 2 months ago

2016 13" MacBook Pro + RX 5700 XT @ 32Gbps-TB3 (AKiTiO Node) + Win10 1903


ReplyQuote
(@massimo_franzese)
Trusted Member
Joined: 3 months ago
 

The black display issue arises if you upgrade MAC OS with the eGPU attached, basically each time you have a mac os or security update it needs to be connected to a monitor or it seriously compromises the integrity, this is actually written in the blackmagic eGPU support notes.

I have reinstalled Mac OS and since I can reboot with the eGPU on however it does not show the apple sign just some weird purple lines. Occasionally it stops booting to which the solution is to switch on mini egpu and monitor in series

I have had other suprises on my mbp including stuck in reboot fan loop that needed Command R to get out or option key

Mac Mini 2018 3.2 Ghz 6 cores
Razer Core X enclosure with Sapphire Vega 64 Nitro
Benq PD2720U


jangoloti liked
ReplyQuote
zhangd116
(@zhangd116)
Active Member
Joined: 3 years ago
 

@massimo_franzese

Interesting, I didn't realize that we are not suppose to update the system with EGPU attached.

I did the 10.15.3 update using mac mini's HDMI port with EGPU detached, and the black screen issue persists. Maybe I should try reinstall mac OS...?

2018 Mac Mini i7 with AMD Radeon RX 5700 in Razer Core X


ReplyQuote
(@massimo_franzese)
Trusted Member
Joined: 3 months ago
 
Posted by: @zhangd116

@massimo_franzese

Interesting, I didn't realize that we are not suppose to update the system with EGPU attached.

I did the 10.15.3 update using mac mini's HDMI port with EGPU detached, and the black screen issue persists. Maybe I should try reinstall mac OS...?

I reinstalled MAC OSX with eGPU turned off. Since then it boots 95% of times with the odd occasion it doesn't and I need just to turn on mini egpu and screen in short sequence

Mac Mini 2018 3.2 Ghz 6 cores
Razer Core X enclosure with Sapphire Vega 64 Nitro
Benq PD2720U


ReplyQuote
zhangd116
(@zhangd116)
Active Member
Joined: 3 years ago
 

@massimo_franzese

Thanks, I will try to reinstall Mac OS  sometime this week. 

On a separate note (rant) I just realized that my bootcamp windows updated itself to 1909 and broke the egpu setup (code 12)... I’m glad that at least Mac OS gives me the option to turn off the auto update feature... 

2018 Mac Mini i7 with AMD Radeon RX 5700 in Razer Core X


ReplyQuote
(@massimo_franzese)
Trusted Member
Joined: 3 months ago
 

@zhangd116

If you reinstall OSX I would like to know if once the eGPU is connected the apple symbol comes back!

Mac Mini 2018 3.2 Ghz 6 cores
Razer Core X enclosure with Sapphire Vega 64 Nitro
Benq PD2720U


ReplyQuote
zhangd116
(@zhangd116)
Active Member
Joined: 3 years ago
 

@massimo_franzese

Just finished reinstalling mac os (I am still on 10.5.3 public beta 1) and it does seem to fix the black screen issue (four successful shut down/restart with egpu attached & connected to the monitor with DisplayPort, no HDMI plugging in the mini). Thanks for the tips! 

If you are talking about the apple logo + boot progress bar on startup, unfortunately they are still not around at this moment. Though this time there's no weird color lines or distortion, the screen remains black and apple logo flashes for a second before the login screen shows up.

This post was modified 2 months ago

2018 Mac Mini i7 with AMD Radeon RX 5700 in Razer Core X


ReplyQuote
(@massimo_franzese)
Trusted Member
Joined: 3 months ago
 

@zhangd116

That is an improvement. When 10.15.3 is stable I will make sure I upgrade with eGPU disconnected to see at least the apple logo

Please consider that also security update my corrupt your eGPU and should be installed without it

Mac Mini 2018 3.2 Ghz 6 cores
Razer Core X enclosure with Sapphire Vega 64 Nitro
Benq PD2720U


ikir liked
ReplyQuote
(@jangoloti_1)
Trusted Member
Joined: 5 months ago
 
Posted by: @massimo_franzese

@zhangd116

That is an improvement. When 10.15.3 is stable I will make sure I upgrade with eGPU disconnected to see at least the apple logo

Please consider that also security update may corrupt your eGPU and should be installed without it

What do you mean with your last sentence? I have lost my eGPU on MacOS on 10.15.1 but before I updated to 10.15.2, which changed nothing. A reinstallation of 10.15.2 improved nothing. The card (Nitro+ RX 5700 XT) does not even power up inside the Breakaway Box (it does on Bootcamp so I know it is not the card). 

If I have corrupted the eGPU what can I do?

Mac Mini 2018 i7 16 GB 512 GB SSD, Mac Book Pro 2016, HP Z31x, Sonnet Breakaway Box 550 W, Nitro+ RX5700 XT, KFA2 SNPR 1060 6GB eGPU,...


ReplyQuote
(@massimo_franzese)
Trusted Member
Joined: 3 months ago
 

@jangoloti_1

Am not sure there was another security update which would be another culprit

the egpu is fine is osx that gets messed up

did you reinstall with the egpu disconnected?

Mac Mini 2018 3.2 Ghz 6 cores
Razer Core X enclosure with Sapphire Vega 64 Nitro
Benq PD2720U


ReplyQuote
(@jangoloti_1)
Trusted Member
Joined: 5 months ago
 

@massimo_franzese

Yes, with eGPU disconnected after reading your post.

Mac Mini 2018 i7 16 GB 512 GB SSD, Mac Book Pro 2016, HP Z31x, Sonnet Breakaway Box 550 W, Nitro+ RX5700 XT, KFA2 SNPR 1060 6GB eGPU,...


ReplyQuote
(@massimo_franzese)
Trusted Member
Joined: 3 months ago
 

@jangoloti_1

And is 10.15.2?

Mac Mini 2018 3.2 Ghz 6 cores
Razer Core X enclosure with Sapphire Vega 64 Nitro
Benq PD2720U


ReplyQuote
itsage
(@itsage)
Illustrious Member Admin
Joined: 3 years ago
 

macOS 10.15.3 Beta came out this morning and has support for a few more Radeon cards.

### AMDRadeonX6000HWServices.kext
* pci device: 7310 - Navi 10
* pci device: 7312 - Navi 10 [Radeon Pro W5700]
* pci device: 7318 - unknown device
* pci device: 7319 - unknown device
* pci device: 731a - unknown device
* pci device: 731b - unknown device
* pci device: 731f - Navi 10 [Radeon RX 5600 OEM/5600 XT / 5700/5700 XT]
* pci device: 7340 - Navi 14 [Radeon RX 5500/5500M / Pro 5500M]
* pci device: 7341 - Navi 14 [Radeon Pro W5500]
* pci device: 7343 - unknown device
* pci device: 7347 - Navi 14 [Radeon Pro W5500M]
* pci device: 7360 - unknown device

external graphics card builds
best laptops for external GPU
eGPU enclosure buyer's guide


Gibby, ikir, mac_editor and 1 people liked
ReplyQuote
ikir
 ikir
(@ikir)
Prominent Member
Joined: 3 years ago
 

@itsage

any changes on performance?


MacBook Pro 2018 Touch Bar i7 quad-core 2.7Ghz - 16GB RAM - 512GB PCIe SSD
my awesome Radeon VII eGPU
my Mantiz Venus extreme mod with Sapphire Nitro+ RX Vega 64


ReplyQuote
ikir
 ikir
(@ikir)
Prominent Member
Joined: 3 years ago
 

Bump. Is 10.15.3 faster now? Does it fix Mac mini black screen with eGPU?


MacBook Pro 2018 Touch Bar i7 quad-core 2.7Ghz - 16GB RAM - 512GB PCIe SSD
my awesome Radeon VII eGPU
my Mantiz Venus extreme mod with Sapphire Nitro+ RX Vega 64


ReplyQuote
rnb2
 rnb2
(@rnb2)
Eminent Member
Joined: 1 year ago
 

@ikir

I somehow missed the suggestion to unplug the eGPU when doing the update- oops.

I had hopes during the update process, as after one reboot, the install progress moved to the eGPU/DP from HDMI, so I unplugged the HDMI cable after logging in at the end of the update process. Unfortunately, restarting left me at a black screen again, so I had to get the HDMI cable back out.

If even reinstalling macOS doesn't show the boot logo, I'm not sure if it's worthwhile, as I'm not sure if this will let me see the Option boot screen, so I'll probably just keep the HDMI cable plugged in until someone else can confirm that the Option boot screen shows up properly.

2018 i7 Mac mini - OWC Mercury Helios FX (Sonnet 550) - ASRock Vega 56 - BenQ SW271


ReplyQuote
semohe
(@semohe)
Active Member
Joined: 8 months ago
 

catalina 10.15.3 still doesnt fix boot to windows using egpu. but i dont see any purple stripes on apple logo anymore. 

2018 mac mini i5 + sonnet 550 + vega 56


ReplyQuote
ikir
 ikir
(@ikir)
Prominent Member
Joined: 3 years ago
 
Posted by: @semohe

catalina 10.15.3 still doesnt fix boot to windows using egpu. but i dont see any purple stripes on apple logo anymore. 

What about macOS? There a lot of Mac mini users who can't boot with eGPU connected (if FileVault si active).


MacBook Pro 2018 Touch Bar i7 quad-core 2.7Ghz - 16GB RAM - 512GB PCIe SSD
my awesome Radeon VII eGPU
my Mantiz Venus extreme mod with Sapphire Nitro+ RX Vega 64


ReplyQuote
semohe
(@semohe)
Active Member
Joined: 8 months ago
 

@ikir

I never had problem with egpu on mac os, maybe is just because i'm using vega 56. I heard this card doesn't affected with this firmware problem. 

2018 mac mini i5 + sonnet 550 + vega 56


ReplyQuote
ikir
 ikir
(@ikir)
Prominent Member
Joined: 3 years ago
 

There are tons of users with this boot issue on Mac mini. Anyway 10.15.3 has been released, lets try.


MacBook Pro 2018 Touch Bar i7 quad-core 2.7Ghz - 16GB RAM - 512GB PCIe SSD
my awesome Radeon VII eGPU
my Mantiz Venus extreme mod with Sapphire Nitro+ RX Vega 64


ReplyQuote
(@mohhamad_aliff)
Active Member
Joined: 1 month ago
 

Ok..........i got the 2018 Mac mini with Catalina 10.15.3 connected to the Razer Core X + Radeon RX 580, it’s outputting to my monitor via the GPU’s HDMI port.

I got the boot option screen but the moment it tries to boot into either macOS or Windows, it wouldn’t display anything at all. macOS might show pink lines at first but then the monitor will go to sleep while Windows will just show a black screen and only a black screen.

2018 i5 Mac mini 256GB, Razer Core X + Gigbyte RX 580


ReplyQuote
(@megaseppl)
Eminent Member
Joined: 1 year ago
 

10.15.3 seems to work again after my problems with 10.15.2 (mac mini 2018 with Razer Core X and 5700 XT).

I can boot again, even with all three DP screens attached (which never worked with 10.15.2). And it even does not kernel panic when I'm using sleep mode (which did even not work with 10.15.1).

I don't know if it helped that I made the 10.15.3 update with disconnected eGPU. According to an other post I found here, System upgrades shall always be done with internal GPU only.

I haven't tested yet if performance has improved.

Mac mini 2018 i7, Razer Core X with PowerColor Red Devil 5700 XT


ReplyQuote
Chillicillin
(@chillicillin)
New Member
Joined: 1 month ago
 

@mohhamad_aliff

I have your exact same setup. Today I updated to 10.15.3 with eGPU disconnected and straight booting to macOS with eGPU connected and turned on (monitor connected to eGPU via HDMI) has not been fixed for me. However, my normal windows cold plug method still works.

 

@itsage has posts detailing this trick to ensure easy cold boot for the setup both you and I have.

- In MacOS, go to the system preferences and under "Startup Disk", ensure that you have Windows selected as the DEFAULT

- Shut down your mac mini. Ensure that the connections are as follows

- Mac Mini to eGPU via TB3 (ENSURE THAT THE PLUG USED IS THE ONE CLOSEST TO THE ETHERNET PORT, NOT THE HDMI)

- eGPU to monitor via HDMI

With these steps, I can cold boot to windows with my eGPU already switched on without any hassle. Let me know if it works for you

Pending: Add my system information and expected eGPU configuration to my signature to give context to my posts


itsage liked
ReplyQuote
itsage
(@itsage)
Illustrious Member Admin
Joined: 3 years ago
 

Boot Screen support through eGPU is still flaky on the 2018 Mac mini. I would see it randomly. It’s more consistent when the machine was off rather than restart.

external graphics card builds
best laptops for external GPU
eGPU enclosure buyer's guide


rnb2 liked
ReplyQuote
Chillicillin
(@chillicillin)
New Member
Joined: 1 month ago
 
Posted by: @itsage

Boot Screen support through eGPU is still flaky on the 2018 Mac mini. I would see it randomly. It's more consistent when the machine was off rather than restart.

So my current setup is Mac mini to egpu to monitor (HDMI). I only did it like this cause I was following a guide. If I changed it so that the monitor connects straight to Mac mini, the cold boot with egpu on actually works.

What’s the main difference between having the monitor connected to eGPU vs the Mac mini?

For context, I use the macOS for work/school and boot camp for games. I’m fine with hot plugging the egpu every time I need to use macOS, but it can get annoying...

Pending: Add my system information and expected eGPU configuration to my signature to give context to my posts


ReplyQuote
(@mohhamad_aliff)
Active Member
Joined: 1 month ago
 

@chillicillin

I’m still seeing blank when Windows boots, even with the TB port near the ethernet port. I think the .3 update had borked up my eGPU setup when ironically my problem for the last one was not seeing the boot select screen and now my problem is the exact opposite!

As for the differences between using an ‘internal’ screen vs a external screen (or using the HDMI port on the mini vs using the HDMI on the GPU for our case), it’s something to do with bandwidth and performance loss. someone here correct me on this but if it’s my understanding, If using the ‘internal’ screen, some of the data will have to be sent back via the TB port thus chewing up the available bandwidth.

 

This post was modified 1 month ago

2018 i5 Mac mini 256GB, Razer Core X + Gigbyte RX 580


ReplyQuote
alexpixel
(@alexpixel)
Active Member
Joined: 1 month ago
 

I updated to 10.15.3 without the egpu connected. When I connect the egpu I get into a reboot loop :-(. When I disconnect the egpu I can boot again normally. 

I tried to reinstall purge-wrangler, but this didn't helped. As soon as it detects the egpu it reboots. I tried to delete the kernel cache, doesn't helped. Everything worked fine in 10.5.2.

Somebody else having the same issue?

MacBook Pro 13" 2013, Sonnet 550, AMD XT 5700

2013 MacBook Pro 13" - Sonnet eGFX Breakaway Box 550 - Sapphire Nitro+ RX5700 XT


ReplyQuote
mac_editor
(@mac_editor)
Famed Member Moderator
Joined: 3 years ago

ReplyQuote
alexpixel
(@alexpixel)
Active Member
Joined: 1 month ago
 

@mac_editor

thanks! awesome works again. I'm new to this whole egpu stuff didn't know you can proceeded with pressing escape :-). Made a small donation to purge-wrangler 🙂

2013 MacBook Pro 13" - Sonnet eGFX Breakaway Box 550 - Sapphire Nitro+ RX5700 XT


ReplyQuote
ikir
 ikir
(@ikir)
Prominent Member
Joined: 3 years ago
 
Posted by: @itsage

Boot Screen support through eGPU is still flaky on the 2018 Mac mini. I would see it randomly. It's more consistent when the machine was off rather than restart.

Let’s hope a firmware update can fix this, or a specific Mac mini minor software update.

Can you confirm issue are gone if FileVault is switched off?


MacBook Pro 2018 Touch Bar i7 quad-core 2.7Ghz - 16GB RAM - 512GB PCIe SSD
my awesome Radeon VII eGPU
my Mantiz Venus extreme mod with Sapphire Nitro+ RX Vega 64


ReplyQuote
Mini i5
(@mini-i5)
Estimable Member
Joined: 6 months ago
 

A big yawn. The 10.15.3 update took about 20 minutes to install.

I haven’t noticed any difference in features or performance. 👨‍💻

(No - this update does not include any dramatic fixes or improvements). 

2018 Mac Mini i5 / 6-core 3.0-4.1 Ghz / 32GB / 256GB / Intel UHD 630 / PowerColor Gaming Station / PowerColor dual-fan RX5700 XT / Mac OS 10.15.3 Catalina / LG 27" 4K display


ReplyQuote
(@mohhamad_aliff)
Active Member
Joined: 1 month ago
 

Weird thing is that for my config, if my card’s BIOS is stock from the factory, the boot selection shows but macOS and Windows don’t display any graphics while if i flash the BIOS then it reverts to what happens on .2 where the boot selection does not show up but macOS and Windows shows up fine on screen.

 

I’m confused 

This post was modified 4 weeks ago

2018 i5 Mac mini 256GB, Razer Core X + Gigbyte RX 580


ReplyQuote
 of  2