macOS 10.13.5 is now available  

 

whiskey_1130
(@whiskey_1130)
Eminent Member
Joined:3 months  ago
Posts: 26
June 1, 2018 5:17 pm  

macOS 10.13.5 is officially out of beta and available to the public. I plan to update and look for changes shortly.

2018 13” MacBook Pro TB + GTX 1070 + Sonnet Breakaway 550


ReplyQuote
nanoBit
(@nanobit)
Trusted Member
Joined:7 months  ago
Posts: 53
June 1, 2018 5:18 pm  

As far as I know no changes for eGPU use. Main change is Messages in Cloud.

Does anyone know if it is possible (and if yes how?) to keep the nVidia driver working after the update? Normally it checks the OS version and stops working if it detects an updated OS

Setup: MacBook Pro 2018 15" 2.6GHz Radeon Pro 560X on macOS 10.14 & Windows 10 (Bootcamp); Sonnet eGFX Breakaway Box 350 with a Zotac GTX1080 AMP! Edition


ReplyQuote
fr34k
(@fr34k)
Honorable Member Moderator
Joined:8 months  ago
Posts: 405
June 1, 2018 5:59 pm  

should someone want to use my script, please use the v02testing branch announced in the tread. I didn't yet implement the wrangler version. Therefore would someone be so kind and post the devinfo the script in that branch returns?

macOS-eGPU.sh on GitHub (fr34k's macOS-eGPU.sh on eGPU.io)
----
2016 15'' MacBook Pro + GTX1080Ti@32Gbps-TB3 (Sonnet Breakaway 550) + macOS 10.13.6 (17G65 driver: 378.10.10.10.30.107 + CUDA: 396.148)


ReplyQuote
whiskey_1130
(@whiskey_1130)
Eminent Member
Joined:3 months  ago
Posts: 26
June 1, 2018 6:09 pm  

I'll give it a shot once the update finishes @fr34k

2018 13” MacBook Pro TB + GTX 1070 + Sonnet Breakaway 550


ReplyQuote
fr34k
(@fr34k)
Honorable Member Moderator
Joined:8 months  ago
Posts: 405
June 1, 2018 6:11 pm  

@whiskey_1130
it will return with error, but also dev info.
You can use the macos10135 branch until I update the script to get your system running.

macOS-eGPU.sh on GitHub (fr34k's macOS-eGPU.sh on eGPU.io)
----
2016 15'' MacBook Pro + GTX1080Ti@32Gbps-TB3 (Sonnet Breakaway 550) + macOS 10.13.6 (17G65 driver: 378.10.10.10.30.107 + CUDA: 396.148)


ReplyQuote
whiskey_1130
(@whiskey_1130)
Eminent Member
Joined:3 months  ago
Posts: 26
June 1, 2018 6:30 pm  

@fr34k

--- dev info here ---

17F77

88411a9cb7d0949fb2eb688281729edbd06f34e41e051a5fb37bf31bd3dbfe6f3d36bfb8917249a4717409417e761b588e7cabad0944602255836b2c1cce4849

--- dev info end ---

2018 13” MacBook Pro TB + GTX 1070 + Sonnet Breakaway 550


ReplyQuote
whiskey_1130
(@whiskey_1130)
Eminent Member
Joined:3 months  ago
Posts: 26
June 1, 2018 6:51 pm  

I did have to reinstall rEFInd and apple_set_os.efi to get things working again in after updating to 10.13.5 off the beta. Mounted my EFI and saw everything was still there but wouldn't show me the boot manager on reboot even after disabling SIP again.

2018 13” MacBook Pro TB + GTX 1070 + Sonnet Breakaway 550


ReplyQuote
Ekohn00
(@ekohn00)
Eminent Member
Joined:4 months  ago
Posts: 45
June 1, 2018 7:13 pm  

@nanobit
I used @fr34k macos10135 branch and flagged to instal the .107 Nvidia Driver
So far so good.


ReplyQuote
fr34k
(@fr34k)
Honorable Member Moderator
Joined:8 months  ago
Posts: 405
June 1, 2018 7:14 pm  

@ekohn00 et al
I'll try to get it out today...


@whiskey_1130
thanks!

macOS-eGPU.sh on GitHub (fr34k's macOS-eGPU.sh on eGPU.io)
----
2016 15'' MacBook Pro + GTX1080Ti@32Gbps-TB3 (Sonnet Breakaway 550) + macOS 10.13.6 (17G65 driver: 378.10.10.10.30.107 + CUDA: 396.148)


ReplyQuote
nanoBit
(@nanobit)
Trusted Member
Joined:7 months  ago
Posts: 53
June 1, 2018 7:30 pm  

@Ekohn00

Thank you for the hint! I'll try it with the reinstall parameter when I'm back home.

Setup: MacBook Pro 2018 15" 2.6GHz Radeon Pro 560X on macOS 10.14 & Windows 10 (Bootcamp); Sonnet eGFX Breakaway Box 350 with a Zotac GTX1080 AMP! Edition


ReplyQuote
Ekohn00
(@ekohn00)
Eminent Member
Joined:4 months  ago
Posts: 45
June 1, 2018 7:42 pm  

@nanobit
Don't than me thank @fr34k for his countless hours helping me.  Hope it works.

PS...avoid 10.13.6 - I believe that will need NVIDIA to upgrade their driver.


ReplyQuote
nanoBit
(@nanobit)
Trusted Member
Joined:7 months  ago
Posts: 53
June 1, 2018 7:53 pm  

@Ekohn00 @fr34k thank both of you! 

yeah I didn't plan to install 10.13.6, no interesting consumer features until now. But I don't know if I can resist 10.14 beta when it's out (hopefully Monday  :mrgreen: )

Setup: MacBook Pro 2018 15" 2.6GHz Radeon Pro 560X on macOS 10.14 & Windows 10 (Bootcamp); Sonnet eGFX Breakaway Box 350 with a Zotac GTX1080 AMP! Edition


ReplyQuote
Ekohn00
(@ekohn00)
Eminent Member
Joined:4 months  ago
Posts: 45
June 1, 2018 8:07 pm  

@nanobit
I'm all about 10.14 or 11, I doubt the eGPU will work for a while - NVIDIA definitely has to update drivers.
10.13.6 just allows a NO 32bit mode.  I downgraded back to .5, and bracing to give up my eGPU on 
Monday.  🙂


ReplyQuote
fr34k
(@fr34k)
Honorable Member Moderator
Joined:8 months  ago
Posts: 405
June 1, 2018 8:49 pm  

bash <(curl -s https://raw.githubusercontent.com/learex/macOS-eGPU/v02/macOS-eGPU.sh)

that's the one to test. -merged, use master as usual
If a few successes are reported I will merge and make the short command active.

macOS-eGPU.sh on GitHub (fr34k's macOS-eGPU.sh on eGPU.io)
----
2016 15'' MacBook Pro + GTX1080Ti@32Gbps-TB3 (Sonnet Breakaway 550) + macOS 10.13.6 (17G65 driver: 378.10.10.10.30.107 + CUDA: 396.148)


ReplyQuote
nanoBit
(@nanobit)
Trusted Member
Joined:7 months  ago
Posts: 53
June 1, 2018 9:21 pm  

@fr34k

I tried the script you posted after the update. It failed every time. I tried different commands like --forceReinstall --nvidiaEGPUsupport --nvidiaDriver 387.10.10.10.30.107

Failed with: 

Checking for incompatibilies and up to date software...

   NVIDIA drivers                                                         [skip]

   NVIDIA eGPU enabler                             [FAILURE, no match was found]

Interrupt...

   cleaning system                                                        [done]

The script has failed.Nothing has been changed.

Setup: MacBook Pro 2018 15" 2.6GHz Radeon Pro 560X on macOS 10.14 & Windows 10 (Bootcamp); Sonnet eGFX Breakaway Box 350 with a Zotac GTX1080 AMP! Edition


ReplyQuote
fr34k
(@fr34k)
Honorable Member Moderator
Joined:8 months  ago
Posts: 405
June 1, 2018 9:32 pm  

@nanobit
well of course. I don't know when I for once won't forget to update the plists as well.
-Fix is out (again, wait 5min for Github to distribute)-

macOS-eGPU.sh on GitHub (fr34k's macOS-eGPU.sh on eGPU.io)
----
2016 15'' MacBook Pro + GTX1080Ti@32Gbps-TB3 (Sonnet Breakaway 550) + macOS 10.13.6 (17G65 driver: 378.10.10.10.30.107 + CUDA: 396.148)


ReplyQuote
Chippy McChipset
(@chippy-mcchipset)
Reputable Member
Joined:11 months  ago
Posts: 264
June 1, 2018 9:38 pm  

Anyone find anything in the installer log or otherwise that suggests eGPU support changes? Just checked their support page, do not see any changes so most likely the answer is "no," but maybe some under-the-hood improvements you guys see?


ReplyQuote
ikir
 ikir
(@ikir)
Honorable Member
Joined:2 years  ago
Posts: 736
June 2, 2018 7:45 am  

@chippy-mcchipset

For me  eject eGPU is more stable, I noticed more speed in Metal games or maybe less stutters

eGPU.it | LG 34" 4K 34UC88 curved ultrawide display
MacBook Pro 2018 Touch Bar i7 quad-core 2.7Ghz - 16GB RAM - 512GB PCIe SSD --> my Mantiz Venus extreme mod with Sapphire Nitro+ RX Vega 64


ReplyQuote
kming9u
(@kming9u)
New Member
Joined:1 year  ago
Posts: 1
June 2, 2018 11:18 am  

Dear fr34k
with your v0.2α, my mpr is working pretty well. 
I upgraded macOS high Sierra 10.13.5 then used your script.
(eGPU is Nvidia 1050ti with akitio Node.)


ReplyQuote
fr34k
(@fr34k)
Honorable Member Moderator
Joined:8 months  ago
Posts: 405
June 2, 2018 4:01 pm  

@kming9u
nice!


387.10.10.10.35.106 is out here

if someone tests with that driver, please report if stable and or improved handling.

macOS-eGPU.sh on GitHub (fr34k's macOS-eGPU.sh on eGPU.io)
----
2016 15'' MacBook Pro + GTX1080Ti@32Gbps-TB3 (Sonnet Breakaway 550) + macOS 10.13.6 (17G65 driver: 378.10.10.10.30.107 + CUDA: 396.148)


ReplyQuote
fr34k
(@fr34k)
Honorable Member Moderator
Joined:8 months  ago
Posts: 405
June 2, 2018 4:37 pm  

@kming9u et al
please rerun the script in the master branch.
There was an error in the short command that's now fixed. An update of the command will be scheduled.

macOS-eGPU.sh on GitHub (fr34k's macOS-eGPU.sh on eGPU.io)
----
2016 15'' MacBook Pro + GTX1080Ti@32Gbps-TB3 (Sonnet Breakaway 550) + macOS 10.13.6 (17G65 driver: 378.10.10.10.30.107 + CUDA: 396.148)


ReplyQuote
lefuturdelavenir
(@lefuturdelavenir)
Active Member
Joined:3 months  ago
Posts: 9
June 9, 2018 4:13 pm  

@whiskey_1130 
rEFind is not working anymore after upgrading to 10.13.5 but reinstalling it is not working for me. The symptom is when rRFind is initialising nothing appears and I'm stuck there. It's kind of weird. What did you do exactly to overcome this problem ?

MacBook Pro 2017 no-touchbar; Razer Core V2; RX 570


ReplyQuote
Darkknight
(@darkknight)
New Member
Joined:2 months  ago
Posts: 4
June 10, 2018 12:05 am  

So are we good to go using the updated script and updating

MacBook Pro Mid 2015 + ASUS GTX 1050Ti 4GB + Akitio Thunder2 PCIe Box


ReplyQuote
mar_kelp
(@mar_kelp)
Eminent Member
Joined:1 year  ago
Posts: 22
June 10, 2018 1:40 am  

I upgraded to 10.13.5 and had to perform the 're-bless' instructions (in Recovery Mode to avoid SIP) from this page:
https://www.rodsbooks.com/refind/bootcoup.html

However, now I only see the Windows selections and no MacOS selections in rEFInd UI. I haven't troubleshooted that yet, but just use the regular Mac EFI selector (option key at boot) when I want to get to MacOS until I figure it out. Likely just nuke rEFInd and reinstall.


ReplyQuote
lefuturdelavenir
(@lefuturdelavenir)
Active Member
Joined:3 months  ago
Posts: 9
June 10, 2018 1:29 pm  

I don't know if it's 10.13.5 related but I'm stuck with this:

I've reinstall rEFInd multiple times on several support, internal and external, using HFS+ and FAT32. No luck. I have no clue on what's going on.
Note that it worked before. It stoped working after upgrading to 10.13.5 but I'm not sure if it's related.
Any idea?

Edit: interestingly my rEFInd USB disk starts normally on another MacBook (mid-2015) under 10.13.4

MacBook Pro 2017 no-touchbar; Razer Core V2; RX 570


ReplyQuote
Darkknight
(@darkknight)
New Member
Joined:2 months  ago
Posts: 4
June 10, 2018 7:00 pm  

Got it all working under the 10.13.5 only issue I am having is Sleep in not working on the MacBook Pro!
@fr34k great work for the community

MacBook Pro Mid 2015 + ASUS GTX 1050Ti 4GB + Akitio Thunder2 PCIe Box


ReplyQuote