Setup & Software Discussions
macOS Catalina - Tidbits & eGPU Updates
 

macOS Catalina - Tidbits & eGPU Updates  

 of  2
  RSS

trollied
(@trollied)
Active Member
Joined: 2 months ago
 
Posted by: @travid

@trollied

I'm on beta 8 and USB ports are working on my Razer Cork X Chroma. 

Yeah, mine's alright too. Think it was just a suspend/resume/hotplug glitch. Happens once in a while.

Razer Core X Chroma. MacBook Pro (2017/13”/i5/16Gb). VEGA 64


ReplyQuote
itsage
(@itsage)
Famed Member Admin
Joined: 3 years ago
 

Dev Beta 9 for macOS 10.15 is huge, 4.99GB. Let’s see if we can find Navi drivers in it! 😛 

Best ultrabooks for eGPU use

eGPU enclosure buying guide


ReplyQuote
steve4332
(@steve4332)
Eminent Member
Joined: 5 months ago
 

The latest dev beta 9 did not solve the 2018 Mac Mini eGPU white screen of death issue.

The current ROM version is now 1037.0.78.0.0 (iBridge: 17.16.10566.5.1,0)

Apple Mac Mini 2018 + Zotac AMP Box Mini + Sapphire RX 570 ITX


ReplyQuote
Eightarmedpet
(@eightarmedpet)
Noble Member
Joined: 3 years ago

itsage liked
ReplyQuote
itsage
(@itsage)
Famed Member Admin
Joined: 3 years ago
 

@eightarmedpet Unfortunately no Navi drivers yet.

 

Best ultrabooks for eGPU use

eGPU enclosure buying guide


ReplyQuote
steve4332
(@steve4332)
Eminent Member
Joined: 5 months ago
 

The latest dev beta 10 did not solve my 2018 Mac Mini eGPU white screen of death issue.

The current ROM version is now 1037.0.78.0.0 (iBridge: 17.16.10569.5.1,0) - only the iBridge firmare was updated.

Apple Mac Mini 2018 + Zotac AMP Box Mini + Sapphire RX 570 ITX


ReplyQuote
steve4332
(@steve4332)
Eminent Member
Joined: 5 months ago
 

The latest dev beta 11 (which is said to be the GM) does not solve my 2018 Mac Mini eGPU white screen of death issue.

The current ROM version is now 1037.0.78.0.0 (iBridge: 17.16.10571.5.1,0) - again, only the iBridge firmare was updated.

Apple Mac Mini 2018 + Zotac AMP Box Mini + Sapphire RX 570 ITX


ReplyQuote
zhangd116
(@zhangd116)
New Member
Joined: 2 years ago
 

@steve4332

I have a similar issue (black screen instead of white screen) on the public release of Catalina, it appears that egpu somehow gets disconnected in the booting process. Switching the power supply off and back on brings the egpu back.

 

Here's the ROM version on my mac mini: 1037.0.78.0.0 (iBridge: 17.16.10572.0.0,0)

2018 Mac Mini i7 with AMD Radeon RX 580 in Akitio Node


ReplyQuote
Ningauble77
(@ningauble77)
Estimable Member
Joined: 2 years ago
 

Did a little preliminary testing here.  Biggest change for me is different scaled resolution options for my 5120 x 1440 display, Catalina now offers 3840 x 1080, 2560 x 720 and even bigger "retina scaled" resolutions.  All of them but the native 5120 x 1440 are a bit too big for my tastes, but this is an improvement on what mojave offered.

When changing resolutions and/or closing lid on laptop the display occaisionally comes up in HDR mode, but as far as I can tell the apple tv app is neither playing back 4k/hdr capable movies in HDR or providing downscaled 4k content, which is a disappointment.

Performance on the Radeon VII seems very similar to mojave, including the suspiciously low geekbench compute results.  Here are a couple of unigine runs:

unigine valley r7Macos

unigine valley R7 Cat

unigine heaven r7macos

unigine heaven R7 cat

 

No apparent changes for me in bootcamp, still running build 295 but booting with egpu attached and igpu disabled, and hotplugging at windows logo to keep igpu active still work.

This post was modified 2 weeks ago

2018 13 Macbook Pro + Core v2 + Radeon VII Win10 1903/MacOS 10.14.6
ASUS X99 Deluxe+Core v2 + Radeon VII Win10 1809


ReplyQuote
TheMadTurtle11
(@themadturtle11)
New Member
Joined: 2 weeks ago
 

@eightarmedpet

There is a 64-bit Steam client, but you have to jump through some hoops to get it installed on a Mac (why they don't just update it, I don't know....). This link will walk you through it.  I did it and it works fine.

https://appleinsider.com/articles/19/09/03/how-to-update-your-steam-install-to-64-bit-before-macos-catalina

2018 Mac mini + Sonnet 550 breakaway + Sapphire Pulse RX580


ReplyQuote
Rycco
(@rycco)
Reputable Member
Joined: 3 years ago
 

My egpu setup on bootcamp was great, 100% reliable when I had Mojave. I installed Catalina, now my eGPU rarely works on Windows. If I get back to Mojave and reinstall bootcamp, will it be fine again or have I installed the newest apple firmware that I can't go back? I have a 2018 MacBook pro with t2. 

mid-2017 15" Macbook Pro RP555 + [email protected] (Mantiz Venus) + macOS & Win10


ReplyQuote
mac_editor
(@mac_editor)
Noble Member Moderator
Joined: 3 years ago
 

@rycco

I don’t have any problems on Catalina + Windows 10 on both AMD + NVIDIA. Ensure your Windows version is 18362.295 or lower. 

purge-wrangler.shpurge-nvda.shset-eGPU.shautomate-eGPU EFI Installer
2018 MacBook Pro 15" RP560X + RX 5700 XT (Mantiz Venus)


ReplyQuote
Rycco
(@rycco)
Reputable Member
Joined: 3 years ago
 
Posted by: @mac_editor

@rycco

I don’t have any problems on Catalina + Windows 10 on both AMD + NVIDIA. Ensure your Windows version is 18362.295 or lower. 

I mean, I had the most updated version of windows on Mojave, and the same one on Catalina. On Mojave I could boot it with the eGPU plugged in, on Catalina if I do that it gets stuck on the initial Apple Logo, so I don't think it's a Windows version fault.

mid-2017 15" Macbook Pro RP555 + [email protected] (Mantiz Venus) + macOS & Win10


ReplyQuote
mac_editor
(@mac_editor)
Noble Member Moderator
Joined: 3 years ago
 

@rycco

That sounds like a firmware issue. I don’t face this with a GTX 1070. Maybe resetting NVRAM and SMC helps?

purge-wrangler.shpurge-nvda.shset-eGPU.shautomate-eGPU EFI Installer
2018 MacBook Pro 15" RP560X + RX 5700 XT (Mantiz Venus)


ReplyQuote
Rycco
(@rycco)
Reputable Member
Joined: 3 years ago
 
Posted by: @mac_editor

Maybe resetting NVRAM and SMC helps

Gonna try that today! Thanks!

mid-2017 15" Macbook Pro RP555 + [email protected] (Mantiz Venus) + macOS & Win10


ReplyQuote
 of  2