macOS High Sierra launches with official External GPU support
 
Notifications
Clear all

macOS High Sierra launches with official External GPU support  

 of  14
  RSS

itsage
(@itsage)
Founder Admin
Joined: 4 years ago
 

@dkgeorge, on the AKiTiO Node you can reverse the mounting bracket to position the radiator in a way that it will close. It's hard to fully explain in words, here's a photo of the GTX 980 Ti Hybrid mounted in an AKiTiO Node to show how it's mounted. I mounted the R9 Fury X this way too so I know the RX Vega Liquid should work because the radiator looks similar.

LinkedIn | Twitter | Facebook | Youtube | Instagram
 
external graphics card builds
best laptops for external GPU
eGPU enclosure buyer's guide

 
2020 13" MacBook Pro [10th,4C,G] + RX 6700 XT @ 32Gbps-TB3 (CM MasterCase EG200) + Win10 1903 [build link]  


ReplyQuote
Tyschri123
(@tyschri123)
New Member
Joined: 4 years ago
 

Interesting challenge here (n00b here):

I have a Mid-2015 15" MBP TB2> TB3 Asus XG Station with XFX Rx 580 Graphics (I've read these can be trouble)

Here's the situation, I have encountered many successful implementations with similar hardware but I acquired the XG station 2 through a friend (for free!) after updating my MBP to High Sierra.

I have installed proper intel thunderbolt drivers after installing Win10 with bootcamp.

Then installed the ASUS hot plug tool needed to detect the device...and here's where my problems start. I am unable to update the XG Station Firmware and receive "0x21e" error code.

When I try to find the device in Device Manager all I can see the thunderbolt bus, not other connections, no graphics, not even the XG station 2.

I have tried reinstaling the PCI connections tree and disabled/re-eneabled all relevent connections but upon reboot, everything is organized differently, but still no relevant connections.

This is not the case when booting macOS, the XG station 2 is visable but no graphics card attached.

I did this all in EFI boot as well following the awesome instructions here on egpu.io

Am I missing something? Do I have to flash the ASUS thunderbolt firmware update to the device, and if so how would one go about this to get everything connected?

Again, I'm a noob, but would love some help.

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
itsage
(@itsage)
Founder Admin
Joined: 4 years ago
 

@Tyschri123, you can only flash the firmware of a Thunderbolt 3 enclosure with a Thunderbolt 3 host (computer). Can you check for the firmware number of your ASUS XG Station? You can accomplish this by booting into macOS, open System Information then expand Thunderbolt tree. It looks like this. We want to see whether your eGPU enclosure has at least firmware version 23,1. 25,1 is the latest version with the best compatibility.

LinkedIn | Twitter | Facebook | Youtube | Instagram
 
external graphics card builds
best laptops for external GPU
eGPU enclosure buyer's guide

 
2020 13" MacBook Pro [10th,4C,G] + RX 6700 XT @ 32Gbps-TB3 (CM MasterCase EG200) + Win10 1903 [build link]  


ReplyQuote
tbl777
(@tbl777)
Trusted Member
Joined: 4 years ago
 

@goalque  @itsage

I also tried Sapphire pulse RX580 4G with the psu power supply, it also not worked with the tb2 enclosure but worked good in the 10.12.6.

late-2013 15" MacBook Pro GT750M + RX580@16Gbps-TB2 (AKiTiO thunder 2) + macOS 10.13


ReplyQuote
Tyschri123
(@tyschri123)
New Member
Joined: 4 years ago
 
Posted by: itsage

@Tyschri123, you can only flash the firmware of a Thunderbolt 3 enclosure with a Thunderbolt 3 host (computer). Can you check for the firmware number of your ASUS XG Station? You can accomplish this by booting into macOS, open System Information then expand Thunderbolt tree. It looks like this. We want to see whether your eGPU enclosure has at least firmware version 23,1. 25,1 is the latest version with the best compatibility.

First off, thank you for the help!

Unfortunately it is still 21,1 

The device is brand new, he hadn’t even opened the box. Regardless, I won’t be able to update the firmware from my TB2 device then right? Doesn’t that just stop me dead in my tracks?

Or is there a way around this using another pc to update the firmware on the XG station, then proceed with next steps.

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
igerard
(@igerard)
Estimable Member
Joined: 4 years ago
 

I gave up for a Vega 56, because of cost : card + power unit update for the Node 

I bought the Asus RX 580 8G (3 fan) 320€

I wonder if the things is going to work with my early 2011 MBP 17 ? I have also a 2015 though

My 2011 setup with the 980 Ti work well with Sierra and my external 34 inches curved Asus display Smile

I receive the card tomorrow, I will give update.

MBP 2018, Touch Bar, i7 2.6 GHz, 32 GB RAM, 1T SSD, Radeon 560X... very nice!
eGPU : Akitio Node + RX 580 + GTX 980 Ti + Vega64


ReplyQuote
Mattlechops
(@mattlechops)
Active Member
Joined: 4 years ago
 

Hi @Goalque’s
I have a 2014 Mini and an Akitio Thunder2 with a RX 560. Can I get the automate-eGPU.kext for 10.13. please?

Appreciate the good work, thanks!

Mac Mini 2014 - Akitio Thunder2 - 120w PSU - MSI Aero ITX RX 560 OC - High Sierra


ReplyQuote
itsage
(@itsage)
Founder Admin
Joined: 4 years ago
 

@Tyschri123, firmware version 21,1 has very limited compatibility. From what I recall, it would only work with eGPU-certified Thunderbolt 3 laptops. What you'll need is the help of a Thunderbolt 3 computer to flash the firmware of your Asus XG Station to the latest version. We created a mapping tool to locate members with a TB3 laptops who can help. There are not many participants yet unfortunately.

LinkedIn | Twitter | Facebook | Youtube | Instagram
 
external graphics card builds
best laptops for external GPU
eGPU enclosure buyer's guide

 
2020 13" MacBook Pro [10th,4C,G] + RX 6700 XT @ 32Gbps-TB3 (CM MasterCase EG200) + Win10 1903 [build link]  


ReplyQuote
raha613
(@raha613)
Active Member
Joined: 4 years ago
 

Hi all, thank you for your help in advance. 

 

I have -

Macbook pro 15 (early 2011) high sierra 

OWC Mercury Helios TB1

HP B4J92AT NVIDIA GeForce GT 630 DP Graphics Card 2GB DDR3 SP 702084-001 

 

I had this working in Sierra with automate-egpu to run 1x Thunderbolt Cinema Display and 1x LED Cinema Display which apple says you can not do. I would connect the LED Cinema Display to the GT630, the Helios to the Thunderbolt Cinema Display then to the computer. Any way to get this working in High Sierra at this point? Any hope for the future?

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
Mkluvin1515
(@mkluvin1515)
New Member
Joined: 4 years ago
 

@goalque appreciate it! Just wanted to check in on your progress. Anything I can provide to help?

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
 of  14