Setup & Software Discussions
MBP 2018 crashes when egpu is plugged in.
 

MBP 2018 crashes when egpu is plugged in.  

  RSS

Junkmailkeep
(@junkmailkeep)
New Member
Joined: 4 months ago
 

I recently got a Akitio Node Pro and a XFX RX 560

After doing my research I figured this would be basically plug-in play.  However once I plugin the t3 cable into any of the four ports. The mac detects the cards, it shows the gpu chip in the task bar then it freezes. After about 5 seconds the screen goes black the fans do a quick high-rev spin and the computer restarts. 

I'm on macOS Mojave Version 10.14.5 (18F132) 

I've tried disabling secure-boot and allow external booting after reading that could cause a issue, however it didn't change anything.   I had an extra 1060 lying around and I know it didn't support it but I tried it anyway. mac picks up the T3 enclosure under the system report. 

I also tried this on my work 2017 MBP  same Mojave version and it also does the same thing. 

the last thing I did was test with different t3 cables but nothing changed. 

The only thing I have left to do is test the graphics card in my normal desktop. 

Any tips or ideas would be great. 

 

Update: I was able to put it in my desktop and it booted and ran fine. I don't think the card is bad. 

This topic was modified 4 months ago

Pending: Add my system information and expected eGPU configuration to my signature to give context to my posts


ReplyQuote
itsage
(@itsage)
Famed Member Admin
Joined: 3 years ago
 

Your XFX RX 560 itself may not be bad. What I’m guessing is the BIOS on it is not friendly with macOS. We have seen XFX GPUs being incompatible with macOS. If possible I’d recommend exchanging it for a different brand RX 560.

Best ultrabooks for eGPU use | eGPU enclosure buying guide


ReplyQuote
Junkmailkeep
(@junkmailkeep)
New Member
Joined: 4 months ago
 

Thanks, I will try and go to the store this week and get a different model.

Pending: Add my system information and expected eGPU configuration to my signature to give context to my posts


ReplyQuote