MBP2014: eGPU works, Internal GPU / dGPU GT750M doesnt, sleep problem
 
Notifications
Clear all

MBP2014: eGPU works, Internal GPU / dGPU GT750M doesnt, sleep problem  

  RSS

AgentSmith
(@agentsmith)
New Member
Joined: 2 months ago
 

Hi,

i happily used my Akitio Thunder2 with a GTX970 as eGPU for my MacBookPro2014 (15") running (High) Sierra.

Then i upgrade to Mojave. Since Apple banished NVIDIA i couldnt use my eGPU on macOS anymore. (Still working fine on my bootcamp Win10).

Then i found purge-wrangler. I got myself a "new" Sapphire RX580 and started running Purge-wrangler and the PurgeNVDA.

Which kinda worked... i was able to start my mac and my external monitor hooked to the RX580 showed me my desktop. The "about this mac" confirmed, the RX580 is running. One weird thing was that the MacBookPro didnt go to sleep but that wasnt my biggest concern. My Internal GPU / dGPU the GT750M isnt working anymore. If shut my MacBookPro down and unplug and restart only the Intel Iris Pro 1536 MB is running.

This was no option for me!

Terminal PurgeNVDA uninstall.
Purge-Wrangler uninstall.

 

Now the GT750M still isnt showing in the "about this mac". If i start Photoshop2020 it only runs on my the Intel Iris Pro.

 

How do I reaktivate the GT750M?

Is there a way to use the eGPU and still keep my GT750M running?

 

 

 

 

 

 

 

 

This topic was modified 2 months ago

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
mac_editor
(@mac_editor)
Famed Member Moderator
Joined: 3 years ago
 

@agentsmith, already mentioned - please read before using scripts: https://github.com/mayankk2308/purge-nvda#known-issues

If you want to avoid using purge-nvda, connect display directly to Mac (no display on eGPU). Read master thread for this Mac (in my signature).

 

purge-wranglertbt-flashpurge-nvdaset-eGPU
Insights Into macOS Video Editing Performance

Master Threads:
2014 15-inch MacBook Pro 750M
2018 15-inch MacBook Pro

 
2019 13" MacBook Pro [8th,4C,U] + RX Vega 64 @ 32Gbps-TB3 (Mantiz Venus) + macOS 10.14.6 & Win10 [build link]  


itsage liked
ReplyQuote
AgentSmith
(@agentsmith)
New Member
Joined: 2 months ago
 

Thanks for your advice - i read the content in advance.

The problem is, uninstalling to revert all changes (-u or --uninstall ) isnt working.

 

PurgeNVDA:

Uninstallation complete.
System ready. Reboot to apply changes.

 

Purge-Wrangler:

No patches detected.
System already clean.

 

Uninstall.
Reboot.
Still not dGPU.

 

Executing it in Save mode (cmd + s) isnt working either.

 

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote