MCBr 15 Late 2013 + W9100 - NEED HELP  

  RSS

Sabharwal
(@sabharwal)
Active Member
Joined: 3 months ago
Posts: 19
September 29, 2018 10:14 pm  
 
 
i ran the automate script
 
findings: 
 
About this mac:
i don't see the W9100 in the overview
 
System Report:
graphics/displays: 
AMD Radeon HD 8xxx:
 
  Chipset Model: AMD Radeon HD 8xxx
  Type: GPU
  Bus: PCIe
  PCIe Lane Width: x8
  Vendor: ATI (0x1002)
  Device ID: 0x67a0
  Revision ID: 0x0000
  gMux Version: 4.0.8 [3.2.8]
 
 
Upon connecting a monitor to the eGPU:
Nothing happens. 
 
can pls anyone help where have i gone wrong. 

Mac Pro 2013 - D700 - Sonnet Echo III TB2 - AMD W9100 - OS 10.13.6 High Sierra
Macbook pro late 2013 - GT750M - Sonnet Echo III TB2 - AMD W9100 - OS 10.11.6 El Captain


ReplyQuote
nu_ninja
(@nu_ninja)
Trusted Member
Joined: 8 months ago
Posts: 77
September 29, 2018 10:35 pm  

Did you set the eGPU display as primary as shown ithis video?

Mid-2012 13" Macbook Pro (MacBookPro9,2) TB1 -> RX 460 (AKiTiO Node)
+ macOS 10.14.1+Win10
+ Linux Mint 19


ReplyQuote
Sabharwal
(@sabharwal)
Active Member
Joined: 3 months ago
Posts: 19
September 29, 2018 10:47 pm  

i cannot see the eGPU in my displays

Mac Pro 2013 - D700 - Sonnet Echo III TB2 - AMD W9100 - OS 10.13.6 High Sierra
Macbook pro late 2013 - GT750M - Sonnet Echo III TB2 - AMD W9100 - OS 10.11.6 El Captain


ReplyQuote
Sabharwal
(@sabharwal)
Active Member
Joined: 3 months ago
Posts: 19
September 29, 2018 11:01 pm  

***      automate-eGPU.sh v1.0.1      ***

* (c) 2016, 2017 by Goalque & FricoRico *

*****************************************

Detected eGPU

 Hawaii XT GL [FirePro W9100]

Current OS X

 10.11.6 15G22010

Previous OS X

 10.11.6 appstore

Latest installed Nvidia web driver

 [not found]

Checking IOPCITunnelCompatible keys...

 

IOPCITunnelCompatible mods done.

Rebuilding caches...

All ready. Please restart the Mac.

Arveens-MacBook-Pro2:Desktop RVN$ 

Mac Pro 2013 - D700 - Sonnet Echo III TB2 - AMD W9100 - OS 10.13.6 High Sierra
Macbook pro late 2013 - GT750M - Sonnet Echo III TB2 - AMD W9100 - OS 10.11.6 El Captain


ReplyQuote
Sabharwal
(@sabharwal)
Active Member
Joined: 3 months ago
Posts: 19
October 4, 2018 9:24 pm  

@goalque 

can you help pls.

Mac Pro 2013 - D700 - Sonnet Echo III TB2 - AMD W9100 - OS 10.13.6 High Sierra
Macbook pro late 2013 - GT750M - Sonnet Echo III TB2 - AMD W9100 - OS 10.11.6 El Captain


ReplyQuote
goalque
(@goalque)
Noble Member Admin
Joined: 2 years ago
Posts: 1315

ReplyQuote
goalque
(@goalque)
Noble Member Admin
Joined: 2 years ago
Posts: 1315

ReplyQuote
Sabharwal
(@sabharwal)
Active Member
Joined: 3 months ago
Posts: 19
October 5, 2018 1:46 pm  
Posted by: goalque

Apple doesn't support W9100.

https://blog.maxsaxedesign.co.uk/2015/11/01/mac-pro-dual-amd-firepro-d700-dual-amd-firepro-w9100-egpus/

I've found this post where this user was able to PnP not one but 2 w9100 without any script with the mac pro 2013 D700 

and also got a chance to speak to him and confirm that they still run without any problem.. 

i was hoping since u guys are Guru's of eGPU you could throw some light and help me out with this setup.

Mac Pro 2013 - D700 - Sonnet Echo III TB2 - AMD W9100 - OS 10.13.6 High Sierra
Macbook pro late 2013 - GT750M - Sonnet Echo III TB2 - AMD W9100 - OS 10.11.6 El Captain


ReplyQuote
goalque
(@goalque)
Noble Member Admin
Joined: 2 years ago
Posts: 1315
October 5, 2018 2:07 pm  

I checked that 0x67a0 device id doesn’t exist in 10.13.6. The old automate-eGPU.sh adds missing ids and might work in Sierra but I have ceased the development and don’t provide any support for scripts. Sorry. Did you try automate-eGPU.kext? (discontinued as well)

automate-eGPU EFIapple_set_os.efi
--
late-2016 13" Macbook Pro nTB + [email protected] (Netstor HL23T) + macOS & Win10
late-2016 13" Macbook Pro nTB + GTX980/[email protected] (Netstor HL23T) + macOS10.13 & Win10


ReplyQuote
Sabharwal
(@sabharwal)
Active Member
Joined: 3 months ago
Posts: 19
October 5, 2018 3:14 pm  
Posted by: goalque

yes, starting from 10.13.4
https://support.apple.com/en-us/HT208544

so if i stick to sierra or lower os will this setup work.

will try install sierra and then try the old scripts. 

sorry for taking ur time bcos im unable to get this setup working and not a very experienced user so asking for your help.

thanks

Mac Pro 2013 - D700 - Sonnet Echo III TB2 - AMD W9100 - OS 10.13.6 High Sierra
Macbook pro late 2013 - GT750M - Sonnet Echo III TB2 - AMD W9100 - OS 10.11.6 El Captain


ReplyQuote
goalque
(@goalque)
Noble Member Admin
Joined: 2 years ago
Posts: 1315
October 5, 2018 3:28 pm  

I don't know. Did you try script's -clpeak option or CL!ng to verify OpenCL functionality if no eGPU screen output? Do you need video output from the eGPU or are you going to use it for calculation purposes only?

automate-eGPU.kext is not generic regarding the macOS version but I remember @mac_editor made a generic version of my kext and you can add easily new device ids.

automate-eGPU EFIapple_set_os.efi
--
late-2016 13" Macbook Pro nTB + [email protected] (Netstor HL23T) + macOS & Win10
late-2016 13" Macbook Pro nTB + GTX980/[email protected] (Netstor HL23T) + macOS10.13 & Win10


ReplyQuote
Sabharwal
(@sabharwal)
Active Member
Joined: 3 months ago
Posts: 19
October 6, 2018 6:48 am  

I haven't tried those scripts bcos I was not aware of them

I need to use physical outputs from the egpu setup.

Mac Pro 2013 - D700 - Sonnet Echo III TB2 - AMD W9100 - OS 10.13.6 High Sierra
Macbook pro late 2013 - GT750M - Sonnet Echo III TB2 - AMD W9100 - OS 10.11.6 El Captain


ReplyQuote
Sabharwal
(@sabharwal)
Active Member
Joined: 3 months ago
Posts: 19
October 9, 2018 5:34 pm  
Posted by: goalque

I don't know. Did you try script's -clpeak option or CL!ng to verify OpenCL functionality if no eGPU screen output? Do you need video output from the eGPU or are you going to use it for calculation purposes only?

automate-eGPU.kext is not generic regarding the macOS version but I remember @mac_editor made a generic version of my kext and you can add easily new device ids.

@goalque 

Mac Pro 2013 - OSX 10.12.6 

I tried the -clpeak, these are the following results. 

Arveens-Mac-Pro:~ rvn$ sudo ./automate-eGPU.sh -clpeak

Password:

sudo: ./automate-eGPU.sh: command not found

Arveens-Mac-Pro:~ rvn$

I wanted to ask this is the following that shows up in the system information - graphic section.

why does my pice lane width show as x8 instead of x16 in which I've installed the GPU since the sonnet echo express iii has 

  • One x8 mechanical (x8 electrical) PCIe 2.0
  • One x16 mechanical (x8 electrical) PCIe 2.0
  • One x8 mechanical (x4 electrical) PCIe 2.0

AMD Radeon HD 8xxx:

 

  Chipset Model: AMD Radeon HD 8xxx

  Type: GPU

  Bus: PCIe

  PCIe Lane Width: x8

  Vendor: ATI (0x1002)

  Device ID: 0x67a0

  Revision ID: 0x0000

  Automatic Graphics Switching: Supported

  gMux Version: 4.0.11 [3.2.8]

  Metal: Supported

 

Mac Pro 2013 - D700 - Sonnet Echo III TB2 - AMD W9100 - OS 10.13.6 High Sierra
Macbook pro late 2013 - GT750M - Sonnet Echo III TB2 - AMD W9100 - OS 10.11.6 El Captain


ReplyQuote
goalque
(@goalque)
Noble Member Admin
Joined: 2 years ago
Posts: 1315
October 9, 2018 6:05 pm  

Run chmod +x automate-eGPU.sh first and check your current working directory in Terminal. CL!ng would be better.

It shows x8 because of the PCIe switch in Echo III.

automate-eGPU EFIapple_set_os.efi
--
late-2016 13" Macbook Pro nTB + [email protected] (Netstor HL23T) + macOS & Win10
late-2016 13" Macbook Pro nTB + GTX980/[email protected] (Netstor HL23T) + macOS10.13 & Win10


ReplyQuote
Sabharwal
(@sabharwal)
Active Member
Joined: 3 months ago
Posts: 19
October 21, 2018 7:17 pm  

@goalque 

sorry for the noob question how to CL!ng ??

Mac Pro 2013 - D700 - Sonnet Echo III TB2 - AMD W9100 - OS 10.13.6 High Sierra
Macbook pro late 2013 - GT750M - Sonnet Echo III TB2 - AMD W9100 - OS 10.11.6 El Captain


ReplyQuote
theitsage
(@itsage)
Famed Member Admin
Joined: 2 years ago
Posts: 3243
October 21, 2018 7:38 pm  

@sabharwal  CL!ng is a free utility to show GPU bandwidth in macOS.

Best ultrabooks for eGPU use

eGPU enclosure buying guide

86 external GPU build guides


ReplyQuote