Missing a step? Mac Mini 2018 + Razer Core X Chroma + Red Devil 6900XT
 
Notifications
Clear all

Missing a step? Mac Mini 2018 + Razer Core X Chroma + Red Devil 6900XT  

 of  3
  RSS

readywater
(@readywater)
Active Member
Joined: 2 months ago
 

Hi! I hope this is the right spot.

I've been trying to follow the guides for getting the eGPU set up on OSX 11.5 Beta (20G5042c).

System specs:

[Please login to see this]

And as mentioned, a core x chroma and 6900xt

I've got the enclosure running, card lights up and is detected by automate-eGPU with the following:

[Please login to see this]

It also appears (I think) under display here:

[Please login to see this]

The Chroma likewise appears on the thunderbolt list, and the ktext wall appears as suggested when I hotswap it while monitoring in console.

I currently have a displayport plugged into the bottom slot of the 6900xt, which in turn is pluged into a 32" dell monitor via its displayport input.

I've attempted a few things like turning on and off, changing the thunderbolt slot on the mini, etc. But without much luck. I'm hoping I'm just missing something super basic, but any advice is appreciated. Also happy to consolidate build info once it's working!

Mac Mini 2018
Razer Core X Chroma
Red Devil 6900 XT


ReplyQuote
Mini i5
(@mini-i5)
Prominent Member
Joined: 2 years ago
 

@readywater

Sorry to hear this. Unexpectedly, some of the RX 6900 XT models don't have driver support in Big Sur (!)

There's more information in this thread:

https://egpu.io/forums/mac-setup/radeon-rx-6800-xt-for-mac/paged/29/

 

2018 Mac Mini + AMD RX 5500 XT (Sonnet Breakaway Box 650) Big Sur 11.5 + Windows 21H1

 
2018 Mac Mini [8th,6C,B] + RX Vega 56 @ 32Gbps-TB3 (Sonnet Breakaway 650) + macOS 11.1 & Win10 [build link]  


ReplyQuote
mac_editor
(@mac_editor)
Famed Member Moderator
Joined: 4 years ago
 

@readywater, 2018 Mac mini natively supports eGPUs. Also, why automate-eGPU.sh? It clearly says it's only for macOS <= 10.12.x. Please read the instructions before running scripts.

If you have a Navi XTXH 6900 XT, it is currently not supported on macOS Big Sur (see @mini-i5's link). However, you can try to get it working (if you are willing to experiment) with: https://egpu.io/forums/mac-setup/kryptonite-tb1-2-mac-egpu-support-with-filevault-sip-and-art-enabled/paged/6/#post-96206

 

Author: kryptonitepurge-wranglertbt-flashpurge-nvdaset-eGPU
Insights Into macOS Video Editing Performance

Master Threads:
2014 15-inch MacBook Pro 750M
2018 15-inch MacBook Pro

 
2019 13" MacBook Pro [8th,4C,U] + RX Vega 64 @ 32Gbps-TB3 (Mantiz Venus) + macOS 10.14.6 & Win10 [build link]  


ReplyQuote
readywater
(@readywater)
Active Member
Joined: 2 months ago
 

Oh god, you're right. x_x I somehow got it into my might that it was greater than and didn't double check. Thank you for pointing that out.

@mini-i5, the card is the ultimate model, so looks like XTXH. Grateful for your sharing that resource and a good lesson to how detailed I should have gotten with this.

@mac_editor I'm inclined to experiment/get this going instead of returning it, since I have a NUC as a backup. Having it on the mini would far-and-away be ideal though.

I'll aim to get kryptonite set up and make an attempt with the ktext you shared. Thank you for putting together these resources and providing some hope.

 

Mac Mini 2018
Razer Core X Chroma
Red Devil 6900 XT


ReplyQuote
mac_editor
(@mac_editor)
Famed Member Moderator
Joined: 4 years ago
 

@readywater, cheers. Do let me know in case you need help setting up the whole thing - happy to help.

 

Author: kryptonitepurge-wranglertbt-flashpurge-nvdaset-eGPU
Insights Into macOS Video Editing Performance

Master Threads:
2014 15-inch MacBook Pro 750M
2018 15-inch MacBook Pro

 
2019 13" MacBook Pro [8th,4C,U] + RX Vega 64 @ 32Gbps-TB3 (Mantiz Venus) + macOS 10.14.6 & Win10 [build link]  


ReplyQuote
readywater
(@readywater)
Active Member
Joined: 2 months ago
 

@mac_editor, Thank you! Your instructions seem pretty clear, but given my inability to read basic operators lately, I'm just going to double check.

I've set the kryptonite partition (512mb, fat32) on an external thunderbolt drive that houses a time machine partition as well.

The arguments I've set are:

[Please login to see this]

and I've placed the AMDLegacySupport.kext file you shared in:

[Please login to see this]

What I wasn't clear on was whether placement in that folder was sufficient (which I'm guessing it isn't), or whether I need to reference that file in the config.plist? My guess was to add an object to the Kernal/add part of config.plist and basically copy what was there for lilu and kryptonite, but wanted to check first.

Once again, grateful for your help on this!

 

Mac Mini 2018
Razer Core X Chroma
Red Devil 6900 XT


ReplyQuote
mac_editor
(@mac_editor)
Famed Member Moderator
Joined: 4 years ago
 
Posted by: @readywater

What I wasn't clear on was whether placement in that folder was sufficient (which I'm guessing it isn't), or whether I need to reference that file in the config.plist? My guess was to add an object to the Kernal/add part of config.plist and basically copy what was there for lilu and kryptonite , but wanted to check first.

Yep, you're on the right track. It needs to be referenced and enabled in config.plist like so: https://egpu.io/forums/mac-setup/kryptonite-tb1-2-mac-egpu-support-with-filevault-sip-and-art-enabled/paged/7/#post-96272

Author: kryptonitepurge-wranglertbt-flashpurge-nvdaset-eGPU
Insights Into macOS Video Editing Performance

Master Threads:
2014 15-inch MacBook Pro 750M
2018 15-inch MacBook Pro

 
2019 13" MacBook Pro [8th,4C,U] + RX Vega 64 @ 32Gbps-TB3 (Mantiz Venus) + macOS 10.14.6 & Win10 [build link]  


ReplyQuote
readywater
(@readywater)
Active Member
Joined: 2 months ago
 

@mac_editor, Awesome, thanks! Going through that thread, it looks like I was able to load it in successfully:

  ~  kextstat | grep -i -e Lilu -e Kry
Executing: /usr/bin/kmutil showloaded
No variant specified, falling back to release
48 1 0 0x2e000 0x2e000 as.vit9696.Lilu (1.5.3) A4C0AB78-C141-3DC5-812F-93408D94A4D7 <8 6 5 3 2 1>
49 0 0 0xf000 0xf000 io.egpu.Kryptonite (1.0.0) 7AC9E35D-F949-3A3E-9181-35CB5915357C <48 8 6 5 3 2 1>

 

However, it's still showing this for sysinfo display:

[Please login to see this]

I was browsing through the thread and saw this, and was wondering if there was a similar thing I should try with the AMD legacy kext?

Here's the config as a gut check

Screen Shot 2021 06 20 at 20.20.57

 

Mac Mini 2018
Razer Core X Chroma
Red Devil 6900 XT


ReplyQuote
mac_editor
(@mac_editor)
Famed Member Moderator
Joined: 4 years ago
 

@readywater, executable path should be empty for AMDLegacySupport kext because it is codeless.

Posted by: @readywater

I was browsing through the thread and saw this, and was wondering if there was a similar thing I should try with the AMD legacy kext?

You can't do that with 3rd-party unsigned kexts with SIP and it's really annoying on Big Sur to try.

Author: kryptonitepurge-wranglertbt-flashpurge-nvdaset-eGPU
Insights Into macOS Video Editing Performance

Master Threads:
2014 15-inch MacBook Pro 750M
2018 15-inch MacBook Pro

 
2019 13" MacBook Pro [8th,4C,U] + RX Vega 64 @ 32Gbps-TB3 (Mantiz Venus) + macOS 10.14.6 & Win10 [build link]  


ReplyQuote
mac_editor
(@mac_editor)
Famed Member Moderator
Joined: 4 years ago
 

@readywater, I think the kext had a mistake as well. Please replace the legacy kext with this one and retry:

 

Author: kryptonitepurge-wranglertbt-flashpurge-nvdaset-eGPU
Insights Into macOS Video Editing Performance

Master Threads:
2014 15-inch MacBook Pro 750M
2018 15-inch MacBook Pro

 
2019 13" MacBook Pro [8th,4C,U] + RX Vega 64 @ 32Gbps-TB3 (Mantiz Venus) + macOS 10.14.6 & Win10 [build link]  


ReplyQuote
 of  3