Missing scaled resolution w/ Vega 64 TB3 + LG 34wk95u-w
 
Notifications
Clear all

Missing scaled resolution w/ Vega 64 TB3 + LG 34wk95u-w  

 of  5
  RSS

foo
 foo
(@foo)
Active Member
Joined: 8 months ago
 

@filchermcurr

Posted by: @filchermcurr

The only thing I notice is that anything in the very center of the monitor now gets sort of cut off. Are you noticing the same thing? In the linked picture, you can see it in the R, the 5, and the X.

https://imgur.com/a/t72Wpaz

I'm having this same issue and it's really annoying. I just updated to Catalina as I thought it might be a Mojave bug, but the issue is still present. I'm using a DisplayPort 1.4 cable and Radeon RX 580 (in Asus XG Pro eGPU case). The monitor res in 5210x2160 and running scaled 3360 x 1417.

Anyone have any ideas on how to get rid of this line down the centre of the screen?

This post was modified 8 months ago

MacBook Pro 13" (2016)
ASUS XG Station Pro
Gigabyte Radeon RX 580 8G
LG 34WK95U-W
DisplayPort 1.4 cable


ReplyQuote
Montoulieu
(@montoulieu)
New Member
Joined: 11 months ago
 

Has anyone been able to get this to work on Catalina?

I had it working perfectly in Mojave but lost the custom resolutions in System Preferences/Displays after the update.

I noticed that after the update the display plist was moved to the Relocated Items on Desktop and now when I try to run the cp command to copy the plist it says that /System/Library/... is a Read-only file system. 🤔

Edit

Just found a solution to this.

After you have disabled SIP and booted back into macOS, you must use the following command to allow read and write to the System folder:

sudo mount -uw /

Restarted my Mac and everything was back to normal.

Thanks again for the post above! 🤘

This post was modified 7 months ago

2016 MacBook Pro 15"
Vega 56 8GB in Razer Core X Chroma


ReplyQuote
hydeyu
(@hydeyu)
Active Member
Joined: 7 months ago
 
Posted by: @montoulieu

Has anyone been able to get this to work on Catalina?

I had it working perfectly in Mojave but lost the custom resolutions in System Preferences/Displays after the update.

I noticed that after the update the display plist was moved to the Relocated Items on Desktop and now when I try to run the cp command to copy the plist it says that /System/Library/... is a Read-only file system. 🤔

Edit

Just found a solution to this.

After you have disabled SIP and booted back into macOS, you must use the following command to allow read and write to the System folder:

sudo mount -uw /

Restarted my Mac and everything was back to normal.

Thanks again for the post above! 🤘

Was able to solve the same problem as the OP's using this method in Catalina, however after updating to 10.15.1, my LG 5k2k will only work in 30hz (5120*2160). eGPU is Razer Core X Chroma + RX570. I'm using the same displayport 1.4 cable as before, was working fine in 5k2k/60hz before 10.15.1. Has anyone got it working 5k2k/60hz in 10.15.1?

(It's fine when using TB3, 60hz no problem, but however I try it will not do 60hz with displayport.)

This post was modified 7 months ago

Mac mini (2018)
Razer Core X Chroma
XFX AMD Radeon VII 16GB HBM2
LG 34wk95u-w


ReplyQuote
joevt
(@joevt)
Noble Member
Joined: 3 years ago
 

Use the following command to check DisplayPort link width and link speed:
/System/Library/Extensions/AppleGraphicsControl.kext/Contents/MacOS/AGDCDiagnose -a > AGDCDiagnose_a.txt 2>&1

Which LG model is it?

Mac mini (2018), Mac Pro (Early 2008), MacBook Pro (Retina, 15-inch, Mid 2015), GA-Z170X-Gaming 7, Sapphire Pulse Radeon RX 580 8GB GDDR5, Sonnet Echo Express III-D, Trebleet Thunderbolt 3 to NVMe M.2 case


ReplyQuote
foo
 foo
(@foo)
Active Member
Joined: 8 months ago
 

@hydeyu

Posted by: @hydeyu

my LG 5k2k will only work in 30hz (5120*2160)

I was having exactly the same problem the other day (running at 30 Hz). After I upgraded to Catalina a few weeks ago, I had to put the DisplayProductID-7720 file back (expected) but it was running at 60 HZ at scaled 3360 x 1417. But then the other day it just stopped working at that scaled res at 60Hz and would only run at 30Hz. I spent the whole weekend trying to fix it. I ended up reinstalling MacOS (Catalina) from a Time Machine backup wondering if this would fix it. After the Time Machine restore and putting the plist file back, it still didn't work. I was so frustrated. I  decided to settle using it at 30 Hz. But then the next day it was running at 60 Hz again, and still is (for now)!! And I didn't make any changes.

I find all this messing around quite frustrating. I've wasted so much time on it. For such an expensive monitor, it should just work. I'm not sure if it's a problem with the monitor or Apple's Mac OS, but I wish they would just fix it. 

PS Has anyone contacted LG or Apple about this issue?

Also, for those running at the scaled res of 3360 x 1417 with an eGPU, does everyone have the missing vertical line down the middle of the screen (about 1 or 2 pixels wide)?

This post was modified 7 months ago

MacBook Pro 13" (2016)
ASUS XG Station Pro
Gigabyte Radeon RX 580 8G
LG 34WK95U-W
DisplayPort 1.4 cable


ReplyQuote
hydeyu
(@hydeyu)
Active Member
Joined: 7 months ago
 

@joevt

Hi, the model  is LG 34wk95u-w UltraFine 34" 21:9 5K2K

I was able to locate AGDCDiagnose, but have no idea how to interpret the result...

This post was modified 7 months ago

Mac mini (2018)
Razer Core X Chroma
XFX AMD Radeon VII 16GB HBM2
LG 34wk95u-w


ReplyQuote
hydeyu
(@hydeyu)
Active Member
Joined: 7 months ago
 

@foo

Hi, have you updated to 10.15.1 yet? And if so is 60hz still working?

Mac mini (2018)
Razer Core X Chroma
XFX AMD Radeon VII 16GB HBM2
LG 34wk95u-w


ReplyQuote
foo
 foo
(@foo)
Active Member
Joined: 8 months ago
 

@hydeyu

Posted by: @hydeyu

have you updated to 10.15.1 yet?

Funny you ask. I was running 10.15.1 when I was having the 30Hz refresh rate issue, and the backup I restored was of 10.15, where I now have 60 Hz again (but not after the intial restore and putting the plist file back. The 60 Hz option just appeared again randomly in the display settings window). I'm still running 10.15 and having upgraded to 10.15.1 yet.

This post was modified 7 months ago

MacBook Pro 13" (2016)
ASUS XG Station Pro
Gigabyte Radeon RX 580 8G
LG 34WK95U-W
DisplayPort 1.4 cable


ReplyQuote
foo
 foo
(@foo)
Active Member
Joined: 8 months ago
 

I'd like to know how many Mac OS users  there are with the LG 34" 5K 34WK95U-W monitor that are having issues? I'm going to assume most of these users would be using an eGPU with this screen also. 

Would be good if we could get together and report these issues to LG or Apple to get resolved. 

MacBook Pro 13" (2016)
ASUS XG Station Pro
Gigabyte Radeon RX 580 8G
LG 34WK95U-W
DisplayPort 1.4 cable


ReplyQuote
Funderful
(@funderful)
New Member
Joined: 7 months ago
 

Has anyone figured out a way to set the correct scaling resolutions on a 21:9 display when connected to a displayport on an eGPU in 10.15.1?  The default scaling on the LG 5k wide display is correct, but all of the alternate scaling resolutions are the wrong aspect ratio.  The exact same display connected directly to 2018 Mac Mini via thunderbolt has the correct ratios for scaling so it seems to be some kind of logic error in how eGPU scaling ratios are calculated by macOS.

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
 of  5