Mouse input lag with new Razer Core X Chroma / 5700 XT
 
Notifications
Clear all

Mouse input lag with new Razer Core X Chroma / 5700 XT  

  RSS

egpuser
(@egpuser)
New Member
Joined: 5 months ago
 

Hi there, has anyone else, particularly those who play competitive FPS/eSports, ever experience about an additional 30-60ms input delay using an eGPU? I just got the setup below going and I'm noticing a significant input lag on my external monitor. If I move the mouse cursor to the MacBook display, it's fine.

Things I’ve tried:

  • connecting the mouse directly to the computer, monitor hub, and eGPU box
  • removing all USBs/Ethernet from eGPU
  • other mouse and keyboard (wired and wireless)
  • another external display
  • HDMI and display port
  • connecting display directly to computer like normal (no epgu) works just fine

Setup:

Would greatly appreciate any thoughts or ideas before I send back my Razer Core X!
Thank you!

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
SudeepStacks
(@sudeepstacks)
Eminent Member
Joined: 5 months ago
 

Bro I got the same exact setup as you except I have the 2019 Macbook Pro 13". I had the Glorious Model O Wired Gaming mouse working perflectly with the Egpu Setup. However, As soon as I got my external monitor in the mail today, and set it up, The mouse barely works now. I switched back to my wireless mouse and it works perfectly. Honestly have no clue what the issue is with wired mouses and the Razer Core X Chroma. I heard something about having the Ethernet plugged in would make it stop working. 

2019 MacBook Pro 13"
Razer Core X Chroma
MSI Mech OC AMD Radeon RX 5700 XT


egpuser liked
ReplyQuote
jisongkun
(@jisongkun)
Active Member
Joined: 2 years ago
 

gigabyte aorus gaming box having same issue with certain firmware. maybe the problem is the bandwidth issue?

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
lilipeipei
(@lilipeipei)
Active Member
Joined: 4 years ago
 

Actually the USB ports on Core X Chroma do not accept any usb hub. Any device connected via hub would get a very laggy experience.

 

There has been reported that connecting via some powered hubs would fix that issue, but I've not tested yet.

MBP15 2016 configured to Radeon Pro 460 (burning a hole on table when driving my 4k monitor
Razer Core X Chroma (USB ports sucks, but it has RGB!
Radeon VII (anyone could stop these fans?


ReplyQuote
egpuser
(@egpuser)
New Member
Joined: 5 months ago
 
Posted by: @lilipeipei

Actually the USB ports on Core X Chroma do not accept any usb hub. Any device connected via hub would get a very laggy experience.

 

There has been reported that connecting via some powered hubs would fix that issue, but I've not tested yet.

I'm experiencing the issues with no hub.

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote