Notifications
Clear all

New To eGPU - Advice Please  

  RSS

jay54654
(@jay54654)
Active Member
Joined: 2 months ago
 

Hi,

So due to unforseen circumstances I need/want to use a eGPU.

I have a GTX1080 and have bought a Akitio Node

I also have a late 2015 imac. I am aware this comes with Thunderbolt 2 ports so will get a Thunderbolt 2 to 3 adapter

Anyway I am also aware that mac's don't out of the box work with Nvidia.

Considering my spec, what is the best way to get my 1080 to work with the mac?

The OS on the mac is Big Sur 

Thank you for any help

 

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
itsage
(@itsage)
Founder Admin
Joined: 5 years ago
 

@jay54654, There's no Nvidia drivers for Big Sur. You'd have to reinstall macOS 10.13.6 and run Purge-Wrangler to make it work with your 2015 iMac.

 

LinkedIn | Twitter | Facebook | Youtube | Instagram
 
external graphics card builds
best laptops for external GPU
eGPU enclosure buyer's guide

 
2018 Mac Mini [8th,4C,B] + RX Vega 56 Nano @ 32Gbps-TB3 (Gigabyte Gaming Box) + macOS 12.0 & Win11 [build link]  


ReplyQuote
jay54654
(@jay54654)
Active Member
Joined: 2 months ago
 

Many thanks, I have given up on getting an Nvidia to work and have got myself an RX570. Just waiting for the thunderbolt cables to arrive then will give it a go

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
jay54654
(@jay54654)
Active Member
Joined: 2 months ago
 

I have a couple of threads on here so will update both. Anyway got it working in the end with an RX 570.

Akitio Node into a Thunderbolt 3 to 2 adapter, Purge wrangler installed following the instructions on the wiki.

RX570 showed up and my Company For Heroes 2 game in the app info bit allows me to choose the external gpu.

I wanted to use the internal monitor but running on the internal monitor it is still using the internal graphics for some reason. 

External monitor it is using the egpu. 

Internal graphics 1920x1080, everything on low = 17fps

eGPU 1920x1080 , everything on high = 44fps 

Using latest version of Big Sur

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

itsage liked
ReplyQuote