Setup & Software Discussions
Newbie MacBook Pro 2014 Razer Core V1 RX580 TB2-3 problem
 

[Solved] Newbie MacBook Pro 2014 Razer Core V1 RX580 TB2-3 problem  

  RSS

dfphoto
(@dfphoto)
Eminent Member
Joined: 4 months ago
 

Hello group,

I'm a complete newbie, I bought a Razer Core V1 on ebay and a new MSI RX580 mk2 OC new I'm having problems figuring this egpu system out. I have a mid 2014 macbook pro with an Nvidia 750m built-in graphic card 2gb. I have an apple TB 2-3 adapter and a belkin TB3 cable... OSX 10.13.6 I'm running a TB2 cable from the computer to the apple TB2-3 adapter and plugging that TB2-3 adapter to the Razer.

I edit video which is the purpose of this system. I installed the card and plugged the unit in and nothing happened, no lights or fan. I have a multi meter and tried the 8 prongs but I am not seeing any voltage. I finally noticed there is an on/off switch but tried both and nothing.

Is this unit suppose to come on regardless of being connected to the computer. I tried chatting with Razer but they had to fwd me to a different person who needs to email the answer to me. If anyone can offer any advice I'd appreciate it.

Update: Overnight, I ran purgewrangler and enabled for nvidia internal AMD external and unlocked Ti82. I ordered a 2nd TB2-3 adapter, I have 2 TB2 cables already that work. I checked the system report and it says nothing is plugged in to my TB ports. I'm trying the purge nvidia script and I'm little stuck on what to select I chose "

NVIDIA eGPUs Disables only the internal NVIDIA GPU and sets the gmux to Intel GPU to enable OpenCL/GL acceleration and high performance with NVIDIA eGPUs with a combination of NVRAM + NVDA kernel extension patches." 

But it says command not found or nvidia web driver needs to be installed. Driving me crazy

This topic was modified 4 months ago

Pending: 2014 macbook pro Nvidia 750 Gigabyte RX580 gaming box OSX 10.13.6 my signature to give context to my posts


ReplyQuote
Eightarmedpet
(@eightarmedpet)
Noble Member
Joined: 3 years ago
 

I think this is a relatively simple one... both your Core 1 and tb2 are locked out of eGPU support by Apple, because Apple. Luckily due to the smart folks on here there are work arounds that are little more involved than a couple of clicks. 

This is what you need... https://egpu.io/forums/mac-setup/script-enable-egpu-on-tb1-2-macs-on-macos-10-13-4/

2017 13" MacBook Pro Touch Bar
GTX1060 + AKiTiO Thunder3 + Win10
GTX1070 + Sonnet Breakaway Box + Win10
GTX1070 + Razer Core V1 + Win10
Vega 56 + Razer Core V1 + macOS + Win10
Vega 56 + Mantiz Venus + macOS + W10

---

LG 5K Ultrafine flickering issue fix


ReplyQuote
dfphoto
(@dfphoto)
Eminent Member
Joined: 4 months ago
 

Hi,

Thanks for replying, I ran that purge wrangler terminal scrip chose the script for Nvidia internal AMD external restarted then I plugged in but nothing is happening on the razer, I thought it would at least power up. Now I'm going through each cable but I'm not seeing a connection with my TB2-3 adapter on a usb c hard drive via my TB2 port... I just ordered another adapter will have tonight.... This is frustrating, I can't tell where the problem is or what is normal.

Pending: 2014 macbook pro Nvidia 750 Gigabyte RX580 gaming box OSX 10.13.6 my signature to give context to my posts


ReplyQuote
Eightarmedpet
(@eightarmedpet)
Noble Member
Joined: 3 years ago
 

@dfphoto sorry I should have been clearer... you are goign to have to do the Ti82 unlock with purgewrangler... the V1 Core's TB3 chip isnt supported in macOS. DO that first and check your core shows up in System preferences and then go from there.

2017 13" MacBook Pro Touch Bar
GTX1060 + AKiTiO Thunder3 + Win10
GTX1070 + Sonnet Breakaway Box + Win10
GTX1070 + Razer Core V1 + Win10
Vega 56 + Razer Core V1 + macOS + Win10
Vega 56 + Mantiz Venus + macOS + W10

---

LG 5K Ultrafine flickering issue fix


ReplyQuote
dfphoto
(@dfphoto)
Eminent Member
Joined: 4 months ago
 

Hi, I checked the TI thing and it says it's enabled, I checked the system and in TB ports nothing is connected it says.... I'm worried the TB 2-3 adapter is not working but it was brand new in the box. I can't get my external hard drive sandisk SSD via usb c to fire up with the TB cables/adapter either... shiat Wow this is very confusing...  One more thing, is it normal to run the TB2 from the laptop to the apple 2-3 adapter then that adapter into the Razer?   

This post was modified 4 months ago

Pending: 2014 macbook pro Nvidia 750 Gigabyte RX580 gaming box OSX 10.13.6 my signature to give context to my posts


ReplyQuote
dfphoto
(@dfphoto)
Eminent Member
Joined: 4 months ago
 

In case anyone else makes the mistake, the Razer Core V1 will not work with the RX580 card for some reason at least on a Mac....

Pending: 2014 macbook pro Nvidia 750 Gigabyte RX580 gaming box OSX 10.13.6 my signature to give context to my posts


ReplyQuote
Eightarmedpet
(@eightarmedpet)
Noble Member
Joined: 3 years ago
 
Posted by: dfphoto

In case anyone else makes the mistake, the Razer Core V1 will not work with the RX580 card for some reason at least on a Mac....

It may not have worked for you but it defo does work. I’m using a Core V1 with my MacBook no probs, I started with a 570 in it which is pretty much the same as a 580. 

Sounds like you’re either doing something wrong or you have faulty hardware.

2017 13" MacBook Pro Touch Bar
GTX1060 + AKiTiO Thunder3 + Win10
GTX1070 + Sonnet Breakaway Box + Win10
GTX1070 + Razer Core V1 + Win10
Vega 56 + Razer Core V1 + macOS + Win10
Vega 56 + Mantiz Venus + macOS + W10

---

LG 5K Ultrafine flickering issue fix


OliverB and itsage liked
ReplyQuote
dfphoto
(@dfphoto)
Eminent Member
Joined: 4 months ago
 

Hi, I didn't notice you had a build with the Core V1, perhaps it was due to my system being older and using 10.13.6, I hope it wasn't the Razer, I sold it on ebay and shipped it Sat. I left my system as is and ordered a gigabyte 580 box and it turned on immediately so that scares me a little. However, the person I bought the Razor said it worked and it looked like new.

I'm not tech enough to figure out complicated solutions, I try my best, I wish I knew what it was or why yours works. You're on 10.14 ran the scripts and plugged in and no problems?

Pending: 2014 macbook pro Nvidia 750 Gigabyte RX580 gaming box OSX 10.13.6 my signature to give context to my posts


ReplyQuote
OliverB
(@oliverb)
Noble Member
Joined: 10 months ago
 

@dfphoto
if you are not "tech enough", you shouldn't make any final statements like "Razer Core V1 will not work with RX580".

2018 15" MBP & 2015 13" MBP connected to RTX2080Ti GTX1080Ti GTX1080 Vega56 RX580 R9-290 GTX680


ReplyQuote
dfphoto
(@dfphoto)
Eminent Member
Joined: 4 months ago
 

Hi Oliver, Tech Support at RAZER told me 100% the unit will not work.

Pending: 2014 macbook pro Nvidia 750 Gigabyte RX580 gaming box OSX 10.13.6 my signature to give context to my posts


ReplyQuote
OliverB
(@oliverb)
Noble Member
Joined: 10 months ago
 
Posted by: dfphoto

Hi Oliver, Tech Support at RAZER told me 100% the unit will not work.

So you believe this more than the experts on this site?

@itsage and @eightarmedpet themselves made it work several times. There are more than one user build where it works.
@mac_editor and @goalque made great software for the purpose to make it work.
I can personally guarantee that everything here that has been reported to work, works perfectly.

You say for yourself you "were not a tech enough", so why can you make such claims?

 

This post was modified 4 months ago

2018 15" MBP & 2015 13" MBP connected to RTX2080Ti GTX1080Ti GTX1080 Vega56 RX580 R9-290 GTX680


ReplyQuote
mac_editor
(@mac_editor)
Noble Member Moderator
Joined: 2 years ago
 

@dfphoto typically official tech support comms would not be aware/stick to policy. For example, if you were to ask Apple if eGPU works on Thunderbolt 2 or Bootcamp, they would say "it is not supported". We have scripts/hacks that allow for these possibilities, which we dub as community support. In your case, I am not sure why the Core V1 did not work if all patches (including Ti82 patch to get the V1 going) were applied appropriately. I see one build guide, but on macOS 10.12 that paired a Core with a TB1/2 Mac. So there is some precedent to it working.

This post was modified 4 months ago

purge-wrangler.shpurge-nvda.shset-eGPU.shautomate-eGPU EFI Installer


OliverB liked
ReplyQuote
OliverB
(@oliverb)
Noble Member
Joined: 10 months ago
 
Posted by: mac_editor

@dfphoto typically official tech support comms would not be aware/stick to policy. For example, if you were to ask Apple if eGPU works on Thunderbolt 2 or Bootcamp, they would say "it is not supported". We have scripts/hacks that allow for these possibilities, which we dub as community support.

There are a lot of Bootcamp setups where you even don't need a hack/script in order to get a eGPU working. I have two of them. Yet Apple support says "Bootcamp is not supported" while it's just "plug-it-in". They just don't want to make the extra support work.

This post was modified 4 months ago

2018 15" MBP & 2015 13" MBP connected to RTX2080Ti GTX1080Ti GTX1080 Vega56 RX580 R9-290 GTX680


ReplyQuote