Setup & Software Discussions
Nvidia announces Mac support for Pascal Gpus (NOW ONLINE)
 

Nvidia announces Mac support for Pascal Gpus (NOW ONLINE)  

 of  3
  RSS

Hector66
(@hector66)
Eminent Member
Joined: 2 years ago
 
Posted by: C4Dman

 

Posted by: Hector66

 

Just did it yesterday. Using a Node out of the box with Late 2013 13 inch MBP and Apple Thunderbolt 2-3 converter.

Just followed the beginner's guide on this site. First run did not take, but disabled csrutil in recovery mode and all was good afterwards. Only have been running Mac. Have not set up Windows yet.   

Nice! Thanks for confirming it is possible. What GPU did you use?

   

I have an MSI 1060 with 6GB. My new problem is getting things working under Windows. Booting to black screens and the EFI updater does not seem to work.

MBP 15" - Mid 2017
Akitio Node
MSI GeForce GTX1060 6GB


ReplyQuote
ikir
 ikir
(@ikir)
Prominent Member
Joined: 3 years ago
 

New drivers 378.05.05.05f02


MacBook Pro 2018 Touch Bar i7 quad-core 2.7Ghz - 16GB RAM - 512GB PCIe SSD
my Mantiz Venus extreme mod with Sapphire Nitro+ RX Vega 64


ReplyQuote
Rycco
(@rycco)
Reputable Member
Joined: 3 years ago
 
Posted by: ikir

 

New drivers 378.05.05.05f02

   

Is it new or just the same beta but not official?

mid-2017 15" Macbook Pro RP555 + [email protected] (Mantiz Venus) + macOS & Win10


ReplyQuote
ikir
 ikir
(@ikir)
Prominent Member
Joined: 3 years ago
 
Posted by: Rycco

 

Posted by: ikir

 

New drivers 378.05.05.05f02

   

Is it new or just the same beta but not official?

   

Don't know but my video distortion and slowdowns seems gone!! I will report tomorrow!


MacBook Pro 2018 Touch Bar i7 quad-core 2.7Ghz - 16GB RAM - 512GB PCIe SSD
my Mantiz Venus extreme mod with Sapphire Nitro+ RX Vega 64


ReplyQuote
Inotna
(@inotna)
Eminent Member
Joined: 3 years ago
 

How do you update the drivers? Do I just install them through the Nvidia preferences pane?

Pending: Add my system information and expected eGPU configuration to my signature to give context to my posts


ReplyQuote
ikir
 ikir
(@ikir)
Prominent Member
Joined: 3 years ago
 
Posted by: Inotna

 

How do you update the drivers? Do I just install them through the Nvidia preferences pane?

   

You need to rerun the script


MacBook Pro 2018 Touch Bar i7 quad-core 2.7Ghz - 16GB RAM - 512GB PCIe SSD
my Mantiz Venus extreme mod with Sapphire Nitro+ RX Vega 64


ReplyQuote
Inotna
(@inotna)
Eminent Member
Joined: 3 years ago
 
Posted by: ikir

 

Posted by: Inotna

 

How do you update the drivers? Do I just install them through the Nvidia preferences pane?

   

You need to rerun the script

   

Thanks!

Pending: Add my system information and expected eGPU configuration to my signature to give context to my posts


ReplyQuote
ikir
 ikir
(@ikir)
Prominent Member
Joined: 3 years ago
 

There is a thread here for pascal stability issue, can you all report your experience? I have login freeze, video corruption. I need to know if it is a issue with my MSI card or pascal driver.


MacBook Pro 2018 Touch Bar i7 quad-core 2.7Ghz - 16GB RAM - 512GB PCIe SSD
my Mantiz Venus extreme mod with Sapphire Nitro+ RX Vega 64


ReplyQuote
nkh004
(@nkh004)
Eminent Member
Joined: 3 years ago
 

Has anyone tried this with an iMac? Any reason it wouldn't work. Would you still need an external display?

 

I'm on a mid 2011 i7

Mid 2011 iMac / Akitio Thunder 2 / GTX1060


ReplyQuote
Username
(@username)
Estimable Member
Joined: 2 years ago
 
Posted by: ikir

 

There is a thread here for pascal stability issue, can you all report your experience? I have login freeze, video corruption. I need to know if it is a issue with my MSI card or pascal driver.

   

How would you describe the login freeze?

For me the 1070 in macos does not display any image while booting up into my file vault enabled mac. The 970 did that perfet though. Is this an Nvidia pascal driver issue or an ogpu related one?

2012 Mac Mini + [email protected] (AKiTiO Thunder3 via TB3->TB2 adapter) + macOS


ReplyQuote
Username
(@username)
Estimable Member
Joined: 2 years ago
 

I'll reply myself. 

I suddenly remembered that I could use the same command as I do on my FileVault enabled servers to do a remote reboot without keyboard and FileVault  password. 

 

sudo fdesetup authrestart

You will be asked for sudo password and then for the FileVault password. 

Directly after typing it and hitting enter, The mac will reboot and pass FileVault auth. It stops at the login window for the user to login. 

It worked perfect for me!

2012 Mac Mini + [email protected] (AKiTiO Thunder3 via TB3->TB2 adapter) + macOS


ReplyQuote
Doren
(@doren)
Eminent Member
Joined: 2 years ago
 
Posted by: ikir

 

There is a thread here for pascal stability issue, can you all report your experience? I have login freeze, video corruption. I need to know if it is a issue with my MSI card or pascal driver.

   

I'm using an Asus GTX1050Ti 4gb Phoenix via thunderbolt2 and sometimes I'm having some distortions and artifacts in safari and the app store, I think that is a pascal drivers problems instead the videocard. 

mid-2012 15'' Macbook Pro GT650M + [email protected]-TB1 (AKiTiO Thunder2) + macOS10.12.6 & Win10 <-- using
mid-2012 15'' Macbook Pro GT650M + [email protected] (AKiTiO Thunder2) + macOS10.12 <-- no windows detection


ReplyQuote
ikir
 ikir
(@ikir)
Prominent Member
Joined: 3 years ago
 
Posted by: Doren

 

Posted by: ikir

 

There is a thread here for pascal stability issue, can you all report your experience? I have login freeze, video corruption. I need to know if it is a issue with my MSI card or pascal driver.

   

I'm using an Asus GTX1050Ti 4gb Phoenix via thunderbolt2 and sometimes I'm having some distortions and artifacts in safari and the app store, I think that is a pascal drivers problems instead the videocard. 

   

I agree, hope to enjoy a fix soon 😉


MacBook Pro 2018 Touch Bar i7 quad-core 2.7Ghz - 16GB RAM - 512GB PCIe SSD
my Mantiz Venus extreme mod with Sapphire Nitro+ RX Vega 64


ReplyQuote
nkh004
(@nkh004)
Eminent Member
Joined: 3 years ago
 

I had this up and running yesterday, then I started to get the boot-loop. I uninstalled everything and re ran the script. 

Script detects 1060, nvidia device manger installs no problem. But it doesn't see the 1060 anymore. 

Any thoughts on what to try?

Mid 2011 iMac / Akitio Thunder 2 / GTX1060


ReplyQuote
goalque
(@goalque)
Noble Member Admin
Joined: 3 years ago
 

@nkh004: To track down what happened, type "log show –last 10m | grep NVDA"

automate-eGPU EFIapple_set_os.efi
--
2018 13" MacBook Pro + Radeon [email protected] + Win10 1809


ReplyQuote
Srider_
(@srider_)
New Member
Joined: 2 years ago
 

The drivers are not ready. I used a Akitio Node TB3 with a 1080 card. In games it would lock up for a split second every 10 seconds. The FPS was anywhere between 20FPS and 200FPS in the same locations. When web browsing it would sometimes just freak out and create large pixels all over the screen and I would have to force a reboot. 

From my observation the drivers are not there yet for Mac. I returned my 1080 and kept my Akitio Node, I am praying for some high performing AMD Vaga cards in May with drivers support or Volta in the fall. I just hope the Volta's show performance gains without a Thunderbolt 3 major bottleneck.

Pending: Add my system information and expected eGPU configuration to my signature to give context to my posts


ReplyQuote
ozzy
 ozzy
(@ozzy)
Trusted Member
Joined: 2 years ago
 

So my 1070 seems to be working great in an Akitio Node TB3 with a 2012 MacBook Pro 15" Retina in OS X.  I can't get it to actually work in Windows though - I posted my problem in this thread and don't necessarily want to duplicate it but thought people might have better suggestions here.  Anyone seen something like this or have any suggestions?

https://egpu.io/forums/builds/2012-15-macbook-pro-retina-650m-107010gbps-tb1-akitio-node-mac-oswin-10/

2012 15" Macbook Pro Retina GT650M + [email protected] (AKiTiO Node via TB3->TB2 adapter) + macOS10.13 & Win10


ReplyQuote
ikir
 ikir
(@ikir)
Prominent Member
Joined: 3 years ago
 

10.12.5 is out

nvidia driver should coming soon I suppose


MacBook Pro 2018 Touch Bar i7 quad-core 2.7Ghz - 16GB RAM - 512GB PCIe SSD
my Mantiz Venus extreme mod with Sapphire Nitro+ RX Vega 64


ReplyQuote
Username
(@username)
Estimable Member
Joined: 2 years ago
 
Posted by: Srider_

 

When web browsing it would sometimes just freak out and create large pixels all over the screen and I would have to force a reboot.    

When I get those blocking effects I do a logout via command-shift-q and then log in again which seems to reset it.

2012 Mac Mini + [email protected] (AKiTiO Thunder3 via TB3->TB2 adapter) + macOS


ReplyQuote
ikir
 ikir
(@ikir)
Prominent Member
Joined: 3 years ago
 

Let's try new web driver 378.05.05.15f01


MacBook Pro 2018 Touch Bar i7 quad-core 2.7Ghz - 16GB RAM - 512GB PCIe SSD
my Mantiz Venus extreme mod with Sapphire Nitro+ RX Vega 64


Username liked
ReplyQuote
Hector66
(@hector66)
Eminent Member
Joined: 2 years ago
 
Posted by: ikir

 

Let's try new web driver 378.05.05.15f01

   

Not seeing that on the Nvidia site, or the Nvidia driver manager. Where did you track that down?

MBP 15" - Mid 2017
Akitio Node
MSI GeForce GTX1060 6GB


ReplyQuote
goalque
(@goalque)
Noble Member Admin
Joined: 3 years ago

gtosi and itsage liked
ReplyQuote
Hector66
(@hector66)
Eminent Member
Joined: 2 years ago
 
Posted by: goalque

 

https://images.nvidia.com/mac/pkg/378/WebDriver-378.05.05.15f01.pkg

The script finds it automatically.

   

Hmm, just ran automate-eGPU.sh and it said "eGPU enabled and Nvidia Web Driver up to date" on 378.05.05.05f02

MBP 15" - Mid 2017
Akitio Node
MSI GeForce GTX1060 6GB


ReplyQuote
goalque
(@goalque)
Noble Member Admin
Joined: 3 years ago
 

What's your macOS 10.12.5 build number? If it is 16F73, there is a match.

automate-eGPU EFIapple_set_os.efi
--
2018 13" MacBook Pro + Radeon [email protected] + Win10 1809


ReplyQuote
Username
(@username)
Estimable Member
Joined: 2 years ago
 

You need to update to 10.12.5 first. After that Nvidias driver will make itself heard and CUDA as well when the drivers is up to date.

 

It seems that my Thunder3 is now listed as Unsupported yet my 1070 works perfect after updating to 10.12.5, WebDriver-378.05.05.15f01, disabled SIP, reinstalled script and enabled SIP without kext.

Ran Heaven and it worked fine except for the fact that is seems to be locked on VSYNC, no matter if I disabled it or not.

 

Other games seems to be doing well and is not locked to any vsync.

2012 Mac Mini + [email protected] (AKiTiO Thunder3 via TB3->TB2 adapter) + macOS


ikir liked
ReplyQuote
Hector66
(@hector66)
Eminent Member
Joined: 2 years ago
 

Okay it's good to know. I have not updated for fear of breaking things.

I haven't seen any big complaints yet, but it's still early.

MBP 15" - Mid 2017
Akitio Node
MSI GeForce GTX1060 6GB


ReplyQuote
ozzy
 ozzy
(@ozzy)
Trusted Member
Joined: 2 years ago
 

I updated last night.  Had no problem with it so far.  Only tested Shadow of Mordor though, which actually had it's big graphical glitch fixed by the latest nVidia driver (think there is still a graphical glitch, but it doesn't take over the screen anymore so it is not as noticeable).  However, I still can't get any reasonable performance out of Shadow of Mordor with the nVidia drivers.  Regardless of resolution (720p through to 1440p) or settings (Very Low through to Ultra) in the benchmark my average FPS ranges from 19-23.  If I switch to the OS X drivers and benchmark it on my MBP nVidia 650m it gets 25-28 FPS at 1680x1050 on Medium.  So there is clearly something wrong with this game and those drivers that hasn't been solved with the latest update.

2012 15" Macbook Pro Retina GT650M + [email protected] (AKiTiO Node via TB3->TB2 adapter) + macOS10.13 & Win10


ReplyQuote
ikir
 ikir
(@ikir)
Prominent Member
Joined: 3 years ago
 
Posted by: ozzy

 

I updated last night.  Had no problem with it so far.  Only tested Shadow of Mordor though, which actually had it's big graphical glitch fixed by the latest nVidia driver (think there is still a graphical glitch, but it doesn't take over the screen anymore so it is not as noticeable).  However, I still can't get any reasonable performance out of Shadow of Mordor with the nVidia drivers.  Regardless of resolution (720p through to 1440p) or settings (Very Low through to Ultra) in the benchmark my average FPS ranges from 19-23.  If I switch to the OS X drivers and benchmark it on my MBP nVidia 650m it gets 25-28 FPS at 1680x1050 on Medium.  So there is clearly something wrong with this game and those drivers that hasn't been solved with the latest update.

   

Maybe it was vsync?


MacBook Pro 2018 Touch Bar i7 quad-core 2.7Ghz - 16GB RAM - 512GB PCIe SSD
my Mantiz Venus extreme mod with Sapphire Nitro+ RX Vega 64


ReplyQuote
ozzy
 ozzy
(@ozzy)
Trusted Member
Joined: 2 years ago
 
Posted by: ikir

 

Posted by: ozzy

 

I updated last night.  Had no problem with it so far.  Only tested Shadow of Mordor though, which actually had it's big graphical glitch fixed by the latest nVidia driver (think there is still a graphical glitch, but it doesn't take over the screen anymore so it is not as noticeable).  However, I still can't get any reasonable performance out of Shadow of Mordor with the nVidia drivers.  Regardless of resolution (720p through to 1440p) or settings (Very Low through to Ultra) in the benchmark my average FPS ranges from 19-23.  If I switch to the OS X drivers and benchmark it on my MBP nVidia 650m it gets 25-28 FPS at 1680x1050 on Medium.  So there is clearly something wrong with this game and those drivers that hasn't been solved with the latest update.

   

Maybe it was vsync?

   

Good question - I'm pretty sure vsync wasn't on, but will double check later.

2012 15" Macbook Pro Retina GT650M + [email protected] (AKiTiO Node via TB3->TB2 adapter) + macOS10.13 & Win10


ReplyQuote
ikir
 ikir
(@ikir)
Prominent Member
Joined: 3 years ago
 

So far these drivers seem much more stable, still no artifact. Worked for hours nd tried few games (few on steam) no issue.

 

Update: sadly it happened again, Safari freeze with gfx distortion, making macOS sluggish. When I closed the tab incriminated, everything become smooth again. I wonder if Nvidia is aware of this.


MacBook Pro 2018 Touch Bar i7 quad-core 2.7Ghz - 16GB RAM - 512GB PCIe SSD
my Mantiz Venus extreme mod with Sapphire Nitro+ RX Vega 64


ReplyQuote
ozzy
 ozzy
(@ozzy)
Trusted Member
Joined: 2 years ago
 
Posted by: ikir

  

Update: sadly it happened again, Safari freeze with gfx distortion, making macOS sluggish. When I closed the tab incriminated, everything become smooth again. I wonder if Nvidia is aware of this.

   

Good question - I hadn't had that issue before but just ran into it in Safari.  Rather annoying

2012 15" Macbook Pro Retina GT650M + [email protected] (AKiTiO Node via TB3->TB2 adapter) + macOS10.13 & Win10


ReplyQuote
cralax
(@cralax)
Active Member
Joined: 2 years ago
 

Could you please what is the process concerning a mac os update?

Does the goalque script uninstall former nvidia drivers and install new ones? Or update the current ones? 

No issue concerning cuda?

Thanks

Pending: Add my system information and expected eGPU configuration to my signature to give context to my posts


ReplyQuote
ikir
 ikir
(@ikir)
Prominent Member
Joined: 3 years ago
 

@cralax

it updates and you manually need to download cura update.

 

@all

http://surveys.nvidia.com/index.jsp?pi=6e7ea6bb4a02641fa8f07694a40f8ac6

maybe we should tell nvidia Pascal driver has issue


MacBook Pro 2018 Touch Bar i7 quad-core 2.7Ghz - 16GB RAM - 512GB PCIe SSD
my Mantiz Venus extreme mod with Sapphire Nitro+ RX Vega 64


ReplyQuote
Username
(@username)
Estimable Member
Joined: 2 years ago
 

Today I had a lot of problems with blocking, crashing out to login-window and even a total freeze.

This was during the end of the Night-Shift phase when the screen will go from low K temp to daylight K. Anyone else experienced increased trouble when using night shift?

2012 Mac Mini + [email protected] (AKiTiO Thunder3 via TB3->TB2 adapter) + macOS


ReplyQuote
ikir
 ikir
(@ikir)
Prominent Member
Joined: 3 years ago
 

https://egpu.io/forums/mac-setup/pascal-stability-issue/


MacBook Pro 2018 Touch Bar i7 quad-core 2.7Ghz - 16GB RAM - 512GB PCIe SSD
my Mantiz Venus extreme mod with Sapphire Nitro+ RX Vega 64


ReplyQuote
 of  3