Occulus Quest 2 works only after disabling Macbook display adaptor
 
Notifications
Clear all

Occulus Quest 2 works only after disabling Macbook display adaptor  

  RSS

Ross Hocking
(@ross_hocking)
New Member
Joined: 2 months ago
 

I have a MBP 2020 with a Radeon 5700 XT, running windows 10 (1903) with bootcamp. I was able to use this setup for the past 4 months using the display on my MBP (no external display).

I decided to get the Occulus quest 2, and tried to get the PC Link working by connecting directly to the MBP USB C ports and connecting with an adaptor to the eGPU. Neither worked, with some research I realized the occulus windows application was detecting the eGPU and so was **not** throwing an error, but the Occulus itself was using the built-in Iris graphics card.

So I decided to get an external display, disable the Iris card and use the second display to run the Occulus Windows app - it worked!! - So I assume I was correct and the Iris card is being used by the Occulus when I run PC Link. But my problem now is that I dont want to keep an external display so I can go through this process every time.

Questions:

1. Is there a way to get the Occulus Quest 2 to ignore the iris graphics card, so I dont have to connect the external display every time I want to run the PC Link?

2. Is there a way for me to disable the Iris graphics card permanently, so the internal display works with the Radeon all the time?

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
itsage
(@itsage)
Illustrious Member Admin
Joined: 4 years ago
 

@ross_hocking, Have you looked in the Windows Graphics settings to assign the Oculus app to the RX 5700 XT eGPU? That may force the loopback acceleration from the eGPU through Intel iGPU then output to the Quest 2.

 

external graphics card builds
best laptops for external GPU
eGPU enclosure buyer's guide

 
2021 15" ASUS TUF Dash F15 [11th,4C,H] + RTX 3080 @ 32Gbps-TB4 (AORUS Gaming Box) + Win10 2004 // my 3rd RTX 3080 build [build link]  


ReplyQuote
Ross Hocking
(@ross_hocking)
New Member
Joined: 2 months ago
 

@itsage, yes I have tried that and it had no effect

 

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote