OS X 10.14.6 Security Update December 10th, 2019 - EGPU is no longer working
 
Notifications
Clear all

OS X 10.14.6 Security Update December 10th, 2019 - EGPU is no longer working  

 of  3
  RSS

Gandalf
(@gandalf)
Active Member
Joined: 1 year ago
 

Hi everyone,

I installed the latest security Update yesterday. It looks like this update is an epic fail - may be only for me?

I use a Razer Core X with a RX590 graphic card and the MacMini 2018. In the last couple of month, everything was running fine. Then there is that big Update and i can no longer boot with an enabled EGPU. If i boot with an enabled EGPU on Win 10, then there is a crash right before the login screen. Same thing for OS X. I don't even reach the login screen.

 

When I boot the OS X with disabled EGPU, then I can start it later and can at least use it. If I boot Win 10 with disabled EGPU and switch it on later, then Win 10 needs a reboot before the EGPU can be used.

The point is: I can no longer use Win 10 with EGPU. I can use an EGPU with OS X but never when I enable the EGPU when the Macmini is booting.

Does anyone have similar troubles? Any Idea how this Problem can be fixed?

Steps I did so fare:
Reset SCM
Reset PRAM/SMC

Best regards, Gandalf

2018 Mac Mini [8th,6C,B] + RX 590 @ 32Gbps-TB3 (Razer Core X) + macOS 10.14.2 & Win10 [build link]  

ReplyQuote
hornedfrog
(@hornedfrog)
Trusted Member
Joined: 1 year ago
 

I am installing this now and it seems to have ruined my egpu boot in MacOS 10.14.6.  Come on Apple!

Mac mini 2018/i7/1TB/32GB RAM
Sonnet Breakaway Box 650W. Sapphire Vega 64 - (21275-03-20G card)
OWC Thunderbolt 3 14 port hub
AKiTiO Node Duo, 1 x Patriot Scorch M.2 512G SSD PCI-E 3.0 x 2 drive.


ReplyQuote
hornedfrog
(@hornedfrog)
Trusted Member
Joined: 1 year ago
 
Posted by: @gandalf

When I boot the OS X with disabled EGPU, then I can start it later and can at least use it.

 

 

 

How did you accomplish this?  Thank you.  

Mac mini 2018/i7/1TB/32GB RAM
Sonnet Breakaway Box 650W. Sapphire Vega 64 - (21275-03-20G card)
OWC Thunderbolt 3 14 port hub
AKiTiO Node Duo, 1 x Patriot Scorch M.2 512G SSD PCI-E 3.0 x 2 drive.


ReplyQuote
Gandalf
(@gandalf)
Active Member
Joined: 1 year ago
 

@hornedfrog

Start your mac with switched of egpu and switch it on after you logged in.

2018 Mac Mini [8th,6C,B] + RX 590 @ 32Gbps-TB3 (Razer Core X) + macOS 10.14.2 & Win10 [build link]  

ReplyQuote
(@branislav_benak)
Eminent Member
Joined: 1 year ago
 

Hi there, 

I read that you already did that. But here I found thread that the resetting of NVRAM did work. Here is the link how they manage it. https://discussions.apple.com/thread/250934910

Please try it and let us know if it works for you. 

1. Macbook Air 13" 2014 + Akitio Thunder2 RX560 (optional GTX1050Ti).
2. MacMini 2018 i3 + Sapphire Gearbox Vega 56.

 
2014 13" MacBook Air [4th,2C,U] + GTX 1050 Ti @ 10Gbps-TB1 (AKiTiO Thunder2) + macOS 10.13.6 [build link]  


ReplyQuote
hornedfrog
(@hornedfrog)
Trusted Member
Joined: 1 year ago
 
Posted by: @gandalf

@hornedfrog

Start your mac with switched of egpu and switch it on after you logged in.

Thank you, that worked.  Is there an easy way to rollback this update?  I have time machine backups.

Posted by: @branislav_benak

Hi there, 

I read that you already did that. But here I found thread that the resetting of NVRAM did work. Here is the link how they manage it. https://discussions.apple.com/thread/250934910

Please try it and let us know if it works for you. 

Thank you!  Will try it too.

Mac mini 2018/i7/1TB/32GB RAM
Sonnet Breakaway Box 650W. Sapphire Vega 64 - (21275-03-20G card)
OWC Thunderbolt 3 14 port hub
AKiTiO Node Duo, 1 x Patriot Scorch M.2 512G SSD PCI-E 3.0 x 2 drive.


ReplyQuote
Gandalf
(@gandalf)
Active Member
Joined: 1 year ago
 

@branislav_benak

It doesn't work Cry . It makes no difference if I reset the NVRAM with EGPU switched on or off.

 

@hornedfrog

Try it and report. I'm not sure if it will work. I read somewhere (at least i think i did), that this is a problem with the firmwareupdate of the MacMini. But i might be wrong.

This post was modified 6 months ago
2018 Mac Mini [8th,6C,B] + RX 590 @ 32Gbps-TB3 (Razer Core X) + macOS 10.14.2 & Win10 [build link]  

ReplyQuote
hornedfrog
(@hornedfrog)
Trusted Member
Joined: 1 year ago
 
Posted by: @gandalf

@branislav_benak

It doesn't work Cry . It makes no difference if I reset the NVRAM with EGPU switched on or off.

 

@hornedfrog

Try it and report. I'm not sure if it will work. I read somewhere (at least i think i did), that this is a problem with the firmwareupdate of the MacMini. But i might be wrong.

Will try, thank you.  Can the update be rolled back with time machine or another way?

Mac mini 2018/i7/1TB/32GB RAM
Sonnet Breakaway Box 650W. Sapphire Vega 64 - (21275-03-20G card)
OWC Thunderbolt 3 14 port hub
AKiTiO Node Duo, 1 x Patriot Scorch M.2 512G SSD PCI-E 3.0 x 2 drive.


ReplyQuote
Gandalf
(@gandalf)
Active Member
Joined: 1 year ago
 

@hornedfrog

Time machine should work fine.

2018 Mac Mini [8th,6C,B] + RX 590 @ 32Gbps-TB3 (Razer Core X) + macOS 10.14.2 & Win10 [build link]  

ReplyQuote
hornedfrog
(@hornedfrog)
Trusted Member
Joined: 1 year ago
 
Posted by: @gandalf

@hornedfrog

Time machine should work fine.

Thank you.

Mac mini 2018/i7/1TB/32GB RAM
Sonnet Breakaway Box 650W. Sapphire Vega 64 - (21275-03-20G card)
OWC Thunderbolt 3 14 port hub
AKiTiO Node Duo, 1 x Patriot Scorch M.2 512G SSD PCI-E 3.0 x 2 drive.


ReplyQuote
 of  3