Random screen freezing (com.apple.DumpGPURestart) - MB Pro 2018 (AMD RP560X) + R...
 
Notifications
Clear all

Random screen freezing (com.apple.DumpGPURestart) - MB Pro 2018 (AMD RP560X) + Razer Core X + 5700XT  

  RSS

alfredleee
(@alfredleee)
New Member
Joined: 9 months ago
 

Hi guys!

More information:

  1. Operating system: Catalina 10.15.3 (19D76)

  2. Laptop: MacBook Pro 2018 15inch with AMD RP560X

  3. Processor: 2.6 GHz 6-Core Intel Core i7

  4. Macbook is clamshell mode, eGPU connected to 2x 4K monitor via 2x Displayport

  5. Graphic card: PowerColor Radeon RX 5700 XT Red Dragon 8GB GDDR6 RDNA

Currently facing issue with my eGPU setup: Random freezing of screen happens without any recognisable pattern between their occurrences. Once it freezes, mouse cursor is still movable but things on the screen are barely clickable (takes 10sec or more for a click to be registered, sluggish performance). Before such freezing occurs, I am simply web surfing or doing some lightweight stuff, definitely not running games or anything intensive.

The issue will be resolved once I forcefully unplug the enclosure, the freezing stops and everything is back to normal even if I plug back the enclosure. However I believe this is not a healthy move.

Solutions tried:

  1. Disable automatic graphic switching --> Doesn't work

I realised that during the freezing, the following is observed in the console's system.log

 

First time happening:

Feb 24 19:26:20 Alfreds-MacBook-Pro-3 com.apple.xpc.launchd[1] (com.apple.DumpGPURestart): Service only ran for 1 seconds. Pushing respawn out by 9 seconds.
Feb 24 19:26:52 --- last message repeated 2 times ---
Feb 24 19:26:52 Alfreds-MacBook-Pro-3 com.apple.xpc.launchd[1] (com.apple.DumpGPURestart): Service only ran for 2 seconds. Pushing respawn out by 8 second
Feb 24 19:27:01 Alfreds-MacBook-Pro-3 com.apple.xpc.launchd[1] (com.apple.DumpGPURestart): Service only ran for 1 seconds. Pushing respawn out by 9 seconds.
Feb 24 19:27:22 --- last message repeated 1 time ---
Feb 24 19:27:22 Alfreds-MacBook-Pro-3 AMPDeviceDiscoveryAgent[425]: Entered:_AMMuxedDeviceDisconnected, mux-device:86
Feb 24 19:27:22 Alfreds-MacBook-Pro-3 AMPDeviceDiscoveryAgent[425]: Entered:__thr_AMMuxedDeviceDisconnected, mux-device:86
Feb 24 19:27:22 Alfreds-MacBook-Pro-3 AMPDeviceDiscoveryAgent[425]: tid:7037 - Mux ID not found in mapping dictionary
Feb 24 19:27:22 Alfreds-MacBook-Pro-3 AMPDeviceDiscoveryAgent[425]: tid:7037 - Can't handle disconnect with invalid ecid
Feb 24 19:27:22 Alfreds-MacBook-Pro-3 com.apple.xpc.launchd[1] (com.apple.DumpGPURestart): Service only ran for 2 seconds. Pushing respawn out by 8 seconds.
Feb 24 19:27:31 Alfreds-MacBook-Pro-3 com.apple.xpc.launchd[1] (com.apple.DumpGPURestart): Service only ran for 1 seconds. Pushing respawn out by 9 seconds.
Feb 24 19:28:01 --- last message repeated 2 times ---
Feb 24 19:28:01 Alfreds-MacBook-Pro-3 com.apple.xpc.launchd[1] (com.apple.DumpGPURestart): Service only ran for 1 seconds. Pushing respawn out by 9 seconds.
Feb 24 19:28:12 --- last message repeated 1 time ---

 

Second time happening:

Feb 26 22:02:03 Alfreds-MacBook-Pro-3 com.apple.xpc.launchd[1] (com.apple.DumpGPURestart): Service only ran for 1 seconds. Pushing respawn out by 9 seconds.
Feb 26 22:02:34 --- last message repeated 2 times ---
Feb 26 22:02:34 Alfreds-MacBook-Pro-3 com.apple.xpc.launchd[1] (com.apple.DumpGPURestart): Service only ran for 2 seconds. Pushing respawn out by 8 seconds.
Feb 26 22:02:39 Alfreds-MacBook-Pro-3 AccountProfileRemoteViewService[2441]: objc[2441]: Class AOSUISpyglassAccountChangeHelper is implemented in both /System/Library/PrivateFrameworks/AOSUI.framework/Versions/A/AOSUI and /System/Library/PrivateFrameworks/AOSUI.framework/Versions/A/XPCServices/AccountProfileRemoteViewService.xpc/Contents/MacOS/AccountProfileRemoteViewService. One of the two will be used. Which one is undefined.
Feb 26 22:02:39 Alfreds-MacBook-Pro-3 AGMService[608]: ProcessPath : /System/Applications/System Preferences.app/Contents/MacOS/System Preferences
Feb 26 22:02:43 Alfreds-MacBook-Pro-3 com.apple.xpc.launchd[1] (com.apple.DumpGPURestart): Service only ran for 1 seconds. Pushing respawn out by 9 seconds.

In both cases, com.apple.DumpGPURestart can be observed.

Appreciate your help here!

This topic was modified 9 months ago

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
itsage
(@itsage)
Illustrious Member Admin
Joined: 4 years ago
 

@alfredleee, What's the specific model of your RX 5700 XT?

 

external graphics card builds
best laptops for external GPU
eGPU enclosure buyer's guide

 
2020 15" HP Spectre X360 [11th,4C,G] + RTX 2080 Ti @ 32Gbps-TB4 (AORUS Gaming Box) + Win10 2004 [build link]  


ReplyQuote
alfredleee
(@alfredleee)
New Member
Joined: 9 months ago
 

@itsage, PowerColor Radeon RX 5700 XT Red Dragon 8GB GDDR6 RDNA. My apology for not stating this.

 

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
itsage
(@itsage)
Illustrious Member Admin
Joined: 4 years ago
 

@alfredleee, That is likely your culprit. I've seen many reports of this particular GPU having issues. It's best if you can exchange it for a different model. I have the Red Devil RX 5700 XT and never experienced crashing issues in macOS on a Thunderbolt 3 system.

 

external graphics card builds
best laptops for external GPU
eGPU enclosure buyer's guide

 
2020 15" HP Spectre X360 [11th,4C,G] + RTX 2080 Ti @ 32Gbps-TB4 (AORUS Gaming Box) + Win10 2004 [build link]  


ReplyQuote
alfredleee
(@alfredleee)
New Member
Joined: 9 months ago
 

@itsage, Really? I have the exact same post on reddit and there's another guy with a Mac mini 2018 + XFX RAW 3 5700 XT + Razer Core X having the same issue as well. Did you install any tweaks (e.g. kext patching or scripts) to get it working without issues? 

It seems to me that this crashing wasn't that frequent when I was just on 1 external monitor. Now that I have 2 of it, seems to happen at least once a day... though I'm still monitoring the situation.

I doubt I can do an exchange, but nevertheless will try contacting them and see what can be done. Cry

 

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
alfredleee
(@alfredleee)
New Member
Joined: 9 months ago
 

Quick update, I have decided not to unplug the GPU when it freezes and see how long it can freeze. Apparently the computer crashed within a minute, and once rebooted the crash report says "BAD MAGIC! (flag set in iBoot panic header), no macOS panic log available".

I googled the error and saw an apple thread on it: https://discussions.apple.com/thread/250826263?answerId=251899532022&page=1

Seems like some of them managed to get it fix after replacement by Apple. In addition, from the comment section, the problem seems to happen for those with peripherals connected to the MacBook and having multiple monitor.

I have disabled both SIP and Secure boot as recommend in the thread since I can't send my Mac in for repair now... shall see how it goes. If it still fails, I will try to use chrome instead of safari and see whether that helps!

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
mfreed420
(@mfreed420)
New Member
Joined: 1 week ago
 

I am having the same issue but my graphics is Intel Iris Pro 1536 MB.  I have a MacBook Pro (Retina, 15-inch, Mid 2014). This issue for me started after I installed 5K Player. I have uninstalled 5K Player but still am having the same issue.  Has anyone been able to to figure out the cause of the crash yet?  Or at least how to prevent it?

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote