Razer Core X Chroma + MacBook Pro 16 + AMD 5700 XT = Constant Blackout
 
Notifications
Clear all

Razer Core X Chroma + MacBook Pro 16 + AMD 5700 XT = Constant Blackout  

  RSS

Husain Mudara
(@husain_mudara)
New Member
Joined: 4 months ago
 

Someone please help me. I've connected my Razer Core Chroma with the AMD 5700 XT GPU with the MacBook Pro's Charger charging the laptop and my 1440p Ultrawide connected to my eGPU enclosure via DisplayPort cable and I keep getting a Black screens, if I disconnect the eGPU my computer goes back to normal, If I leave it connected then after about 2 mins it restarts with the fans blaring and full speed for 1 second.

I'm playing WoW on MacOS and I seemingly cannot get this gpu to work. I had my RX 580 installed on the Razer Core and seemed to operate normally. Is there anything I am doing wrong? So far the black screens seem to only occur in game. 

I'm on 10.15.5 Supplemental. Should I downgrade to 10.15.(1,2,3 or 4)?

Most fixes mentioned on forums are targeted towards gaming on bootcamp which I would like to avoid.

Please help 🙁

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
Husain Mudara
(@husain_mudara)
New Member
Joined: 4 months ago
 
[Update]

I ran a metal Geekbench test and was only getting a score of 33000+ I've read on forums and some youtubers adding a dummy HDMI apdater to trick it into thinking that two displays are connected. I didn't have a dummy adapter but my monitor has 2 forms of input so I connected 1 HDMI and 1 Display port cable from my monitor to my eGPU enclosure.

Ran the Geekbench Metal benchmark and am getting scores up to 64000+ now. I'll keep testing through out the day but the black screens seemed to have stopped for now running the setup in this way.

This is a link to the recommended HDMI adapter (I'm going to place an order if I can't find it in my country)

https://www.amazon.com/gp/product/B06XT1Z9TF?pf_rd_r=X3XNCBWSSAP9HZ1R8140&pf_rd_p=edaba0ee-c2fe-4124-9f5d-b31d6b1bfbee

I hope this helps someone.

 

If anyone from the community knows why this worked and would like to post the technicalities of it so I may learn more I would be grateful.

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote