[SCRIPT] PurgeWrangler: AMD + NVIDIA eGPUs for all Thunderbolt Macs
 
Notifications
Clear all

[Solved] [SCRIPT] PurgeWrangler: AMD + NVIDIA eGPUs for all Thunderbolt Macs  

 of  176
  RSS

Micah
(@micah)
New Member
Joined: 2 years ago
 

@mac_editor

After I use the long installation command on terminal, nothing happened. The script is not installed. I have disabled SIP. How should I solve this?  

Computer: Mac Pro (Late 2013)
OS: 10.14.6
eGPU: Gigabyte AMD Vega 64 8GB
enclosure: Razer Core X


ReplyQuote
mac_editor
(@mac_editor)
Famed Member Moderator
Joined: 4 years ago
 

@micah ensure you are connected to the internet while running the command. Alternatively, download the script from the Releases page manually.

purge-wranglertbt-flashpurge-nvdaset-eGPU
Insights Into macOS Video Editing Performance

Master Threads:
2014 15-inch MacBook Pro 750M
2018 15-inch MacBook Pro

 
2019 13" MacBook Pro [8th,4C,U] + RX Vega 64 @ 32Gbps-TB3 (Mantiz Venus) + macOS 10.14.6 & Win10 [build link]  


ReplyQuote
Niyaz Ahmed
(@niyaz_ahmed)
New Member
Joined: 1 year ago
 

Hello all,

I had attempted an egpu setup couple of years back and stopped after hitting some roadblocks. Recently got my hands on a mid 2012 13" MacBook Air and a zotac gtx 970 that was retired by its previous owners. Though id give it another go since I still had a Akitio Thunder2.

I factory reset the MacBook Air and now it has Mojave. I did try the purge-wrangler method and it seems there's no web drivers. How should I proceed?

This post was modified 1 year ago

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
philw
(@philw)
Trusted Member
Joined: 3 years ago
 

@niyaz_ahmed

🙁 Sorry - Mojave has ruined it for you. Same reason I gave up. Looking like Nividia and Apple won't be friends ever again... I was hopeful for ages but not any more...

Given up on all my Macs...but successfully running: Gigabyte Designare Z390, Core i9-9900K, 64GB RAM, 2x Internal GTX 1080TI, 2x GTX 1070 eGPU (Sonnet eGFX)

 
2018 Gigabyte Z390 Designare (GTX1080TIx2) [9th,8C,K] + GTX 1070 @ 32Gbps-TB3 (Sonnet Breakaway 350) + Win10 [build link]  


ReplyQuote
Niyaz Ahmed
(@niyaz_ahmed)
New Member
Joined: 1 year ago
 

@philw

Managed to get it rolled back to 10.13.6 , build 17G65. 

Disabled SIP and relogged back in. Without connecting the thunderbolt cable from egpu, ran purge-wrangler. Selected Nvidia GPUs and tried to download web drivers. Got the following error.

"Fetching webdriver information...

Data retrieved.

Downloading drivers (387.10.10.10.40.105)...

                                                                           1.1%

curl: (56) LibreSSL SSL_read: SSL_ERROR_SYSCALL, errno 54

Download complete.

Sanitizing package...

Could not unarchive /usr/local/NVDAInstall.pkg (archive verify failed)

Unable to patch driver.

NVIDIA Web Drivers requested, but not installed."

Retried with better internet and got following error.

"Fetching webdriver information...

Data retrieved.

Downloading drivers (387.10.10.10.40.105)...

######################################################################## 100.0%

Download complete.

Sanitizing package...

Package sanitized.

Installing...

Installation failed.

Continuing patch...

 

Patching components..."

Restarted the system with the egpu connected and it is visible in the system information but not in "about this mac".

Retried running the webdriver option but says its already installed.

This post was modified 1 year ago

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
mac_editor
(@mac_editor)
Famed Member Moderator
Joined: 4 years ago
 

@niyaz_ahmed Please verify if GPU is visible/functional via benchmarks such as GeekBench or LuxMark and not About This Mac. We can debug next steps once its certain that the issue is something else.

purge-wranglertbt-flashpurge-nvdaset-eGPU
Insights Into macOS Video Editing Performance

Master Threads:
2014 15-inch MacBook Pro 750M
2018 15-inch MacBook Pro

 
2019 13" MacBook Pro [8th,4C,U] + RX Vega 64 @ 32Gbps-TB3 (Mantiz Venus) + macOS 10.14.6 & Win10 [build link]  


ReplyQuote
Micah
(@micah)
New Member
Joined: 2 years ago
 

@mac_editor

Thank you for rapid reply. I have installed purge-wrangler by downloading it from github. In the beginning, everything seems works well.  About half hour later, UI is getting freeze. Then, I find there is a thread named "DumpGPURestart" in my activity monitor. I have tried to  uninstall/reinstall the script for several times. Same results. Please help.

This post was modified 1 year ago

Computer: Mac Pro (Late 2013)
OS: 10.14.6
eGPU: Gigabyte AMD Vega 64 8GB
enclosure: Razer Core X


ReplyQuote
Niyaz Ahmed
(@niyaz_ahmed)
New Member
Joined: 1 year ago
 

@mac_editor

GPU wasn't initially being used in Unigine Heaven so I uninstalled and restarted the whole purge-wrangler process. It wasn't being used in Unigine Heaven even after the fresh install. Dug around a bit more and was able to find and run set-egpu.sh . Success 😀 At least in Unigine Heaven. 

Though I'm just using internal screen throughout this process. Will try get an external one sometime soon. Do I connect the HDMI cable straight to the 970? 

This post was modified 1 year ago

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
OliverB
(@oliverb)
Noble Member
Joined: 2 years ago
 

@niyaz_ahmed If you want Mojave AND nVidia, you could try a GTX 780 Ti or any card of the same chip (Kepler): The GTX 780 Ti should be about the same performance as your GTX 970.

2018 15" MBP & 2015 13" MBP connected to RTX2080Ti GTX1080Ti GTX1080 Vega56 RX580 R9-290 GTX680

 
2018 15" MacBook Pro (RP560X) [8th,6C,H] + RX 5700 XT @ 32Gbps-TB3 (ASUS XG Station Pro) + Win10 & macOS 10.15.4 [build link]  


ReplyQuote
philw
(@philw)
Trusted Member
Joined: 3 years ago
 

My issues were that I need CUDA - if you just need OPENGL/METAL then the above is ok.

Given up on all my Macs...but successfully running: Gigabyte Designare Z390, Core i9-9900K, 64GB RAM, 2x Internal GTX 1080TI, 2x GTX 1070 eGPU (Sonnet eGFX)

 
2018 Gigabyte Z390 Designare (GTX1080TIx2) [9th,8C,K] + GTX 1070 @ 32Gbps-TB3 (Sonnet Breakaway 350) + Win10 [build link]  


ReplyQuote
 of  176