[SCRIPT] PurgeWrangler: AMD + NVIDIA eGPUs for all Thunderbolt Macs
 
Notifications
Clear all

[Solved] [SCRIPT] PurgeWrangler: AMD + NVIDIA eGPUs for all Thunderbolt Macs  

 of  172
  RSS

Kensei
(@kensei)
Active Member
Joined: 4 weeks ago
 

I am not allowed to send messages yet, so I post it here.

I use eGPU with my Macbook Pro with external display only in the way that my Macbook shell is always closed. When I turn on eGPU and then try to "wake up" the Macbook it reboots by itself.

Can I do something about it?

Here is my error message once it is rebooted:

panic(cpu 2 caller 0xffffff800084aa3a): Kernel trap at 0xffffff7f843e5ed1, type 14=page fault, registers:
CR0: 0x000000008001003b, CR2: 0x0000000000000000, CR3: 0x0000000004b32000, CR4: 0x00000000001626e0
RAX: 0xffffff800100e0c0, RBX: 0xffffff819ed52000, RCX: 0x0000000000000000, RDX: 0x0000000001000000
RSP: 0xffffff921155bdc0, RBP: 0xffffff921155bde0, RSI: 0xffffff80203426e0, RDI: 0x0000000000000000
R8: 0xffffff8043b54e60, R9: 0x000000000000000e, R10: 0x0000000000000092, R11: 0xffffff8020464430
R12: 0x0000000000000000, R13: 0x0000000000000000, R14: 0x0000000000000001, R15: 0xffffff8028d2d180
RFL: 0x0000000000010286, RIP: 0xffffff7f843e5ed1, CS: 0x0000000000000008, SS: 0x0000000000000000
Fault CR2: 0x0000000000000000, Error code: 0x0000000000000000, Fault CPU: 0x2, PL: 0, VF: 1

Backtrace (CPU 2), Frame : Return Address
0xffffff921155b820 : 0xffffff800071f5cd 
0xffffff921155b870 : 0xffffff8000858b05 
0xffffff921155b8b0 : 0xffffff800084a68e 
0xffffff921155b900 : 0xffffff80006c5a40 
0xffffff921155b920 : 0xffffff800071ec97 
0xffffff921155ba20 : 0xffffff800071f087 
0xffffff921155ba70 : 0xffffff8000ec27cc 
0xffffff921155bae0 : 0xffffff800084aa3a 
0xffffff921155bc60 : 0xffffff800084a738 
0xffffff921155bcb0 : 0xffffff80006c5a40 
0xffffff921155bcd0 : 0xffffff7f843e5ed1 
0xffffff921155bde0 : 0xffffff8000e086a6 
0xffffff921155be40 : 0xffffff8000e081e1 
0xffffff921155bef0 : 0xffffff8000e0757e 
0xffffff921155bf50 : 0xffffff8000e09d36 
0xffffff921155bfa0 : 0xffffff80006c513e 
Kernel Extensions in backtrace:
com.apple.kext.AMDRadeonX6000Framebuffer(3.0.9)[E9880F7F-25D3-340E-9F59-0FB58854EF20]@0xffffff7f843dd000->0xffffff7f8480efff
dependency: com.apple.iokit.IOACPIFamily(1.4)[0A7D7382-66FE-391B-9F93-97A996256C25]@0xffffff7f814a1000
dependency: com.apple.iokit.IOPCIFamily(2.9)[BE052F4D-9B80-3FCD-B36D-BACB7DEE0DF2]@0xffffff7f814b3000
dependency: com.apple.iokit.IOGraphicsFamily(576.1)[B1C0006F-E1F5-37D9-9548-5F918E92B422]@0xffffff7f817ee000
dependency: com.apple.AppleGraphicsDeviceControl(5.2.4)[CD6E2942-2A23-3CE8-9BCA-D5A772667EB8]@0xffffff7f81926000

BSD process name corresponding to current thread: kernel_task

Mac OS version:
19F101

Kernel version:
Darwin Kernel Version 19.5.0: Tue May 26 20:41:44 PDT 2020; root:xnu-6153.121.2~2/RELEASE_X86_64
Kernel UUID: 54F1A78D-6F41-32BD-BFED-4381F9F6E2EF
Kernel slide: 0x0000000000400000
Kernel text base: 0xffffff8000600000
__HIB text base: 0xffffff8000500000
System model name: MacBookPro11,1 (Mac-189A3D4F975D5FFC)
System shutdown begun: NO
Panic diags file available: YES (0x0)

System uptime in nanoseconds: 34481793653783
last loaded kext at 1144370806322: @filesystems.afpfs 11.2 (addr 0xffffff7f8738b000, size 364544)
loaded kexts:
com.getdropbox.dropbox.kext 1.11.1
@filesystems.afpfs 11.2
@nke.asp-tcp 8.1
@filesystems.smbfs 3.4.3
@filesystems.exfat 1.4
>!ATopCaseHIDEventDriver 3430.1
>!AMikeyHIDDriver 131
@fileutil 20.036.15
@filesystems.autofs 3.0
>AudioAUUC 1.70
@kext.AMDRadeonX6000 3.0.9
@kext.AMDRadeonServiceManager 3.0.9
>!APlatformEnabler 2.7.0d0
>AGPM 111.4.4
>X86PlatformShim 1.0.0
>!AGFXHDA 100.1.428
>!AHDAHardwareConfigDriver 283.15
>!AHDA 283.15
>!AUpstreamUserClient 3.6.8
>!AGraphicsDevicePolicy 5.2.4
@AGDCPluginDisplayMetrics 5.2.4
>eficheck 1
>!AHV 1
|IOUserEthernet 1.0.1
|IO!BSerialManager 7.0.5f6
>!A!IHD5000Graphics 14.0.6
>AGDCBacklightControl 5.2.4
>!ASMCLMU 212
>pmtelemetry 1
@Dont_Steal_Mac_OS_X 7.0.0
>!A!IFramebufferAzul 14.0.6
>!AFIVRDriver 4.1.0
>!ABacklight 180.3
>!AMCCSControl 1.14
>!AThunderboltIP 3.1.4
>ACPI_SMC_PlatformPlugin 1.0.0
>!A!ISlowAdaptiveClocking 4.0.0
>!ALPC 3.1
>!ACameraInterface 7.6.0
|SCSITaskUserClient 422.120.3
|IO!BUSBDFU 7.0.5f6
>!U!SCoexistentDriver 489.120.1
>!UCardReader 489.120.1
>!UTCKeyEventDriver 255
>!UTCButtons 255
>!UTCKeyboard 255
>!AFileSystemDriver 3.0.1
>!AVirtIO 1.0
@filesystems.hfs.kext 522.100.5
@!AFSCompression.!AFSCompressionTypeDataless 1.0.0d1
@BootCache 40
@!AFSCompression.!AFSCompressionTypeZlib 1.0.0
@filesystems.apfs 1412.120.2
>!AAHCIPort 341.0.2
|!ABCM5701Ethernet 10.3.5
>AirPort.BrcmNIC 1400.1.1
@private.KextAudit 1.0
>!ASmartBatteryManager 161.0.0
>!ARTC 2.0
>!AACPIButtons 6.1
>!AHPET 1.8
>!ASMBIOS 2.1
>!AACPIEC 6.1
>!AAPIC 1.7
$!AImage4 1
@nke.applicationfirewall 303
$TMSafetyNet 8
@!ASystemPolicy 2.0.0
|EndpointSecurity 1
$SecureRemotePassword 1.0
>!AHIDKeyboard 209
>!AMultitouchDriver 3440.1
>!AInputDeviceSupport 3440.8
>!AHS!BDriver 3430.1
>IO!BHIDDriver 7.0.5f6
@kext.AMDRadeonX6000HWLibs 1.0
@kext.triggers 1.0
@kext.AMDRadeonX6000HWServices 3.0.9
@kext.AMDRadeonX6000Framebuffer 3.0.9
@kext.AMDSupport 3.0.9
>DspFuncLib 283.15
@kext.OSvKernDSPLib 529
>!AGraphicsControl 5.2.4
|IOAVB!F 850.1
>!ASSE 1.0
|IOAccelerator!F2 438.5.4
@!AGPUWrangler 5.2.4
@!AGraphicsDeviceControl 5.2.4
>!ABacklightExpert 1.1.0
|IONDRVSupport 576.1
>!ASMBus!C 1.0.18d1
>!AHDA!C 283.15
|IOGraphics!F 576.1
|IOHDA!F 283.15
>IOPlatformPluginLegacy 1.0.0
>X86PlatformPlugin 1.0.0
>!AThunderboltEDMSink 4.2.3
>!AThunderboltDPOutAdapter 6.2.6
|IOSlowAdaptiveClocking!F 1.0.0
>!ASMBusPCI 1.0.14d1
>IOPlatformPlugin!F 6.0.0d8
@plugin.IOgPTPPlugin 840.3
|Broadcom!BHost!CUSBTransport 7.0.5f6
|IO!BHost!CUSBTransport 7.0.5f6
|IO!BHost!CTransport 7.0.5f6
|IO!B!F 7.0.5f6
|IO!BPacketLogger 7.0.5f6
>!AThunderboltDPInAdapter 6.2.6
>!AThunderboltDPAdapter!F 6.2.6
>!AThunderboltPCIUpAdapter 2.5.4
>!AThunderboltPCIDownAdapter 2.5.4
>!AHPM 3.4.4
>!A!ILpssI2C!C 3.0.60
>!A!ILpssDmac 3.0.60
>!A!ILpssI2C 3.0.60
|IOUSBMass!SClass 4.0.4
>usb.!UHub 1.2
>!UMultitouch 264
>usb.IOUSBHostHIDDevice 1.2
>!UAudio 323.1
>usb.cdc 5.0.0
>usb.networking 5.0.0
>usb.!UHostCompositeDevice 1.2
|IOAudio!F 300.2
@vecLib.kext 1.2.0
|IOSerial!F 11
|IOSurface 269.11
@filesystems.hfs.encodings.kext 1
>!AXsanScheme 3
|IOAHCIBlock!S 316.100.5
|IOAHCI!F 290.0.1
|IOEthernetAVB!C 1.1.0
>!AThunderboltNHI 5.8.6
|IOThunderbolt!F 7.6.1
|IO80211!F 1200.12.2b1
>mDNSOffloadUserClient 1.0.1b8
>corecapture 1.0.4
|IOSkywalk!F 1
>!A!ILpssGspi 3.0.60
>usb.!UXHCIPCI 1.2
>usb.!UXHCI 1.2
>usb.!UHostPacketFilter 1.0
|IOUSB!F 900.4.2
>!AEFINVRAM 2.1
>!AEFIRuntime 2.1
|IOSMBus!F 1.1
|IOHID!F 2.0.0
$quarantine 4
$sandbox 300.0
@kext.!AMatch 1.0.0d1
>DiskImages 493.0.0
>!AFDEKeyStore 28.30
>!AEffaceable!S 1.0
>!AKeyStore 2
>!UTDM 489.120.1
|IOSCSIBlockCommandsDevice 422.120.3
>!ACredentialManager 1.0
>KernelRelayHost 1
>!ASEPManager 1.0.1
>IOSlaveProcessor 1
|IOUSBMass!SDriver 157.121.1
|IOSCSIArchitectureModel!F 422.120.3
|IO!S!F 2.1
|IOUSBHost!F 1.2
>!UHostMergeProperties 1.2
>usb.!UCommon 1.0
>!ABusPower!C 1.0
|CoreAnalytics!F 1
>!AMobileFileIntegrity 1.0.5
@kext.CoreTrust 1
|IOTimeSync!F 840.3
|IONetworking!F 3.4
|IOReport!F 47
>!AACPIPlatform 6.1
>!ASMC 3.1.9
>watchdog 1
|IOPCI!F 2.9
|IOACPI!F 1.4
@kec.pthread 1
@kec.corecrypto 1.0
@kec.Libm 1

Macbook Pro 13" late 2013 + Razer Core X + Sapphire Radeon RX 5700 XT


ReplyQuote
psonice
(@psonice)
Estimable Member
Joined: 3 years ago
 

Big Sur beta 3 turns out to be a pain, but I now have eGPU working again. I have a 2014 27" iMac w. Radeon 295X, plus a sonnet eGFX with Vega 56 over TB2.

Summary:

- Script fails because it needs "at least 10.13" (looks like the sw_ver command now correctly reports macOS 11.0 instead of 10.16). My bash scripting skills don't run as far as fixing this, so I just commented out the version checks to bypass it.

- Rebooted, and got the dreaded "eternal loading bar". Solution for this:

1. Reboot into recovery (cmd-r), open Terminal

2. Mount the file system in read/write mode:

mount -uw /Volumes/<your macOS disk>

3. Use bless to fix the boot problem:

bless --folder /Volumes/<your macOS disk>/System/Library/CoreServices --bootefi --create-snapshot

4. Reboot.

This post was modified 2 weeks ago

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
mac_editor
(@mac_editor)
Famed Member Moderator
Joined: 3 years ago
 

@psonice, Thanks for continuously testing. Latest commit includes version check fix. However, have been unable to fix the eternal loading bar issue. It occurs only the first time after patch. After that, uninstalling/reinstalling seems to work fine. Maybe I'll try the bless mechanism instead.

 

purge-wranglertbt-flashpurge-nvdaset-eGPU
Insights Into macOS Video Editing Performance

Master Threads:
2014 15-inch MacBook Pro 750M
2018 15-inch MacBook Pro

 
2019 13" MacBook Pro [8th,4C,U] + RX Vega 64 @ 32Gbps-TB3 (Mantiz Venus) + macOS 10.14.6 & Win10 [build link]  


ReplyQuote
Michael Vincent
(@michael_vincent)
New Member
Joined: 6 days ago
 

@itsage

 

 

i watched the video on install i did everything he said.. 

 
i get to installing purge wrangler then 
 
press 1 setup gpu but he says to leave it alone til you restart
 
then Ti82 support he say leave it alone if you haver a gpu that mac reconizes so i set to 
NO
 
i have sonet breakawaybox with radeon 5700xt
 
i then select amd 

final i hit NO to LEgacy
 
 
but when i reboot the apple symbol at the start and the line goes to end and freezes.. tried to start 5 times...  never starts
 
just want to intal can i pay some to get this up.. thanks
 
michael
 
310-968-4758

 

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
Heylogo
(@heylogo)
New Member
Joined: 1 day ago
 

@michael_vincent, I ran into the same problem and used the guide from @psonice (thanks!) on the current page to fix it. https://egpu.io/forums/postid/83676/  

 

 

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
Michael Vincent
(@michael_vincent)
New Member
Joined: 6 days ago
 

@heylogo

thank you illl give it a go now!

 

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
killercheung
(@killercheung)
Active Member
Joined: 1 month ago
 

Anyone test the script on Big Sur Beta 4?

The script detected my EGPU, install without any error, however nothing happen after reboot (But It can boot without enter recovery and run the bless command)

Run the script again, it shows the system was patched.

 

 

Macmini 2012 + Sonnect egfx 550 + AMD Radeon RX 570


ReplyQuote
 of  172