[Sticky] [SCRIPT] Enable AMD & NVIDIA eGPUs on TB1/2/3 Macs on macOS 10.13.4+  

Page 27 / 31 Prev Next
  RSS

tsakal
(@tsakal)
Estimable Member
Joined: 3 months ago
Posts: 122
October 2, 2018 1:53 pm  

@mac_editor

In addition the internal gpu is not utilised now, i tried to render a video and there is max 15% use of the gpu. and the tb2 cable end on the mbp get warm so the box is trying to connect to the mbp. 

A. 2.7 GHz I7 4 Cores, 16Gb, 1TB MBP 13 2018 TB3 , EGPU Gigabyte Gaming Box RX580 8Gb

B. 3.1 GHz I7, 16Gb, 1TB MBP 13 2015 TB2 , EGPU Gigabyte Gaming Box RX580 8Gb


ReplyQuote
mac_editor
(@mac_editor)
Noble Member Moderator
Joined: 2 years ago
Posts: 1600
October 2, 2018 2:46 pm  

@lqd Updating is easy if you've used the previous version: just run it - it will prompt that an update is available.

 
@tsakal I'm not sure what's going on with your box. I did have similar troubles on a TB2 machine with the Aorus, but they were fixed if I waited for 10min with everything disconnected or used a cable with power switch as linked above.

purge-wrangler.shpurge-nvda.shset-eGPU.sh
----
Troubleshooting eGPUs on macOS
Command Line Swiss Knife
----
Multiple Build Guides


ReplyQuote
tsakal
(@tsakal)
Estimable Member
Joined: 3 months ago
Posts: 122
October 2, 2018 4:46 pm  

@mac_editor

thank you i just ordered the cable 
in the meantime if you get any other ideas please let me know

A. 2.7 GHz I7 4 Cores, 16Gb, 1TB MBP 13 2018 TB3 , EGPU Gigabyte Gaming Box RX580 8Gb

B. 3.1 GHz I7, 16Gb, 1TB MBP 13 2015 TB2 , EGPU Gigabyte Gaming Box RX580 8Gb


ReplyQuote
tsakal
(@tsakal)
Estimable Member
Joined: 3 months ago
Posts: 122
October 2, 2018 5:18 pm  

@mac_editor

Sorry i forgot to ask how can i get my internal gpu working again? 
I tried to change the menu bar on the setting display menu to either the laptop display or the external one but the results are the same. 
By the way if i want to remove the script all together what do i need to do? 
Thanks

A. 2.7 GHz I7 4 Cores, 16Gb, 1TB MBP 13 2018 TB3 , EGPU Gigabyte Gaming Box RX580 8Gb

B. 3.1 GHz I7, 16Gb, 1TB MBP 13 2015 TB2 , EGPU Gigabyte Gaming Box RX580 8Gb


ReplyQuote
mac_editor
(@mac_editor)
Noble Member Moderator
Joined: 2 years ago
Posts: 1600
October 2, 2018 5:51 pm  

@tsakal Uninstalling from the script should be sufficient to undo/remove any changes from the script. I don't provide the option to remove the script itself because in case the system doesn't boot, the user has an option to recover. If you want to remove even the script, the backups, etc., I responded to someone few posts back in this thread with how to do that.

You say internal GPU is not working - how are you testing this? Please run a benchmark and show results. This script does not affect internal GPUs.

purge-wrangler.shpurge-nvda.shset-eGPU.sh
----
Troubleshooting eGPUs on macOS
Command Line Swiss Knife
----
Multiple Build Guides


ReplyQuote
Saluck
(@saluck)
New Member
Joined: 3 months ago
Posts: 4
October 2, 2018 8:14 pm  

Hey man I'm using a MacBook 2018 with Razor Core X and the RTX 2080, I followed the steps and got the icon of the Nvidia drives, however it doesn't recognise my card and my external monitor doesn't respond to the eGPU, any thoughts on what I could do? I know the RTX series just came out but any pointers would be greatly appreciated

Soon I will add my system & eGPU details or a build link to this my signature to give context to my posts


ReplyQuote
mac_editor
(@mac_editor)
Noble Member Moderator
Joined: 2 years ago
Posts: 1600
October 2, 2018 8:43 pm  

@saluck Web drivers don't support RTX at this time.

purge-wrangler.shpurge-nvda.shset-eGPU.sh
----
Troubleshooting eGPUs on macOS
Command Line Swiss Knife
----
Multiple Build Guides


ReplyQuote
Sabharwal
(@sabharwal)
Active Member
Joined: 3 months ago
Posts: 19
October 2, 2018 8:48 pm  

@mac_editor 

does your  script support w9100 gpu ?

Mac Pro 2013 - D700 - Sonnet Echo III TB2 - AMD W9100 - OS 10.13.6 High Sierra
Macbook pro late 2013 - GT750M - Sonnet Echo III TB2 - AMD W9100 - OS 10.11.6 El Captain


ReplyQuote
mac_editor
(@mac_editor)
Noble Member Moderator
Joined: 2 years ago
Posts: 1600
October 2, 2018 8:52 pm  

@arveen As far as I know, macOS natively supports the WX9100 GPU (reference: Apple), don't know about W9100 FirePro. Please state your config. in your signature. For non-TB3 Mac, option #1 of the script should enable the GPU. Any driver-related problem (such as Display showing in Graphics/Displays) is unrelated to the patch itself.

Try enabling legacy AMD GPU support (asked in Option #1) and testing.

purge-wrangler.shpurge-nvda.shset-eGPU.sh
----
Troubleshooting eGPUs on macOS
Command Line Swiss Knife
----
Multiple Build Guides


ReplyQuote
lqd
 lqd
(@lqd)
Eminent Member
Joined: 8 months ago
Posts: 25
October 2, 2018 10:12 pm  

@mac_editor  Sorry 🙂 You wrote just run it, but... when I run wrangler ... just typing purge-wrangler into terminal, it show just the old menu 4.2.5 - no notice to update showed... so what should I do? Thanks

#iMac Pro #Sonnet Breakaway #Quadro P5000+GTX 1080Ti #High Sierra 10.3.6.


ReplyQuote
ricc
 ricc
(@ricc)
Eminent Member
Joined: 9 months ago
Posts: 22
October 2, 2018 10:13 pm  

2014 MBP 15" /w Iris Pro + Aorus Gaming Box GTX1070

I downloaded purge-wrangler. The MacOS setup is reaaaaally easy. Just install and run the script by following all the steps, reboot, plug in the headless adapter (or external monitor) to eGPU box, plug the box into the mac, logout, login, everything works like a charm!

Not totally sure it's related but:
After installing purge-wrangler on MacOS, I can plug in an external monitor to the box, the box to the mac and boot into bootcamp. Immediately the external monitor starts showing images as soon as the windows login screen appears.

Thank you! @mac_editor

2014 Macbook Pro 15" Iris Pro /w Aorus Gaming Box GTX 1070


mac_editor liked
ReplyQuote
mac_editor
(@mac_editor)
Noble Member Moderator
Joined: 2 years ago
Posts: 1600
October 2, 2018 10:14 pm  

@lqd It may have had trouble connecting to the internet/github. No biggie, just go to the first post on this thread and run that long command.

purge-wrangler.shpurge-nvda.shset-eGPU.sh
----
Troubleshooting eGPUs on macOS
Command Line Swiss Knife
----
Multiple Build Guides


ReplyQuote
lqd
 lqd
(@lqd)
Eminent Member
Joined: 8 months ago
Posts: 25
October 2, 2018 10:22 pm  

@mac_editor  Yeah. It works in that way. Thanks 🙂

#iMac Pro #Sonnet Breakaway #Quadro P5000+GTX 1080Ti #High Sierra 10.3.6.


ReplyQuote
Sabharwal
(@sabharwal)
Active Member
Joined: 3 months ago
Posts: 19
October 3, 2018 6:52 am  
Posted by: mac_editor

@arveen As far as I know, macOS natively supports the WX9100 GPU (reference: Apple), don't know about W9100 FirePro. Please state your config. in your signature. For non-TB3 Mac, option #1 of the script should enable the GPU. Any driver-related problem (such as Display showing in Graphics/Displays) is unrelated to the patch itself.

Try enabling legacy AMD GPU support (asked in Option #1) and testing.

thanks for the reply. will try the option #1 again. 

my cofig is:
Mac Pro 2013 - D700 - sonnet echo III TB2 enclosure - w9100 - os 10.13.6 high sierra

Mac Pro 2013 - D700 - Sonnet Echo III TB2 - AMD W9100 - OS 10.13.6 High Sierra
Macbook pro late 2013 - GT750M - Sonnet Echo III TB2 - AMD W9100 - OS 10.11.6 El Captain


ReplyQuote
(@gxalpha)
Active Member
Joined: 3 months ago
Posts: 5
October 3, 2018 7:45 pm  

Hello, I've got a problem with the patch. I want to enable NVIDIA-eGPUs, but when it's coming to install web driver (which I need, I want to use a 1050 ti), it says:
No web driver available for your System at this time.
Your preference disables web driver pitching.

What did I do wrong?
I'm using a base-line MacBook Pro late 2013 (TB2) with macOS 10.13.6.

Thanks  🙂

Soon I will add my system & eGPU details or a build link to this my signature to give context to my posts


ReplyQuote
mac_editor
(@mac_editor)
Noble Member Moderator
Joined: 2 years ago
Posts: 1600
October 3, 2018 8:06 pm  

@gxalpha Choose preferences option in the menu, and set the preference for web driver patching to ask.

purge-wrangler.shpurge-nvda.shset-eGPU.sh
----
Troubleshooting eGPUs on macOS
Command Line Swiss Knife
----
Multiple Build Guides


ReplyQuote
(@gxalpha)
Active Member
Joined: 3 months ago
Posts: 5
October 3, 2018 9:58 pm  

@mac_editor Thanks for your answer! I did this, selecting "yes" was still the same error, and when I was selecting "no", it installed the patch, but without the web drivers, I think. I can't test it out yet, should it work with a 1050 ti now?

Soon I will add my system & eGPU details or a build link to this my signature to give context to my posts


ReplyQuote
mac_editor
(@mac_editor)
Noble Member Moderator
Joined: 2 years ago
Posts: 1600
October 3, 2018 10:19 pm  

@gxalpha Thank you for bringing this up. It's a bug in v5.0.0. A fix will be out shortly.

purge-wrangler.shpurge-nvda.shset-eGPU.sh
----
Troubleshooting eGPUs on macOS
Command Line Swiss Knife
----
Multiple Build Guides


ReplyQuote
mac_editor
(@mac_editor)
Noble Member Moderator
Joined: 2 years ago
Posts: 1600
October 3, 2018 10:53 pm  

@gxalpha the fix is out (5.0.1). Please let me know if it works.

purge-wrangler.shpurge-nvda.shset-eGPU.sh
----
Troubleshooting eGPUs on macOS
Command Line Swiss Knife
----
Multiple Build Guides


ReplyQuote
homer_holmes
(@homer_holmes)
New Member
Joined: 3 months ago
Posts: 1
October 4, 2018 2:58 am  

@mac_editor 😥 Me sitting here refreshing this page after purchasing a Gigabyte AORUS GTX 1080 Gaming Box yesterday before reading all the way through this post. Running 10.14.... Come on NVIDIA drivers pleeeaasseee! Purge-wrangler confirmed working on MacBook Pro (15-inch, 2016) running 10.14. System Reports NVIDIA GeForce GTX1080 External GPU, monitors are detected with correct screen resolution but the output is blank.  🙄  Why did i upgrade to Mojave over the weekend

Thanks for all the hard work you've put into this @mac_editor expect a donation once I get this up and running

Soon I will add my system & eGPU details or a build link to this my signature to give context to my posts


ReplyQuote
(@gxalpha)
Active Member
Joined: 3 months ago
Posts: 5
October 4, 2018 7:41 am  

@mac_editor The patch ran without any issues now and installed the web drivers. Thank you for your work!  🙂

Soon I will add my system & eGPU details or a build link to this my signature to give context to my posts


ReplyQuote
tsakal
(@tsakal)
Estimable Member
Joined: 3 months ago
Posts: 122
October 4, 2018 12:34 pm  

@mac_editor

Quick question, does the selection of the menu bar either on laptop screen or external monitor make a difference ? Is there a preferred option for the script for tb2 mbp 13 2015? 
Also is there a preferred sequence of how to connect the gaming box with and without the cable you recommended ? i.e power followed by display port followed by usbc in the box followed by tb2 ? Also after disconnecting the gaming box shall i alway take the tb2 cable out or i can reboot with the box connected ? 

Thanks

A. 2.7 GHz I7 4 Cores, 16Gb, 1TB MBP 13 2018 TB3 , EGPU Gigabyte Gaming Box RX580 8Gb

B. 3.1 GHz I7, 16Gb, 1TB MBP 13 2015 TB2 , EGPU Gigabyte Gaming Box RX580 8Gb


ReplyQuote
Sabharwal
(@sabharwal)
Active Member
Joined: 3 months ago
Posts: 19
October 4, 2018 9:22 pm  

@mac_editor 

do i need to reinstall os bcos I've tried freak's script as well as ur script

i did uninstall each script before trying the other. 

I'm confused where I'm going wrong. 

thanks

Mac Pro 2013 - D700 - Sonnet Echo III TB2 - AMD W9100 - OS 10.13.6 High Sierra
Macbook pro late 2013 - GT750M - Sonnet Echo III TB2 - AMD W9100 - OS 10.11.6 El Captain


ReplyQuote
(@iamqk-bsd)
New Member
Joined: 3 months ago
Posts: 3
October 5, 2018 5:47 am  

@Mac_editor

last night I install new 10.13.6 on may MacBook Pro 2015 15 and patch with you script, (gaming box 1080)
after run patch, it did not success, card not shown in macOS's video card list
status showed thunderbolt patch failed, is it a bug? or the thunder should be patched by other script

thank you for you work

Soon I will add my system & eGPU details or a build link to this my signature to give context to my posts


ReplyQuote
mac_editor
(@mac_editor)
Noble Member Moderator
Joined: 2 years ago
Posts: 1600
October 5, 2018 5:49 am  

@iamqk For NVIDIA GPU, as long as status for NVIDIA patch shows enabled, patch is active.

purge-wrangler.shpurge-nvda.shset-eGPU.sh
----
Troubleshooting eGPUs on macOS
Command Line Swiss Knife
----
Multiple Build Guides


ReplyQuote
(@iamqk-bsd)
New Member
Joined: 3 months ago
Posts: 3
October 5, 2018 5:52 am  

@Mac_editor ok thank you ,got it

Soon I will add my system & eGPU details or a build link to this my signature to give context to my posts


ReplyQuote
tsakal
(@tsakal)
Estimable Member
Joined: 3 months ago
Posts: 122
October 5, 2018 2:24 pm  

@Mac_editor

I am back in business again today. However, i would like in a few words whether  i should avoid any steps in the usual switch on /off routine that might affect the state of the connection to the box. 

I have a question though. When checking the display preferences the egpu is assigned only on the external monitor. I thought that if I have the menu bar over the external monitor both internal and external monitors are driven by the egpu.  Also my second display has free sync, black stabiliser and changing response time. Could any of these features affect the connection to the gaming box. 

Everything seems to work normal now. Switched to my other display at home and worked normally. 

When the mbp and screen go to sleep the gaming box does also fans and light go off. As soon as i wake the mbp up everything wakes up normally. 

Also after ejecting the egpu last night and switching off the mbp. This morning i switched it on with the cable attached and everything started normal. Is this recommended or shall i always disconnect the box from the mbp. 

Fixed. The only thing missing is that the  eject icon does not appear on the menu bar.

 Waking up Steps for reference. 
I have not used the cable you recommended yet. I I followed a few tips i read here or there, and at the end it just worked. I read from various people using one of the following tricks below but in different versions of macOS and with different setups with or without patches. I list below what i did and in what order. 

1 I left the box off all cable overnight. This afternoon i connected the power first, then the display port connected to monitor and then the usbc cable with the cable matters tb2. This did not work 
2 I tried the hotplugging trick connecting the the box to the mbp after restarting while on log in screen. That did not work either. 
3 I tried the same trick as above but after i disabled the guest account. This didn't work
4 i swapped the cable matters cable with the apple tb2 cable and followed the hot plugging trick. This didn't work. 
5 i swapped the display port cable to display port cable and did the hot plugging trick. While waiting in the login screen the box fired up and the monitor connected. 

Although everything could have helped in waking up the box the use of the HDMI seemed to do the trick. @vikalive in this forum has suggested this trick back in july but i don't know his setup. 

A. 2.7 GHz I7 4 Cores, 16Gb, 1TB MBP 13 2018 TB3 , EGPU Gigabyte Gaming Box RX580 8Gb

B. 3.1 GHz I7, 16Gb, 1TB MBP 13 2015 TB2 , EGPU Gigabyte Gaming Box RX580 8Gb


ReplyQuote
tsakal
(@tsakal)
Estimable Member
Joined: 3 months ago
Posts: 122
October 8, 2018 8:59 am  

@Mac_editor

Update

Following my previous issues with waking up the gaming box, want to share the following. The only issue i have now is that the little icon on the menu bar to disconnect the egpu is absent. What is the best alternative way to disconnect it ? 

Thank you 

Follow up 

For as long as the gaming box i connected to the mbp switching the mbp on / off it will still connect. 

As long as you unplug the gaming box, the use of an HDMI instead of display port is required to wake the box up.

A. 2.7 GHz I7 4 Cores, 16Gb, 1TB MBP 13 2018 TB3 , EGPU Gigabyte Gaming Box RX580 8Gb

B. 3.1 GHz I7, 16Gb, 1TB MBP 13 2015 TB2 , EGPU Gigabyte Gaming Box RX580 8Gb


ReplyQuote
tsakal
(@tsakal)
Estimable Member
Joined: 3 months ago
Posts: 122
October 8, 2018 9:20 am  

@Mac_editor

Can you please help. 

I am planning to upgrade my mbp 13 2015 to a mbp 13 2018. Do i need to uninstall the patch update my backup and then set up the 2018 mbp from the final backup? Are there anything else i need to do.

Finally now that the patch is stable and running can i re-enable the SIP? 

Thanks in advance 

Best

A. 2.7 GHz I7 4 Cores, 16Gb, 1TB MBP 13 2018 TB3 , EGPU Gigabyte Gaming Box RX580 8Gb

B. 3.1 GHz I7, 16Gb, 1TB MBP 13 2015 TB2 , EGPU Gigabyte Gaming Box RX580 8Gb


ReplyQuote
Liosandro
(@liosandro)
New Member
Joined: 1 year ago
Posts: 3
October 8, 2018 11:53 am  

Hi all,
first of all my setup:
MacBook Pro (15-inch, 2016)
Mojave
BizonBox3 T3 enclosure that in the SysRep is reported as AKiTiO Thunder3 PCIe Box
Nvidia GTX1080Ti
I already used the enclosure easily with MacOS 10.12, a bit harder, using purge-wrangler on 10.13, but now I can't use it on Mojave 10.14.
I just need to have a clear idea on what is supported and what not using the Purge-Wrangler and, if everything should work, what is the step-by-step procedure to turn everything on.

Thanks!
Alessandro

Soon I will add my system & eGPU details or a build link to this my signature to give context to my posts


ReplyQuote
Larouzey
(@larouzey)
New Member
Joined: 2 months ago
Posts: 1
October 8, 2018 3:18 pm  

Help!
Who can help me solve this problem.
My notebook is mbp17, 15inch with Touch Bar. The system is mac OS 10.13.6. After I installed the Nvidia driver, but I can't use the card. And I feel very stuck. I am using a DP connected to the LG display. The feeling for me is that I am using Intel's core graphics card instead of an external graphics card. Who can teach me how to set it up so that it can really be used.
Thank you very much!
JY

Soon I will add my system & eGPU details or a build link to this my signature to give context to my posts


ReplyQuote
lqd
 lqd
(@lqd)
Eminent Member
Joined: 8 months ago
Posts: 25
October 8, 2018 4:54 pm  

@Liosandro You can't use GTX1080 on Mojave right now, until the Nvidia releases their webdriver for Mojave. Just wait for it, it should come soon.

#iMac Pro #Sonnet Breakaway #Quadro P5000+GTX 1080Ti #High Sierra 10.3.6.


theitsage liked
ReplyQuote
Liosandro
(@liosandro)
New Member
Joined: 1 year ago
Posts: 3
October 9, 2018 7:58 am  
Posted by: lqd

@Liosandro You can't use GTX1080 on Mojave right now, until the Nvidia releases their webdriver for Mojave. Just wait for it, it should come soon.

Well thanks mate,
that was I thought, but combing through all the thread is too time demanding.

thanks again,
Ale

Soon I will add my system & eGPU details or a build link to this my signature to give context to my posts


ReplyQuote
the-simian
(@the_simian)
New Member
Joined: 3 months ago
Posts: 3
October 10, 2018 3:04 pm  

@mac_editor you're a champion, 100%. Thank you for your work! This is a really great tool, and actually it has helped me move forward with my setup, but I still have an issue. 

I used this with an AkiTio Node Pro Chassis and an AMD Vega 56 paired with a (slightly older) mid 2015 macbook pro with TB2. The setup works seemingly fine when the laptop is open, but when I try to use the laptop in my dock (clamshell mode) the external screen always turns off.

Has anyone else been able to use this, or configure their system to support expected 'docking' behavior?

Macbook Pro mid 2015
AkiTio Node Pro with Tb2 -> Tb3 adapter
Amd Vega 56


mac_editor liked
ReplyQuote
tsakal
(@tsakal)
Estimable Member
Joined: 3 months ago
Posts: 122
October 11, 2018 11:12 am  
Posted by: tsakal

@Mac_editor

Can you please help. 

I am planning to upgrade my mbp 13 2015 to a mbp 13 2018. Do i need to uninstall the patch update my backup and then set up the 2018 mbp from the final backup? Are there anything else i need to do.

Finally now that the patch is stable and running can i re-enable the SIP? 

Thanks in advance 

Best

@Mac_editor

Can you please provide an answer on
a . does the selection of the menu bar either on laptop screen or external monitor make a difference ? Is there a preferred option for the script for tb2 mbp 13 2015 running mojave 10.14 public? 
b, on steps, regarding the patch, to follow before i setup a new 2018 mbp13, see above? 
c. whether SIP can reenabled again now that everything works on the mbp 2015

Update regarding the wake up issue. If the box is left conpletely un-connected overnight i need an HDMI connected monitor to wake it up. However if i disconnect the egpu while connected to a monitor through a DP, i shut down the mbp leaving the tb2 cable connected and switch off the suko plug i use to connect the mains cable to the wall. Next day when i switch on the suko plug turn on the mbp and the box connects with no issues. .

Thank you again for everything.

A. 2.7 GHz I7 4 Cores, 16Gb, 1TB MBP 13 2018 TB3 , EGPU Gigabyte Gaming Box RX580 8Gb

B. 3.1 GHz I7, 16Gb, 1TB MBP 13 2015 TB2 , EGPU Gigabyte Gaming Box RX580 8Gb


ReplyQuote
mac_editor
(@mac_editor)
Noble Member Moderator
Joined: 2 years ago
Posts: 1600
October 13, 2018 12:46 am  

@tsakal Consider reading the troubleshooting guide and search the forums for a.

b. Uninstall patch. Migrate system. If you didn't uninstall before migrating, eGPU won't work (since patched for TB2), but just use recovery option of the script and all should be as expected.
c. SIP must always be disabled as long as patch is active.

purge-wrangler.shpurge-nvda.shset-eGPU.sh
----
Troubleshooting eGPUs on macOS
Command Line Swiss Knife
----
Multiple Build Guides


ReplyQuote
Page 27 / 31 Prev Next