Share:

[Sticky] [SCRIPT] PurgeWrangler: AMD + NVIDIA eGPUs for all Thunderbolt Macs  

Page 36 / 36
  RSS

(@topbestmusic2015)
New Member
Joined: 2 weeks ago
Posts: 3
May 12, 2019 10:32 pm  
1080 will not work on Mojave?
 

Pending: Add my system information and expected eGPU configuration to my signature to give context to my posts


ReplyQuote
Jeroenvankeulen
(@jeroen-van-keulen)
Trusted Member
Joined: 1 year ago
Posts: 80
May 19, 2019 8:27 pm  

Semi off topic:

On 10.13.6 developer beta 1 I get the e-Gpu icon in the menu bar even when not connected to my setup. 
I can't click even when it actually is connected. I cant disconnect my egpu, instead I need to shutdown my macbook.

Anyone els having the same problem? Or having a solution?

ALLn1
MBP11,4, i7-4980HQ, 256gb SSD, 16gbRAM Mojave (Sonnet Breakaway box 350 + Gigabyte Radeon RX 580 Gaming 8GB)
MacBook7,1 A1342, P8600 120gb SSD 4gbRAM. Mojave (Hiking/Camping)
iMac7,1 A1224, T9500 CPU upgrade 120gb SSD 4gbRAM. HS
Mac mini3,1 P7350, 250gb SSD 8gbRAM. HS (server) iPhone10,3 64gb. iOS12 iPad5,3, 16gb. iOS12 iPod shuffle 2nd gen. 2gb
GeekBench


ReplyQuote
mac_editor
(@mac_editor)
Noble Member Moderator
Joined: 2 years ago
Posts: 2049
May 19, 2019 8:29 pm  

@jeroen-van-keulen I presume you mean 10.14.6 Beta 1. Yes, that is a bug. The SafeEjectGPU mechanism has a fault in this build. Should be a minor fix which we might see in the next beta.

purge-wrangler.shpurge-nvda.shset-eGPU.shautomate-eGPU EFI Installer
----
Troubleshooting eGPUs on macOS
Command Line Swiss Knife
eGPU Hardware Chart
Multiple Build Guides
----
Current: MacBook Pro RP560X + 480/R9 Fury/Vega 64 | GTX 780/1070
Previous: 2014 MacBook Pro 750M + 480/R9 Fury | GTX 780/980 Ti/1070


ReplyQuote
Jeroenvankeulen
(@jeroen-van-keulen)
Trusted Member
Joined: 1 year ago
Posts: 80
May 19, 2019 9:07 pm  
Posted by: mac_editor

@jeroen-van-keulen I presume you mean 10.14.6 Beta 1. Yes, that is a bug. The SafeEjectGPU mechanism has a fault in this build. Should be a minor fix which we might see in the next beta.

yeah, 10.14.6 (big fingers)

I thought sorbet hadn't read it anywhere.

ALLn1
MBP11,4, i7-4980HQ, 256gb SSD, 16gbRAM Mojave (Sonnet Breakaway box 350 + Gigabyte Radeon RX 580 Gaming 8GB)
MacBook7,1 A1342, P8600 120gb SSD 4gbRAM. Mojave (Hiking/Camping)
iMac7,1 A1224, T9500 CPU upgrade 120gb SSD 4gbRAM. HS
Mac mini3,1 P7350, 250gb SSD 8gbRAM. HS (server) iPhone10,3 64gb. iOS12 iPad5,3, 16gb. iOS12 iPod shuffle 2nd gen. 2gb
GeekBench


ReplyQuote
bladerunner
(@bladerunner)
New Member
Joined: 4 weeks ago
Posts: 1
May 20, 2019 5:31 pm  

Hello, I am new here. I would like to send a message to @mac_editor but the system says I am not allowed yet. So I write in the only place I can find : here.
I would ask @Mac_editor, if he thinks to develop patch also for new macOS too came.
I donate, 40$, for the existing patch.

Thankyou @mac_editor your patch helped me much.
Francesco

Pending: Add my system information and expected eGPU configuration to my signature to give context to my posts


ReplyQuote
mac_editor
(@mac_editor)
Noble Member Moderator
Joined: 2 years ago
Posts: 2049
May 21, 2019 1:20 am  

@bladerunner not exactly sure what you wanted to ask, but good to hear everything working for you as expected. The latest releases are already supported (for NVIDIA, NVIDIA/Apple need to release web drivers).

This post was modified 6 days ago

purge-wrangler.shpurge-nvda.shset-eGPU.shautomate-eGPU EFI Installer
----
Troubleshooting eGPUs on macOS
Command Line Swiss Knife
eGPU Hardware Chart
Multiple Build Guides
----
Current: MacBook Pro RP560X + 480/R9 Fury/Vega 64 | GTX 780/1070
Previous: 2014 MacBook Pro 750M + 480/R9 Fury | GTX 780/980 Ti/1070


ReplyQuote
(@romer_tanaleon)
Eminent Member
Joined: 3 weeks ago
Posts: 22
May 25, 2019 1:21 am  

@mac_editor Hello, I have been trying to get my MBP Late 2013 running with eGPU with no success. I actually posted an issue on the Helios FX page but never got a reply. I have an RX 560 from an old pc and wanted to used it as a eGPU. Installed it on Helios FX, run the Purge script, installed legacy support and the ti82 and reboot. I login first on the Mac and as soon as I plugged in the eGPU, screen turned black and then displayed the "Your computer restart because of a problem". This is with High Sierra 10.13.6 and I know I got the same thing on .4, I then tried updating on Mojave 10.14.5 and I actually got a message that I need to repatch Purge again so I did but only end up with the same issue. I don't really know what I'm doing wrong or missing a step while I see everyone getting their old MBP running with their eGPU setup. Please help. I really need help on getting my setup running. If you tell me to reinstall High Sierra 10.13.4, I can do that but I desperately need a guide on what to do next. Thank you.

Pending: Add my system information and expected eGPU configuration to my signature to give context to my posts


ReplyQuote
mac_editor
(@mac_editor)
Noble Member Moderator
Joined: 2 years ago
Posts: 2049
May 25, 2019 1:22 am  

@romer_tanaleon there is a feature in the script called Anomaly Detection. What does it say? I am guessing you have a Mac with the NVIDIA GT 750M. If so, use purge-nvda as well (if you are using an external display). You also do not require Ti82 or legacy support for Mojave.

This post was modified 2 days ago

purge-wrangler.shpurge-nvda.shset-eGPU.shautomate-eGPU EFI Installer
----
Troubleshooting eGPUs on macOS
Command Line Swiss Knife
eGPU Hardware Chart
Multiple Build Guides
----
Current: MacBook Pro RP560X + 480/R9 Fury/Vega 64 | GTX 780/1070
Previous: 2014 MacBook Pro 750M + 480/R9 Fury | GTX 780/980 Ti/1070


ReplyQuote
(@romer_tanaleon)
Eminent Member
Joined: 3 weeks ago
Posts: 22
May 25, 2019 1:28 am  

@Mac_editor my Mac only shows Intel Iris 1536 MB.

Aso PurgeWrangler is version 6.0.0 and I don't see that option anymore.

This post was modified 2 days ago

Pending: Add my system information and expected eGPU configuration to my signature to give context to my posts


ReplyQuote
mac_editor
(@mac_editor)
Noble Member Moderator
Joined: 2 years ago
Posts: 2049
May 25, 2019 1:47 am  

@romer_tanaleon Please use the latest public release and NOT script versions under development or from the latest GitHub commit. Not sure why you would use an unreleased build/version unless you are a developer testing the script. It can be potentially dangerous, and you will not be able receive support from fellow users of latest public releases.

Please share screenshot of About This Mac > System Report > Graphics/Displays.

Uninstall everything. In your case, after uninstalling and rebooting (ensure Mac is functional normally), delete /Library/Application Support/Purge-Wrangler directory.

If your Mac has only the Intel GPU, then running enabling AMD eGPUs via purge-wrangler will be enough.

purge-wrangler.shpurge-nvda.shset-eGPU.shautomate-eGPU EFI Installer
----
Troubleshooting eGPUs on macOS
Command Line Swiss Knife
eGPU Hardware Chart
Multiple Build Guides
----
Current: MacBook Pro RP560X + 480/R9 Fury/Vega 64 | GTX 780/1070
Previous: 2014 MacBook Pro 750M + 480/R9 Fury | GTX 780/980 Ti/1070


ReplyQuote
(@romer_tanaleon)
Eminent Member
Joined: 3 weeks ago
Posts: 22
May 25, 2019 1:47 am  
Screen Shot 2019 05 24 at 8.46.13 PM

I run 5.1.2 wrangler and check anomaly's

Pending: Add my system information and expected eGPU configuration to my signature to give context to my posts


ReplyQuote
mac_editor
(@mac_editor)
Noble Member Moderator
Joined: 2 years ago
Posts: 2049
May 25, 2019 1:49 am  

@romer_tanaleon Thank you. Uninstall all patches. Reboot and ensure system is clean. Enable patches for AMD GPUs. Do not enable legacy or Ti82 support. Reboot. Hot-plug eGPU. Report what you see.

purge-wrangler.shpurge-nvda.shset-eGPU.shautomate-eGPU EFI Installer
----
Troubleshooting eGPUs on macOS
Command Line Swiss Knife
eGPU Hardware Chart
Multiple Build Guides
----
Current: MacBook Pro RP560X + 480/R9 Fury/Vega 64 | GTX 780/1070
Previous: 2014 MacBook Pro 750M + 480/R9 Fury | GTX 780/980 Ti/1070


ReplyQuote
(@romer_tanaleon)
Eminent Member
Joined: 3 weeks ago
Posts: 22
May 25, 2019 1:51 am  

Screen Shot 2019 05 24 at 8.49.18 PM

I will go ahead on the next step and deleting the directory and install the released version and go from there.

@Mac_editor no good. I installed only AMD GPUs, reboot, plugged in eGPU after log in and got the "Your computer restarted..." message. I even tried leaving it plugin, tried before the loading on the apple logo and also tried to time it after the load finish and before log in and still the same error...

This post was modified 2 days ago

Pending: Add my system information and expected eGPU configuration to my signature to give context to my posts


ReplyQuote
mac_editor
(@mac_editor)
Noble Member Moderator
Joined: 2 years ago
Posts: 2049
May 25, 2019 2:05 am  

@romer_tanaleon I see. Can you verify if the GPU itself is functional (assuming correct assembly in enclosure) in a PC? This behavior is typical of a failed/faulty AMD GPU (have had the issue myself - replacing it fixed the problem).

This post was modified 2 days ago

purge-wrangler.shpurge-nvda.shset-eGPU.shautomate-eGPU EFI Installer
----
Troubleshooting eGPUs on macOS
Command Line Swiss Knife
eGPU Hardware Chart
Multiple Build Guides
----
Current: MacBook Pro RP560X + 480/R9 Fury/Vega 64 | GTX 780/1070
Previous: 2014 MacBook Pro 750M + 480/R9 Fury | GTX 780/980 Ti/1070


ReplyQuote
(@romer_tanaleon)
Eminent Member
Joined: 3 weeks ago
Posts: 22
May 25, 2019 2:09 am  

@Mac_editor the only way for me to check the gpu is by putting it back to the old pc. I did it before and even update the software, I believed it is the Adrenalin 2019 version. It is working but I can do it again. Is there any info do you need if I can get the gpu running on the old pc?

This post was modified 2 days ago

Pending: Add my system information and expected eGPU configuration to my signature to give context to my posts


ReplyQuote
mac_editor
(@mac_editor)
Noble Member Moderator
Joined: 2 years ago
Posts: 2049
May 25, 2019 2:16 am  

@romer_tanaleon running a benchmark on it to see if it’s working fine under load would be sufficient. If this is indeed the case and the GPU is fine, then something else is causing the reboot - because the current patch works fine on 10.14.5. Next debugging step would be to install a clean copy of macOS on another partition (with APFS, just add a new volume and install macOS to it) and try on that install.

purge-wrangler.shpurge-nvda.shset-eGPU.shautomate-eGPU EFI Installer
----
Troubleshooting eGPUs on macOS
Command Line Swiss Knife
eGPU Hardware Chart
Multiple Build Guides
----
Current: MacBook Pro RP560X + 480/R9 Fury/Vega 64 | GTX 780/1070
Previous: 2014 MacBook Pro 750M + 480/R9 Fury | GTX 780/980 Ti/1070


ReplyQuote
(@romer_tanaleon)
Eminent Member
Joined: 3 weeks ago
Posts: 22
May 25, 2019 2:34 am  

IMG 0602

@Mac_editor benchmark is still running on the pc right now...OpenGL at 1080p High. FPS avg 13.87..it just finished. I'll take a screenshot of it...

Superposition Benchmark v1.0 1854 1558751456

Here is the result

This post was modified 2 days ago

Pending: Add my system information and expected eGPU configuration to my signature to give context to my posts


ReplyQuote
nu_ninja
(@nu_ninja)
Estimable Member
Joined: 1 year ago
Posts: 173
May 25, 2019 3:45 am  

It looks like you have an XFX card, I think those do not work well with macOS? (Someone clarify if I'm wrong on this)

Mid-2012 13" Macbook Pro (MacBookPro9,2) TB1 -> RX 460/560 (AKiTiO Node/Thunder2)
+ macOS 10.14+Win10
+ Linux Mint 19.1


ReplyQuote
(@romer_tanaleon)
Eminent Member
Joined: 3 weeks ago
Posts: 22
May 25, 2019 3:47 am  

@mac_editor sigh...no luck. I installed Mojave on a new volume. I tried connecting the eGPU without running the script first and already got the error. I then reboot, installed the script with AMD GPU only and same thing. Could this be hardware issue? I'm thinking of getting new cable and TB3>TB2 adapter but its already late. I hope its not the enclosure itself. Not sure what else now...

Pending: Add my system information and expected eGPU configuration to my signature to give context to my posts


ReplyQuote
mac_editor
(@mac_editor)
Noble Member Moderator
Joined: 2 years ago
Posts: 2049
May 25, 2019 4:35 am  
Posted by: Romer Tanaleon

@mac_editor sigh...no luck. I installed Mojave on a new volume. I tried connecting the eGPU without running the script first and already got the error.

@romer_tanaleon this shouldn't have happened. Reset NVRAM and SMC and see what happens without scripts on the clean install. If the error still occurs, it may be a hardware issue.

@nu_ninja that used to be the case previously, but not so today it seems. Apple's official eGPU documentation does not shy away from recommending XFX cards.

This post was modified 2 days ago

purge-wrangler.shpurge-nvda.shset-eGPU.shautomate-eGPU EFI Installer
----
Troubleshooting eGPUs on macOS
Command Line Swiss Knife
eGPU Hardware Chart
Multiple Build Guides
----
Current: MacBook Pro RP560X + 480/R9 Fury/Vega 64 | GTX 780/1070
Previous: 2014 MacBook Pro 750M + 480/R9 Fury | GTX 780/980 Ti/1070


ReplyQuote
(@romer_tanaleon)
Eminent Member
Joined: 3 weeks ago
Posts: 22
May 25, 2019 4:42 am  

@mac_editor how do i reset nvram and smc? and i hope its not because its an XFX...don't really have funds to get a new gpu...

Pending: Add my system information and expected eGPU configuration to my signature to give context to my posts


ReplyQuote
mac_editor
(@mac_editor)
Noble Member Moderator
Joined: 2 years ago
Posts: 2049
May 25, 2019 4:43 am  

@romer_tanaleon A quick google search would help:

https://support.apple.com/en-us/HT201295

https://support.apple.com/en-us/HT204063

purge-wrangler.shpurge-nvda.shset-eGPU.shautomate-eGPU EFI Installer
----
Troubleshooting eGPUs on macOS
Command Line Swiss Knife
eGPU Hardware Chart
Multiple Build Guides
----
Current: MacBook Pro RP560X + 480/R9 Fury/Vega 64 | GTX 780/1070
Previous: 2014 MacBook Pro 750M + 480/R9 Fury | GTX 780/980 Ti/1070


ReplyQuote
(@romer_tanaleon)
Eminent Member
Joined: 3 weeks ago
Posts: 22
May 25, 2019 4:54 am  

@mac_editor ok something different is happening. I reset both NVRAM and SMC, I also made sure the script was uninstalled first. I then reboot and plugin the eGPU...no "Your computer restarted because of a problem" message but my mac keeps rebooting after the load bar gets halfway, I let it do it a couple of times then I unplugged the eGPU and it boots properly. Is that a good sign?

Pending: Add my system information and expected eGPU configuration to my signature to give context to my posts


ReplyQuote
mac_editor
(@mac_editor)
Noble Member Moderator
Joined: 2 years ago
Posts: 2049
May 25, 2019 4:55 am  

@romer_tanaleon That should not happen. What happens on hot-plugging (after successful boot)?

purge-wrangler.shpurge-nvda.shset-eGPU.shautomate-eGPU EFI Installer
----
Troubleshooting eGPUs on macOS
Command Line Swiss Knife
eGPU Hardware Chart
Multiple Build Guides
----
Current: MacBook Pro RP560X + 480/R9 Fury/Vega 64 | GTX 780/1070
Previous: 2014 MacBook Pro 750M + 480/R9 Fury | GTX 780/980 Ti/1070


ReplyQuote
(@romer_tanaleon)
Eminent Member
Joined: 3 weeks ago
Posts: 22
May 25, 2019 5:02 am  

@mac_editor it kicks me out and reboot

Pending: Add my system information and expected eGPU configuration to my signature to give context to my posts


ReplyQuote
mac_editor
(@mac_editor)
Noble Member Moderator
Joined: 2 years ago
Posts: 2049
May 25, 2019 5:04 am  

@romer_tanaleon I cannot pinpoint the issue. Basically this shouldn't be happening on a clean install, so definitely try switching up the hardware components.

purge-wrangler.shpurge-nvda.shset-eGPU.shautomate-eGPU EFI Installer
----
Troubleshooting eGPUs on macOS
Command Line Swiss Knife
eGPU Hardware Chart
Multiple Build Guides
----
Current: MacBook Pro RP560X + 480/R9 Fury/Vega 64 | GTX 780/1070
Previous: 2014 MacBook Pro 750M + 480/R9 Fury | GTX 780/980 Ti/1070


ReplyQuote
(@romer_tanaleon)
Eminent Member
Joined: 3 weeks ago
Posts: 22
May 25, 2019 5:07 am  

@mac_editor I will have to wait tomorrow to try to get a new cable and the TB3>TB2 adapter. If this is happening on macOS, it wouldn't make a difference if I try on bootcamp right?

Pending: Add my system information and expected eGPU configuration to my signature to give context to my posts


ReplyQuote
goalque
(@goalque)
Noble Member Admin
Joined: 3 years ago
Posts: 1399
May 25, 2019 8:07 am  
Posted by: mac_editor

@nu_ninja that used to be the case previously, but not so today it seems. Apple's official eGPU documentation does not shy away from recommending XFX cards.

@nu_ninja True.

Only the Sapphire Pulse from AMD Polaris architecture is an exception, otherwise you should always use the reference AMD vBIOS. Apple does not have time to test every single brand and model. You have to change brand or flash the vBIOS:

https://egpu.io/forums/mac-setup/apple-is-supporting-external-gpus-with-high-sierra/paged/7/#post-15098

Avoid XFX:

https://egpu.io/forums/gpu-monitor-peripherals/why-does-amd-get-away-with-selling-cards-vega-series-that-require-2x-more-power-of-similar-performing-cards/#post-60135

automate-eGPU EFIapple_set_os.efi
--
2018 13" MacBook Pro + Radeon [email protected] + Win10 1809


ReplyQuote
(@romer_tanaleon)
Eminent Member
Joined: 3 weeks ago
Posts: 22
May 25, 2019 8:26 pm  

@goalque @mac_editor Holy fart it work!!! It was the XFX after all...I flash the bios on the GPU and put a sapphire bios on it. I don't know how long this will keep up but it works!!!

Screen Shot 2019 05 25 at 3.24.23 PM
Screen Shot 2019 05 25 at 3.24.13 PM
Screen Shot 2019 05 25 at 3.23.12 PM

What can I use to benchmark on mac? I am on latest Mojave btw. I'm freakin excited!!!

Pending: Add my system information and expected eGPU configuration to my signature to give context to my posts


ReplyQuote
mac_editor
(@mac_editor)
Noble Member Moderator
Joined: 2 years ago
Posts: 2049
May 25, 2019 8:30 pm  

@romer_tanaleon Awesome! Well I guess there is a reason for the RX 560 (excluding all-in-one Sonnet Puck) not being mentioned on the Apple eGPU support docs (in the same way as the other cards) - which ties in well to @goalque's point above - "Apple does not have time to test every single brand and model."

Just use whatever apps you need. If you aren't using an external monitor, ensure the "Prefer External GPU" box is selected for apps (in their Get Info window - read Apple doc).

This post was modified 2 days ago

purge-wrangler.shpurge-nvda.shset-eGPU.shautomate-eGPU EFI Installer
----
Troubleshooting eGPUs on macOS
Command Line Swiss Knife
eGPU Hardware Chart
Multiple Build Guides
----
Current: MacBook Pro RP560X + 480/R9 Fury/Vega 64 | GTX 780/1070
Previous: 2014 MacBook Pro 750M + 480/R9 Fury | GTX 780/980 Ti/1070


ReplyQuote
(@romer_tanaleon)
Eminent Member
Joined: 3 weeks ago
Posts: 22
May 25, 2019 8:39 pm  

@mac_editor I have to reinstall everything...I'm going to start with DaVinci Resolve!!!

Pending: Add my system information and expected eGPU configuration to my signature to give context to my posts


ReplyQuote
Page 36 / 36