[SCRIPT] PurgeWrangler: AMD + NVIDIA eGPUs for all Thunderbolt Macs
 
Notifications
Clear all

[Solved] [SCRIPT] PurgeWrangler: AMD + NVIDIA eGPUs for all Thunderbolt Macs  

 of  170
  RSS

Dominik Eber
(@dominik_eber)
New Member
Joined: 2 years ago
 

Hey, first I want to say awesome work! I hope I did not miss anything but I have a problem with the external display connected to my eGPU. I have the black screen showing only the mouse. The workarounds stated do not work for me because when I log out with the  eGPU plugged in I get a black internal screen , cannot log back in and have to do a hard shutdown. Any ideas on this?
My setup is a 5k iMac with TB2, donnet Breakaway Box 550 and GTX 1080ti.

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
mac_editor
(@mac_editor)
Famed Member Moderator
Joined: 3 years ago
 

Quick update:
I mentioned developing a UI eGPU application -> I have plans for it, but have decided to wait until 10.14 Beta to see what's changed and then move on. Plus have a lot of other projects that I'd like to deal with too. So delaying the app.

Will continue making improvements to scripts when possible once I'm in better health. I've yet to look at what's wrong with my AMD eGPU setup (looks like GPU failure) so might not have an AMD to test when 10.14 arrives (should not be a problem since you guys can test anyway ;p).

purge-wranglertbt-flashpurge-nvdaset-eGPU
Insights Into macOS Video Editing Performance

Master Threads:
2014 15-inch MacBook Pro 750M
2018 15-inch MacBook Pro

 
2019 13" MacBook Pro [8th,4C,U] + RX Vega 64 @ 32Gbps-TB3 (Mantiz Venus) + macOS 10.14.6 & Win10 [build link]  


ReplyQuote
Riss
 Riss
(@riss)
Eminent Member
Joined: 3 years ago
 

Thanks a milion! The script worked immediately on my mid 2012 Mac mini with Akitio Thunder 2 and Quadro P2000, will backup my mid 2014 MBP 15" w GT750m and test it there too.

This certainly deserves a donation 😉

mid 2014 MBP 15" GT750m | Mac mini 2012 | Akitio Thunder 2 & 3 | GTX 780 3GB (flashed) | GTX Black Titan 6GB (stock) | Quadro P2000 (stock)


ReplyQuote
Eightarmedpet
(@eightarmedpet)
Noble Member Moderator
Joined: 3 years ago
 
Posted by: mac_editor

Quick update:
I mentioned developing a UI eGPU application -> I have plans for it, but have decided to wait until 10.14 Beta to see what's changed and then move on. Plus have a lot of other projects that I'd like to deal with too. So delaying the app.

Will continue making improvements to scripts when possible once I'm in better health. I've yet to look at what's wrong with my AMD eGPU setup (looks like GPU failure) so might not have an AMD to test when 10.14 arrives (should not be a problem since you guys can test anyway ;p).

If you ever need help with the visuals I’m a UI designer.

2017 13" MacBook Pro Touch Bar
GTX1060 + AKiTiO Thunder3 + Win10
GTX1070 + Sonnet Breakaway Box + Win10
GTX1070 + Razer Core V1 + Win10
Vega 56 + Razer Core V1 + macOS + Win10
Vega 56 + Mantiz Venus + macOS + W10

---

LG 5K Ultrafine flickering issue fix

 
2017 13" MacBook Pro [7th,2C,U] + RX 5700 XT @ 32Gbps-TB3 (Mantiz Venus) + macOS 10.15.4 & Win10 2004 [build link]  


ReplyQuote
Zetthard
(@zetthard)
Active Member
Joined: 3 years ago
 

Success for mid-2014 15" MBP (Iris only) + TB2->TB3 adapter + TB2 cable + Sonnet 350 + RX580. MacOS 10.13.4 (17E202). No issues. I'm going to submit build guide soon, once I manage to set up Bootcamp build (no luck yet).

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
Harry M
(@yurk)
Active Member
Joined: 2 years ago
 

@jeroen-van-keulen The first 3 pages report success with TB1 and AMD GPUs. Let me rephrase my question:

Does the script support Nvidia eGPUs on TB1 a 13" 2012 Macbook?

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
Jeroenvankeulen
(@jeroen-van-keulen)
Trusted Member
Joined: 3 years ago
 
Posted by: Yurk

@jeroen-van-keulen The first 3 pages report success with TB1 and AMD GPUs. Let me rephrase my question:

Does the script support Nvidia eGPUs on TB1 a 13" 2012 Macbook?

Well... at this point I’m questioning if you read the threads name. Sorry to be so hard on you. It literally says: 

[SCRIPT] Enable AMD+NVIDIA eGPUs on TB1/2/3 Macs on macOS 10.13.4+  

In the first post it says:

For NVIDIA eGPUs, you must also install NVIDIA Web Drivers and NVIDIAEGPUSupport.

So the answer to your question was literally in the first post!

To get good detailed output on a question, one must provide good input.

you have a:

2012 13” Macbook... what? Air or Pro
a eGPU box? What kind?
a Nvidia GPU what kind?

people here are willing to help those in need, they really are! But you don’t get to be lazy! Make an effort!

ALLn1
MBP11,4, i7-4980HQ, 256gb SSD, 16gbRAM Cathalina (Sonnet Breakaway box 350 + Gigabyte Radeon RX 580 Gaming 8GB)
MacBook7,1 A1342, P8600 120gb SSD 4gbRAM. Mojave (Hiking/Camping)
iMac7,1 A1224, T9500 CPU upgrade 120gb SSD 4gbRAM. HS
Mac mini3,1 P7350, 250gb SSD 8gbRAM. HS (server) iPhone10,3 64gb. iOS12 iPad5,3, 16gb. iOS12 iPod shuffle 2nd gen. 2gb
✧✧

 
2015 15" MacBook Pro [4th,4C,H] + RX 580 @ 16Gbps-TB2>TB3 (Sonnet Breakaway 350) + macOS 10.14 [build link]  


ReplyQuote
Harry M
(@yurk)
Active Member
Joined: 2 years ago
 

@jeroen-van-keulen I really don't know why you have to attack people or call them lazy. Please change your tone. It is quite rude/obnoxious. This forum is awesome, and extremely helpful, please do not ruin it by being nasty to people.

I read the whole thread. I really did. I saw no success stories with Nvidia on TB1 (except @rmvz3 who has a different mac). I also read a post of someone not being able to make Nvidia work with a 2012 Macbook Pro on MacOS 10.13.4, and a response that it does not work yet. This prompted my question. So, let me rephrase, once again:

"Are there any success stories with Nvidia eGPUs on the Mid 2012 13" MacBookPro?"

My configuration is: Mid 2012 13" MacBookPro  + Gigabyte Aorus 1080 (via TB3 -> TB2/TB1 Adaptor) macOS 10.13.4

 

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
rmvz3
(@rmvz3)
Trusted Member
Joined: 3 years ago
 

I read the whole thread. I really did. I saw no success stories with Nvidia on TB1 (except @rmvz3 who has a different mac).

I ended up removing it because, although my card was recognized and working properly, the hardware acceleration didn't work. Also, eventually, when rebooting the computer, it could not boot macOS and remained on a black screen. I think the TB1 + Nvidia dGPU + Nvidia eGPU models just don't work well with this method.

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
Jeroenvankeulen
(@jeroen-van-keulen)
Trusted Member
Joined: 3 years ago
 
Posted by: rmvz3

I read the whole thread. I really did. I saw no success stories with Nvidia on TB1 (except @rmvz3 who has a different mac).

I ended up removing it because, although my card was recognized and working properly, the hardware acceleration didn't work. Also, eventually, when rebooting the computer, it could not boot macOS and remained on a black screen. I think the TB1 + Nvidia dGPU + Nvidia eGPU models just don't work well with this method.

@rmvz3,

Yurk has a 13". So no dGPU, that will help a fair bit in its stability.

ALLn1
MBP11,4, i7-4980HQ, 256gb SSD, 16gbRAM Cathalina (Sonnet Breakaway box 350 + Gigabyte Radeon RX 580 Gaming 8GB)
MacBook7,1 A1342, P8600 120gb SSD 4gbRAM. Mojave (Hiking/Camping)
iMac7,1 A1224, T9500 CPU upgrade 120gb SSD 4gbRAM. HS
Mac mini3,1 P7350, 250gb SSD 8gbRAM. HS (server) iPhone10,3 64gb. iOS12 iPad5,3, 16gb. iOS12 iPod shuffle 2nd gen. 2gb
✧✧

 
2015 15" MacBook Pro [4th,4C,H] + RX 580 @ 16Gbps-TB2>TB3 (Sonnet Breakaway 350) + macOS 10.14 [build link]  


ReplyQuote
 of  170