[SCRIPT] fr34k's macOS-eGPU.sh - one script, all solutions, fully automated  

Page 14 / 14 Prev
 

benwabenwa
(@benwabenwa)
New Member
Joined:7 months  ago
Posts: 2
June 11, 2018 7:00 pm  

The script worked really fine for me :

Mac pro 2013 + Atikio Node + GTX 1070


ReplyQuote
mrghanim
(@mrghanim)
Active Member
Joined:1 week  ago
Posts: 5
June 12, 2018 1:15 am  

Hi there,

I tried all the steps for both MacBook Pro 2018 and iMac with no luck.. is there a clip I can look at to make it easier ?


ReplyQuote
keefar
(@keefar)
New Member
Joined:2 months  ago
Posts: 2
June 12, 2018 3:15 pm  

The script worked fine on 10.13.5:
MacBook Pro 13" Touchbar 2017
GTX 960 in Sonnet Breakaway 350

eGPU is discovered during boot and during login screen. Disconnect or eject is not possible without kp.

Thanks a lot!

Edited: 6 days  ago

ReplyQuote
(@mikey_schreurs)
Active Member
Joined:5 months  ago
Posts: 12
June 12, 2018 5:02 pm  

I had to do a restart in 10.13.5 and now my eGPU setup is broken. I've tried installing again to no avail. Won't recognize. If I reboot with eGPU connect I wont even get the startup sound. 

Ideas? I feel like I've tried everything in the Known issues.

Mac Pro Late 2013, Sonnet Breakaway 350 with GTX 1070Ti. Currently on 387.10.10.10.35.106 Web Driver.

@benwabenwa Have you ran into any issues yet with your setup?

Edited: 1 week  ago

ReplyQuote
Rycco
(@rycco)
Reputable Member
Joined:1 year  ago
Posts: 229
June 12, 2018 5:46 pm  

The script worked fine on 10.14:
MacBook Pro 15" Touchbar 2017
GTX 1080 ti in Mantiz Venus

eGPU is discovered during boot and during login screen. Disconnect or eject is not possible without kp.

Thanks a lot!

mid-2017 15" Macbook Pro RP555 + GTX1080i@32Gbps-TB3 (Mantiz Venus) + macOS & Win10


ReplyQuote
Eightarmedpet
(@eightarmedpet)
Honorable Member
Joined:1 year  ago
Posts: 697
June 12, 2018 7:29 pm  

Got bored of waiting for AMD to play easier in Bootcamp and/or FCP to utilise external GPUs so reran this script and switching workflow to DaVinci...

MASSIVE thanks to everyone for their hard work. Ran perfectly, had disconnect "null" if I plugged in after boot (even after logging out) but booting with it plugged in no wozza...

Screen Shot 2018 06 12 at 20.26.21
Screen Shot 2018 06 12 at 20.22.09
Screen Shot 2018 06 12 at 20.30.46

Edit: It crashes the whole system on disconnect, which is technically quite bad and not sure what bad things its doing, but then I'm not too fussed about hot plugging so hopefully shutting down works fine.

Edited: 7 days  ago

2017 13" MacBook Pro Touchbar + GTX1060@32Gbps-TB3 (AKiTiO Thunder3) + Win10
2017 13" MacBook Pro Touch Bar + GTX1070@32Gbps-TB3 (Sonnet Breakaway Box) + Win10
---
LG 5K Ultrafine flickering issue fix


ReplyQuote
merlinz
(@merlinz)
New Member
Joined:3 months  ago
Posts: 4
June 13, 2018 11:20 am  

Quick update,
I've mentioned the other day, new script has been installed successfully and overall it worked well beside Adobe Premier and Vray render for Sketchup.

Today,
I've installed the old verison of CUDA driver - inspired by some other posting though, and just re-update as CUDA Preference suggested.

Tada! all works properly - haven't checked the CUDA version when I installed the new script.

Anyhow it works as expected. Thanks again both of you.

cuda_a cuda_b
cuda_c

iMac Retina 5K 2017 64GB + Sonnet Breakaway Box 550 + GTX 1080Ti


ReplyQuote
Silverblade555
(@silverblade555)
New Member
Joined:7 months  ago
Posts: 2
June 14, 2018 9:23 am  

First off I want to thank fr34k, mac_editor and all the geniuses that give their valuable time for this excellent work that benefits people like me who is desperate for a nvidia Cuda solution for Mac yet lack of scripting skill. Meddling with terminal is terrifying but fr34k script made it almost idiot proof.

Here's my result after installing the script.
My system:
iMac 5k, 27", 2017
4.2 Ghz Intel Core i7
Thunderbolt 3
memory 40gb 2400 MHz DDR4
Radeon Pro 580 8gb
macOS 10.13.5 (17F77)
SIP: disabled

eGPU enclosure:
Razer Core X

eGPU:
Nvidia GTX 1080 Ti 11gb
PCIe lane width - x4

The initial installation failed a couple of times due to time out when downloading nvidia driver. My internet speed is considerably fast but the downloading was terribly slow. Final installation was successful after multiple retry as it gets better each time with the downloading speed.
The disconnect is in (null) state as expected and can only do hot plug in otherwise the screen will just go black when start up.
Cuda driver version: 396.64
GPU driver version: 387.10.10.10.35.106 after updated from 387.10.10.10.35.107

This setup is mainly for 3D rendering. Thus far, only blender cycle can pick up the Cuda cores and rendered 3x faster than my CPU.
As for Octane render, it can only identify nvidia card but not Cuda cores. Octane render window show only black screen and nothing gets rendered. The GPU activity window indicated there wasn't any activity as well. I'm not sure if is due to the unidentified Cuda cores. Can anyone who had successfully run octane render with this script share some lights how you did it?
Many thanks in advance.


ReplyQuote
23d1
 23d1
(@23d1)
Active Member
Joined:8 months  ago
Posts: 14
June 14, 2018 4:32 pm  

Works great on Mac Pro (Late 2013) with Sonnet eGFX Breakaway Box 550w and Nvidia 1080 Ti under macOS 10.13.5. Going to give it a go on an iMac Pro with dual eGPUs when I get a chance.


ReplyQuote
(@tinus_64)
New Member
Joined:5 days  ago
Posts: 1
June 14, 2018 8:14 pm  
  • Hey guys, I don’t have a good english because I’am french so I will try to explain to you my problem. 
  • I bought a egpu with a Nvidia gtx 1060 and I install purge-wrangler, the webdrivers and the drivers nvidia cuda. The nvidia cuda detec a egpu but when go in the system report from my mac who is a MacBook Pro retina 13’ 2015 with MacOS higt Sierra 10.13.5 in the category « graphic cars » there is just write the Intel graphic card whereas in the category « thunderbolt » it is written that egpu is conect. So i don’t unserstand why the mac give me no choice to use the egpu and ok course i have a external display connected to the egpu with HDMI cable. And when i want to reboot my mac with the egpu connected the screen goes black and nothing happens. 
  • Do you have a solution ? 

ReplyQuote
(@hans_k)
New Member
Joined:5 days  ago
Posts: 1
June 14, 2018 10:46 pm  

The Script worked fine with my MBP2017 I7 512gb and a Mantiz Venus ( Xotac 780ti AMP)

For gaming I use SwitchResX to turn off the internal LCD of the MBP

 

But here are two Bugs I encountered now:

1. Boot is stuck when you put your MBP with the EGPU to sleep.

Solution: Reinstall

2. It crashed suddenly (no response) now it Boots but as soon as I plug the EGPU in it freezes and panics.

im going to reinstall the script. don't know if it helps 


ReplyQuote
mooovy
(@mooovy)
New Member
Joined:4 days  ago
Posts: 1
June 15, 2018 8:59 pm  

This is working perfectly on a iMac Pro with Mac OS 10.13.5. (I had some issues with 10.13.3)
Sonnet 550 - GTX 1080 ti
Thanks a lot !


ReplyQuote
ghostronaut
(@ghostronaut)
Eminent Member
Joined:6 months  ago
Posts: 22
June 16, 2018 8:21 am  

@fr34k

Still running into this problem, which makes it unusable for me atm. I've updated everything and also tried the boot - log out - plugin - login cycle with no luck:

When I boot into macOS with the eGPU (Aorus Gaming Box 1080) already attached, everything works for a couple of seconds, then my internal screen goes black and the performance on the external is super laggy. When I manage to log out (which takes a while because I have to do it on the laggy screen) and log back in, performance is good again for a couple of seconds, then back to the lag.

Any tips on what I could try? Hot plugging doesn't work at all, results on plug-in in black screens on both internal and external, on plug-out on system crash.

EDIT

Finally got it working again. I've tried it before but only just now it worked (via Github fixes).

1 Boot without eGPU
2 Hot plug eGPU without monitor
3 Wait 15"
4 log out
5 hot plug monitor
6 Wait 15"
7 log in
8 boom.

Thanks for all the help!

Edited: 3 days  ago

ReplyQuote
EnigmaticChaos
(@enigmaticchaos)
New Member
Joined:3 days  ago
Posts: 1
June 16, 2018 3:47 pm  

I'm on a 2017 15' macbook pro, with a GTX 1080 ti in a mantiz venus. I'm on 10.13.5, and the setup works wonderful in bootcamp. But I can't get my external monitor working on my mac. It freezes when I open chrome, and then constantly flickers.


ReplyQuote
mintroini
(@mintroini)
Active Member
Joined:4 weeks  ago
Posts: 6
June 17, 2018 11:17 pm  

I've done this step by step, and I do see the GPU showing up on the bar and also I am having HDMI output from the card. I am using a GTX760.
The issue I'm having, is I am unable to run any games, it says "Failed to create an OpenGL context. Your graphics card must support at least OpenGL v3.1.". I think my graphics do take OpenGL but not quite sure if I am right.

Also I am unable to turn off the macbook's internal display, is that right?
I am using a rMBP 2012 Intel + gt650m


ReplyQuote
dvogiatzis
(@dvogiatzis)
Active Member
Joined:8 months  ago
Posts: 19
June 19, 2018 1:34 pm  

I was using Mac OS 10.13.3 until yesterday but today I decided to give a go on 10.13.5 and upgrade my system.

My specs:
Macbook Pro 15"mid 2017 with Radeon Pro 560.
Aorus Gaming Box 1070 connected via mDP with a DELL U3417W

I tried the first script [SCRIPT] Enable AMD+NVIDIA eGPUs on TB1/2/3 Macs on macOS 10.13.4+ without luck. I was plugging the eGPU but nothing was happening... After few hours of troubleshooting without result I tried this script on this thread and it worked right away.

Now I had the problem with the black screen and the mouse cursor. After few hours of reading posts here and there I tried 2 things that solved this:

  • Boot with the eGPU connected
  • While in Mac OS plug the eGPU and when you get the black screen use CMD+SHIFT+Q to log out and after few seconds the login screen will appear.

Thanks for all the good work with this script. I'm using my rig for rendering and video editing. I should write up when I find some time.

I see it's not sticky anymore... I wonder why? It used to be at least a while ago...


ReplyQuote
Page 14 / 14 Prev