[SCRIPT] fr34k's macOS-eGPU.sh - one script, all solutions, fully automated
 
Notifications
Clear all

[SCRIPT] fr34k's macOS-eGPU.sh - one script, all solutions, fully automated  

 of  76
  RSS

Architek1
(@architek1)
New Member
Joined: 2 years ago
 

Day 4 with no laptop working after upgrading from 10.13.4 to 10.13.6. Never loads the OS as the progress bar stops halfway through. No safe mode only recovery and single user. In recovery mode I have tried the bash <(curl...) script and nothing happens. I tried without bash, being that it’s a bash shell anyways. Error: /dev/fd/63 permission denied. Would someone with more experience be able to help?

MacBook Pro 10.13.6 > Akitio Node > 980Ti

MacBook Pro 2012> Akitio Node> 980Ti > Cinema HD


ReplyQuote
Mymantiz_John
(@mymantiz_john)
Vendor
Joined: 3 years ago
 

Assist customer :
2017 MBP15“ with 10.13.6
Mantiz Venus + 1080TI
Successfully working
Great job, Thanks Fr34K

Mantiz: ● ●


fr34k liked
ReplyQuote
precision01
(@precision01)
Trusted Member
Joined: 3 years ago
 
Posted by: Dennis Kievits (Elertan)

@precision01

I'm facing the exact same issue, can you try logging in as guest user, to see if Chromium based apps are causing the issues? It seems to be the fact that Chromium apps try to use the dGPU acceleration which makes the GPU shit itself  Cry

Hi, Dennis. I also have the same issues if I login as guest user. And I never used Chromium browser.

Razer Core X + AMD Radeon RX 5700 XT - Macbook Pro 15" Mid 2019 Radeon 560X


ReplyQuote
precision01
(@precision01)
Trusted Member
Joined: 3 years ago
 
Posted by: elpmis

Does anyone know how to power LG Ultrafine 5K with eGPU?

It seems that you can't. You would need a eGPU chassis like the one from BackMagicDesign, that was recently released and endorsed by apple.

Razer Core X + AMD Radeon RX 5700 XT - Macbook Pro 15" Mid 2019 Radeon 560X


ReplyQuote
precision01
(@precision01)
Trusted Member
Joined: 3 years ago
 
Posted by: DeNachtwacht

I installed this today on my New 2018 13,3" MacBook Pro with a Aorus Gaming Box 1080 and I am surprised to be able to tell you that it works flawless, I can even enable G-Sync without problems. I also installed Boot Camp because I expected problems with macOS but in Windows 10 I get all kinds of problems (USB doesn't work, can't set resolutions correctly et cetera). So keep up the good work, and maybe... also build a script for windows? 😉

Interesting. Could you please explain what do you do to make it work? Do you hotplug the eGPU after macOS finishes the boot process?

Razer Core X + AMD Radeon RX 5700 XT - Macbook Pro 15" Mid 2019 Radeon 560X


ReplyQuote
Technomad
(@technomad)
Eminent Member
Joined: 2 years ago
 
Posted by: precision01
Posted by: DeNachtwacht

I installed this today on my New 2018 13,3" MacBook Pro with a Aorus Gaming Box 1080 and I am surprised to be able to tell you that it works flawless, I can even enable G-Sync without problems. I also installed Boot Camp because I expected problems with macOS but in Windows 10 I get all kinds of problems (USB doesn't work, can't set resolutions correctly et cetera). So keep up the good work, and maybe... also build a script for windows? 😉

Interesting. Could you please explain what do you do to make it work? Do you hotplug the eGPU after macOS finishes the boot process?

FWIW, I’m hotplugging after OS X completes it’s boot process - not immediately after logging in. I then log out and in again, and am now getting superb performance and no UI lag - CUDA, OpenGL, OpenCL and Metal are all performing well, with Lightroom dramatically faster than it’s ever been before. The only outstanding problem I’m having is getting a clean shutdown.

Mid-2017 MBP 15”/3.1GHz, Razer Core v2, EVGA GTX1080Ti, LG 34UM95, HTC Vive, Samsung Odyssey, MS Hololens.


ReplyQuote
Keith Walls
(@keith_walls)
Eminent Member
Joined: 3 years ago
 

For the record, still no dice with an iMac Pro running 10.13.6. with an nVidia eGPU. As soon as the system detects the eGPU, the external monitor has a standard Apple blue background, and the internal display has the Apple Boot Logo (in green) with a half-full progress bar underneath. The cursor works on both screens, but nothing else. Forced logouts in this state fail. I'm using the latest script as of today.

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
fr34k
(@fr34k)
Reputable Member Moderator
Joined: 3 years ago
 
Posted by: Technomad

Just tried the new version and it’s working perfectly - everything accelerated, and no lag. Works fine with the log in, hot plug, log out & in again protocol.  What I can’t work out though is how to sleep or shut down without a last-minute KP. Any suggestions?

Try reboot, and once the system has shut down and your eGPU looses power unplug.

fr34k's macOS-eGPU.sh on GitHub or on eGPU.io

2016 15'' MacBook Pro + GTX1080Ti@32Gbps-TB3 (Sonnet Breakaway 550) + macOS 10.13.6 (17G65 driver: 378.10.10.10.30.107 + CUDA: 396.148)


ReplyQuote
fr34k
(@fr34k)
Reputable Member Moderator
Joined: 3 years ago
 
Posted by: iaomw

Hi, I didn't see the little menu to disconnect eGPU, What should I do to enable it?

You can't and you needn't.

fr34k's macOS-eGPU.sh on GitHub or on eGPU.io

2016 15'' MacBook Pro + GTX1080Ti@32Gbps-TB3 (Sonnet Breakaway 550) + macOS 10.13.6 (17G65 driver: 378.10.10.10.30.107 + CUDA: 396.148)


ReplyQuote
fr34k
(@fr34k)
Reputable Member Moderator
Joined: 3 years ago
 
Posted by: kingabidal X

Hey dude, I've been trying to get this to work for the past week with no luck. When I boot up with my eGPU plugged in after running the default script I get a black screen. I tried connecting my eGPU to an external monitor but nothing shows. Please help me, I am willing to DONATE to anyone who can get it to work for me. I beg anybody for help!!!!!!!!!

Donations as well as cries for help won't work.
YOU MUST PROVIDE AS MUCH INFORMATION AS POSSIBLE! The more information one provides the better one can reproduce and help. One start would be the output of my script using the --checkSystem flag...

fr34k's macOS-eGPU.sh on GitHub or on eGPU.io

2016 15'' MacBook Pro + GTX1080Ti@32Gbps-TB3 (Sonnet Breakaway 550) + macOS 10.13.6 (17G65 driver: 378.10.10.10.30.107 + CUDA: 396.148)


Antani72 and itsage liked
ReplyQuote
 of  76