Stability issues- frequent freezing with 2014 5K imac, Akitio Node thunderbolt 3, GTX1080i, Dell P2715Q  

  RSS

Panoptical
(@panoptical)
Active Member
Joined: 2 years ago
Posts: 17
August 28, 2017 5:51 pm  

Hi- I have the same set up as DANgerous25 using Rastafabi's eGPU enabler, and been rolling along for the last 3 months, all is working normally, the start up and great rendering times, however things have recently started getting weird, with frequent freezing. I am running 10.12.6. and have updated Nvidia to latest drivers. Have uninstalled and reinstalled. My screens freeze even if i am doing mundane things such as looking at images in folders with the Finder preview, or writing emails. My primary use for the eGPU is rendering, but i often dont even have modeling software open when it crashes. I have stuck with using only the Dell (primary screen) as i suspected having mail open on the imac screen and photoshop on the Dell was causing the problem, but now, its freezing even while only using Finder!

 Any suggestions on how to problem solve this? Would very much appreciate it. 

Best R

 

 

 

2016 macbook pro touch bar & 2014 imac 5k | GTX1080Ti in AKiTiO Node | Dell P2415Q display


ReplyQuote
danfalconar
(@danfalconar)
Estimable Member
Joined: 2 years ago
Posts: 159
August 30, 2017 10:53 am  

Hey, I don't know if something happened recently, but I've started having issues as well. I wouldn't say crashing, but graphical glitches. As I write this now, there are some "blocks" hanging around on the bottom of the screen, which flicker if I move windows among them. Sometimes the glitches worsen and take up the entire screen, effectively rendering the screen completely useless - restarting brings back to a useable state but I still have small blocks.

Was there any kind of recent automatic software update that caused this? I didn't install anything consciously, and it has been working flawlessly for months!

Edit: If I switch from eGPU to the internal AMD card the glitches disappear, so it's not my iMac screen itself. Also it doesn't appear on my Dell monitor, only on the iMac screen.

late-2017 27" iMac Pro RPVega64 + [email protected] (AKiTiO Node) + MacOS 10.13.2
late-2014 27" iMac 5k R9 M295X + [email protected] (AKiTiO Node via TB3->TB2 adapter) + macOS10.13 & Win10


ReplyQuote
ikir
 ikir
(@ikir)
Prominent Member
Joined: 2 years ago
Posts: 756
August 30, 2017 2:51 pm  

If you search the forums is quite common, I had these issue ofter during the day and especially using Final Cut X but also surfing with safari. I've noticed that if you are able to close the app which is causing the corruption, everything continue to work again.

Anyway I switched to AMD for this reason. You can try to contact Nvidia or at least write on support forum even if I think they don't care at all.

Never had a single freeze with RX 480 and 580. I will personally not using Nvidia product anymore.

eGPU.it | LG 34" 4K 34UC88 curved ultrawide display
MacBook Pro 2018 Touch Bar i7 quad-core 2.7Ghz - 16GB RAM - 512GB PCIe SSD --> my Mantiz Venus extreme mod with Sapphire Nitro+ RX Vega 64


ReplyQuote
theitsage
(@itsage)
Famed Member Admin
Joined: 2 years ago
Posts: 3201
August 30, 2017 2:55 pm  

Nvidia web drivers are unstable and can cause freezing issues. I have installed a GTX 1070 eGPU on my nMP recently to test. I have not used it since but there are Nvidia drivers installed. The nMP would randomly lock up even though there was no Nvidia GPU attached.

Best ultrabooks for eGPU use

eGPU enclosure buying guide

86 external GPU build guides


ReplyQuote
Panoptical
(@panoptical)
Active Member
Joined: 2 years ago
Posts: 17
August 30, 2017 3:54 pm  

DANgerous25, and then there's that. The blocks are how it started, and it still does it, but not as often as the freezing, which is several times a day. When frozen, I can move the cursor, but no response to any key commands. I can access the imac via local network and pull whatever i was working on to my laptop. I have to do a restart. Its a giant drag... as i was very happy with this set up!

 

2016 macbook pro touch bar & 2014 imac 5k | GTX1080Ti in AKiTiO Node | Dell P2415Q display


ReplyQuote
Panoptical
(@panoptical)
Active Member
Joined: 2 years ago
Posts: 17
August 31, 2017 4:48 pm  

@DANgerous25- Let me know if you find any way out of these problems. my tech friends are telling me wait for High Sierra and with built in egpu support things may work better before dumping the set up. Sadly my render engine is optimized for Nvidia so its not as simple as changing the card. Do you think 3rd party apps could be a contributing factor?

best R 

2016 macbook pro touch bar & 2014 imac 5k | GTX1080Ti in AKiTiO Node | Dell P2415Q display


ReplyQuote
danfalconar
(@danfalconar)
Estimable Member
Joined: 2 years ago
Posts: 159
September 2, 2017 1:18 am  

Hi guys, this is all a bit weird. I don't use my machine for anything particularly taxing (just mainly browsing/tinkering/netflix/etc.), nor have I changed the apps I'm using day to day. I haven't consciously installed any updates, but this has only started happening perhaps in the last couple of weeks.

Something must have changed...

late-2017 27" iMac Pro RPVega64 + [email protected] (AKiTiO Node) + MacOS 10.13.2
late-2014 27" iMac 5k R9 M295X + [email protected] (AKiTiO Node via TB3->TB2 adapter) + macOS10.13 & Win10


ReplyQuote
danfalconar
(@danfalconar)
Estimable Member
Joined: 2 years ago
Posts: 159
September 2, 2017 1:12 pm  

@Pantoptical, check out this thread. I managed to solve the glitch issues, and indeed get one step closer to an almost native feeling setup.

late-2017 27" iMac Pro RPVega64 + [email protected] (AKiTiO Node) + MacOS 10.13.2
late-2014 27" iMac 5k R9 M295X + [email protected] (AKiTiO Node via TB3->TB2 adapter) + macOS10.13 & Win10


ReplyQuote