State of eGPU for Macs – Catalina 10.15 Update
 
Notifications
Clear all

State of eGPU for Macs – Catalina 10.15 Update  

 of  18
  RSS

Yang LI
(@yang_li_1)
Eminent Member
Joined: 2 years ago
 
Posted by: @rnb2

@loic_bonvarlet

I would stay on 10.15.1 for now - I haven't seen anybody else corroborate my issue yet, but after updating to 15.2, I can no longer boot with my eGPU attached. I have to boot with HDMI connected, then plug the eGPU in at the login screen. This also means that booting into Windows is no longer straightforward, as I can't get a boot menu with the eGPU connected, either. It appears that I'll have to shut down completely, unplug the eGPU, plug in HDMI, then turn the mini on and select my boot device, then connect the eGPU.

Interesting, I’ve upgraded to 15.2 too. Power on with egpu plug in, Bootcamp(295) works fine as usual, but MacOS occasionally will stuck on login screen need power off and restart, say 20% opp. 

hot plug then both OS working well.

MBP 15 2019
Asus XG Station Pro
PowerColor Red Devil 5700XT


ReplyQuote
Loic Bonvarlet
(@loic_bonvarlet)
New Member
Joined: 1 year ago
 

Thanks for all the comments. Seems like a new version will be needed to stabilize all this...

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
craftsman
(@craftsman)
Estimable Member
Joined: 2 years ago
 
Posted by: @yang_li_1
Posted by: @rnb2

@loic_bonvarlet

I would stay on 10.15.1 for now - I haven't seen anybody else corroborate my issue yet, but after updating to 15.2, I can no longer boot with my eGPU attached. I have to boot with HDMI connected, then plug the eGPU in at the login screen. This also means that booting into Windows is no longer straightforward, as I can't get a boot menu with the eGPU connected, either. It appears that I'll have to shut down completely, unplug the eGPU, plug in HDMI, then turn the mini on and select my boot device, then connect the eGPU.

Interesting, I’ve upgraded to 15.2 too. Power on with egpu plug in, Bootcamp(295) works fine as usual, but MacOS occasionally will stuck on login screen need power off and restart, say 20% opp. 

hot plug then both OS working well.

I had this after the 10.15.2 update too. macOS got stuck during booting when the MacBook Pro is connected to the eGPU. Have to disconnect everything, boot up, reconnect eGPU.

2019 16" MacBook Pro (RP5500M) [9th,8C,H] + RX 5700 XT @ 32Gbps-TB3 (Razer Core X Chroma) + macOS 10.15.1 [build link]  

ReplyQuote
Ben D
 Ben D
(@Ben D)
Joined: 1 year ago
 

Hi

I just updated to macOS Catalina 10.15.2 official update.
Initially, the eGPU icon in the menubar disappeared.

But after uninstalling purge-wrangler and re-installing purge-wrangler,
everything was back to normal (same as 10.15.1)

Hope this helps everyone.

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
dre
 dre
(@dre)
Eminent Member
Joined: 3 years ago
 

I'm having an issue with all my machines where the egpu is NOT rendering, the internal GPU is. This is on a MacMini, 13" & 16" MBP, all running catalina......Exporting h.264 files. It's great having a checkbox/settings to use the eGpu to render inside FCPX but NOT if it's literally a dumb checkbox!!

 

Anyone got any workarounds? This is so reminiscent of why I joined this site 2 years ago..... 

Vega 64 / Razer CORE X TB3 enclosure
2016 MacBook Pro 13’
2018 intel Hades Canyon NUC
2018 Mac Mini
2019 Macbook Pro 16'


ReplyQuote
craftsman
(@craftsman)
Estimable Member
Joined: 2 years ago
 
Posted by: @dre

I'm having an issue with all my machines where the egpu is NOT rendering, the internal GPU is. This is on a MacMini, 13" & 16" MBP, all running catalina......Exporting h.264 files. It's great having a checkbox/settings to use the eGpu to render inside FCPX but NOT if it's literally a dumb checkbox!!

 

Anyone got any workarounds? This is so reminiscent of why I joined this site 2 years ago..... 

h.264 is handled by the encoder on the Intel chip because it more energy efficient and in some cases faster than the encoder on the graphics card. This also happens on Windows depending on the codec you are exporting too and which apps you are using.

2019 16" MacBook Pro (RP5500M) [9th,8C,H] + RX 5700 XT @ 32Gbps-TB3 (Razer Core X Chroma) + macOS 10.15.1 [build link]  

ikir liked
ReplyQuote
dre
 dre
(@dre)
Eminent Member
Joined: 3 years ago
 
Posted by: @craftsman
Posted by: @dre

I'm having an issue with all my machines where the egpu is NOT rendering, the internal GPU is. This is on a MacMini, 13" & 16" MBP, all running catalina......Exporting h.264 files. It's great having a checkbox/settings to use the eGpu to render inside FCPX but NOT if it's literally a dumb checkbox!!

 

Anyone got any workarounds? This is so reminiscent of why I joined this site 2 years ago..... 

h.264 is handled by the encoder on the Intel chip because it more energy efficient and in some cases faster than the encoder on the graphics card. This also happens on Windows depending on the codec you are exporting too and which apps you are using.

It used to be handled by the egpu. Nothing is handled on rendering on the eGpu now. On the 16" the AMD handles rendering, on the macMini, it's the woeful internal graphics (was great before). I'm surprised there's nothing on here?? There's a thread on the apple site.... https://discussions.apple.com/thread/250714680?answerId=251776941022

Vega 64 / Razer CORE X TB3 enclosure
2016 MacBook Pro 13’
2018 intel Hades Canyon NUC
2018 Mac Mini
2019 Macbook Pro 16'


ReplyQuote
aestivalis
(@aestivalis)
Active Member
Joined: 2 years ago
 

I accidentally updated 10.15.2, haven't encountered any problem so far.

ProRender still works with both dGPU and eGPU.

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
The Professor
 The Professor
(@The Professor)
Joined: 1 year ago
 

Still doing AMAZING things with my GTX 1070 EGPU/Thunderbolt 2/powered riser setup through Bootcamp on a 2015 4k retina Imac. Playing the newest games on ultra and testing at 60+ FPS on Unigine's Heaven benchmark.

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
steve4332
(@steve4332)
Eminent Member
Joined: 2 years ago
 

Catalina eGPU is a complete trainwreck for me (Mini 2018 + RX 570). I can still not boot with eGPU attached. And now (after updating to 10.15.2) the TV app stopped working - trailers work fine but protected materials stop playing after about a second.

Apple Mac Mini 2018 + Zotac AMP Box Mini + Sapphire RX 570 ITX

 
2018 Mac Mini [8th,6C,B] + RX 570 @ 32Gbps-TB3 (Zotac AMP Box Mini) + macOS 10.14.5 [build link]  


ReplyQuote
 of  18