State of eGPU for Macs – Catalina 10.15 Update
 
Notifications
Clear all

State of eGPU for Macs – Catalina 10.15 Update  

 of  18
  RSS

Alexander Fox
(@alexander_fox)
New Member
Joined: 2 years ago
 

TL;DR Catalina breaks HDCP in videos (Apple TV App) on external displays

Hello folks, 

I took the risk and updated from Mojave to Catalina 10.15.3. Now, I noticed a very annoying bug. Whenever I try to play a movie or Apple+ (i.e. For All Mankind) the Apple TV app would either crash or the movie window would just disappear. I can still hear audio for a few seconds. I tried a few titles from my library and noticed that some movies, especially older, will play flawlessly, others will force the app to crash. I believe it has something to do with DRM and HDCP. It seems newer movies/streams use an updated digital rights protection. I can play Apples video just fine with the eGPU attached if the video window is on internal display.

Any ideas how to solve this bug?

Side note: with High Sierra, I also experienced occasional random video artifacts and sometimes even severe crashes (full freeze/reboots) when playing videos via iTunes. Problems went away by updating to Mojave. With Catalina the crashes are back.

 

EDIT: After further trial and error. I noticed that basically any movie with a 4K label won't play via eGPU external monitors. Older movies with a simple HD label will play.

 

Do you have similar problems and possible solutions?

My hardware: 

MacBook Pro 2018 15-inch
Gigabyte Gaming Box with a Radeon RX 580

This post was modified 1 year ago

MacBook Pro (15-inch, 2018) 2.2 GHz 6c i7 16GB • Gigabyte Gaming Box Radeon RX 580 8 GB


itsage liked
ReplyQuote
ikir
 ikir
(@ikir)
Prominent Member
Joined: 4 years ago
 
Posted by: @mohhamad_aliff

Anybody on the Catalina 10.15.4 beta? How was the experience and can you guys see the boot screen/startup disk picker while the display output is from the eGPU?

I really hope those boot screen issue are fixed Roll


MacBook Pro 13" 2020 Touch Bar M1 8-core CPU 8-core GPU - 16GB unified memory - 512GB PCIe SSD
MacBook Pro 13" 2020 Touch Bar i7 quad-core 2.3Ghz - 16GB RAM - 1TB PCIe SSD

my awesome Radeon VII eGPU
my Mantiz Venus extreme mod with Sapphire Nitro+ RX Vega 64

 
2018 13" MacBook Pro [8th,4C,U] + Radeon VII @ 32Gbps-TB3 (Mantiz Venus) + macOS 10.15 [build link]  


ReplyQuote
Juan C. Yunis
(@juan_c_yunis)
Reputable Member
Joined: 3 years ago
 

@ikir, sadly nope, i can boot with the eGPU connected but i select a disk to boot, i have a blank screen and i have to wait for purple artifacts to appear and then i get screen output with login.

 

2018 Mac Mini Core i7 8700B 32GB RAM 512GB SSD + Razer Core X + AMD Radeon VII


ReplyQuote
ikir
 ikir
(@ikir)
Prominent Member
Joined: 4 years ago
 

Argh. Are you filling bug reports guys?


MacBook Pro 13" 2020 Touch Bar M1 8-core CPU 8-core GPU - 16GB unified memory - 512GB PCIe SSD
MacBook Pro 13" 2020 Touch Bar i7 quad-core 2.3Ghz - 16GB RAM - 1TB PCIe SSD

my awesome Radeon VII eGPU
my Mantiz Venus extreme mod with Sapphire Nitro+ RX Vega 64

 
2018 13" MacBook Pro [8th,4C,U] + Radeon VII @ 32Gbps-TB3 (Mantiz Venus) + macOS 10.15 [build link]  


ReplyQuote
Jef Girdler
(@jef_girdler)
New Member
Joined: 2 years ago
 

So my 2015 MBP updated to 10.15.3 last night and now I've got an issue where the macbook does but doesn't recognize my RX580 gaming box - the computer boots and using Splashtop, I can see that when I log in to the desktop the system says that no removable GPU is detected, until I unplug my macbook from the dock and then it says "eGPU not disconnected properly". Purge-wrangler is also popping up every time I boot asking if I want to reapply the patches after an update, to which I always say yes and enter my password into terminal but then it tells me the fix has already been applied and I need to uninstall it first to update??? I can't seem to figure out how to do so. I'm hoping that'd fix things. 

Retina MBP Mid-2015, MacOS 10.15.3 (was working an hour before on 10.15.2)
Gigabyte AORUS Gaming box RX580, TB2-TB3 adapter

Mid-2015 Macbook Pro 15", 2.2 Ghz i7, 16GB
Gigabyte Gaming Box, RX580
TB2 - TB3 Adapter


ReplyQuote
winnertakesteve
(@winnertakesteve)
Active Member
Joined: 2 years ago
 

since 10.15.3, my 2018 macbook pro crashes every night when left connected to my razer core x/vega64. moreover, the login will hang after the crash unless i disconnect the egpu first. this is pretty frustrating, as i use the razer core x as my power connection for the laptop at home, and now i can't leave it charging overnight or it will crash. i've submitted every single crash report, but i have a feeling apple doesn't give egpu problems much priority 🙁

MacBook Pro 2018 560X dgpu + Razer Core x + Vega 64, macOS Mojave + windows 10


ReplyQuote
Lucas
(@lucas)
Active Member
Joined: 4 years ago
 

Any tutorials to enable a GTX 1070 on a 15" MBP 2016 with TB3?

MacBook Pro (15-inch, 2016), 2.7 GHz Quad-Core Intel Core i7, 16 GB 2133 MHz LPDDR3, Radeon Pro 455 2 GB, Intel HD Graphics 530 1536 MB, AKiTiO Node with GTX 1070


ReplyQuote
Federico Litenstein Goldzweig
(@federico_litenstein_goldzweig)
New Member
Joined: 11 months ago
 

Mac mini 2018 with AORUS GAMING BOX RX580X, Catalina 10.15.4, finally black screen of death has been fixed for me.

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

itsage liked
ReplyQuote
Vesuvias
(@vesuvias)
New Member
Joined: 10 months ago
 

Seems like 10.15.4 has caused that dreaded "no removable GPU" issue to start cropping up. It was all fine and good today, update ran, and now screen flicks on and then nothing on my attached monitor. Just goes back to the laptop screen, and the icon disappears. Running a Macbook Pro 5600XT (Sapphire Pulse). Tested to see it working on my Windows laptop. Something changed in macOS to cause this.

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
TheMadTurtle11
(@themadturtle11)
Active Member
Joined: 1 year ago
 

@federico_litenstein_goldzweig Really?  Is your eGPU plugged directly into the monitor?

2018 Mac mini + Sonnet 550 breakaway + Sapphire Pulse RX580


ReplyQuote
 of  18