State of eGPU for Macs – Catalina 10.15 Update
 
Notifications

State of eGPU for Macs – Catalina 10.15 Update  

 of  5
  RSS

(@mohhamad_aliff)
Active Member
Joined: 2 months ago
 

Anybody on the Catalina 10.15.4 beta? How was the experience and can you guys see the boot screen/startup disk picker while the display output is from the eGPU?

This post was modified 2 months ago

2018 i5 Mac mini 256GB, Razer Core X + Gigbyte RX 580


ReplyQuote
(@ted_dawson)
Active Member
Joined: 5 months ago
 

@mohhamad_aliff

I have not, I'm still on 15.1 and limping along. I'm waiting to hear if 15.3 is any better?

Pending: Add my system information and expected eGPU configuration to my signature to give context to my posts


ReplyQuote
mowglibook
(@mowglibook)
Eminent Member
Joined: 1 year ago
 

I've finally upgraded to Catalina. (A fresh install actually, not an upgrade) and I've been using  my MacBook Pro with the Gaming Box connected to it for 3 days straight doing development work, and migrating photo libraries in the background.

It's been really stable, no disconnection, glitches of anything, and the VRAM is used, it fills up to 99% from caching stuff (iTerm2, IntelliJ IDEA, Parallels Desktop, Apple Photos etc)

I have also go sleep & wake from sleep back, which wasn't working on the last version of Mojave I was running. That might just be the clean install though.

Mid 2018 13" MacBook Pro: 2.7 GHz i7, 16GB DDR3, 1TB SSD, Touch Bar, 4 TB3 Ports
eGPU: Gigabyte RX 580 Gaming Box - Thunderbolt F1.0_H2D - Holtek F1.1 - GV-RX580IXEB-8GD F2
eGPU Mods: PSU Fan: Sunon KDE1204PKV1 - Side Fans: Noctua NF-A4x10 FLX - BIOS Overlocked 1355MHz


ReplyQuote
bonifaczi
(@bonifaczi)
New Member
Joined: 2 years ago
 

@mowglibook What is your operating system Build?

 

MBP 13 2017 + Gigabyte (Aorus) Gaming Box RX580


ReplyQuote
mowglibook
(@mowglibook)
Eminent Member
Joined: 1 year ago
 

10.15.3 (19D76)

Mid 2018 13" MacBook Pro: 2.7 GHz i7, 16GB DDR3, 1TB SSD, Touch Bar, 4 TB3 Ports
eGPU: Gigabyte RX 580 Gaming Box - Thunderbolt F1.0_H2D - Holtek F1.1 - GV-RX580IXEB-8GD F2
eGPU Mods: PSU Fan: Sunon KDE1204PKV1 - Side Fans: Noctua NF-A4x10 FLX - BIOS Overlocked 1355MHz


ReplyQuote
(@jangoloti_1)
Trusted Member
Joined: 6 months ago
 
Posted by: @ikir
Posted by: @jangoloti_1
Posted by: @ikir

10.15.2 seems like a very bad update for eGPU. Let’s hope 10.15.3 come out soon, BTW beta is available

10.15.3 did not solve anything for me.

Everyone with this issue should contact Apple, use feedback page or beta report. I have many fiends with this problem on Mac mini 2018, it is a nightmare

Changing the cable solved the issue for me, be wary of third party Thunderbolt cables that promise 40 GB/s speeds.

Mac Mini 2018 i7 16 GB 512 GB SSD, Mac Book Pro 2016, HP Z31x, Sonnet Breakaway Box 550 W, Nitro+ RX5700 XT, KFA2 SNPR 1060 6GB eGPU,...


ReplyQuote
(@alexander_fox)
New Member
Joined: 1 year ago
 

TL;DR Catalina breaks HDCP in videos (Apple TV App) on external displays

Hello folks, 

I took the risk and updated from Mojave to Catalina 10.15.3. Now, I noticed a very annoying bug. Whenever I try to play a movie or Apple+ (i.e. For All Mankind) the Apple TV app would either crash or the movie window would just disappear. I can still hear audio for a few seconds. I tried a few titles from my library and noticed that some movies, especially older, will play flawlessly, others will force the app to crash. I believe it has something to do with DRM and HDCP. It seems newer movies/streams use an updated digital rights protection. I can play Apples video just fine with the eGPU attached if the video window is on internal display.

Any ideas how to solve this bug?

Side note: with High Sierra, I also experienced occasional random video artifacts and sometimes even severe crashes (full freeze/reboots) when playing videos via iTunes. Problems went away by updating to Mojave. With Catalina the crashes are back.

 

EDIT: After further trial and error. I noticed that basically any movie with a 4K label won't play via eGPU external monitors. Older movies with a simple HD label will play.

 

Do you have similar problems and possible solutions?

My hardware: 

MacBook Pro 2018 15-inch
Gigabyte Gaming Box with a Radeon RX 580

This post was modified 1 month ago

MacBook Pro (15-inch, 2018) 2.2 GHz 6c i7 16GB • Gigabyte Gaming Box Radeon RX 580 8 GB


itsage liked
ReplyQuote
ikir
 ikir
(@ikir)
Prominent Member
Joined: 3 years ago
 
Posted by: @mohhamad_aliff

Anybody on the Catalina 10.15.4 beta? How was the experience and can you guys see the boot screen/startup disk picker while the display output is from the eGPU?

I really hope those boot screen issue are fixed Roll


MacBook Pro 2018 Touch Bar i7 quad-core 2.7Ghz - 16GB RAM - 512GB PCIe SSD
my awesome Radeon VII eGPU
my Mantiz Venus extreme mod with Sapphire Nitro+ RX Vega 64


ReplyQuote
Juan C. Yunis
(@juan_c_yunis)
Reputable Member
Joined: 2 years ago
 

@ikir, sadly nope, i can boot with the eGPU connected but i select a disk to boot, i have a blank screen and i have to wait for purple artifacts to appear and then i get screen output with login.

 

2018 Mac Mini Core i7 8700B 32GB RAM 512GB SSD + Razer Core X + AMD Radeon VII


ReplyQuote
ikir
 ikir
(@ikir)
Prominent Member
Joined: 3 years ago
 

Argh. Are you filling bug reports guys?


MacBook Pro 2018 Touch Bar i7 quad-core 2.7Ghz - 16GB RAM - 512GB PCIe SSD
my awesome Radeon VII eGPU
my Mantiz Venus extreme mod with Sapphire Nitro+ RX Vega 64


ReplyQuote
(@jef_girdler)
New Member
Joined: 11 months ago
 

So my 2015 MBP updated to 10.15.3 last night and now I've got an issue where the macbook does but doesn't recognize my RX580 gaming box - the computer boots and using Splashtop, I can see that when I log in to the desktop the system says that no removable GPU is detected, until I unplug my macbook from the dock and then it says "eGPU not disconnected properly". Purge-wrangler is also popping up every time I boot asking if I want to reapply the patches after an update, to which I always say yes and enter my password into terminal but then it tells me the fix has already been applied and I need to uninstall it first to update??? I can't seem to figure out how to do so. I'm hoping that'd fix things. 

Retina MBP Mid-2015, MacOS 10.15.3 (was working an hour before on 10.15.2)
Gigabyte AORUS Gaming box RX580, TB2-TB3 adapter

Mid-2015 Macbook Pro 15", 2.2 Ghz i7, 16GB
Gigabyte Gaming Box, RX580
TB2 - TB3 Adapter


ReplyQuote
winnertakesteve
(@winnertakesteve)
New Member
Joined: 1 year ago
 

since 10.15.3, my 2018 macbook pro crashes every night when left connected to my razer core x/vega64. moreover, the login will hang after the crash unless i disconnect the egpu first. this is pretty frustrating, as i use the razer core x as my power connection for the laptop at home, and now i can't leave it charging overnight or it will crash. i've submitted every single crash report, but i have a feeling apple doesn't give egpu problems much priority 🙁

MacBook Pro 2018 560X dgpu + Razer Core x + Vega 64, macOS Mojave + windows 10


ReplyQuote
Lucas
(@lucas)
Active Member
Joined: 3 years ago
 

Any tutorials to enable a GTX 1070 on a 15" MBP 2016 with TB3?

MacBook Pro (15-inch, 2016), 2.7 GHz Quad-Core Intel Core i7, 16 GB 2133 MHz LPDDR3, Radeon Pro 455 2 GB, Intel HD Graphics 530 1536 MB, AKiTiO Node with GTX 1070


ReplyQuote
 of  5