Notifications
Clear all

Switch from Intel to Nvidia  

  RSS

tfindlay
(@tfindlay)
New Member
Joined: 3 years ago
 

Hi Folks,

To set the scene, I have a late 2016 13" MBP (personal) with an Akitio Node containing an Nvidia 1070, this works great.

 

However, I now have a 2017 13" MBP from my work. So I'm trying to work from home, but cant get it working.

I have the NVidia Web drivers installed.

Screen Shot 2018 02 05 at 11.29.04 am

I'm using OSX 10.13.3
A system report shows the GPU, my external screens are working,

Screen Shot 2018 02 05 at 11.28.04 am

but in "About This Mac" it still shows Intel Iris Plus Graphics.

Screen Shot 2018 02 05 at 11.24.04 am

I have checked the Nvidia driver manager thing and it has the Nvidia driver selected, and shows the GPU in the G-SYNC and ECC tabs.

I've tried all the freak'n scripts (webdriver.sh, automate-eGPU, gpu-switch) but nothing is helping.

The Intel driver/card is Sooooo slow! Please help.

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
itsage
(@itsage)
Illustrious Member Admin
Joined: 4 years ago
 

You have to set one of the external monitor as the primary screen before "About this Mac" would show NVIDIA GeForce GTX 1070 in Graphics.

external graphics card builds
best laptops for external GPU
eGPU enclosure buyer's guide

 
2021 15" ASUS TUF Dash F15 [11th,4C,H] + RTX 3080 @ 32Gbps-TB4 (AORUS Gaming Box) + Win10 2004 // my 3rd RTX 3080 build [build link]  


ReplyQuote
Arthy
(@arthy)
Eminent Member
Joined: 3 years ago
 

Just discovered this thread. I'm having the exact same problem in 10.13.4. So it's not an issue due to update.
@itsage is there anything I can do to force the eGPU switch to the internal display?

Edit: the eGPU appears in SitRep graphics alongside Intel, but only Intel appears in About or Display.

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote