Notifications
Clear all

tb3 script enabler issues...  

 of  3
  RSS

Eightarmedpet
(@eightarmedpet)
Noble Member
Joined: 3 years ago
 

So, just edited the kext... all went OK I think... start up feels slower and maybe a bit different, is that normal? anyone else experienced that? Repaired permissions etc...

Currently have Power and an Apple Cinema Display plugged in with adapters and they are working as per before so assume all is well (but you know what they say about assumptions).

 

Next up - which macOS set up process to follow? The script is the default choice for most but the GUI based installer appeals to me (as it has a GUI I feel safer and I read someone had no luck with the script but the GUI version worked fine). Thoughts anyone?

2017 13" MacBook Pro Touch Bar
GTX1060 + AKiTiO Thunder3 + Win10
GTX1070 + Sonnet Breakaway Box + Win10
GTX1070 + Razer Core V1 + Win10
Vega 56 + Razer Core V1 + macOS + Win10
Vega 56 + Mantiz Venus + macOS + W10

---

LG 5K Ultrafine flickering issue fix


ReplyQuote
Rapunzel
(@rapunzel)
Eminent Member
Joined: 3 years ago
 

Beta 5 recognizes my Akitio Thunder 3 after HEX patching. My Nvidia 1050 is recognized as VGA compatible controller (system report/hardware/PCI) with no installed driver. So I assume, that it would work with an appropriate driver. Does "Tunnel-kompatibel" indicate support for external enclosure?

Typ: VGA-kompatibler Controller
Treiber installiert: Nein
Tunnel-kompatibel: Nein
Kompatibles Gerät anhalten: Nein
MSI: Nein
Bus: PCI
Steckplatz: Thunderbolt@10,0,0
Hersteller-ID: 0x10de
Geräte-ID: 0x1c81
Subsystem-Hersteller-ID: 0x1462
Subsystem-ID: 0x8c97
Versions-ID: 0x00a1
Link-Breite: x4
Link-Geschwindigkeit: 8.0 GT/s

Pending: Add my system information and expected eGPU configuration to my signature to give context to my posts


ReplyQuote
Eightarmedpet
(@eightarmedpet)
Noble Member
Joined: 3 years ago
 

Had issues linking mine to a 4K TV, worked in Windows but not quite in macOS but I think that may be my TV rather than anything else, will check on a monitor asap.

 

Interesting and exciting to hear that thunder3's may work in HS after all? Pending driver support...

2017 13" MacBook Pro Touch Bar
GTX1060 + AKiTiO Thunder3 + Win10
GTX1070 + Sonnet Breakaway Box + Win10
GTX1070 + Razer Core V1 + Win10
Vega 56 + Razer Core V1 + macOS + Win10
Vega 56 + Mantiz Venus + macOS + W10

---

LG 5K Ultrafine flickering issue fix


ReplyQuote
ibob
 ibob
(@ibob)
Eminent Member
Joined: 3 years ago
 

So got an AMD RX 480 card and an external PSU, removed my thunder3 case and installed the card and the PSU. Went to Windows, installed AMD's drivers and works perfectly and fast, went back to macOS, updated it to the latest beta (17A344b), patched again, and got a message "External GPU Detected. You must log out to begin using the external GPU", so I did and it it started working, which is a very good news, but, I noticed that the fan are not running, they won't turn on, so checked the system details and it is recognized as a "AMD R9 xxx", so I guess the drivers are not fully compatible, and for that reason I won't be able to do benchmarks and stuff... Let's see if can find something around... Do you guys heard anything similar? 

 

2016 13" MBP + RX560@32Gbps-TB3 (AKiTiO Thunder3) + macOS-HS


itsage liked
ReplyQuote
itsage
(@itsage)
Illustrious Member Admin
Joined: 3 years ago
 

@ibob can you run Luxmark 3.1 and see if the eGPU is working?

external graphics card builds
best laptops for external GPU
eGPU enclosure buyer's guide


ReplyQuote
Eightarmedpet
(@eightarmedpet)
Noble Member
Joined: 3 years ago
 

iBob thats amazing news... in a way I'm not too bothered about macOS using the eGPU so long as it can pass signal through it so I can keep cabling as simple as possible. Nvidia drivers are out for 10.13 right? So someone may be able to test? Exciting times!

2017 13" MacBook Pro Touch Bar
GTX1060 + AKiTiO Thunder3 + Win10
GTX1070 + Sonnet Breakaway Box + Win10
GTX1070 + Razer Core V1 + Win10
Vega 56 + Razer Core V1 + macOS + Win10
Vega 56 + Mantiz Venus + macOS + W10

---

LG 5K Ultrafine flickering issue fix


ReplyQuote
ibob
 ibob
(@ibob)
Eminent Member
Joined: 3 years ago
 

@itsage I am trying to figure out why the fans are not working in macOS. The GPU works, HDMI works, and it seems to be accelerated because I opened Unreal Engine with a simple scene and it was super fluid, but it gets crazy hot, super fast, so I don't want to benchmark because I might end killing the GPU, or the external case. 

@Eightarmedpet yes I heard, haven't looked, but I still have the 1050 ti, so I might end testing that too... Let's see... 

2016 13" MBP + RX560@32Gbps-TB3 (AKiTiO Thunder3) + macOS-HS


ReplyQuote
ibob
 ibob
(@ibob)
Eminent Member
Joined: 3 years ago
 

Can't find NVidia drivers for 10.13, there's only a patched version for macOS 10.13 (17A315i), but I have (17A344b), so no luck.
About the fans off on the RX 480, still nada...  

2016 13" MBP + RX560@32Gbps-TB3 (AKiTiO Thunder3) + macOS-HS


ReplyQuote
itsage
(@itsage)
Illustrious Member Admin
Joined: 3 years ago
 

When I tried the RX 480 with a TI82 enclosure macOS High Sierra was able to detect the eGPU but things were not working right. This is after modding the IOThunderboltFamily kext to allow the use of TI82 enclosures in 10.13. There’s no Nvidia web drivers for 10.13.

external graphics card builds
best laptops for external GPU
eGPU enclosure buyer's guide


ibob liked
ReplyQuote
ualwayaslose
(@ualwayaslose)
Active Member
Joined: 3 years ago
 

Hey,

I was able to get my Razer core with AMD 570 working with my TB Macbook Pro 13 Inch by editing the IOThunderboltFamily.kext with the appropriate edits as described by itsage.

For macOS Sierra 10.12.x 

55 48 89 E5 41 57 41 56 41 55 41 54 53 48 81 EC 38 01 

55 48 89 E5 31 C0 5D C3 41 55 41 54 53 48 81 EC 38 01

For macOS High Sierra 10.13.x 

55 48 89 E5 41 57 41 56 41 55 41 54 53 48 81 EC 28 01 

55 48 89 E5 31 C0 5D C3 41 55 41 54 53 48 81 EC 28 01 

I had 10.12.6 and it did not work with Razer Core with the edits. So I installed High Sierra. After one failed update, then trying again I was able to edit the kext file again with the new Hex settings for High Sierra. After a reboot I plugged in the Razer core, logged out after being prompted and it appears to be working. 

I ran some benchmarks and seems appropriate. Final Cut Pro wont open when eGPU is connected so thats a bummer. Some games seem to be accelerated though so thats a plus. (Though MacOS has really bad performance compared to my windows setup)

Here are some benchmarks.

Intel 550

https://browser.geekbench.com/v4/compute/1034945

AMD 570 (Some reason Geekbnech says its a 580)

https://browser.geekbench.com/v4/compute/1034949

Pending: Add my system information and expected eGPU configuration to my signature to give context to my posts


itsage liked
ReplyQuote
itsage
(@itsage)
Illustrious Member Admin
Joined: 3 years ago
 

Thank you for the report and I’m glad to hear this edit allow TI82 eGPU enclosure to work in 10.13. When I tried it with my RX 480 + Razer Core, it didn’t work with 10.13 Beta 3.

external graphics card builds
best laptops for external GPU
eGPU enclosure buyer's guide


ReplyQuote
ualwayaslose
(@ualwayaslose)
Active Member
Joined: 3 years ago
 

Just updated to latest Beta (PB6)

 

Still getting a crash on load in Final Cut Pro with 570 attached. Think it has something to do with having Intel and 570 loaded same time.

Pending: Add my system information and expected eGPU configuration to my signature to give context to my posts


ReplyQuote
ibob
 ibob
(@ibob)
Eminent Member
Joined: 3 years ago
 

Hi.

So, just wanted to comment that in the latest beta update (17A352a), after applying the patch to IOThunderbolt that btw, works well, my AMD RX 480 is working and both fans turn on when needed. It's still recognized as "AMD R9 xxx 8 GB", but works perfectly well and it is recognized as AMD RX 480 by programs like Blender 3D when using OpenCL ... Screenshots attached. 

Also did a small OpenCL benchmark with this:  http://www.luxrender.net/release/luxmark/v3.1/luxmark-macos64-v3.1.zip

Results also attached... 

Screen Shot 2017 08 22 at 9.06.20 PM
Screen Shot 2017 08 22 at 9.01.04 PM
Screen Shot 2017 08 22 at 9.03.46 PM
Screen Shot 2017 08 22 at 8.06.49 PM

 


Cinebench benchmarks....

Screen Shot 2017 08 22 at 9.41.02 PM
Screen Shot 2017 08 22 at 9.43.29 PM

 


Yet another one….

Geekbench 4 Compute OpenCL:

AMD RX 480 https://browser.geekbench.com/v4/compute/1040897

Intel(R) Iris(TM) Graphics 550:  https://browser.geekbench.com/v4/compute/1040898

Sorry, not trying to SPAM, just thought you guys would like to see some benchmarks…

 

2016 13" MBP + RX560@32Gbps-TB3 (AKiTiO Thunder3) + macOS-HS


nando4 and itsage liked
ReplyQuote
Eightarmedpet
(@eightarmedpet)
Noble Member
Joined: 3 years ago
 

Not spamming at all! This is amazing to see/hear. I'm very tempted to grab one of those OEM mini 480's or a 570 off eBay as it doesn't look like they are ever coming back in stock... thanks for sharing, really appreciate it!

2017 13" MacBook Pro Touch Bar
GTX1060 + AKiTiO Thunder3 + Win10
GTX1070 + Sonnet Breakaway Box + Win10
GTX1070 + Razer Core V1 + Win10
Vega 56 + Razer Core V1 + macOS + Win10
Vega 56 + Mantiz Venus + macOS + W10

---

LG 5K Ultrafine flickering issue fix


ReplyQuote
itsage
(@itsage)
Illustrious Member Admin
Joined: 3 years ago
 

This is encouraging news for those with older TI82 enclosures.

external graphics card builds
best laptops for external GPU
eGPU enclosure buyer's guide


ReplyQuote
ibob
 ibob
(@ibob)
Eminent Member
Joined: 3 years ago
 

Thanks. Yeah I think that this is good because with something small like the ATiKio Thunder3 (with a 120w addapter) and the "Asus Radeon Rx 550 4gb" that needs no extra power is a good combination for a MacBookPro or any other Mac with Thunderbolt 3... 

2016 13" MBP + RX560@32Gbps-TB3 (AKiTiO Thunder3) + macOS-HS


ReplyQuote
ualwayaslose
(@ualwayaslose)
Active Member
Joined: 3 years ago
 
Posted by: ibob

Hi.

So, just wanted to comment that in the latest beta update (17A352a), after applying the patch to IOThunderbolt that btw, works well, my AMD RX 480 is working and both fans turn on when needed. It's still recognized as "AMD R9 xxx 8 GB", but works perfectly well and it is recognized as AMD RX 480 by programs like Blender 3D when using OpenCL ... Screenshots attached... 

Can you test if Final Cut Pro works with your setup?

Pending: Add my system information and expected eGPU configuration to my signature to give context to my posts


ReplyQuote
Eightarmedpet
(@eightarmedpet)
Noble Member
Joined: 3 years ago

ibob liked
ReplyQuote
ibob
 ibob
(@ibob)
Eminent Member
Joined: 3 years ago
 

Sorry @ualwayslose, I don't have Final Cut, but as you see OpenCL recognizes it, so I suppose it should work. 

2016 13" MBP + RX560@32Gbps-TB3 (AKiTiO Thunder3) + macOS-HS


ReplyQuote
Eightarmedpet
(@eightarmedpet)
Noble Member
Joined: 3 years ago
 

My 570 is arriving this weekend, I'm going to see how she fires in Windows and then see about grabbing High Sierra, not sure whether to get a Beta or just wait for full release, I wonder if they will change anything for public release? I almost suspect they will, fingers crossed the 570 will be fine with just the simple kext edit for the Ti82 as detailed above. Will do a write up if so. Thanks again folks!

2017 13" MacBook Pro Touch Bar
GTX1060 + AKiTiO Thunder3 + Win10
GTX1070 + Sonnet Breakaway Box + Win10
GTX1070 + Razer Core V1 + Win10
Vega 56 + Razer Core V1 + macOS + Win10
Vega 56 + Mantiz Venus + macOS + W10

---

LG 5K Ultrafine flickering issue fix


ReplyQuote
ibob
 ibob
(@ibob)
Eminent Member
Joined: 3 years ago
 

570! Cool!
Well I am sure they will make the drivers better, and also I am 80% positive that NVidia will release drivers for their video cards after the GM version is out. But I am also sure Apple will allow "approved" hardware only, because it's their business, we will need to patch that IOThunderbolt kext on every update, and I hope they don't modify it so people won't be able to patch it!...  

2016 13" MBP + RX560@32Gbps-TB3 (AKiTiO Thunder3) + macOS-HS


ReplyQuote
Eightarmedpet
(@eightarmedpet)
Noble Member
Joined: 3 years ago
 

ibob - any updates on how your set up is performing?

I paid through the nice for a 570 and it finally arrived, but I ran into error 12 in windows and gave up, maybe slightly prematurely, and put my 1060 back in. Might give it another go once HS is officially released.

2017 13" MacBook Pro Touch Bar
GTX1060 + AKiTiO Thunder3 + Win10
GTX1070 + Sonnet Breakaway Box + Win10
GTX1070 + Razer Core V1 + Win10
Vega 56 + Razer Core V1 + macOS + Win10
Vega 56 + Mantiz Venus + macOS + W10

---

LG 5K Ultrafine flickering issue fix


ReplyQuote
ibob
 ibob
(@ibob)
Eminent Member
Joined: 3 years ago
 

Hi! Hmmm, my setup is still working (with the RX 480 + AKiTiO Thunder3 + External Power Supply). New versions of macOS I had to patch IOThunderBolt again, but works. Windows works too. Maybe try removing video card drivers and try again? Not sure, don't have a 570 handy to test... If I get the chance, I'll do tests...

 

2016 13" MBP + RX560@32Gbps-TB3 (AKiTiO Thunder3) + macOS-HS


ReplyQuote
(@manny_ramirez)
New Member
Joined: 3 years ago
 

Good Evening, folks!

 

I tried the TB3 enabling workaround suggested for High Sierra, but it renders my mac useless and I have to re-install the OS after modifying the suggested file.  Any ideas are greatly appreciated!! I have an Akitio Thunder 3 Duo Pro that worked just fine in Sierra with the earlier workaround.   

 

Manny

Pending: Add my system information and expected eGPU configuration to my signature to give context to my posts


ReplyQuote
raybanner
(@raybanner)
Eminent Member
Joined: 3 years ago
 

Edit

I followed the steps for replacing the the kext with the values for high sierra. I use the thunder3 and RX460 over the Apple TB3 to TB2 Adapter. 

In system profiler it shows me the Thunder3 under Thunderbolt and AMD R9 XXX in the Graphics/Display 

But the screen on my Dell 4k Display is just black.

Any ideas? Do I have to edit some kext to "activate" my RX460, if so how?

 

Bildschirmfoto 2017 10 04 um 20.40.16

Pending: Add my system information and expected eGPU configuration to my signature to give context to my posts


ReplyQuote
Eightarmedpet
(@eightarmedpet)
Noble Member
Joined: 3 years ago
 

Do you get the "egpu detected" prompt in macOS? I would guess not seeing as the 460 isnt actually supported (could be wrong). 

As far as I have heard from folks on here its only 470/570 480/580 that are supported - I had a 570 in a Sonnet and it was plug and play...

2017 13" MacBook Pro Touch Bar
GTX1060 + AKiTiO Thunder3 + Win10
GTX1070 + Sonnet Breakaway Box + Win10
GTX1070 + Razer Core V1 + Win10
Vega 56 + Razer Core V1 + macOS + Win10
Vega 56 + Mantiz Venus + macOS + W10

---

LG 5K Ultrafine flickering issue fix


ReplyQuote
raybanner
(@raybanner)
Eminent Member
Joined: 3 years ago
 

RX46o should not be that hard to if I modify some kext I guess, but I dont know how to do that.

Any AMD card you can recommend that works with the 120W PSU and fits the case?

Pending: Add my system information and expected eGPU configuration to my signature to give context to my posts


ReplyQuote
Eightarmedpet
(@eightarmedpet)
Noble Member
Joined: 3 years ago

ReplyQuote
goalque
(@goalque)
Noble Member Admin
Joined: 3 years ago
 

The new automate-eGPU installer will support 17 AMD cards, including RX 460/560. Just wait.

automate-eGPU EFIapple_set_os.efi

Mid 2015 15-inch MacBook Pro eGPU Master Thread


ReplyQuote
tbl777
(@tbl777)
Trusted Member
Joined: 2 years ago
 

@raybanner

In the system report displaying the R9 xxx not means you have the eGPU activated......must display the external display under your R9 xxx and this means your eGPU is working!!!

late-2013 15" MacBook Pro GT750M + RX580@16Gbps-TB2 (AKiTiO thunder 2) + macOS 10.13


ReplyQuote
tbl777
(@tbl777)
Trusted Member
Joined: 2 years ago
 
Posted by: raybanner

Edit

I followed the steps for replacing the the kext with the values for high sierra. I use the thunder3 and RX460 over the Apple TB3 to TB2 Adapter. 

In system profiler it shows me the Thunder3 under Thunderbolt and AMD R9 XXX in the Graphics/Display 

But the screen on my Dell 4k Display is just black.

Any ideas? Do I have to edit some kext to "activate" my RX460, if so how?

 

Bildschirmfoto 2017 10 04 um 20.40.16

I know what your problem is, you should use mac_editor’s script to idle the GPU_nvidia and only use iGPU.

reference:

https://egpu.io/forums/mac-setup/nvidia-workaround-for-high-sierra-egpu-acceleration/#post-17121

late-2013 15" MacBook Pro GT750M + RX580@16Gbps-TB2 (AKiTiO thunder 2) + macOS 10.13


ReplyQuote
Eightarmedpet
(@eightarmedpet)
Noble Member
Joined: 3 years ago
 

champ @goalque

Any update on Nvidia GPU's? I know its a bigger problem to solve, but...

Also, the previous script wasn't compatible with my LG 5K (it messed up my display settings), was that an odd bug specific to my set up or have there been other reports of the issue?

2017 13" MacBook Pro Touch Bar
GTX1060 + AKiTiO Thunder3 + Win10
GTX1070 + Sonnet Breakaway Box + Win10
GTX1070 + Razer Core V1 + Win10
Vega 56 + Razer Core V1 + macOS + Win10
Vega 56 + Mantiz Venus + macOS + W10

---

LG 5K Ultrafine flickering issue fix


ReplyQuote
tbl777
(@tbl777)
Trusted Member
Joined: 2 years ago
 

Nvidia gpu's script maybe in the next year, at least the web driver is incompatible with high sierra...

late-2013 15" MacBook Pro GT750M + RX580@16Gbps-TB2 (AKiTiO thunder 2) + macOS 10.13


ReplyQuote
goalque
(@goalque)
Noble Member Admin
Joined: 3 years ago
 
Posted by: tbl777

Nvidia gpu's script maybe in the next year, at least the web driver is incompatible with high sierra...

There isn't any sign in the Nvidia's web driver that it would be eGPU compatible now or in the future on macOS High Sierra. I wish good luck @Rastafabi but at present it seems that hacking is nearly impossible.

automate-eGPU EFIapple_set_os.efi

Mid 2015 15-inch MacBook Pro eGPU Master Thread


ReplyQuote
Eightarmedpet
(@eightarmedpet)
Noble Member
Joined: 3 years ago
 

Thanks for the info guys... I hope Apple and Nvidia do work together to get eGPU's working, I suspect they might seeing as Nvidia are officially working on eGPUS's but who knows... to be fair I only use mine for gaming in windows so might not really matter.

2017 13" MacBook Pro Touch Bar
GTX1060 + AKiTiO Thunder3 + Win10
GTX1070 + Sonnet Breakaway Box + Win10
GTX1070 + Razer Core V1 + Win10
Vega 56 + Razer Core V1 + macOS + Win10
Vega 56 + Mantiz Venus + macOS + W10

---

LG 5K Ultrafine flickering issue fix


ReplyQuote
raybanner
(@raybanner)
Eminent Member
Joined: 3 years ago
 

I know tried everything on my wifes 13" MBP with the same results. External Dell Display showing as connected to the AMD card in the system profile, but the Display itself is just black, no image even though the system recognizes the external display. I guess the last bit of modifying is to make the RX460 work.

Pending: Add my system information and expected eGPU configuration to my signature to give context to my posts


ReplyQuote
 of  3