Video Editing Playback with eGPU Choppy
 
Notifications
Clear all

Video Editing Playback with eGPU Choppy  

  RSS

rawweb
(@rawweb)
Trusted Member
Joined: 3 years ago
 

Wonder if anyone has any ideas or could help. In Premiere Pro and Resolve I'm getting very choppy playback. I've got a 2013 Mac Pro and a Blackmagic eGPU Pro (Vega 56). Playing back various ProRes footage with the eGPU and Ultrafine 5k and Apple Cinema Display both attached to eGPU produces unusable choppiness and bad playback (reproduced this choppy playback with a 2019 Mac Pro) On the flip, if I disconnect and use the D700, it works without issues. Running the latest Catalina (10.15.6) and eGPU purge-wrangler script.

This rig works beautifully in Windows for light gaming.

 

2017 15" MacBook Pro + 16GB + Radeon Pro 560
2013 Mac Pro
Blackmagic Design Radeon Pro 580
Mantiz Venus - Radeon RX 580
LG Ultrafine 5k - Dual

 
2017 15" MacBook Pro (RP560) [7th,4C,H] + RP 580 @ 32Gbps-TB3 (Blackmagic eGPU) + macOS 10.14.5 & Win10 [build link]  


ReplyQuote
Koncept_Zero
(@koncept_zero)
Trusted Member
Joined: 9 months ago
 

Try transcoding to prores proxy. What type of drive is your media on? If you're working with 4k media, you can also try creating a 1080p timeline. Once you're done editing you can then change it back to 4k and export.

2018 Mac Mini [8th,6C,B] + RX 5700 XT @ 32Gbps-TB3 (Razer Core X) + macOS 10.15.5 [build link]  

ReplyQuote
rawweb
(@rawweb)
Trusted Member
Joined: 3 years ago
 

I'm editing off super fast raid media, never been an issue using the native dGPU on either the 2013 or 2019 Mac Pro. Just curious why playback is so bad. I suppose I can always just disconnect the eGPU when video editing... 😕 

2017 15" MacBook Pro + 16GB + Radeon Pro 560
2013 Mac Pro
Blackmagic Design Radeon Pro 580
Mantiz Venus - Radeon RX 580
LG Ultrafine 5k - Dual

 
2017 15" MacBook Pro (RP560) [7th,4C,H] + RP 580 @ 32Gbps-TB3 (Blackmagic eGPU) + macOS 10.14.5 & Win10 [build link]  


ReplyQuote
Koncept_Zero
(@koncept_zero)
Trusted Member
Joined: 9 months ago
 

That's all super odd. When using it paired to a 2019 Mac Pro, does DR give you the option to use both GPU's at the same time? It sounds like you may need to adjust your DR memory & gpu preferences? Can you post those up? I have mine set to Auto and both "use display gpu for compute" and "use gpu scopes" unchecked. 

 

2018 Mac Mini [8th,6C,B] + RX 5700 XT @ 32Gbps-TB3 (Razer Core X) + macOS 10.15.5 [build link]  

ReplyQuote