[APP] NVIDIA eGPU support for High Sierra (NVIDIAEGPUSupport)
 
Notifications
Clear all

[APP] NVIDIA eGPU support for High Sierra (NVIDIAEGPUSupport)  

 of  199
  RSS

CodeBleu
(@codebleu)
Active Member
Joined: 3 years ago
 
Posted by: RealChigga

I saw the update for mirror link but there's no pkg installer in that git repository.

Same. I'm too much a noob to build it straight from the code! Anybody still have this file?

2017 15" MacBook Pro (RP560) [7th,4C,H] + RX Vega 64 @ 32Gbps-TB3 (Mantiz Venus) + macOS 10.13.4 & Win10 [build link]  

ReplyQuote
i0ntempest
(@i0ntempest)
Trusted Member
Joined: 3 years ago
 

Help! After updated to 10.13.1 everything stopped working. My 1070 can no longer be detected by the system, not even “NVIDIA chip model”, just a “VGA Compatible Controller” shows up in the PCI section, and no driver installed. Tried reinstalling WebDriver and NVIDIAEGPUSupport, tried enabling and disabling SIP, tried switch drivers, nothing works. I’ll try to reinstall the system to see if i can get it working. Anyone pls help!

Setup 1: Apple iMac 2017 21.5” 4K + eGPU
dGPU: AMD Radeon Pro 560
eGPU: ASUS Strix AMD Radeon Vega 56 via Thunderbolt 3 (AKiTiO Node)
OS: macOS Catalina 10.15.3, Windows 10 1809, Kali Linux 2020.1
Setup 2: Apple Mac mini 2018 + eGPU
iGPU: Intel UHD Graphics 630
eGPU: AMD Radeon RX 570 MXM via Thunderbolt 3 (Sonnet Breakaway Puck)
OS: macOS Catalina 10.15.4 Beta, Windows 10 1909


ReplyQuote
unknownsolo
(@unknownsolo)
Trusted Member
Joined: 3 years ago
 

Tried the latest Nvidia drivers for 10.13.1,

https://www.tonymacx86.com/threads/nvidia-releases-alternate-graphics-drivers-for-macos-high-sierra-10-13-1-378-10-10-10-20.236101/

The drivers install just fine and let you enable "Nvidia Web Driver" again. However, this fix on page one is not working. My Mac no longer sees my GPU. Not even the generic "Nvidia Chip Model"

Late 2019 MacBook Pro 16-inch with AMD 5500m dGPU - Razer Core X Chroma - AMD RX 5700 XT

 
2017 15" MacBook Pro (RP560) [7th,4C,H] + GTX 1080 Ti @ 32Gbps-TB3 (ASUS XG Station 2) + macOS 10.13.1 [build link]  


ReplyQuote
i0ntempest
(@i0ntempest)
Trusted Member
Joined: 3 years ago
 
Posted by: unknownsolo

Tried the latest Nvidia drivers for 10.13.1, the drivers install just fine and let you enable "Nvidia Web Driver" again. However, this fix on page one is not working. My Mac no longer sees my GPU. Not even the generic "Nvidia Chip Model"

+1, this is exactly my problem. Rolling back to 10.13 rn.

Setup 1: Apple iMac 2017 21.5” 4K + eGPU
dGPU: AMD Radeon Pro 560
eGPU: ASUS Strix AMD Radeon Vega 56 via Thunderbolt 3 (AKiTiO Node)
OS: macOS Catalina 10.15.3, Windows 10 1809, Kali Linux 2020.1
Setup 2: Apple Mac mini 2018 + eGPU
iGPU: Intel UHD Graphics 630
eGPU: AMD Radeon RX 570 MXM via Thunderbolt 3 (Sonnet Breakaway Puck)
OS: macOS Catalina 10.15.4 Beta, Windows 10 1909


ReplyQuote
Eightarmedpet
(@eightarmedpet)
Noble Member Moderator
Joined: 3 years ago
 

Cheers buddy... I'm going to hold off for a few days, see how the dust settles and whats happening with the App/this os update.

 

edit: Those drivers installed errorless for me unlike the last ones. Have followed a clean your instal up guide which includes uninstalling and cache rebuilds. ready for the 10.13.1 App update... (fingers crossed).

2017 13" MacBook Pro Touch Bar
GTX1060 + AKiTiO Thunder3 + Win10
GTX1070 + Sonnet Breakaway Box + Win10
GTX1070 + Razer Core V1 + Win10
Vega 56 + Razer Core V1 + macOS + Win10
Vega 56 + Mantiz Venus + macOS + W10

---

LG 5K Ultrafine flickering issue fix

 
2017 13" MacBook Pro [7th,2C,U] + RX 560 @ 32Gbps-TB3 (AKiTiO Node Lite) + macOS 10.15.4 & Win10 [build link]  


ReplyQuote
Eightarmedpet
(@eightarmedpet)
Noble Member Moderator
Joined: 3 years ago
 
Posted by: CodeBleu
Posted by: RealChigga

I saw the update for mirror link but there's no pkg installer in that git repository.

Same. I'm too much a noob to build it straight from the code! Anybody still have this file?

Yeah, I have a pkg file of the app, happy to share (if thats allowed?).

2017 13" MacBook Pro Touch Bar
GTX1060 + AKiTiO Thunder3 + Win10
GTX1070 + Sonnet Breakaway Box + Win10
GTX1070 + Razer Core V1 + Win10
Vega 56 + Razer Core V1 + macOS + Win10
Vega 56 + Mantiz Venus + macOS + W10

---

LG 5K Ultrafine flickering issue fix

 
2017 13" MacBook Pro [7th,2C,U] + RX 560 @ 32Gbps-TB3 (AKiTiO Node Lite) + macOS 10.15.4 & Win10 [build link]  


ReplyQuote
devild
(@devild)
Trusted Member
Joined: 3 years ago
 

10.13.1 installer (update &, just checked on my MBA) and 10.13.0 installer (original &)

 

Source:  NVIDIAEGPUSupport (source fork).  Note: yifanlu's installer package is no longer hosted on GitHub .

I’ve compiled it by myself from updated a few hours ago source files.

Note for update process: I installed new drivers with SIP disabled on both my Macs w/o errors.

Checked my 15″ MBP 2016 – eGPU is working with an external monitor w/ log out-in procedure.

 

That is not dead which can eternal lie, And with strange aeons even death may die.


ReplyQuote
ibob
 ibob
(@ibob)
Eminent Member
Joined: 3 years ago
 

Working good, thanks!
Just in case, what I did:

– Installed macOS update
– Disabled SIP
– Patched IOThunderbolt (Btw, TB3 enabler is script is up to date on github!)
– Enabled SIP
– NVidia notified me about the driver update, so installed. 
– Enabled SIP without kext…
– Install NVIDIAEGPUSupport V2. 
– Restarted, plugged the AKiTio Thunder3, logged out and in…
– Works. 
Thanks again!

🙂 

2016 13" MBP + RX560@32Gbps-TB3 (AKiTiO Thunder3) + macOS-HS


Argonaut and itsage liked
ReplyQuote
Juan C. Yunis
(@juan_c_yunis)
Reputable Member
Joined: 3 years ago
 

V2 is working for me 10.13.1, 2017 15″ MBP with Radeon 560. Mantiz Venus with a GTX 1080 Ti.

Posted by: ibob

Working good, thanks!
Just in case, what I did:

– Installed macOS update
– Disabled SIP
– Patched IOThunderbolt (Btw, TB3 enabler is script is up to date on github!)
– Enabled SIP
– NVidia notified me about the driver update, so installed. 
– Enabled SIP without kext…
– Install NVIDIAEGPUSupport V2. 
– Restarted, plugged the AKiTio Thunder3, logged out and in…
– Works. 
Thanks again!

🙂 

What is that IOThunderbolt patch?

2018 Mac Mini Core i7 8700B 32GB RAM 512GB SSD + Razer Core X + AMD Radeon VII


ReplyQuote
itsage
(@itsage)
Illustrious Member Admin
Joined: 4 years ago
 

@ Juan C. Yunis, IOThunderbolt patch is a workaround to make macOS compatible with Thunderbolt 3 enclosure with the older TI82 controller. AKiTiO Thunder3, Razer Core V1, and some Power Color Devil Box are the only enclosures need this patch.

external graphics card builds
best laptops for external GPU
eGPU enclosure buyer's guide

 
2020 13" MacBook Pro [10th,4C,G] + RX 5700 @ 32Gbps-TB3 (Prototype eGPU Enclosure) + macOS 10.15.4 & Win10 1903 [build link]  


ReplyQuote
 of  199