[APP] NVIDIA eGPU support for High Sierra (NVIDIAEGPUSupport)  

Page 54 / 54 Prev
 

devild
(@devild)
Trusted Member
Joined:1 year  ago
Posts: 54
May 7, 2018 12:29 pm  

If anybody still needs it, here is the NVDAEGPUSupport.kext for 10.13.4 17E202 (working OK with @mac_editor script)

Nvidia web driver -  https://images.nvidia.com/mac/pkg/387/WebDriver-387.10.10.10.30.107.pkg

Edited: 2 weeks  ago

That is not dead which can eternal lie, And with strange aeons even death may die.


mac_editor liked
ReplyQuote
fr34k
(@fr34k)
Reputable Member Moderator
Joined:5 months  ago
Posts: 330
May 7, 2018 1:15 pm  

@trampilot

bash <(curl -s https://raw.githubusercontent.com/learex/macOS-eGPU/master/macOS-eGPU.sh) --uninstall

this should be sufficient. The script will automatically search for existing installations and remove them.

macOS-eGPU.sh (fr34k's macOS-eGPU.sh)
temporary 10.13.4 script
----
2016 15'' MacBook Pro + GTX1080Ti@32Gbps-TB3 (Sonnet Breakaway 550) + macOS 10.13.4 (17E202 driver: 378.10.10.10.30.107 + CUDA: 387.178)
CUDA NN bench: 382s [397s base]


ReplyQuote
jtob
 jtob
(@jtob)
Active Member
Joined:5 months  ago
Posts: 18
May 7, 2018 4:04 pm  

@fr34k
I've had results with the latest alpha of your script, but support for dual eGPU's fails.  I have a trashcan Mac Pro with TB2 ports running os 10.13.3

After a run of your script on a fresh OS install the second eGPU enclosure isn't recognized by the system no matter which port its plugged into.

Luckily the fix is super easy: sudo automate-eGPU.sh -a 

the -a option does something to my P-Ram which resolves the issue and the computer recognizes the eGPU.  I wish I understood what was happening and why this -a option fixes things!  i am worried about this not working in the future and using the use of my second GPU


ReplyQuote
simplekitten
(@simplekitten)
Eminent Member
Joined:2 weeks  ago
Posts: 21
May 7, 2018 4:30 pm  

Hi all,

I’m very new to this hacky eGPU environment. I have a late 2013 15” MacBook Pro that consists of a “intel iris pro graphics and GeForce GT 750M” I bought a Aorus 1080 gaming box. I’ve tried multiple ways from @fr34k and @mac_editor post. But always end up with a unbootable mac and I had to reinstall the OS.
I’ve tried:
csrutil disable
purge-wrangler 
enable TB1/2
NVIDIA driver (with SIP enabled)
nvdaegpuSupport (with SIP disabled)

when rebooting it kinda stucked with the apple logo.

I’ve also tried the other way round:
NVIDIA driver (with SIP enabled)
nvdaegpuSupport (with SIP disabled)
Install CUDA
Reboot and it stuck at boot again.

Am I missing anything or I did the steps wrongly?


ReplyQuote
efra
 efra
(@efra)
New Member
Joined:2 weeks  ago
Posts: 1
May 7, 2018 4:58 pm  

hi all, i'm new here, i subscribed to thank all the dev for their efforts 
i was waiting for this and the OpenCL move of C4D ProRender to update to 10.13.4
So, after some troubles ( i've forgot to uninstall previous GPUenabler from 10.12 -  no comment ),  i ran pure-wrangler ( for TH1 and Nvidia ) then NVDAEGPU-8
and it works nice, internal monitor on dGPU and 2 external displays on eGPU  !
Resolve 14 works nice ( with StudioMini Monitor Output and Cuda for the GTX 970). Although, it seems, as mentioned in macOS-eGPU help that OpenCL or Metal2(?) doesn't work for me ( C4D last version > Prorender still works on the dGPU 650 m - Luxmark > doesn't see the 970 )
Again, thank you guys
MBPR 2012 with Nvidia 650M and TH1 - Akitio Thunder2 box - GTX 970


fr34k liked
ReplyQuote
fr34k
(@fr34k)
Reputable Member Moderator
Joined:5 months  ago
Posts: 330
May 7, 2018 5:53 pm  

@jtob
I know about that, will implement the functions that @goalque's script does with -a soon (don't know when soon is but I promise it will come)

macOS-eGPU.sh (fr34k's macOS-eGPU.sh)
temporary 10.13.4 script
----
2016 15'' MacBook Pro + GTX1080Ti@32Gbps-TB3 (Sonnet Breakaway 550) + macOS 10.13.4 (17E202 driver: 378.10.10.10.30.107 + CUDA: 387.178)
CUDA NN bench: 382s [397s base]


goalque and jtob liked
ReplyQuote
wuyefeng
(@wuyefeng)
New Member
Joined:2 weeks  ago
Posts: 2
May 9, 2018 10:20 am  

1. R u  using External screen?
 can both In

2. can both In/External screen work at same time?
Yes

3.is Bootcamp Win10 still OK?
Not tested BootCamp Windows


ReplyQuote
lqd
 lqd
(@lqd)
Active Member
Joined:1 month  ago
Posts: 6
May 14, 2018 1:31 pm  

Hi all... 🙂
Can someone confirm, that the last new  V9 support works like a charm, like before 'critical' security update on Mac OS? (or still better not update Mac OS?)
(iMac 2017, Sonnet Breakaway+NVidia Quadro P5000)

thanks 🙂

Edited: 1 week  ago

iMac 2017 5K +Sonnet Breakaway 350 with NVidia Quadro P5000, MacOS 10.3.4. (bef sec.updt)


ReplyQuote
fr34k
(@fr34k)
Reputable Member Moderator
Joined:5 months  ago
Posts: 330
May 14, 2018 1:32 pm  

@lqd
reuse my script again.

macOS-eGPU.sh (fr34k's macOS-eGPU.sh)
temporary 10.13.4 script
----
2016 15'' MacBook Pro + GTX1080Ti@32Gbps-TB3 (Sonnet Breakaway 550) + macOS 10.13.4 (17E202 driver: 378.10.10.10.30.107 + CUDA: 387.178)
CUDA NN bench: 382s [397s base]


ReplyQuote
lqd
 lqd
(@lqd)
Active Member
Joined:1 month  ago
Posts: 6
May 14, 2018 1:36 pm  

@fr34k 
That was quick 🙂 So, I consider your reply to: YES

iMac 2017 5K +Sonnet Breakaway 350 with NVidia Quadro P5000, MacOS 10.3.4. (bef sec.updt)


ReplyQuote
fr34k
(@fr34k)
Reputable Member Moderator
Joined:5 months  ago
Posts: 330
May 14, 2018 1:37 pm  

@lqd
V9 will not work. My script uses a custom universal installer. Also you need the patch as well

Edited: 1 week  ago

macOS-eGPU.sh (fr34k's macOS-eGPU.sh)
temporary 10.13.4 script
----
2016 15'' MacBook Pro + GTX1080Ti@32Gbps-TB3 (Sonnet Breakaway 550) + macOS 10.13.4 (17E202 driver: 378.10.10.10.30.107 + CUDA: 387.178)
CUDA NN bench: 382s [397s base]


ReplyQuote
(@albert_johannes)
New Member
Joined:1 week  ago
Posts: 2
May 15, 2018 12:23 pm  

Hey guys, So I have a mid 2014 Macbook pro - non dgpu. My setup is as follows. I have a 4k screen with a 1070ti running in a sonnet breakaway box 350w with the tb3->tb2 Connector.
Currently, I have bootcamp running perfectly and Macos on 10.13.3. I plan now to try 10.13.4 If I make a time machine backup, will it be possible to revert back to 10.13.3 without problems? Thanks


ReplyQuote
incognito
(@incognito)
New Member
Joined:1 week  ago
Posts: 1
May 17, 2018 3:49 pm  

Hi there, I'm still on 10.13.3 with a late 2016 MacBook Pro, Aikito Node and 1080 Ti and everything working fine with nvidia-egpu-v7.zip.

What's the recommended procedure to get 10.13.4 to work currently? Do I have to uninstall anything? Are we still waiting for fr34k's magic script? The most important feature to me is being able to hot-plug / unplug the GPU as it's currently a major pain to have to shut down or log out every time.. Is that something that is going to work?

Thanks for the great work fr34k!!


ReplyQuote
Page 54 / 54 Prev