[APP] NVIDIA eGPU support for High Sierra (NVIDIAEGPUSupport)
 
Notifications
Clear all

[APP] NVIDIA eGPU support for High Sierra (NVIDIAEGPUSupport)  

 of  199
  RSS

itsage
(@itsage)
Illustrious Member Admin
Joined: 4 years ago
 
Posted by: MagicPi

May I ask a question?
if I'm currently on Seirra 10.12.6,
with macbook pro 2016 15" with 460

I'm planning to get a aorus gaming box 1080

is it better to use the "eGPU Enabler by Rastafabi"
and stay on 10.12.6 or
go High Sierra and use the method here??

I know it looks like there's still issues with this and with gaming box
And still , both options seem to be "Not hot plug-able" 

If you primarily use the eGPU with macOS, AMD is the way to go. Nvidia cards in macOS is going to be a constant cat and mouse game for the foreseeable future. If you must use Nvidia, stay with 10.12.6 for now.

external graphics card builds
best laptops for external GPU
eGPU enclosure buyer's guide

 
2020 13" MacBook Pro [10th,4C,G] + RTX 2080 Ti @ 32Gbps-TB3 (AORUS Gaming Box) + Win10 2004 [build link]  


ReplyQuote
MagicPi
(@magicpi)
Eminent Member
Joined: 3 years ago
 

thanks for the reply!

so I think I should stay at 10.12.6 then,
because I got a G-sync 165hz monitor, so I prefer to go with Nvidia card, and Aorus gaming box seems to be a nice deal.

I can stand with mac not really using the full power eGPU under MacOS,
and it still works as a USB dock and can connect my monitor and everything with one cable to my MBP.
But at least I need it to work, so I don't have to constantly switching my monitor cable...
(MacOS with DP to Type C / Windows with DP connect to eGPU ,  if not working)

....and really hope the "cat and mouse" game will change....

 

2016 Macbook pro 15" Pro460 10.12.6 / Razer Blade 15" 144hz GTX1060
Aorus GTX 1080 Gaming Box / ASUS ROG PG279Q 165hz / iphone Xs Max / iPad Pro 9.7


ReplyQuote
Robert Avram
(@robert_avram)
Active Member
Joined: 3 years ago
 

The v2 of the script does not work on the new version of MacOS HIGH SIERRA 10.13.1 with the 2017-11-29 security update that got pushed today.
My compute refused to boot and I had to boot in SINGLE USER MODE (CONTROL + S) to delete NVDAEGPUSupport.kext in Library > Extensions.
Do you have an updated version ?

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
Avelino a2daj Santa Ana Jr
(@ajeatssushi)
Active Member
Joined: 3 years ago
 

Can anyone else confirm whether or not Nvidia's latest webdrivers installer from Nov 1st can even begin the install process after installing the latest (Nov 29th) macOS security patch? "I get the Mac OS X version is not compatible" warning and cannot install the drivers. I'm seeing the error on both of the Macs I had previously been able to run them prior to the security patch. Unfortunately, one of them had to be reformatted so it doesn't have the webdrivers installed at all so I can't even install the NVDAEGPUSupport-v2.pkg.

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
betha
(@betha)
Active Member
Joined: 3 years ago
 

Mac OS Security update 2017.0001 give the web driver is not compatible with your current OS. After update to 378.10.10.10.20.108 App Store re download security patch and same error with web driver

I believe shitting apple, with this security patch, close the possibility to run alternative gpu on Mac 

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
Avelino a2daj Santa Ana Jr
(@ajeatssushi)
Active Member
Joined: 3 years ago
 

I can't seem to edit my previous post for some reason. After hacking the build version in the SystemVersion.plist from 17B1002 to 17B48 I was able to trick the 378.10.10.10.20.107 installer into letting me install the drivers. However, the 107 drivers won't actually work. Using the web driver PrefPane to check for updates revealed a 108 update that doesn't seem to be available from the Nvidia website driver search yet. But I was able to download it with the PrefPane. So Nvidia seems to be aware and it's just a matter of time before their website is updated.

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
betha
(@betha)
Active Member
Joined: 3 years ago
 

Mac OS X version 10.13.1 (17B1003) after patch before was  17B1002

news web driver :  https://images.nvidia.com/mac/pkg/378/WebDriver-378.10.10.10.20.108.pkg

but still not working

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
Avelino a2daj Santa Ana Jr
(@ajeatssushi)
Active Member
Joined: 3 years ago
 

It looks like NVIDIAEGPUSupport will need to be updated to be compatible with the latest version as well. It might just be updating an Info.plist.

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
devild
(@devild)
Trusted Member
Joined: 4 years ago
 

WebDriver-378.10.10.10.20.108.pkg is not compatible with 10.13.1 (17B1003). A new version is required.

NVIDIAEGPUSupport.kext also needs to be updated for new OS build version and new drivers.

So just wait for new Nvidia drivers and source files update from pedroresende/huntrax11.

That is not dead which can eternal lie, And with strange aeons even death may die.


ReplyQuote
betha
(@betha)
Active Member
Joined: 3 years ago
 

I got the update twice, first time build 17b1002, after installing web driver 108(working), App Store give me a new patch with build 17b003 and web driver not compatible with my current OS

This is an apple cat game

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
 of  199