[APP] NVIDIA eGPU support for High Sierra (NVIDIAEGPUSupport)
 
Notifications
Clear all

[APP] NVIDIA eGPU support for High Sierra (NVIDIAEGPUSupport)  

 of  199
  RSS

Eightarmedpet
(@eightarmedpet)
Noble Member Moderator
Joined: 3 years ago
 

I assume you have your monitor plugged into your eGPU, I wonder if my often recommended against set up will actually work well here as the LG 5K gets plugged into the laptop with eGPU being piped through and back out to external.

Will try various boot/plugin options this eve (GMT).

2017 13" MacBook Pro Touch Bar
GTX1060 + AKiTiO Thunder3 + Win10
GTX1070 + Sonnet Breakaway Box + Win10
GTX1070 + Razer Core V1 + Win10
Vega 56 + Razer Core V1 + macOS + Win10
Vega 56 + Mantiz Venus + macOS + W10

---

LG 5K Ultrafine flickering issue fix

 
2017 13" MacBook Pro [7th,2C,U] + RX 560 @ 32Gbps-TB3 (AKiTiO Node Lite) + macOS 10.15.4 & Win10 [build link]  


ReplyQuote
tbl777
(@tbl777)
Trusted Member
Joined: 3 years ago
 

It worked good on macbook pro retina 15 2013-late with asus gtx970 itx on high sierra.

@goalque

So far, it didn't work on AMD-based macbook, is it?

late-2013 15" MacBook Pro GT750M + RX580@16Gbps-TB2 (AKiTiO thunder 2) + macOS 10.13


ReplyQuote
tbl777
(@tbl777)
Trusted Member
Joined: 3 years ago
 
Posted by: yifanlu
Posted by: tbl777
Posted by: yifanlu

Backlight with no actual output seems to be the problem I'm having with my 1060. 

Hi, I have macbook pro retina 15 2013-late with gt750m, This model can't work with eGPU either AMD_based or Nvidia_based. 

I'm not sure I understand your question. All this does is make the High Sierra behavior consistent with Sierra. If your device works on Sierra, it should work on High Sierra.

Apple introduced AMD-eGPU with High Sierra, this worked on all iGPU-based and AMD-based macbooks or mac devices, but not worked on NVIDIA-based macbooks, such as macbook pro retina 15 2013-late with gt750m.
When remove NVIDIA and Gefore driver, enable it to iGPU-based macbook, it worked with AMD_eGPU, so this is the problem only between NVIDIA-based graphics and AMD_eGPU, when plug AMD_eGPU to NVIDI-based macbook, it got black-screen both internal and external screens, so there are two options, either disable NVIDIA graphics on boot or solve the compatibility between NVIDIA-based graphics and AMD_eGPU.
First option is confirmed wrong, because when disable the NVIDIA graphics on boot, the function of screen light-adjustment did not work.
So there's one option left, solve the compatibility between NVIDIA-based graphics and AMD_eGPU.
I see your solution bypass the check, so if when boot or even log out with hot-plug, can disable the framebuffer check, and make AMD_eGPU configure firstly, then it will work fine with AMD-eGPU.Simply first setting up AMD-eGPU, then setting up gt750m, it should solve this problem, but I don't know how to take the first step.

late-2013 15" MacBook Pro GT750M + RX580@16Gbps-TB2 (AKiTiO thunder 2) + macOS 10.13


ReplyQuote
alew3
(@alew3)
Eminent Member
Joined: 3 years ago
 

Can confirm it works! Just upgraded to High Sierra ... MBPt 13" 2016 , Mantiz Venus, Titan X (Pascal)!!

Congrats  @yifanlu !

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
VOD
 VOD
(@vod)
Active Member
Joined: 3 years ago
 
Posted by: mklegend

I followed the steps from yifanlu first post, setup run smoothly, after final restart the internal display had some strange artifacts and the external one worked with the backlight only and keeps powering off and on again, if I unplugged my egpu macOS will start correctly.

Same Problem here, Macbook 2016 15" High Sierra + Akitio Node + 1080ti

2016 15" MacBook Pro (RP455) [6th,4C,H] + GTX 1080 Ti @ 32Gbps-TB3 (AKiTiO Node) + Win10 [build link]  

ReplyQuote
Eightarmedpet
(@eightarmedpet)
Noble Member Moderator
Joined: 3 years ago

ReplyQuote
goalque
(@goalque)
Noble Member Admin
Joined: 4 years ago
 
Posted by: VOD
Posted by: mklegend

I followed the steps from yifanlu first post, setup run smoothly, after final restart the internal display had some strange artifacts and the external one worked with the backlight only and keeps powering off and on again, if I unplugged my egpu macOS will start correctly.

Same Problem here, Macbook 2016 15" High Sierra + Akitio Node + 1080ti

AMD dGPU + Nvidia framebuffer incompatibility?

automate-eGPU EFIapple_set_os.efi

Mid 2015 15-inch MacBook Pro eGPU Master Thread

 
2018 13" MacBook Pro [8th,4C,U] + Radeon VII @ 32Gbps-TB3 (ASUS XG Station Pro) + Win10 1809 [build link]  


ReplyQuote
alew3
(@alew3)
Eminent Member
Joined: 3 years ago
 
Posted by: alew3

Can confirm it works! Just upgraded to High Sierra ... MBPt 13" 2016 , Mantiz Venus, Titan X (Pascal)!!

Congrats  @yifanlu !

I didn't have much time to test as I had to leave for work, but when I shutdown the computer it crashed and rebooted. This used to happen in Sierra, but I think I fixed it at the time with goalque's script. Should I run this script under HS? I'll try when I get back home tonight..

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
imcalledandy
(@imcalledandy)
Estimable Member
Joined: 3 years ago
 
Posted by: alew3
Posted by: alew3

Can confirm it works! Just upgraded to High Sierra ... MBPt 13" 2016 , Mantiz Venus, Titan X (Pascal)!!

Congrats  @yifanlu !

I didn't have much time to test as I had to leave for work, but when I shutdown the computer it crashed and rebooted. This used to happen in Sierra, but I think I fixed it at the time with goalque's script. Should I run this script under HS? I'll try when I get back home tonight..

With @yifanlu's installer, you do not need to run @goalque's script or use @rastafabi's app. Just follow the steps in the first post of this thread.

2013 Mac Pro (FP D700 x2) [3rd,8C,E] + GTX 980 Ti x2 @ 16Gbps-TB2 (AKiTiO Thunder2) + macOS 10.13.1 [build link]  

ReplyQuote
alew3
(@alew3)
Eminent Member
Joined: 3 years ago
 
Posted by: imcalledandy
Posted by: alew3
Posted by: alew3

Can confirm it works! Just upgraded to High Sierra ... MBPt 13" 2016 , Mantiz Venus, Titan X (Pascal)!!

Congrats  @yifanlu !

I didn't have much time to test as I had to leave for work, but when I shutdown the computer it crashed and rebooted. This used to happen in Sierra, but I think I fixed it at the time with goalque's script. Should I run this script under HS? I'll try when I get back home tonight..

With @yifanlu's installer, you do not need to run @goalque's script or use @rastafabi's app. Just follow the steps in the first post of this thread.

I did, just reporting that shutdown is crashing my mac.

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
 of  199