General Discussions
Aorus 1070 Gaming Box stutter on BF5/BFV
 

Aorus 1070 Gaming Box stutter on BF5/BFV  

  RSS

marakalastic
(@marakalastic)
Active Member
Joined: 4 months ago
 

Hey guys,

Struggling to figure out this stuttering issue. It exists whether I'm on the lowest settings or ultra settings.

Specs: X1 Extreme

i7 8750H

16Gb 2666MHz

Aorus Gaming Box w/ 1070

External monitor, laptop monitor disabled. DX12 on and off.

 

Screenshot of stutter:  https://imgur.com/h85lB81

This also happens in the menus with constant spikes:  https://imgur.com/1CWeUbt

There's a video of a Macbook Pro with a 1070 eGPU running the BF5 beta buttery smooth so I know specs are not the culprits. Any suggestions? I just updated nVidia drivers as well to 425.xx. I've already used DDU to do a clean install of nVidia drivers.

Additionally, there are no constant spikes like the ones shown in the screenshots when running off the discrete 1050ti inside my laptop. This constant spiking only occurs when the Aorus Gaming Box is plugged in, regardless of whether I'm using an external display. 

This topic was modified 4 months ago

Pending: Add my system information and expected eGPU configuration to my signature to give context to my posts


ReplyQuote
itsage
(@itsage)
Famed Member Admin
Joined: 3 years ago
 

@marakalastic I'd recommend checking the PCH temps through HWiNFO during gameplay. We have found that to be the culprit for several 8th generation H-CPU laptops. Here's the XPS 9570 with overheating PCH chipset and inconsistent eGPU performance.

This post was modified 4 months ago

Best ultrabooks for eGPU use

eGPU enclosure buying guide


ReplyQuote
marakalastic
(@marakalastic)
Active Member
Joined: 4 months ago
 
Posted by: itsage

@marakalastic I'd recommend checking the PCH temps through HWiNFO during gameplay. We have found that to be the culprit for several 8th generation H-CPU laptops. Here's the XPS 9570 with overheating PCH chipset and inconsistent eGPU performance.

Its not a CPU thermal throttling issue, the game stutters immediately upon boot but works perfectly fine if I run the game without the eGPU and instead with my discrete 1050ti. I used CPUID HWMonitor - https://imgur.com/ykS3rhx

Additionally, I haven't had any problems with any other game (Forza Horizon 4, Rise of the Tomb Raider, Apex Legends) using the eGPU so I know it is specific to BF5. Just hoping someone on here has actually ran BF5 with an eGPU successfully

EDIT: with HWiNFO, I don't see a PCH sensor. 

This post was modified 4 months ago

Pending: Add my system information and expected eGPU configuration to my signature to give context to my posts


ReplyQuote
marakalastic
(@marakalastic)
Active Member
Joined: 4 months ago
 
Posted by: itsage

@marakalastic I'd recommend checking the PCH temps through HWiNFO during gameplay. We have found that to be the culprit for several 8th generation H-CPU laptops. Here's the XPS 9570 with overheating PCH chipset and inconsistent eGPU performance.

@itsage I figured out what was going on. 

While it was related to my CPU, it wasn't the PCH throttling or anything to do with temperature. My CPU simply wasn't increasing its clock speed beyond its base clock of 1.59GHz for some reason. I just checked on Forza Horizon 4 and it didn't increase its clock as well. I just never noticed it for other games as they're usually more GPU intensive than CPU. Solution: Downloaded ThrottleStop and let my CPU freely reach its max of 3.9GHz per core and disabled bi-directional thermal throttling as well. The CPU is still capable of throttling if it overheats.

Pending: Add my system information and expected eGPU configuration to my signature to give context to my posts


itsage liked
ReplyQuote
(@gareth_rees)
Eminent Member
Joined: 4 months ago
 
Posted by: itsage

@marakalastic I'd recommend checking the PCH temps through HWiNFO during gameplay. We have found that to be the culprit for several 8th generation H-CPU laptops. Here's the XPS 9570 with overheating PCH chipset and inconsistent eGPU performance.

You will have excessive PCH temps with Windows Power Plan --> PCI Express --> Link State Power Management at Maximum Performance aka Off

When it's set to maximum, it's sending full activation/performance to every device possible. Card reader, M.2 SSD, WIfi, TB3, and SSD NVME drives are known for excessive heat. It essentially heats the laptop overall which some are not really able to handle it. I've tried varying heatsinks on the PCH and they all don't really help without active cooling when link state management is at max perf.

E.g.

This post was modified 4 months ago

Dell Latitude 5491 14" BIOS 1.8.1 | Core i7 8850H + liquid metal - | 32GB DDR4 2400 | Samsung 512GB PM981 AS SSD 4600 score | | MX130 + liquid metal | Logitech Z-2300 | Razer Death Adder Chroma | Corsair K70 Rapdifire | HP Omen Accelerator 700W PSU + STRIX Vega 56 8GB HBM2


itsage liked
ReplyQuote
Quickie
(@quickie)
New Member
Joined: 3 months ago
 

Try disabling the built in GPU, I was having problems like that and when I disabled it the games became very smooth.

Pending: Add my system information and expected eGPU configuration to my signature to give context to my posts


ReplyQuote
prasys
(@prasys)
Active Member
Joined: 4 months ago
 

You would need to disable the Intel iGPU not the GeForce 1050Ti and it would become smooth. For some reason it copies frame buffer data to iGPU first (i am not sure - even tho the internal display is disabled). I guess the system is thinking it's an Optimus-enabled graphics card.

Pending: Add my system information and expected eGPU configuration to my signature to give context to my posts


ReplyQuote