eGPU RTX 2070 Super usage problem
 
Notifications

eGPU RTX 2070 Super usage problem  

  RSS

Macintosh16
(@macintosh16)
Active Member
Joined: 2 months ago
 

Hello altogether,

I'm new to this forum but I'm very thrilled that it exists because it did help me a lot when building my own eGPU solution, so thanks for that. 

My current build is the following:

MacBook Pro 16 inch with i7 CPU, Radeon Pro 5500M

Razer Core X with RTX 2070 Super Founders Edition

LG UltraFine 5K Display

The connection between MacBook and Core X is with the Thunderbolt 3 cable that comes with the enclosure. 

The connection between GPU and display is via USB-C cable.

The setup worked very easily. I connected the eGPU to Windows and downloaded the Nvidia drivers, and that's basically it. I can also adjust the brightness of my display and can connect my mouse and stereo setup over the display with no problems! 

The RTX card seems to work fine since there is a noticeable fps-boost when playing The Witcher 3 for example compared to the dGPU of my MacBook. Also in Battlefield 5 I can activate Raytracing! But there is one problem that I don't understand at all. When playing a game the TaskManager says that the RTX 2070 Super is only used at 10-20%. And I do have a significant performance loss compared to the same GPU in a Tower PC. In the Witcher for example, I get around 30 fps in 4K, but I should be 40-50 fps. That is a loss much more than the 10% that I expected. I just can't understand why I get the performance boost but the eGPU seems to be doing nothing. And it gets really complicated when I try the UnigineHeaven benchmark. Then TaskManager says that the eGPU is used at 100%, and the fans of the GPU also speed up more than when gaming. I also went into windows graphics settings and set it to power mode which should force the game to use the RTX card. Has anyone got experience with this problem? Because I am out of ideas and don't understand what could possibly cause such a performance drop! 

I would be very very thankful for any replies!

Pending: Add my system information and expected eGPU configuration to my signature to give context to my posts


ReplyQuote
(@sibov97)
Active Member
Joined: 5 months ago
 

Performance loss is normal for egpu enclosures. For example, if you would use egpu for internal display acceleration it would be around 27% of loss (as for me with 1080ti). With external display your perfomance loss has to be around 15%. What about benchmark, probably your processor throttles in the long game sessions, try wattage decrease with intel utility. 

Macbook Pro 15 2019, Sonnet Breakway 550W + Nvidia Gtx 1080 ti


ReplyQuote
Macintosh16
(@macintosh16)
Active Member
Joined: 2 months ago
 

Thanks for your reply! So I also looked at my CPU and in Battlefield 5 it does get to 100% but as it is a 6 core CPU it shouldn't prevent the game from getting more than 30 fps and TaskManager shows that it actually runs with 3.5 to 4GHz which is clearly above it's base clock of 2.5 GHz! So I wouldn't say that the CPU is thermal throttled! And in the Witcher 3 the CPU is at 70% percent and still I get 10-20 fps less than in a Tower PC! 

But what does Intel Utility do and does it work with my MacBook? And will it affect the macOS system?

Pending: Add my system information and expected eGPU configuration to my signature to give context to my posts


ReplyQuote
Mini i5
(@mini-i5)
Reputable Member
Joined: 7 months ago
 

@macintosh16

1.) Go into the Nvidia Control Panel --> Manage 3D settings --> cllick the Program Settings tab --> select witcher3.exe from the pull-down menu.

2.) In that menu, select CUDA - GPUs. It should say, "Use global setting (All)". Click that and a small sub-menu will appear.

3.) Click the dot next to "Use these GPUs" and check the box next to your 2070.

4.) While there, ensure that Power management mode is set to "Prefer maximum performance".

 

 

2018 Mac Mini i5 / 6-core 3.0-4.1 Ghz / 32GB / 256GB / Intel UHD 630 / PowerColor Gaming Station / PowerColor dual-fan RX5700 XT / Mac OS 10.15.3 Catalina / LG 27" 4K display


ReplyQuote
Macintosh16
(@macintosh16)
Active Member
Joined: 2 months ago
 

Thanks very much for your reply Mini i5! I will try this let's see if it helps something!

Pending: Add my system information and expected eGPU configuration to my signature to give context to my posts


ReplyQuote
Macintosh16
(@macintosh16)
Active Member
Joined: 2 months ago
 

So I did just test it but there is no performance improvement! In taskmanager it clearly says that the eGPU is used but in the 3d department it shows basically no activity when playing games! 

Pending: Add my system information and expected eGPU configuration to my signature to give context to my posts


ReplyQuote
Mini i5
(@mini-i5)
Reputable Member
Joined: 7 months ago
 

@macintosh16

In the Task Manager graph try selecting Graphics 1, Compute 1, or CUDA from the drop-down panel instead of 3D.

6EF29B26 5685 4840 A9F3 E190DD144A39

 

2018 Mac Mini i5 / 6-core 3.0-4.1 Ghz / 32GB / 256GB / Intel UHD 630 / PowerColor Gaming Station / PowerColor dual-fan RX5700 XT / Mac OS 10.15.3 Catalina / LG 27" 4K display


ReplyQuote
Mini i5
(@mini-i5)
Reputable Member
Joined: 7 months ago
 

@macintosh16

Turn off vsynch in the game settings. Try setting the FPS to 45 or 40.

Also try turning off Borderless Window mode.

 

2018 Mac Mini i5 / 6-core 3.0-4.1 Ghz / 32GB / 256GB / Intel UHD 630 / PowerColor Gaming Station / PowerColor dual-fan RX5700 XT / Mac OS 10.15.3 Catalina / LG 27" 4K display


ReplyQuote
Macintosh16
(@macintosh16)
Active Member
Joined: 2 months ago
 

So I tried The Witcher 3 once more in fullscreen mode (I had that already) and with V-Sync turned off! But there is no difference! I also compared my eGPU setup with a gaming PC with the RTX 2070 Super and also went into the same region where the PC was tested! The PC got around 73 fps, I just got 55 fps! That is more than 20% of performance loss! I just don‘t know where that comes from!

Pending: Add my system information and expected eGPU configuration to my signature to give context to my posts


ReplyQuote
Mini i5
(@mini-i5)
Reputable Member
Joined: 7 months ago
 

@macintosh16

Check your game settings for Hair Works:

https://www.logicalincrements.com/games/witcher3

55 FPS is pretty close to the maximum 60hz refresh rate of your display. 

 

2018 Mac Mini i5 / 6-core 3.0-4.1 Ghz / 32GB / 256GB / Intel UHD 630 / PowerColor Gaming Station / PowerColor dual-fan RX5700 XT / Mac OS 10.15.3 Catalina / LG 27" 4K display


ReplyQuote
(@jens_engels)
Active Member
Joined: 1 month ago
 

Was this solved?

Late 2016 Macbook Pro + Razer Core X + AMD RX 5700 XT


ReplyQuote
Macintosh16
(@macintosh16)
Active Member
Joined: 2 months ago
 

Yeah it has been solved! So I didn‘t find anything that could make the performance of the eGPU better! So I get around a 20% LOSS in performance when playing games which is pretty unfortunate! Thank you for all your responses!

Pending: Add my system information and expected eGPU configuration to my signature to give context to my posts


ReplyQuote
(@jens_engels)
Active Member
Joined: 1 month ago
 

@macintosh16, indeed, you have more performance loss in other games by any chance? Have you tried Cod:warzone by any chance? And if so how is performance there in 4k?

im asking as im trying to figure out if i have to accept a major performance loss or search further 😉

 

Late 2016 Macbook Pro + Razer Core X + AMD RX 5700 XT


ReplyQuote
Macintosh16
(@macintosh16)
Active Member
Joined: 2 months ago
 

So I didn‘t test COD Warzone but what I did play with the eGPU was Battlefield 5, The Witcher 3, Metro Exodus, Anno 1800 and Assassins Creed Origins! In Battlefield 5 I was able to achieve 60 fps in WQHD (ultra settings) without raytracing but not all the time as to my surprise it seems that some times even the core i7 of my MacBook Pro is limiting the performance massively to the point where I got only 30 fps! This is kind of strange but I couldn‘t fix it in any way! With raytraing turned on I was never able to get 60 fps, it hovered between 40 and 50 most of the time! In The Witcher 3 in 4K and full settings I got around 30 fps, in the Crookbag Bog area or when fighting it sometimes went below the 30 fps mark though! Metro Exodus did crash when starting most of the time but when I had the chance to get it running I got around 30 fps I would guess (the fps-counter wasn‘t activated) with ultra settings (not extreme) and raytracing turned to high, though in the WOLGA scenario I think it went below 30 fps! Anno 1800 ran in 4K and max settings except for antialaising with around 30 fps as well, but often also below that mark! And Assassins Creed Origins also had some starting issues! I had to install it to an external drive to get it running! In 4K and full settings without antialaising I got around 30 fps but in the big cities it also went below 30 sometimes, and unfortunately in general Assassins Creed didn‘t feel really fluid although it ran with 30 fps like on a console! I don‘t know why that happened! Also an issue that was a bit annoying was that V-snyc didn‘t work in some games as I experiences screen tearing even with V-sync truned on! I hope that helps you a little?

Pending: Add my system information and expected eGPU configuration to my signature to give context to my posts


ReplyQuote
(@alex_zeng)
New Member
Joined: 2 weeks ago
 

@macintosh16

 

In your build, Can LG 5K get full 5210*2880 res??  Thanks!

 

Pending: Add my system information and expected eGPU configuration to my signature to give context to my posts


ReplyQuote
(@alex_zeng)
New Member
Joined: 2 weeks ago
 

@macintosh16

 

In your build, Can LG 5K get full 5210*2880 res??  Thanks!

 

Pending: Add my system information and expected eGPU configuration to my signature to give context to my posts


ReplyQuote
Macintosh16
(@macintosh16)
Active Member
Joined: 2 months ago
 

No unfortunately that isn't possible, at least as far as I know. I used the VR-Link of the RTX 2070 Super to connect the GPU to my monitor and as this is a USB-C cable it is only capable of 4K at 60fps. But I did read somewhere that maybe 5K 30fps is possible with some tricks. But when going to the settings in Windows, I never saw an option to change the resolution to 5K. And in macOS of course the Nvidia GPU doesn't work but the you get 5K 60fps because you can use a Thunderbolt 3 cable. I hope that this helps you!

Pending: Add my system information and expected eGPU configuration to my signature to give context to my posts


ReplyQuote
joevt
(@joevt)
Noble Member
Joined: 3 years ago
 

LG UltraFine 5K can only do 5K 60Hz using dual HBR2 connection over Thunderbolt 3.

LG UltraFine 5K does not support 5K with a single connection such as 5K60 8bpc with HBR3 or 5K60 6bpc with HBR2 or 5K30 with HBR2.

The Apple Pro Display XDR does support single connection methods for 5K and 6K as well as dual connection methods (Thunderbolt only). For example, I've seen it support 5K60 6 bpc with HBR2. I have not seen it support low refresh rates (30 Hz or less) (no-one has tried that yet).

 

Mac mini (2018), Mac Pro (Early 2008), MacBook Pro (Retina, 15-inch, Mid 2015), GA-Z170X-Gaming 7, Sapphire Pulse Radeon RX 580 8GB GDDR5, Sonnet Echo Express III-D, Trebleet Thunderbolt 3 to NVMe M.2 case


ReplyQuote
phila-delphia
(@phila-delphia)
Active Member
Joined: 3 months ago
 
Posted by: @macintosh16

So I didn‘t test COD Warzone but what I did play with the eGPU was Battlefield 5, The Witcher 3, Metro Exodus, Anno 1800 and Assassins Creed Origins! In Battlefield 5 I was able to achieve 60 fps in WQHD (ultra settings) without raytracing but not all the time as to my surprise it seems that some times even the core i7 of my MacBook Pro is limiting the performance massively to the point where I got only 30 fps! This is kind of strange but I couldn‘t fix it in any way! With raytraing turned on I was never able to get 60 fps, it hovered between 40 and 50 most of the time! In The Witcher 3 in 4K and full settings I got around 30 fps, in the Crookbag Bog area or when fighting it sometimes went below the 30 fps mark though! Metro Exodus did crash when starting most of the time but when I had the chance to get it running I got around 30 fps I would guess (the fps-counter wasn‘t activated) with ultra settings (not extreme) and raytracing turned to high, though in the WOLGA scenario I think it went below 30 fps! Anno 1800 ran in 4K and max settings except for antialaising with around 30 fps as well, but often also below that mark! And Assassins Creed Origins also had some starting issues! I had to install it to an external drive to get it running! In 4K and full settings without antialaising I got around 30 fps but in the big cities it also went below 30 sometimes, and unfortunately in general Assassins Creed didn‘t feel really fluid although it ran with 30 fps like on a console! I don‘t know why that happened! Also an issue that was a bit annoying was that V-snyc didn‘t work in some games as I experiences screen tearing even with V-sync truned on! I hope that helps you a little?

Hi there!

First of all - have you tried disabeling the dGPU in your Notebook while the 2070 is plugged in? My system runs with dGPU and eGPU both from nvidia which makes this mandatory for me unless I want to get Hickups.

Second - whats your CPU exactly? 8th and 9th generation CPUs seem to suffer from an extra bad eGPU performance -> https://egpu.io/forums/builds/2015-15-dell-precision-7510-q-m1000m-6th4ch-gtx-1080-ti-32gbps-m2-adt-link-r43sg-win10-1803-nando4-compared-to-tb3-performance/#post-72109

Third - Different games perform better or worse on an eGPU. There might be a huge difference between the titles!!! Assassins Creed Origins & Odyssey for example are absolutely horrible. In fact they run much better on my integrated 1650 (50 FPS med-high) than they doon my eGPU (30 FPS same settings). As for The Witcher 3 the perfomace is o.k. though in my case held back through ONE setting: I guess you are playing all on ultra?! -> (appart form disabeling Hairworks) take down foliage distance one notch to "high" (for me this has an huge impact!).

Best regards

phila

 

Lenovo Yoga c940 15": i7-9750h / GTX 1650 Max-Q / 16 GB RAM / 1 TB NVMe @ Razer Core Chroma: RTX 2070 Super / 1 TB SSD / 2 TB RAID 1 / AOC C3583FQ / LG 1500 / G 604 / G 613 / Sony MDR 1000


ReplyQuote