eGPU with RTX 3080 - Framerate drops in low demanding games
 
Notifications
Clear all

eGPU with RTX 3080 - Framerate drops in low demanding games  

  RSS

sandorengholm
(@sandorengholm)
New Member
Joined: 12 months ago
 

Hi everyone,

In certain games i experience framerate drops / stuttering, and it's quite annoying and defeats the purpose of having a considerable expensive setup, if it can't even handle the simplest of games at excellent performance.

I hereby want to figure out which part of my setup is causing this issue, so i can take action upon it.

The games i experience framerate drops / stuttering:

- Rocket League (In menus when mousing over menu items)

- Tabletop Simulator (Consistent every 5 sec)

- Planet Zoo (rare)

Here's a video showcasing the issue in Rocket League:

 

As you can see, my CPU, GPU and Memory isn't at pressure at all.

 

Could this be because of TB3 bottlenecking my performance, or is it purely because of the games being unoptimized? Crysis 3 and Forza Horizon 4 doesn't stutter at all and perform at highest quality at 1440p 60fps+ consistently.

My setup:

- Macbook Pro 16" 2019

- CPU: i7 9750H 2,6 GHz 6 cores

- Memory: 16GB DDR3

- EGPU: Razer Core X

- GPU: RTX 3080

- Monitor: 1440p 60hz

 

This is my first post, so sorry if i missed some information necessary to diagnose the issue.

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
Lycid
(@lycid)
Eminent Member
Joined: 2 years ago
 

Make sure you're doing the following:

 

1. Only use an external monitor with eGPU

2. Do the same frame drops happen when you disable your dGPU inside your macbook via device manager? For me, I need to disable my dGPU to get smooth results.

3. Install drivers completely cleanly using DDU + disable windows from installing drivers on its own + install manually using device manager. There's a guide someone posted here a while ago that goes through it. It's the best way to get a smooth eGPU result.

2021 16" Lenovo Legion 7i Gen 6 (RTX3060) [11th,8C,H] + RTX 3090 @ 32Gbps-TB4 (Razer Core X Chroma) + Win10 21H1 [build link]  

ReplyQuote
Andrew Makarenko
(@andrew_makarenko)
Active Member
Joined: 5 months ago
 
Posted by: @sandorengholm

Hi everyone,

In certain games i experience framerate drops / stuttering, and it's quite annoying and defeats the purpose of having a considerable expensive setup, if it can't even handle the simplest of games at excellent performance.

I hereby want to figure out which part of my setup is causing this issue, so i can take action upon it.

The games i experience framerate drops / stuttering:

- Rocket League (In menus when mousing over menu items)

- Tabletop Simulator (Consistent every 5 sec)

- Planet Zoo (rare)

Here's a video showcasing the issue in Rocket League:

 

As you can see, my CPU, GPU and Memory isn't at pressure at all.

 

Could this be because of TB3 bottlenecking my performance, or is it purely because of the games being unoptimized? Crysis 3 and Forza Horizon 4 doesn't stutter at all and perform at highest quality at 1440p 60fps+ consistently.

My setup:

- Macbook Pro 16" 2019

- CPU: i7 9750H 2,6 GHz 6 cores

- Memory: 16GB DDR3

- EGPU: Razer Core X

- GPU: RTX 3080

- Monitor: 1440p 60hz

 

This is my first post, so sorry if i missed some information necessary to diagnose the issue.

Have you resolved the issue? It looks like I have the same problem 🙁

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote
RaggaMuffin
(@raggamuffin)
Active Member
Joined: 6 months ago
 

@andrew_makarenko I used to have a similar issue as well. For me, disabling game mode in Windows 10 completely fixed it. But also switching between DX11 and DX12 could fix the issue as depending on the game you can get wildly different performance by using one or the other. Sometimes disabling Control Flow Guard (CFG) under Exploit protection can help with stuttering.

2018 Lenovo T480s [8th,4C,U] + GTX 1080 @ 16Gbps-TB3 (Razer Core X) + Win10 / Arch


ReplyQuote
papoose02
(@papoose02)
Eminent Member
Joined: 4 years ago
 

Hi

i Can confirm that disabling dGPU in Windows device manager should solve the issue. 
did the trick for me.

To do: Create my signature with system and expected eGPU configuration information to give context to my posts. I have no builds.

.

ReplyQuote