General Discussions
[HELP] Razer Core X + RTX 2070 + MacbookPro 15 eGPU error
 

[HELP] Razer Core X + RTX 2070 + MacbookPro 15 eGPU error  

  RSS

teafoos
(@teafoos)
New Member
Joined: 12 months ago
 

Hello folks. I bought recently Razer Core X + GeForce RTX 2070 to use with my 15" MacbookPro 2018 in Bootcamp - with external monitor hooked up to eGPU. First time I set it up like month ago it worked perfectly, just updated Windows 10 x64 to max, inserted cards, installed all drivers, rebooted and it worked. It even worked without any EFI, manual switching of GPUs - my regular boot order was insert eGPU, boot up Windows and game.

It worked perfectly until like few days ago, when in Dota I had some weird display glitch where a lot of small green lines appear on my monitor and then system crashed. From this point I was able to boot it with some hassle - but only in a way to wait for OS switch in boot, then plug eGPU after windows logo appeared. It worked well but after 30-60 minutes of gaming same artifacts, crash and here we go again.

After some tries I decided to reinstall Win as I only had few games there, did everything the same as last time but when I have fresh Win10 installed with all updates, I hook up eGPU, it is somehow recognized - though with wrong name as some generic VGA display adapter. I am able to install Nvidia drivers (431.60-desktop-win10-64bit-international-dch-whql) that will go well, but after reboot I can not get external display working. Bootcamp Win will always freeze when I plug in eGPU - does not matter if pre-boot / during Win logo booting / after system booted up. This will only happen after I install drivers - prior that I can plug/unplug it as I wish and system seems to be stable.

I do not know what may be causing this problem. First I thought it is hardware issue as those glitches seems to be like when GPU is failing. But then I am not sure why eGPU would still be recognized and I am still abel to install GPU drivers correctly. Also some weird stuff is happening after I install drivers - I can see RTX 2070 twice in hidden devices in Device Manager in Windows.

Any advice here? I did not want to go down the road using EFI patches as it is my main work computer and I read some posts taht it can brick whole drive. I will intend to test sole GPU in standalone friends PC today to rule out GPU failure, but until then I am open to any advice.

Thanks a lot, cheers.

2018 15" Macbook Pro Touchbar /w Radeon Pro 560X 4 GB
Razer Core X + Nvidia RTX 2070
27" AOC Q2775 (2560x1440)


ReplyQuote
Eightarmedpet
(@eightarmedpet)
Noble Member
Joined: 3 years ago
 

Hate to say it but those green lines sound like GPU failure to me... 
Don't fear the EFI work rounds either, its only one of the more complicated Clover based ones that can brick machines I believe, I use rEFInd and the EFI Bootmanager with reckless abandon on my main work machine and all is fine.

2017 13" MacBook Pro Touch Bar
GTX1060 + AKiTiO Thunder3 + Win10
GTX1070 + Sonnet Breakaway Box + Win10
GTX1070 + Razer Core V1 + Win10
Vega 56 + Razer Core V1 + macOS + Win10
Vega 56 + Mantiz Venus + macOS + W10

---

LG 5K Ultrafine flickering issue fix


ReplyQuote
teafoos
(@teafoos)
New Member
Joined: 12 months ago
 

@eightarmedpet

Thanks, I thought so. I do not have picture of it as it happened fast but it seem like this but those lines were much thinner and in much less number. Also they started rapidly appearing one after another and while this was happening computer was still somehow responsive. Strange part is when it first happened, before system rebooted mouse was still active but I could not do anything in Windows - but menubar items hoover on effect still worked.

Anyhow if it is GPU failure warranty replacement should solve this as I bought it 1 month ago.

2018 15" Macbook Pro Touchbar /w Radeon Pro 560X 4 GB
Razer Core X + Nvidia RTX 2070
27" AOC Q2775 (2560x1440)


ReplyQuote